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SMath is a software tool for performing and documenting of engineering calculations.
An SMath document or worksheet consists of formulas, texts, plots and images, which
can be placed on a two-dimensional grid, the canvas. Formulas can be composed from
pocket-calculator-like buttons, whereas experienced users are much faster using the key-
board. SMath comes with magnificent support of scientific units. The formulas are
self-documenting mathematical instructions. They appear in natural mathematical nota-
tion (not just lines of code), such that people who aren’t familiar with SMath still can
understand them.

SMath initially was a hobby project of the Saint Peterburg based software engineer Andrey
Ivashov. Meanwhile the development is maintained by SMath Ltd. (ООО Эсмат) with
Andrey Ivashov being the CEO. Customers outside Russia are supported by SMath Israel.

SMath has an integrated extension manager, which provides access to the so called online
gallery. This gallery contains functional extensions (plugins), examples, documentations
and code snippets provided by the community and the developers. The introduction you
are just reading can also be found there.

This guide is a compact alternative to the comprehensive manual (Kraska, 2020). After 1-2
hours, you will be familiar with the basic operating concept and able to create worksheets
like the one on the following page.

The author has many years of experience using SMath in research and teaching at the
Brandenburg University of Applied Sciences (THB). He is active in the user forum on
smath.com and oversees the development of an interface to the free and open-source com-
puter algebra system Maxima. This interface offers features such as symbolic integration,
equation solving, and three-dimensional diagrams (see Kraska (2023)).
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CHAPTER 1. FIRST CONTACT

1.1 Example Worksheet

The following figure shows a worksheet with the typical features of SMath Studio:

• Text, formulas, sketches, and diagrams can be freely arranged on the worksheet.

• The formulas are displayed in the usual mathematical notation.

• Units of measurement can be used in the calculations. These appear in blue and
are not italicized.

• Formulas with := are definitions.

• Formulas with = are result displays (you can set their unit, and the conversion is
done automatically).

• Input data can be highlighted in yellow, and result data can be framed. Of course,
other arrangements are possible, but a consistent design makes the worksheets easier
to use.

Figure 1.1: A worksheet with formulas, text, sketch, and diagram. The basic version of
SMath and the X-Y Plot plugin were used here.
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CHAPTER 1. FIRST CONTACT

1.2 Installation

The installation is very simple:

• Go to the website smath.com.

• Download the Windows installer, which is only a few MB.

• Install the program either for yourself or for all users of the computer (the latter
requires admin rights).

• Afterwards, you will have a "SMath Solver" icon on your desktop, which resembles
the symbolism of the Berlin S-Bahn.

Start the program by double-clicking the icon. While the program is loading, a wel-
come screen will be displayed. Finally, the program window will appear. It should look
something like this:

Figure 1.2: SMath Studio in its default state. Under the "Tools" menu, settings can be
adjusted, and under "Activate," you can register for free (this will remove the
watermark when printing).

Dr. Martin Kraska 6 September 26, 2024
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CHAPTER 1. FIRST CONTACT

1.3 Registration and Activation

SMath is free to use in its basic version for personal, non-commercial purposes without
registration and activation. If necessary, you can skip these steps.

Limitations of the basic version:

• Limited use of the cloud version of SMath (storage restrictions, all worksheets are
public, no version control).

• Restrictions on exporting worksheets as executable applications.

• Limited to 5 devices.

• Watermark on prints and PDF exports.

• Some commercial plugins aren’t accessible.

There are no limitations on calculation or documentation functions in the basic version.

Registration and activation of the basic version are free for personal, non-commercial use.

Pressing the red button Activate in the top right corner opens the login portal:

For activation, you need an SMath account, which can be created at Free registration.
You will be asked to provide your email, desired username (login), and password.

After successful registration, you can log in with your credentials. The activation button
will then turn green and display your name.

Dr. Martin Kraska 7 September 26, 2024

https://smath.com/en-US/Security/register


CHAPTER 1. FIRST CONTACT

1.4 Settings for Language and Notation

If you are happy with the default language and notation settings, you can skip this
section. Otherwise you can adjust them to your preferences. We will show this for
German language and continental notation.

The settings are found under under Tools > Options (or Extras > Einstellungen if
you’ve already switched to German).

On the “Interface” page, you can define:

• The language for the user interface and the unit system

• The notation for function names (e.g., atan versus arctg)

• Separators for decimal numbers and functions with multiple arguments (e.g., round(π,2))

These settings take effect globally on the entire worksheet immediately.

Dr. Martin Kraska 8 September 26, 2024



CHAPTER 1. FIRST CONTACT

1.5 Settings for Result Display

On the "Calculation" page, you can change the default settings for result display. These
only affect new formulas. For existing formulas, you can change the settings in the context
menu, but more on that later.

Make sure the settings are as indicated in the screenshot below.

The settings specify:

• 3 decimal places should be displayed. Significant figures mode is enables, therefore,
the setting in fact specifies 3 significant figures. This level of precision is usually
appropriate for technical calculations.

• Numbers are displayed in scientific notation starting from 105.

• Trailing zeros in decimal fractions are omitted, so 1 instead of 1.00.

• The Decimal places option refers to the mantissa length (number of significant digits)
rather than the number of digits after the decimal point. Together with the setting
of 3 decimal places, this gives, for example, π “ 3.14.

• Fractions are displayed as decimals (and not with a fraction bar).

• Lists are shown without removing repeated (multiple) values.

• Rounding is done mathematically (round to even: if the last digit to be kept is
followed by a 5, rounding is done to the nearest even number).

Background: Floating-point numbers are internally represented as a product of a base
number and a power of ten. The power of ten corresponds to a shift of the decimal point
in the base number. Depending on the magnitude of the value to be represented, the
decimal point "floats" to the correct position.

The power of ten indicates the order of magnitude of the value. The number of digits in
the base number indicates the precision of the number representation. The sequence of
digits in the base number is called the mantissa. Its length corresponds to the number of
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CHAPTER 1. FIRST CONTACT

significant digits. These settings only affect the result display. Internally, calculations are
always performed with the standard precision of floating-point numbers (15–16 significant
digits).

In technical calculations, input data is rarely known with more than three significant
digits. Therefore, it seldom makes sense to display results with greater precision. In
principle, one should never display more digits than can be reasonably justified by the
precision. Thus, we recommend displaying results with three significant digits as a default
setting.

Trailing zeros in decimal fractions can be useful when emphasizing the guaranteed preci-
sion. Example: 1400mm “ 1.400m. If the display showed 1.4m, it would remain unclear
whether the value is accurate to the centimeter. However, displaying the whole number
2 with trailing zeros and three significant digits would look like this: 2.00. To avoid this,
we recommend turning off trailing zeros.

The default setting of SMath (4 decimal places) often leads to overly long digit sequences,
which give the impression of greater precision than actually exists and are either useless
or confusing for the reader. Make an effort to be reader-friendly.
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2 Text and Math

Contents

2.1 Saving and Undoing . . . . . . . . . . . . . . . . . . . . . . . 11

2.2 Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

2.3 Formulas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

2.4 Defining Variables with Units . . . . . . . . . . . . . . . . . . 14

2.5 Defining Functions . . . . . . . . . . . . . . . . . . . . . . . . 15

2.6 Formatting of Results . . . . . . . . . . . . . . . . . . . . . . 16

2.7 Cleaning Up . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

2.1 Saving and Undoing

Once the default settings are adjusted, you can start working on your first worksheet.
SMath does not create backups, so save the empty worksheet under the desired name right
away. This works like in any other program with File> Save As. SMath worksheets
have the file extension .sm.

At the beginning of your work, set the file name with File> Save As. Save regularly
(most conveniently with Ctrl S , which means pressing Ctrl and S simultaneously).

Undo with Ctrl Z and Redo with Ctrl Y work in most cases but only up to the last
save point.

Undoing with Ctrl Z is the best option to correct typos. The backspace key some-
times removes more than just the last character.

Create a new worksheet Oscillator.sm
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CHAPTER 2. TEXT AND MATH

2.2 Text

Click on an empty spot in the worksheet and just start typing.

At the first space character, SMath recognizes that you are writing text, since spaces do
not occur in formulas. A text region is then created.

If no space appears in a text, simply add one at the end or create the text field using
Insert > Text region, or start with a quotation mark ” .

You can adjust the text width afterward by dragging the vertical bar on the right .
The lines will be wrapped accordingly. However, SMath does not support hyphenation.

Line break can be enforced using Shift Enter .

In the toolbar you find buttons for the text attributes

• Bold face Strg B

• Italic Strg I

• Underline Strg U

• Text color

• Background color

• Box (frame) around the whole region

These settings apply to the current text selection, except for the box attribute. To insert
framed words, insert a text region inside the current region using the menu: Insert>
Text region. This region can be framed separately.

You should be sparing with formatting anyway, as there are (currently) no formatting
templates in SMath.

Now you can create all the text regions in the example sheet.
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CHAPTER 2. TEXT AND MATH

2.3 Formulas

As long as you don’t type a space character, you will always create a formula when typing
in the worksheet.

Let’s do some calculations: Click on an empty spot in the worksheet and type 1+1=

As you can see, the result is displayed. The black box (placeholder) to the right is for
units, but we don’t need that here. If you click outside the formula on the worksheet or
change focus to the next or previous region with Ó or Ò , the placeholder disappears.

Instead of typing, you can also use the calculator palette (Arithmetic) on the right-hand
side with the mouse. If you hover the mouse over a button, the corresponding keyboard
command is displayed.

Inserting Functions

• Type the name followed by an open parenthesis, e.g., sin(

• Use the "Functions" palette in the sidebar

• Selection dialog, accessible via Insert > Function

Dr. Martin Kraska 13 September 26, 2024



CHAPTER 2. TEXT AND MATH

2.4 Defining Variables with Units

Variables are defined using the operator :=. It can be found in the Arithmetic palette
or can be generated by typing : (colon). Type m:1’kg

The apostrophe (prime) ’ indicates a unit of measurement with which the preceding
number can be multiplied. When typing names (letters), the dynamic assistance is
displayed. If it recognizes a name, it shows its meaning. This helps avoid spelling errors.

Subscripted name parts (text indices) are created using a dot or comma. Typev.0:30’cm/’s.

Greek letters can be obtained from the Symbols (α-ω) and Symbols (A-Ω) palettes in
the sidebar.

Do not use Greek letters that look the same as Latin letters. Otherwise, you will get
different names that you cannot visually distinguish.

Sometimes similarities are unavoidable, especially confusing are:

• w (like whiskey) and ω (omega)

• σ (sigma) and δ (delta)

• ρ (rho) and p (like papa).

Now you can enter the formulas in the example worksheet. We will define the function
xptq later. If you have problems with the units of measurement, refer to Chapter 3
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CHAPTER 2. TEXT AND MATH

2.5 Defining Functions

Functions are defined just like variables using the operator :=.

On the left hand side is the function name, followed by an opening parenthesis, then the
argument(s), and a closing parenthesis.

On the right hand side is the expression that produces the function value. This expression
should include the arguments whose values are passed during the function call. However,
all other variables from the spreadsheet can also be used.

Example: The input

c(a;b Space :\a^2 Space +b^2

generates the function

It is now known in the dynamic assistance. When you type "c", you can browse through
the list of names starting with c that appears. Here, for example, you can see the already
defined variable c (spring stiffness), the unit c (speed of light), the just defined function
cpa, bq, and the unit C (Coulomb).

The function can be evaluated for particular values:

Example worksheet: Define the function xptq.
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CHAPTER 2. TEXT AND MATH

2.6 Formatting of Results

Clicking the right mouse button opens the so called context menu:

Here you can change the settings for a single result. The default settings for the program
are set under Tools> Options> Calculation (see Section 1.5).

• Optimization: Here you can switch to Symbolic, but in this guide, we will always
use Numerical.

• Decimal places: Accuracy of the display. The checkmark for Significant figures
mode indicates how the value is interpreted. Activating the checkmark indicates
that the given number specifies significant digits instead of decimal places.

• Exponential threshold: Indicates the order of magnitude for which scientific
notation is used (base number times power of ten):

• Fractions: Decimal or as rational number (numerator divided by denominator).
For numeric results, display as decimal fraction is appropriate in most cases.

When the number of decimal places is set, the relative accuracy of the result depends on
the order of magnitude and the unit of measurement used. Therefore, the recommendation
is: Always use the significant digits mode.
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CHAPTER 2. TEXT AND MATH

2.7 Cleaning Up

Regions can be arranged freely on the spreadsheet.

The evaluation always takes place from left to right and from top to bottom. The reference
point is the top left corner of the region. Therefore, within a row, the regions must be
aligned at the top edge

Copying, Moving, or Deleting Whole Formulas

To copy, move, or delete entire formulas, you can drag a rectangular window with the
mouse over the regions to be marked. They will then appear in light blue:

Marked areas can then be

• moved with the mouse or arrow keys,

• copied with Ctrl C ,

• removed with Del or Ctrl X ,

• duplicated with Ctrl and mouse drag.

Conventions for Formatting

Formatting should be used sparingly. The following conventions are recommended:

• Input values are highlighted in light yellow.

• Results are framed.

Making and Removing Vertical Space

The spacing between the lines should not be unnecessarily large so that more of the
calculation can be seen at once on the screen or on the printed page.

If you want to change the vertical spacing between areas, place the red mouse pointer on
the background in between.

• Enter creates additional space,

• or Del remove space.
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3.1 SMath and Units of Measurement

SMath is capable of performing calculations with units of measurement. Variables can be
defined with units, and results are automatically converted into specified units.
If the units do not match in sums, an error message will appear. Thus, SMath performs
a certain level of unit checking.
Not always do the units of results suggested by SMath correspond to the usual units for
the quantity. For example, the product of a force and a length could be a torque (force
times lever arm) 1N ¨ 1m “ 1Nm or a work (force times displacement) 1N ¨ 1m “ 1 J.
Unit conversions are extremely simple: write the value with the given unit and display it
with the desired unit:
Write: 6’ft=

The result is displayed with the default unit and in the default precision. You had
previously set the number of significant figures to 3.
Units are written in blue and upright in SMath, while variable names are written in black
and italic.
Units are internally marked with a preceding prime, so the letter m can represent the
variable m (mass) and also the unit m (meter).

For the example worksheet, only the first two sections of this chapter are needed.
However, the sections on angles, angular velocities, and temperature units are still impor-
tant, as not everything is intuitive and mistakes are often made.
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CHAPTER 3. UNITS OF MEASUREMENT

3.2 Inserting Units

Units are essentially just specially marked variable names that are internally converted
to base units.

The quickest way to enter units is by using the keyboard. The dynamic assistance shows
whether the name is recognized.

To insert units, there is a selection dialog that can be accessed via Insert> Unit... (also

reachable via Ctrl-W or through the button in the toolbar). In this dialog, you can
narrow down the options based on the physical dimension or by typing letters (Quick
Search):

Under Dimension/Property> Physical Constants, you will find several predefined
physical constants.

A special unit is the percent, which represents the factor 1{100.
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CHAPTER 3. UNITS OF MEASUREMENT

3.3 Units in the Result Display

SMath provides unit suggestions for results.

If the result is work (force times distance), then that is appropriate. However, if it is
meant to be a torque (force times lever arm), then one would not want to leave it as J .

The desired result unit can be typed into the black placeholder to the right of the result
or inserted from the selection dialog. Composite units can be constructed using the
appropriate arithmetic operators (divide, multiply or powers).

The recalculation occurs only when you leave the formula region (by clicking elsewhere
or by using the arrow keys Ó or Ò to exit the current region).

In this way, unit conversions are extremely simple: write the value with the given unit
and display it with the desired unit:

Please write: 6’ft=

Then place the cursor in the placeholder on the right and type ’km or confirm km in the
dynamic assistance using Tab .

Here, you can see the advantage of the result display with three significant figures instead
of a fixed number of decimal places. The required number of decimal places is determined
automatically.

With three decimal places, you would only see the value 0.001 km here.

Example worksheet: Check the formulas and make any necessary additions and correc-
tions.
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CHAPTER 3. UNITS OF MEASUREMENT

3.4 Degrees and Radians

The base unit for angles is the radian (rad), which is the dimensionless ratio u{r between
the arc length u and the radius r. For a full circle, with u “ 2πr, this equals 2π. Ad-
ditionally, SMath comes with other predefined angular units, which are always internally
converted to radians.

Note: Some results are displayed symbolically (operator Ñ in the arithmetic palette), so
there are no decimal fractions, but rather 1/60, 1/3600, or 2π.

Trigonometric functions expect their argument in radians. However, since values in de-
grees are correctly converted to radians, one can, for example, write 90° instead of π{2.
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3.5 Frequencies and Angular Velocities

Frequency (symbol f) is the number of events (oscillation periods, impulses) per unit
time. It is measured in Hz (Hertz).

Angular velocity (symbol ω, lowercase Omega) is the angle covered per unit time during
a rotation. It is measured in rad/s.

Circular frequency is a special angular velocity used in harmonic oscillations. In this
case, a full period is assigned the angular value 2π. Circular frequency is also
measured in rad/s.

Rotational speed (symbol n) is physically an angular velocity, but it is defined like a
frequency, that is, events (full rotations) per unit time. It is measured in 1/min or
min´1or rpm. Frequently, the term ”RPM” refers to the quantity itself instead of
the unit.

SMath deviates from these conventions in two ways:

• In SMath, the unit rev “ 2π is defined as an angle! Therefore, 10 rpm is an angular
velocity. When using given formulas for rotational speeds, one may only use the
unit min´1.

• By default, SMath considers anything with the dimension 1{time to be a frequency.
Therefore, even for angular velocities, the result (in numerical evaluation) will ini-
tially display the unit Hz (Hertz), which is, of course, incorrect. The correct units
here are 1{s or rad/s (manually specify as result unit).

In the case of rotational speed, the specification in Hz is correct, as it measures
events per unit time.

For rotational speed and angular velocity, different equations apply. An example:

The power P is the product of torque M and angular velocity ω.

If calculations are performed using rotational speed instead of angular velocity, then the
conversion factor 2π must be integrated into the formula.

See Section 3.7 for deeper discussion of numerical-value equations versus physical equa-
tions.
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CHAPTER 3. UNITS OF MEASUREMENT

3.6 Temperature Units

The conversion formulas for temperatures (state variables) and temperature differences
are different.

Temperature It holds that 0 °C “ 273.15K and 0K “ ´273.15 °C.

Temperature difference: 1K “ 1 °C.

The user must indicate whether a value is a temperature or a temperature difference.

The solution in SMath: For temperature changes, units such as °C (degrees Celsius) and
°F (degrees Fahrenheit) are prefixed with a ∆.

K (Kelvin) can be used for both temperatures and differences (changes) of temperature,
as this is an absolute unit without a zero point shift.

The examples in red show what happens if the distinction is not observed in SMath!

Caution with negative numerical values in non-absolute units! These must be en-
closed in parentheses!

What happened here? On the left side, it actually states: Zero minus ten degrees Celsius.

Due to the order of operations (multiplication before addition), SMath first calculates
10 °C “ 283.15K and then applies the minus sign.

Thus, the left side is evaluated completely correctly as ´p10 °Cq “ ´p283.15Kq.

When displaying in °C, 273.15 must be subtracted from the Kelvin value, resulting in a
value of -556.3.

However, outside of SMath, the minus is considered part of the number and not as a
subtraction operation. Hence the confusion. The familiar behavior must therefore be
enforced with parentheses.

For the math experts: The author of SMath made the design decision to use unusual low
priority of the unary minus operator.
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CHAPTER 3. UNITS OF MEASUREMENT

3.7 Numerical-Value Equations

In physics, the formula should not depend on the units of measurement used. Such
equations are called physical equations or quantity equations.

However, in engineering regulations and documentation, one often encounters formulas
that only work with specific units of measurement. These are called numerical-value
equations. They are simple to use in hand calc and in non-unit aware software as Excel,
because all required unit conversions are embedded in a separate factor. This factor is
valid only for the specified sets of units and people tend to forget about this. Therefore, use
of such equations is strongly discouraged. Use them only if you can’t find the appropriate
physical equation or if regulations or authorities enforce you to do so.

SMath formulas are expected to be physical formulas, where the variables represent quan-
tities with measurement number and unit of measurement. For example, here we directly
use the physical equation to calculate the damping ratio in the example worksheet from
the system constants:

The following numerical-value equation gives the damping ratio in % if the damping
constant is given in N/(m/s), the mass in kg and the stiffness in N/cm. The symbols for
the numerical values indicate the units used.

D% “ 500
dN{pcm{sq

?
cN{cm mkg

The symbols in this equation are numerical values (hence the name of such equations).
In SMath, we create them from the physical quantities by dividing them by the required
unit.

Hint: SMath Studio can be used to design numerical value equations: Here is how you
find the factor in the above equation using SMath Studio’s solve() function.
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4 Plotting

Contents

4.1 X-Y Plot (Plugin) . . . . . . . . . . . . . . . . . . . . . . . . . 26

4.2 2D-Plot (native) . . . . . . . . . . . . . . . . . . . . . . . . . . 28

4.3 Lists . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

SMath comes with a very simple plot region by default. This allows for quick genera-
tion of function representations. However, there are limited options for customizing the
appearance.

The X-Y Plot region from the X-Y Plot plugin offers more options. It is recommended
as the standard and used in the example worksheet.

Lists (see Section 4.3) can be used to represent multiple functions in a single plot.

Three-dimensional diagrams can only be created using the Maxima plugin, which is not
covered in this introduction, a thorough reference can be found in Kraska (2023).
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4.1 X-Y Plot (Plugin)

This feature requires the X-Y Plot plugin. Here’s how to install it:

• Options > Plugins...

• In the top right: change "Local Storage" to "Online Gallery".

• In the list of "Plugins," select the X-Y Plot plugin.

• Click "Install" and wait for the installation to complete.

Usually, the installed plugin works without restart of SMath.

A new X-Y plot region can be created with Insert > Plot > X-Y Plot:

In the placeholder at the bottom left, you can enter the expression to be plotted. You
can drag the edge markers with the mouse to change the size of the diagram. The border
disappears when you leave the area.

For function plots, any undefined name (that has no value yet) can be used as the inde-
pendent variable. In the following image, the region has been reduced to the minumum
available size.

sin(x Enter

If multiple expressions are to be plotted, a list is needed (see section 4.3).
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Settings

The settings dialog can be opened by double-clicking on the plot or by using the context
menu (right-click)> Settings.

Important Settings

• Labels > XLabel, YLabel: Labels for the axes

• X-Axis > Max, Min, Ticks: Range settings and axis tick spacing for the x-axis

• Y-Axis > Max, Min, Ticks: Range settings and axis tick spacing for the y-axis.

Range Settings with the Mouse

First, the plot must be clicked so that the edge markers are visible (plot has mouse focus).

• Move the view: Click and drag the diagram area

• Zoom both axes: Mouse wheel

• Zoom only the x-axis: Shift + mouse wheel

• Zoom only the y-axis: Ctrl + mouse wheel

Example worksheet: Now you can create the diagram. Write xptq in the placeholder.
Multiply t by the unit s (second) and divide the result by the desired display unit cm.
Adjust the axis labels and ranges accordingly.
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4.2 2D-Plot (native)

The native 2D plot region does not require installation of plugins. Such regions are created
using a hot key or via menu entry.

• @

• Insert> Plot> 2D

A plot region will appear. The expression to be plotted is entered in the placeholder. The
independent variable must be named x.

Range Settings with the Mouse

Mouse control works as in the X-Y plot. First, the plot must be clicked so that the edge
markers are visible (plot has mouse focus).

• Move the view: Click and drag the diagram area

• Zoom both axes: Mouse wheel

• Zoom only the x-axis: Shift + mouse wheel

• Zoom only the y-axis: Ctrl + mouse wheel

There is no settings dialog for the native 2D plot. When dealing with very small or very
large values, it can be cumbersome to scale the axes using the mouse wheel. In such cases,
the axes can be scaled by using appropriate factors in the expression to be represented:

• x-axis: Multiply x by a factor

• y-axis: Multiply the expression by a factor

If multiple expressions are to be represented, a list is needed (see section 4.3).
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4.3 Lists

If you want to have multiple curves in one diagram, you can group the expressions in a
list (SMath designation "System"). Lists can be created by

• Typing sys Ô (Tab key) or

• Using the symbol in the Functions palette of the sidebar.

Example:

sys Ô sin(x Ñ Ñ cos(x Enter

Change the size of the list with the mouse:

• Click on the bracket of the list

• Drag with the mouse at the grab point in the bottom right corner

Insert list elements:

• Place the insertion cursor on an element

• Type the argument separator , . A new placeholder will appear.

Delete list elements:

• Place the insertion cursor on an element

• Press the Backspace or Delete Del key multiple times.
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5 Editable Sketches

Contents

5.1 Creating and Adjusting an Image Region . . . . . . . . . . . 31

5.2 Editing the Image . . . . . . . . . . . . . . . . . . . . . . . . . 32

For technical calculations, sketches are often needed. Such sketches may change during
the work on the document. Therefore, it is beneficial if they can be edited directly from
within SMath. One way to do this is demonstrated here.

You need to install the Image Region Plugin. Here’s how to do it:

• Options > Plugins...

• In the top right: change "Local Storage" to "Online Gallery".

• In the list of "Plugins," select the Image Region plugin.

• Click "Install" and wait for the installation to complete.

Now you will find the option to insert an image region under Insert> Image. If it’s not
there, restart SMath.
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5.1 Creating and Adjusting an Image Region

First, you insert an image region: Insert> Image and drag it to the approximate desired
size:

In the placeholder at the bottom left, you can specify the name of an image file. However,
you can also create an empty image file and then edit it directly from SMath.

For this, the context menu (right-click) is important:

Display input data: Here you can disable the display of the placeholder.

Open With: Here you can specify which program should open the image file. The
default is the system’s standard program for the selected file type.

Blank File Type: Selection of the internal file format (default is PNG).

Switch border on/off: Here you can disable the border of the image.
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5.2 Editing the Image

Use Context menu> Open With... to select and start a program for editing the file.
Double click on the image region launches the default program for the selected file format.

In the editing program, you create the file contents. Here is an example of what it looks
like in Paint, where a PNG file is being edited:

Then close the program (if you forgot to save, you will be prompted to do so). You may
need to click next to the image in order to see the changes in SMath:

It is best to create the annotations directly in SMath by overlaying formulas on the image.
This ensures a consistent appearance of symbols throughout the worksheet.

Images created in this way are saved with the worksheet and can be edited later. This can
be done by double-clicking on the image or using the Context menu> Open With....
The image will then open in the preset or selected program.

Example Worksheet: Create the system diagram and label it in SMath.
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6.1 Export as PDF

For sharing worksheets as a PDF, you have two options:

1. Via the print output. A PDF printer must be set up in the system for this.

2. Using File> Save As. In the dialog, select the file type below the file name entry.

For this, the PDF Files plugin must be installed. Here’s how to do it:

• Options > Plugins...

• In the top right: change "Local Storage" to "Online Gallery".

• In the list of "Plugins," select the PDF Files plugin.

• Click "Install" and wait for the installation to complete.

Usually, the installed plugin works without needing to restart SMath.

Example Worksheet: Export the document as a PDF and check the result with a PDF
viewer.
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6.2 The SMath User Forum

The SMath community is primarily active in the Anwenderforum on the SMath website.

You can read the forum without a user account. However, to post contributions, you must
register and log in (independently of SMath activation). Due to excessive spamming,
registration to the forum is sometimes disabled.

Factors for a good chance of receiving answers:

• Search the forum first to see if similar questions have already been asked.

• Explain the problem with the simplest possible example (minimum working exam-
ple).

• Attach the example as a .sm file and as an image (screenshot) so that readers can
understand what the issue is without having to download and open the file.

For small documents, create the image using File> Save as> File type: Image files.
This will save the file as a PNG, similar to exporting as a PDF.

Creating a Post in the Forum

• Log in.

• Search for an appropriate subforum in the forum, e.g., Bugs & Problems.

• Start a new discussion with New Topic (bottom right).

• Provide at least a title (Subject) and a message text (Message).

• Inserting images and files: A bit cumbersome, but still important.

– Press the paperclip button.

– In the new window, select "Upload new files".

– In the dialog, either drag files onto "Drop file(s) here" or use the button + Add file(s) .

– Then press Ñ Start Upload(s) .

• References to the imported data will appear in the text editor: [attach]19130[/attach].

• With Preview (below the editor window), you can get a preview, and with Save ,
you save the post.
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6.3 Offline Activation

By default, SMath Studio requires an active internet connection for license activation.
The credencials (user name and password) must be input whenever you start SMath. If
the connection is lost, SMath blockes completely until you confirm the logout in a separate
dialog, which may be hard to find on the desktop (is not in the foreground by default).

In this dialog, select

• Refresh if you re-established the internet connection.

• Close a program to close SMath (with eventually loosing your work)

• Sign Out to continue in de-activated mode

Follow these steps for offline activation, to avoid such problems.

1. Log in to smath.com. If you are not logged in, the following steps won’t work.

2. Click the red Activate button in the top right corner of the SMath program. This
opens the ”Account” dialog:

3. Use the QR-code. This should get you to the Licensing page, go on with item 5
below.

4. or use the link Other options to activate and in the new window follow the link
”this hyperlink” (first option)
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5. On this page, select the license to be activated if necessary.

The data for "Device ID" and "Program Version" can be found in the Account
dialog above. Set the reservation time for the device from which the Device ID
originates.

6. With "Activate License," the reservation is executed, and the license file is down-
loaded (with the extension .lic).

7. In SMath (dialog under point 2), select the received license file by clicking "Select
license file to activate." The program is now activated offline, so you no longer need
to log in to activate it.
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6.4 Interactive Manual

In the Extension Management (Tools> Plugins), you have access to manuals and ex-
amples. Make sure that you have switched to the online gallery.

Recommended Resources

• The German manual (almost 350 pages, under Handbooks), the most comprehen-
sive presentation of the program, though it is from 2020.

• The interactive tutorial (SMath document with exercises, under Examples). It is
somewhat more extensive and detailed than the present guide.

• The interactive manual (under Interactive books). It can be accessed after in-
stallation using the ? button in the toolbar.

1. Select the Interactive SMath Handbook, then Download .

2. Check the box Use by default .

3. Start with ? in the toolbar.
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6.5 Further Reading

There is not much literature on SMath, some books are listed on the official website. You
can also find inspiration in books about the use of Mathcad and dialog-oriented computer
algebra systems for technical calculations.

Liengme (2015) First book on SMath on the market.

Очков et al. (2023) Russian lecture notes with many
interesting applications in logistics, geometry, mechanics,
thermodynamics and astronomy. Extensive support material
can be found at twt.mpei.ac.ru/OCHKOV/smath.

Kraska (2023) Handbook with focus on the Maxima plugin,
which brings computer algebra and 3D plotting to SMath
Studio. DOI 10.25933/opus4-2949
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