Meta.Numerics

CollapseAll image | DropDown image
C#

Visual Basic

Visual C++

F#

Meta.Numerics Library
Meta.Numerics
Meta.Numerics is a library for scientific and technical computation.

Namespaces

Namespace | Description
Meta.Numerics | Contains types used throughout the Meta.Numerics library.
Meta.Numerics.Analysis | Contains types used to analyze user-supplied functions.
Meta.Numerics.Functions | Contains types that evaluate advanced functions.
Meta.Numerics.Matrices | Contains types that store and operate on matrices.
Meta.Numerics.SignalProcessing | Contains types supporting Fourier and related transformation used in signal processing applications.
Meta.Numerics.Statistics | Contains types that store and analyze statistical data.
Meta.Numerics.Statistics.Distributions | Contains types that represent probability distributions.

http://www.meta-numerics.net


Meta.Numerics Namespace

F#

Meta.Numerics Library
Meta.Numerics Namespace
Contains types used throughout the Meta.Numerics library.

Types

All Types | Classes | Structures
Name | Description
Complex | Represents a complex number.
ComplexMath | Provides simple functions of complex arguments.
DimensionMismatchException | The exception that is thrown when attempting an operation on objects with incompatible dimensions.
Interval | Represents an interval on the real number line.
MoreMath | Contains addtional basic math operations.
NonconvergenceException | The exception that is thrown when an algorithm fails to converge.
Polynomial | Represents a polynomial with real coefficients.
UncertainMath | Contains methods for computing basic mathematical functions of uncertain values.
UncertainValue | Represents a value with an associated uncertainty.
XY | Represents a two-dimensional point.


Complex Structure

F#

| Members | See Also
Meta.Numerics Library
Complex Structure
Represents a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct Complex : IEquatable<Complex>
Public Structure Complex
    Implements IEquatable(Of Complex)
public value class Complex : IEquatable<Complex>
[<SealedAttribute>]
type Complex =
    struct
        interface IEquatable<Complex>
    end

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Complex(Double, Double) | Initializes a new complex number.
Addition(Complex, Complex) | Adds two complex numbers.
Conjugate | Gets the complex conjugate of the complex number.
Division(Complex, Complex) | Divides two complex numbers.
Equality(Complex, Complex) | Tests the equality of two complex numbers.
Equals(Object) | Determines whether the given object represents the same complex number. (Overrides ValueType..::..Equals(Object).)
Equals(Complex) | Determines whether the given complex number is the same.
ExplicitNarrowingExplicitExplicitExplicit(Complex to Double) | Converts the complex number to a double-precision real number.
GetHashCode()()()() | Returns a hash code for the complex number. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
I | Gets the square root of negative one.
Im | Gets the imaginary part of the complex number.
ImplicitWideningImplicitImplicitImplicit(Double to Complex) | Converts a double-precision real number to a complex number.
Inequality(Complex, Complex) | Tests the inequality of two complex numbers.
Multiply(Double, Complex) | Multiplies a complex number by a real number.
Multiply(Complex, Complex) | Multiplies two complex numbers.
Multiply(Complex, Double) | Multiplies a real number by a complex number.
One | Gets the complex value of one.
Re | Gets the real part of the complex number.
Subtraction(Complex, Complex) | Subtracts the second complex number from the first.
ToString()()()() | Produces a string representation of the complex number. (Overrides ValueType..::..ToString()()()().)
UnaryNegation(Complex) | Negates a complex number.
Zero | Gets the complex value of zero.

Remarks

Version 4.0 of the .NET Framework introduced a Complex structure equivalent to this one. To maintain compatibility with earlier versions of the .NET Framework, Meta.Numerics maintains its own Complex structure.

See Also

Meta.Numerics Namespace


Complex Constructor

F#

| See Also
Meta.Numerics Library
Complex Constructor
Initializes a new complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex(
    double re,
    double im
)
Public Sub New (
    re As Double,
    im As Double
)
public:
Complex(
    double re,
    double im
)
new :
        re : float *
        im : float -> Complex

Parameters

re
Double
The real part of the complex number.
im
Double
The imaginary part of the complex number.

See Also

Complex Structure
Meta.Numerics Namespace


Complex Fields

F#

Meta.Numerics Library
Complex Fields

The Complex type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
I | Gets the square root of negative one.
One | Gets the complex value of one.
Zero | Gets the complex value of zero.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.I Field

F#

Meta.Numerics Library
Complex..::I Field
Gets the square root of negative one.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static readonly Complex I
Public Shared ReadOnly I As Complex
public:
static initonly Complex I
static val I: Complex

Field Value

Complex

See Also

Complex Structure
Meta.Numerics Namespace


Complex.One Field

F#

Meta.Numerics Library
Complex..::One Field
Gets the complex value of one.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static readonly Complex One
Public Shared ReadOnly One As Complex
public:
static initonly Complex One
static val One: Complex

Field Value

Complex

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Zero Field

F#

Meta.Numerics Library
Complex..::Zero Field
Gets the complex value of zero.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static readonly Complex Zero
Public Shared ReadOnly Zero As Complex
public:
static initonly Complex Zero
static val Zero: Complex

Field Value

Complex

See Also

Complex Structure
Meta.Numerics Namespace


Complex Methods

F#

Meta.Numerics Library
Complex Methods

The Complex type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the given object represents the same complex number. (Overrides ValueType..::..Equals(Object).)
Equals(Complex) | Determines whether the given complex number is the same.
GetHashCode()()()() | Returns a hash code for the complex number. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Produces a string representation of the complex number. (Overrides ValueType..::..ToString()()()().)

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Equals Method

F#

Meta.Numerics Library
Complex..::Equals Method

Overload List

Name | Description
Equals(Object) | Determines whether the given object represents the same complex number. (Overrides ValueType.Equals(Object).)
Equals(Complex) | Determines whether the given complex number is the same.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Equals Method (Object)

F#

Meta.Numerics Library
Complex..::Equals Method (Object)
Determines whether the given object represents the same complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object to compare.

Return Value

Boolean
True if the object represents the same complex number, otherwise false.

See Also

Complex Structure
Equals Overload
Meta.Numerics Namespace


Complex.Equals Method (Complex)

F#

Meta.Numerics Library
Complex..::Equals Method (Complex)
Determines whether the given complex number is the same.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Equals(
    Complex other
)
Public Function Equals (
    other As Complex
) As Boolean
public:
virtual bool Equals(
    Complex other
) sealed
abstract Equals :
        other : Complex -> bool
override Equals :
        other : Complex -> bool

Parameters

other
Complex
The complex number to compare.

Return Value

Boolean
True if the complex number is the same, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

Complex Structure
Equals Overload
Meta.Numerics Namespace


Complex.GetHashCode Method

F#

Meta.Numerics Library
Complex..::GetHashCode Method
Returns a hash code for the complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A hash code.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.ToString Method

F#

Meta.Numerics Library
Complex..::ToString Method
Produces a string representation of the complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string represenation of the complex number.

See Also

Complex Structure
Meta.Numerics Namespace


Complex Operators

F#

Meta.Numerics Library
Complex Operators

The Complex type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(Complex, Complex) | Adds two complex numbers.
Division(Complex, Complex) | Divides two complex numbers.
Equality(Complex, Complex) | Tests the equality of two complex numbers.
ExplicitNarrowingExplicitExplicitExplicit(Complex to Double) | Converts the complex number to a double-precision real number.
ImplicitWideningImplicitImplicitImplicit(Double to Complex) | Converts a double-precision real number to a complex number.
Inequality(Complex, Complex) | Tests the inequality of two complex numbers.
Multiply(Double, Complex) | Multiplies a complex number by a real number.
Multiply(Complex, Complex) | Multiplies two complex numbers.
Multiply(Complex, Double) | Multiplies a real number by a complex number.
Subtraction(Complex, Complex) | Subtracts the second complex number from the first.
UnaryNegation(Complex) | Negates a complex number.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Addition Operator

F#

Meta.Numerics Library
Complex..::Addition Operator
Adds two complex numbers.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator +(
    Complex z1,
    Complex z2
)
Public Shared Operator + (
    z1 As Complex,
    z2 As Complex
) As Complex
public:
static Complex operator +(
    Complex z1,
    Complex z2
)
static let inline (+)
        z1 : Complex *
        z2 : Complex  : Complex

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Complex
The sum of the complex numbers.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Division Operator

F#

Meta.Numerics Library
Complex..::Division Operator
Divides two complex numbers.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator /(
    Complex z1,
    Complex z2
)
Public Shared Operator / (
    z1 As Complex,
    z2 As Complex
) As Complex
public:
static Complex operator /(
    Complex z1,
    Complex z2
)
static let inline (/)
        z1 : Complex *
        z2 : Complex  : Complex

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Complex
The quotient of the two complex numbers.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Equality Operator

F#

Meta.Numerics Library
Complex..::Equality Operator
Tests the equality of two complex numbers.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    Complex z1,
    Complex z2
)
Public Shared Operator = (
    z1 As Complex,
    z2 As Complex
) As Boolean
public:
static bool operator ==(
    Complex z1,
    Complex z2
)
static let inline (=)
        z1 : Complex *
        z2 : Complex  : bool

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Boolean
True if the two complex numbers are equal, otherwise false.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Explicit Operator

F#

Meta.Numerics Library
Complex..::Explicit Operator
Converts the complex number to a double-precision real number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static explicit operator double (
    Complex z
)
Public Shared Narrowing Operator CType (
    z As Complex
) As Double
static explicit operator double (
    Complex z
)
F# does not support the declaration of new casting operators.

Parameters

z
Complex
The complex number to covert.

Return Value

Double
The corresponding double-precision real number.

Remarks

This explicit cast will fail if the complex number has a non-zero imaginary part. If you just want to obtain the real part of a complex number, use the Re property.

Exceptions

Exception | Condition
System..::..InvalidCastException | z.Im ≠ 0

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Implicit Operator

F#

Meta.Numerics Library
Complex..::Implicit Operator
Converts a double-precision real number to a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static implicit operator Complex (
    double x
)
Public Shared Widening Operator CType (
    x As Double
) As Complex
static implicit operator Complex (
    double x
)
F# does not support the declaration of new casting operators.

Parameters

x
Double
The double-precision real number to convert.

Return Value

Complex
The corresponding complex number.

Remarks

The complex number output has a zero imaginary part and real part equal to the input number.

This is an implicit cast; the compiler will apply it automatically whenever a real number is given in a situation where a complex number is required.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Inequality Operator

F#

Meta.Numerics Library
Complex..::Inequality Operator
Tests the inequality of two complex numbers.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    Complex z1,
    Complex z2
)
Public Shared Operator <> (
    z1 As Complex,
    z2 As Complex
) As Boolean
public:
static bool operator !=(
    Complex z1,
    Complex z2
)
static let inline (<>)
        z1 : Complex *
        z2 : Complex  : bool

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Boolean
False if the two complex numbers are equal, otherwise true.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Multiply Method

F#

Meta.Numerics Library
Complex..::Multiply Method

Overload List

Name | Description
Multiply(Double, Complex) | Multiplies a complex number by a real number.
Multiply(Complex, Complex) | Multiplies two complex numbers.
Multiply(Complex, Double) | Multiplies a real number by a complex number.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Multiply Operator (Double, Complex)

F#

Meta.Numerics Library
Complex..::Multiply Operator (Double, Complex)
Multiplies a complex number by a real number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator *(
    double a,
    Complex z
)
Public Shared Operator * (
    a As Double,
    z As Complex
) As Complex
public:
static Complex operator *(
    double a,
    Complex z
)
static let inline (*)
        a : float *
        z : Complex  : Complex

Parameters

a
Double
The real number.
z
Complex
The complex number.

Return Value

Complex
The product az.

See Also

Complex Structure
Multiply Overload
Meta.Numerics Namespace


Complex.Multiply Operator (Complex, Complex)

F#

Meta.Numerics Library
Complex..::Multiply Operator (Complex, Complex)
Multiplies two complex numbers.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator *(
    Complex z1,
    Complex z2
)
Public Shared Operator * (
    z1 As Complex,
    z2 As Complex
) As Complex
public:
static Complex operator *(
    Complex z1,
    Complex z2
)
static let inline (*)
        z1 : Complex *
        z2 : Complex  : Complex

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Complex
The product of the two complex numbers.

See Also

Complex Structure
Multiply Overload
Meta.Numerics Namespace


Complex.Multiply Operator (Complex, Double)

F#

Meta.Numerics Library
Complex..::Multiply Operator (Complex, Double)
Multiplies a real number by a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator *(
    Complex z,
    double a
)
Public Shared Operator * (
    z As Complex,
    a As Double
) As Complex
public:
static Complex operator *(
    Complex z,
    double a
)
static let inline (*)
        z : Complex *
        a : float  : Complex

Parameters

z
Complex
The complex number.
a
Double
The real number.

Return Value

Complex
The product za.

See Also

Complex Structure
Multiply Overload
Meta.Numerics Namespace


Complex.Subtraction Operator

F#

Meta.Numerics Library
Complex..::Subtraction Operator
Subtracts the second complex number from the first.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator -(
    Complex z1,
    Complex z2
)
Public Shared Operator - (
    z1 As Complex,
    z2 As Complex
) As Complex
public:
static Complex operator -(
    Complex z1,
    Complex z2
)
static let inline (-)
        z1 : Complex *
        z2 : Complex  : Complex

Parameters

z1
Complex
The first complex number.
z2
Complex
The second complex number.

Return Value

Complex
The difference of the complex numbers.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.UnaryNegation Operator

F#

Meta.Numerics Library
Complex..::UnaryNegation Operator
Negates a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex operator -(
    Complex z
)
Public Shared Operator - (
    z As Complex
) As Complex
public:
static Complex operator -(
    Complex z
)
static let inline (-)
        z : Complex  : Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The argument times -1.

See Also

Complex Structure
Meta.Numerics Namespace


Complex Properties

F#

Meta.Numerics Library
Complex Properties

The Complex type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Conjugate | Gets the complex conjugate of the complex number.
Im | Gets the imaginary part of the complex number.
Re | Gets the real part of the complex number.

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Conjugate Property

F#

Meta.Numerics Library
Complex..::Conjugate Property
Gets the complex conjugate of the complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex Conjugate { get; }
Public ReadOnly Property Conjugate As Complex
    Get
public:
property Complex Conjugate {
    Complex get ();
}
member Conjugate : Complex with get

Property Value

Complex

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Im Property

F#

Meta.Numerics Library
Complex..::Im Property
Gets the imaginary part of the complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Im { get; }
Public ReadOnly Property Im As Double
    Get
public:
property double Im {
    double get ();
}
member Im : float with get

Property Value

Double

See Also

Complex Structure
Meta.Numerics Namespace


Complex.Re Property

F#

Meta.Numerics Library
Complex..::Re Property
Gets the real part of the complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Re { get; }
Public ReadOnly Property Re As Double
    Get
public:
property double Re {
    double get ();
}
member Re : float with get

Property Value

Double

See Also

Complex Structure
Meta.Numerics Namespace


ComplexMath Class

F#

| Members | See Also
Meta.Numerics Library
ComplexMath Class
Provides simple functions of complex arguments.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class ComplexMath
Public NotInheritable Class ComplexMath
public ref class ComplexMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ComplexMath =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Abs(Complex) | Computes the absolute value of a complex number.
Arg(Complex) | Computes the phase of a complex number.
Cos(Complex) | Computes the cosine of a complex number.
Cosh(Complex) | Computes the hyperbolic cosine of a complex number.
Exp(Complex) | Computes e raised to the power of a complex number.
I | Gets the unit imaginary number I.
Log(Complex) | Computes the natrual logarithm of a complex number.
Pow(Double, Complex) | Raises a real number to an arbitrary complex power.
Pow(Complex, Double) | Raises a complex number to an arbitrary real power.
Pow(Complex, Int32) | Raises a complex number to an integer power.
Sin(Complex) | Computes the sine of a complex number.
Sinh(Complex) | Computes the hyperbolic sine of a complex number.
Sqr(Complex) | Computes the square of a complex number.
Sqrt(Complex) | Computes the square root of a complex number.
Tan(Complex) | Computes the tangent of a complex number.
Tanh(Complex) | Computes the hyperbolic tangent of a complex number.

Inheritance Hierarchy

System..::..Object
Meta.Numerics..::..ComplexMath

See Also

Meta.Numerics Namespace


ComplexMath Methods

F#

Meta.Numerics Library
ComplexMath Methods

The ComplexMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Abs(Complex) | Computes the absolute value of a complex number.
Arg(Complex) | Computes the phase of a complex number.
Cos(Complex) | Computes the cosine of a complex number.
Cosh(Complex) | Computes the hyperbolic cosine of a complex number.
Exp(Complex) | Computes e raised to the power of a complex number.
Log(Complex) | Computes the natrual logarithm of a complex number.
Pow(Double, Complex) | Raises a real number to an arbitrary complex power.
Pow(Complex, Double) | Raises a complex number to an arbitrary real power.
Pow(Complex, Int32) | Raises a complex number to an integer power.
Sin(Complex) | Computes the sine of a complex number.
Sinh(Complex) | Computes the hyperbolic sine of a complex number.
Sqr(Complex) | Computes the square of a complex number.
Sqrt(Complex) | Computes the square root of a complex number.
Tan(Complex) | Computes the tangent of a complex number.
Tanh(Complex) | Computes the hyperbolic tangent of a complex number.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Abs Method

F#

Meta.Numerics Library
ComplexMath..::Abs Method
Computes the absolute value of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Abs(
    Complex z
)
Public Shared Function Abs (
    z As Complex
) As Double
public:
static double Abs(
    Complex z
)
static member Abs :
        z : Complex -> float

Parameters

z
Complex
The argument.

Return Value

Double
The value of |z|.

Remarks

The absolute value of a complex number is the distance of the number from the origin in the complex plane. This is a compatible generalization of the definition of the absolute value of a real number.

See Also

ComplexMath Class
Meta.Numerics Namespace
Math..::..Abs(Double)


ComplexMath.Arg Method

F#

Meta.Numerics Library
ComplexMath..::Arg Method
Computes the phase of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Arg(
    Complex z
)
Public Shared Function Arg (
    z As Complex
) As Double
public:
static double Arg(
    Complex z
)
static member Arg :
        z : Complex -> float

Parameters

z
Complex
The argument.

Return Value

Double
The value of arg(z).

Remarks

The phase of a complex number is the angle between the line joining it to the origin and the real axis of the complex plane.

The phase of complex numbers in the upper complex plane lies between 0 and π. The phase of complex numbers in the lower complex plane lies between 0 and -π. The phase of a positive real number is zero.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Cos Method

F#

Meta.Numerics Library
ComplexMath..::Cos Method
Computes the cosine of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Cos(
    Complex z
)
Public Shared Function Cos (
    z As Complex
) As Complex
public:
static Complex Cos(
    Complex z
)
static member Cos :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of cos(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Cosh Method

F#

Meta.Numerics Library
ComplexMath..::Cosh Method
Computes the hyperbolic cosine of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Cosh(
    Complex z
)
Public Shared Function Cosh (
    z As Complex
) As Complex
public:
static Complex Cosh(
    Complex z
)
static member Cosh :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of cosh(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Exp Method

F#

Meta.Numerics Library
ComplexMath..::Exp Method
Computes e raised to the power of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Exp(
    Complex z
)
Public Shared Function Exp (
    z As Complex
) As Complex
public:
static Complex Exp(
    Complex z
)
static member Exp :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of ez.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Log Method

F#

Meta.Numerics Library
ComplexMath..::Log Method
Computes the natrual logarithm of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Log(
    Complex z
)
Public Shared Function Log (
    z As Complex
) As Complex
public:
static Complex Log(
    Complex z
)
static member Log :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of ln(z).

Remarks

The image below shows the complex log function near the origin, using domain coloring.

You can see the zero at (0, 1) and the branch cut extending along the negative real axis from the pole at the origin.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Pow Method

F#

Meta.Numerics Library
ComplexMath..::Pow Method

Overload List

Name | Description
Pow(Double, Complex) | Raises a real number to an arbitrary complex power.
Pow(Complex, Double) | Raises a complex number to an arbitrary real power.
Pow(Complex, Int32) | Raises a complex number to an integer power.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Pow Method (Double, Complex)

F#

Meta.Numerics Library
ComplexMath..::Pow Method (Double, Complex)
Raises a real number to an arbitrary complex power.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Pow(
    double x,
    Complex z
)
Public Shared Function Pow (
    x As Double,
    z As Complex
) As Complex
public:
static Complex Pow(
    double x,
    Complex z
)
static member Pow :
        x : float *
        z : Complex -> Complex

Parameters

x
Double
The real base, which must be non-negative.
z
Complex
The complex exponent.

Return Value

Complex
The value of xz.

See Also

ComplexMath Class
Pow Overload
Meta.Numerics Namespace


ComplexMath.Pow Method (Complex, Double)

F#

Meta.Numerics Library
ComplexMath..::Pow Method (Complex, Double)
Raises a complex number to an arbitrary real power.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Pow(
    Complex z,
    double p
)
Public Shared Function Pow (
    z As Complex,
    p As Double
) As Complex
public:
static Complex Pow(
    Complex z,
    double p
)
static member Pow :
        z : Complex *
        p : float -> Complex

Parameters

z
Complex
The argument.
p
Double
The power.

Return Value

Complex
The value of zp.

See Also

ComplexMath Class
Pow Overload
Meta.Numerics Namespace


ComplexMath.Pow Method (Complex, Int32)

F#

Meta.Numerics Library
ComplexMath..::Pow Method (Complex, Int32)
Raises a complex number to an integer power.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Pow(
    Complex z,
    int n
)
Public Shared Function Pow (
    z As Complex,
    n As Integer
) As Complex
public:
static Complex Pow(
    Complex z,
    int n
)
static member Pow :
        z : Complex *
        n : int -> Complex

Parameters

z
Complex
The argument.
n
Int32
The power.

Return Value

Complex
The value of zn.

See Also

ComplexMath Class
Pow Overload
Meta.Numerics Namespace


ComplexMath.Sin Method

F#

Meta.Numerics Library
ComplexMath..::Sin Method
Computes the sine of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Sin(
    Complex z
)
Public Shared Function Sin (
    z As Complex
) As Complex
public:
static Complex Sin(
    Complex z
)
static member Sin :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of sin(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Sinh Method

F#

Meta.Numerics Library
ComplexMath..::Sinh Method
Computes the hyperbolic sine of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Sinh(
    Complex z
)
Public Shared Function Sinh (
    z As Complex
) As Complex
public:
static Complex Sinh(
    Complex z
)
static member Sinh :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of sinh(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Sqr Method

F#

Meta.Numerics Library
ComplexMath..::Sqr Method
Computes the square of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Sqr(
    Complex z
)
Public Shared Function Sqr (
    z As Complex
) As Complex
public:
static Complex Sqr(
    Complex z
)
static member Sqr :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of z2.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Sqrt Method

F#

Meta.Numerics Library
ComplexMath..::Sqrt Method
Computes the square root of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Sqrt(
    Complex z
)
Public Shared Function Sqrt (
    z As Complex
) As Complex
public:
static Complex Sqrt(
    Complex z
)
static member Sqrt :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The square root of the argument.

Remarks

The image below shows the complex square root function near the origin, using domain coloring.

You can see the branch cut extending along the negative real axis from the zero at the origin.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Tan Method

F#

Meta.Numerics Library
ComplexMath..::Tan Method
Computes the tangent of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Tan(
    Complex z
)
Public Shared Function Tan (
    z As Complex
) As Complex
public:
static Complex Tan(
    Complex z
)
static member Tan :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of tan(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.Tanh Method

F#

Meta.Numerics Library
ComplexMath..::Tanh Method
Computes the hyperbolic tangent of a complex number.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Tanh(
    Complex z
)
Public Shared Function Tanh (
    z As Complex
) As Complex
public:
static Complex Tanh(
    Complex z
)
static member Tanh :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of tanh(z).

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath Properties

F#

Meta.Numerics Library
ComplexMath Properties

The ComplexMath type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
I | Gets the unit imaginary number I.

See Also

ComplexMath Class
Meta.Numerics Namespace


ComplexMath.I Property

F#

Meta.Numerics Library
ComplexMath..::I Property
Gets the unit imaginary number I.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex I { get; }
Public Shared ReadOnly Property I As Complex
    Get
public:
static property Complex I {
    Complex get ();
}
static member I : Complex with get

Property Value

Complex
The unit imaginary number.

See Also

ComplexMath Class
Meta.Numerics Namespace


DimensionMismatchException Class

F#

| Members | See Also
Meta.Numerics Library
DimensionMismatchException Class
The exception that is thrown when attempting an operation on objects with incompatible dimensions.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class DimensionMismatchException : InvalidOperationException
Public Class DimensionMismatchException
    Inherits InvalidOperationException
public ref class DimensionMismatchException : public InvalidOperationException
type DimensionMismatchException =
    class
        inherit InvalidOperationException
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DimensionMismatchException()()()() | Initializes a new dimension mismatch exception.
DimensionMismatchException(String) | Inititalizes a new dimension mismatch exception with the given exception message.
DimensionMismatchException(String, Exception) | Initializes a new dimension mismatch exception with the given exception message and inner exception.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..InvalidOperationException
Meta.Numerics..::..DimensionMismatchException

See Also

Meta.Numerics Namespace


DimensionMismatchException Constructor

F#

Meta.Numerics Library
DimensionMismatchException Constructor

Overload List

Name | Description
DimensionMismatchException()()()() | Initializes a new dimension mismatch exception.
DimensionMismatchException(String) | Inititalizes a new dimension mismatch exception with the given exception message.
DimensionMismatchException(String, Exception) | Initializes a new dimension mismatch exception with the given exception message and inner exception.

See Also

DimensionMismatchException Class
Meta.Numerics Namespace


DimensionMismatchException Constructor

F#

Meta.Numerics Library
DimensionMismatchException Constructor
Initializes a new dimension mismatch exception.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public DimensionMismatchException()
Public Sub New
public:
DimensionMismatchException()
new : unit -> DimensionMismatchException

See Also

DimensionMismatchException Class
DimensionMismatchException Overload
Meta.Numerics Namespace


DimensionMismatchException Constructor (String)

F#

Meta.Numerics Library
DimensionMismatchException Constructor (String)
Inititalizes a new dimension mismatch exception with the given exception message.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public DimensionMismatchException(
    string message
)
Public Sub New (
    message As String
)
public:
DimensionMismatchException(
    String^ message
)
new :
        message : string -> DimensionMismatchException

Parameters

message
String
The exception message.

See Also

DimensionMismatchException Class
DimensionMismatchException Overload
Meta.Numerics Namespace


DimensionMismatchException Constructor (String, Exception)

F#

Meta.Numerics Library
DimensionMismatchException Constructor (String, Exception)
Initializes a new dimension mismatch exception with the given exception message and inner exception.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public DimensionMismatchException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
DimensionMismatchException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> DimensionMismatchException

Parameters

message
String
The exeption message.
innerException
Exception
The inner exception.

See Also

DimensionMismatchException Class
DimensionMismatchException Overload
Meta.Numerics Namespace


DimensionMismatchException Methods

F#

Meta.Numerics Library
DimensionMismatchException Methods

The DimensionMismatchException type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DimensionMismatchException Class
Meta.Numerics Namespace


DimensionMismatchException Properties

F#

Meta.Numerics Library
DimensionMismatchException Properties

The DimensionMismatchException type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)

See Also

DimensionMismatchException Class
Meta.Numerics Namespace


Interval Structure

F#

| Members | See Also
Meta.Numerics Library
Interval Structure
Represents an interval on the real number line.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct Interval
Public Structure Interval
public value class Interval
[<SealedAttribute>]
type Interval =  struct end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClosedContains(Double) | Determines whether the argument lies in the closed interval.
Equality(Interval, Interval) | Determines whether two intervals are equal.
Equals(Object) | Determines whether a given object is an equal interval. (Overrides ValueType..::..Equals(Object).)
FromEndpointAndWidth(Double, Double) | Creates a new interval, given its lower endpoint and width.
FromEndpoints(Double, Double) | Creates a new interval, given its endpoints.
FromMidpointAndWidth(Double, Double) | Creates a new interval, given its midpoint and width.
GetHashCode()()()() | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(Interval, Interval) | Determines whether two intervals are not equal.
LeftEndpoint | Gets the left (lower) endpoint of the interval.
Midpoint | Gets the mid-point of the interval.
OpenContains(Double) | Determines whether the argument lies in the open interval.
RightEndpoint | Gets the right (upper) endpoint of the interval.
ToString()()()() | Produces a string representation of the interval. (Overrides ValueType..::..ToString()()()().)
Width | Gets the width of the interval.

Remarks

Use the static methods FromEndpoints(Double, Double), FromMidpointAndWidth(Double, Double), and FromEndpointAndWidth(Double, Double) to instantiate intervals.

See Also

Meta.Numerics Namespace


Interval Methods

F#

Meta.Numerics Library
Interval Methods

The Interval type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClosedContains(Double) | Determines whether the argument lies in the closed interval.
Equals(Object) | Determines whether a given object is an equal interval. (Overrides ValueType..::..Equals(Object).)
FromEndpointAndWidth(Double, Double) | Creates a new interval, given its lower endpoint and width.
FromEndpoints(Double, Double) | Creates a new interval, given its endpoints.
FromMidpointAndWidth(Double, Double) | Creates a new interval, given its midpoint and width.
GetHashCode()()()() | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OpenContains(Double) | Determines whether the argument lies in the open interval.
ToString()()()() | Produces a string representation of the interval. (Overrides ValueType..::..ToString()()()().)

See Also

Interval Structure
Meta.Numerics Namespace


Interval.ClosedContains Method

F#

Meta.Numerics Library
Interval..::ClosedContains Method
Determines whether the argument lies in the closed interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool ClosedContains(
    double x
)
Public Function ClosedContains (
    x As Double
) As Boolean
public:
bool ClosedContains(
    double x
)
member ClosedContains :
        x : float -> bool

Parameters

x
Double
The argument.

Return Value

Boolean
True if x lies in [a,b], otherwise False.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.Equals Method

F#

Meta.Numerics Library
Interval..::Equals Method
Determines whether a given object is an equal interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
An object.

Return Value

Boolean
True if obj is an equal Interval, otherwise false.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.FromEndpointAndWidth Method

F#

Meta.Numerics Library
Interval..::FromEndpointAndWidth Method
Creates a new interval, given its lower endpoint and width.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Interval FromEndpointAndWidth(
    double endpoint,
    double width
)
Public Shared Function FromEndpointAndWidth (
    endpoint As Double,
    width As Double
) As Interval
public:
static Interval FromEndpointAndWidth(
    double endpoint,
    double width
)
static member FromEndpointAndWidth :
        endpoint : float *
        width : float -> Interval

Parameters

endpoint
Double
The left (lower) endpoint of the interval.
width
Double
The width of the interval.

Return Value

Interval
The specified interval.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.FromEndpoints Method

F#

Meta.Numerics Library
Interval..::FromEndpoints Method
Creates a new interval, given its endpoints.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Interval FromEndpoints(
    double a,
    double b
)
Public Shared Function FromEndpoints (
    a As Double,
    b As Double
) As Interval
public:
static Interval FromEndpoints(
    double a,
    double b
)
static member FromEndpoints :
        a : float *
        b : float -> Interval

Parameters

a
Double
The left (lower) endpoint of the interval.
b
Double
The right (upper) endpoint of the interval.

Return Value

Interval
The specified interval.

Remarks

If width of the interval is very much smaller than its endpoint values, accuracy will be better maintained by constructing the interval using one endpoint and its width.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.FromMidpointAndWidth Method

F#

Meta.Numerics Library
Interval..::FromMidpointAndWidth Method
Creates a new interval, given its midpoint and width.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Interval FromMidpointAndWidth(
    double midpoint,
    double width
)
Public Shared Function FromMidpointAndWidth (
    midpoint As Double,
    width As Double
) As Interval
public:
static Interval FromMidpointAndWidth(
    double midpoint,
    double width
)
static member FromMidpointAndWidth :
        midpoint : float *
        width : float -> Interval

Parameters

midpoint
Double
The midpoint of the interval.
width
Double
The width of the interval.

Return Value

Interval
The specified interval.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.GetHashCode Method

F#

Meta.Numerics Library
Interval..::GetHashCode Method
Returns the hash code for this instance.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A 32-bit signed integer that is the hash code for this instance.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.OpenContains Method

F#

Meta.Numerics Library
Interval..::OpenContains Method
Determines whether the argument lies in the open interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool OpenContains(
    double x
)
Public Function OpenContains (
    x As Double
) As Boolean
public:
bool OpenContains(
    double x
)
member OpenContains :
        x : float -> bool

Parameters

x
Double
The argument.

Return Value

Boolean
True if x lies in (a,b), otherwise False.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.ToString Method

F#

Meta.Numerics Library
Interval..::ToString Method
Produces a string representation of the interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string representation of the interval.

See Also

Interval Structure
Meta.Numerics Namespace


Interval Operators

F#

Meta.Numerics Library
Interval Operators

The Interval type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equality(Interval, Interval) | Determines whether two intervals are equal.
Inequality(Interval, Interval) | Determines whether two intervals are not equal.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.Equality Operator

F#

Meta.Numerics Library
Interval..::Equality Operator
Determines whether two intervals are equal.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    Interval i1,
    Interval i2
)
Public Shared Operator = (
    i1 As Interval,
    i2 As Interval
) As Boolean
public:
static bool operator ==(
    Interval i1,
    Interval i2
)
static let inline (=)
        i1 : Interval *
        i2 : Interval  : bool

Parameters

i1
Interval
The first interval.
i2
Interval
The second interval.

Return Value

Boolean
True if i1 and i2 are equal, otherwise false.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.Inequality Operator

F#

Meta.Numerics Library
Interval..::Inequality Operator
Determines whether two intervals are not equal.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    Interval i1,
    Interval i2
)
Public Shared Operator <> (
    i1 As Interval,
    i2 As Interval
) As Boolean
public:
static bool operator !=(
    Interval i1,
    Interval i2
)
static let inline (<>)
        i1 : Interval *
        i2 : Interval  : bool

Parameters

i1
Interval
The first interval.
i2
Interval
The second interval.

Return Value

Boolean
True if i1 and i2 are not equal, otherwise false.

See Also

Interval Structure
Meta.Numerics Namespace


Interval Properties

F#

Meta.Numerics Library
Interval Properties

The Interval type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LeftEndpoint | Gets the left (lower) endpoint of the interval.
Midpoint | Gets the mid-point of the interval.
RightEndpoint | Gets the right (upper) endpoint of the interval.
Width | Gets the width of the interval.

See Also

Interval Structure
Meta.Numerics Namespace


Interval.LeftEndpoint Property

F#

Meta.Numerics Library
Interval..::LeftEndpoint Property
Gets the left (lower) endpoint of the interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double LeftEndpoint { get; }
Public ReadOnly Property LeftEndpoint As Double
    Get
public:
property double LeftEndpoint {
    double get ();
}
member LeftEndpoint : float with get

Property Value

Double

See Also

Interval Structure
Meta.Numerics Namespace


Interval.Midpoint Property

F#

Meta.Numerics Library
Interval..::Midpoint Property
Gets the mid-point of the interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Midpoint { get; }
Public ReadOnly Property Midpoint As Double
    Get
public:
property double Midpoint {
    double get ();
}
member Midpoint : float with get

Property Value

Double

See Also

Interval Structure
Meta.Numerics Namespace


Interval.RightEndpoint Property

F#

Meta.Numerics Library
Interval..::RightEndpoint Property
Gets the right (upper) endpoint of the interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double RightEndpoint { get; }
Public ReadOnly Property RightEndpoint As Double
    Get
public:
property double RightEndpoint {
    double get ();
}
member RightEndpoint : float with get

Property Value

Double

See Also

Interval Structure
Meta.Numerics Namespace


Interval.Width Property

F#

Meta.Numerics Library
Interval..::Width Property
Gets the width of the interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double

See Also

Interval Structure
Meta.Numerics Namespace


MoreMath Class

F#

| Members | See Also
Meta.Numerics Library
MoreMath Class
Contains addtional basic math operations.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class MoreMath
Public NotInheritable Class MoreMath
public ref class MoreMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MoreMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cos(Double) | Computes the cosine of the given value to full significance over the full range of arguments.
ExpMinusOne(Double) | Computes ex-1.
Hypot(Double, Double) | Computes the length of a right triangle's hypotenuse.
LogOnePlus(Double) | Computes log(1+x).
Pow(Double, Int32) | Rasises an argument to an integer power.
Sin(Double) | Computes the sine of the given value to full significance over the full range of arguments.
Sqr(Double) | Computes x2.

Remarks

The Math class defines many basic math operations, but a few that are important for optimal numerical practice are missing. They are defined by this class.

Inheritance Hierarchy

System..::..Object
Meta.Numerics..::..MoreMath

See Also

Meta.Numerics Namespace


MoreMath Methods

F#

Meta.Numerics Library
MoreMath Methods

The MoreMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cos(Double) | Computes the cosine of the given value to full significance over the full range of arguments.
ExpMinusOne(Double) | Computes ex-1.
Hypot(Double, Double) | Computes the length of a right triangle's hypotenuse.
LogOnePlus(Double) | Computes log(1+x).
Pow(Double, Int32) | Rasises an argument to an integer power.
Sin(Double) | Computes the sine of the given value to full significance over the full range of arguments.
Sqr(Double) | Computes x2.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.Cos Method

F#

Meta.Numerics Library
MoreMath..::Cos Method
Computes the cosine of the given value to full significance over the full range of arguments.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Cos(
    double x
)
Public Shared Function Cos (
    x As Double
) As Double
public:
static double Cos(
    double x
)
static member Cos :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of sin(x).

Remarks

For an explanaition of this method, see the remarks for the Sin(Double) method.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.ExpMinusOne Method

F#

Meta.Numerics Library
MoreMath..::ExpMinusOne Method
Computes ex-1.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ExpMinusOne(
    double x
)
Public Shared Function ExpMinusOne (
    x As Double
) As Double
public:
static double ExpMinusOne(
    double x
)
static member ExpMinusOne :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of ex-1.

Remarks

If x is close to 0, then ex is close to 1, and computing ex-1 by by subtracting one from ex as computed by the Exp(Double) function will be subject to severe loss of significance due to cancelation. This method maintains full precision for all values of x by switching to a series expansion for values of x near zero.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.Hypot Method

F#

Meta.Numerics Library
MoreMath..::Hypot Method
Computes the length of a right triangle's hypotenuse.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Hypot(
    double x,
    double y
)
Public Shared Function Hypot (
    x As Double,
    y As Double
) As Double
public:
static double Hypot(
    double x,
    double y
)
static member Hypot :
        x : float *
        y : float -> float

Parameters

x
Double
The length of one side.
y
Double
The length of another side.

Return Value

Double
The length of the hypotenuse, sqrt(x2 + y2).

Remarks

The length is computed accurately, even in cases where x2 or y2 would overflow.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.LogOnePlus Method

F#

Meta.Numerics Library
MoreMath..::LogOnePlus Method
Computes log(1+x).

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LogOnePlus(
    double x
)
Public Shared Function LogOnePlus (
    x As Double
) As Double
public:
static double LogOnePlus(
    double x
)
static member LogOnePlus :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of log(1+x).

Remarks

If x is close to 0, computing log(1+x) by first adding one and then taking the log can result in a loss of accuracy. This function maintains full precision of all values of x by switching to a series expansion for values of x near zero.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.Pow Method

F#

Meta.Numerics Library
MoreMath..::Pow Method
Rasises an argument to an integer power.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Pow(
    double x,
    int n
)
Public Shared Function Pow (
    x As Double,
    n As Integer
) As Double
public:
static double Pow(
    double x,
    int n
)
static member Pow :
        x : float *
        n : int -> float

Parameters

x
Double
The argument.
n
Int32
The power.

Return Value

Double
The value of xn.

Remarks

Low integer powers can be computed by optimized algorithms much faster than the general alrogithm for an arbitrary real power employed by Pow(Double, Double).

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.Sin Method

F#

Meta.Numerics Library
MoreMath..::Sin Method
Computes the sine of the given value to full significance over the full range of arguments.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Sin(
    double x
)
Public Shared Function Sin (
    x As Double
) As Double
public:
static double Sin(
    double x
)
static member Sin :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of sin(x).

Remarks

This method addresses several subtle shortcommings of the Sin(Double) method. One shortcoming, quite striking but rarely encountered, is that Sin(Double) returns entirely wrong results very large arguments; for x larger than about 1020, it simply returns the argument as the function value! (I have no idea why the base class library designers did not at least choose to return NaN so as to signal to the user that the result should not be trusted. No floating point standard specifies this crazy behavior.) Another shortcomming, more commonly encountered but often unnoticed, is that for large but not necessarily very large arguments, function values loose precision, particularly near zeros of the function.

One way to view these shortcommings is that they are justified by the uncertainty inherent in floating point representations. In this view, any Double should be seen as an uncertain value with a relative error of ~10-16. If the number is very large, then the absolute size of this error can be as large or larger than 2π; in this circumstance we should not expect to be able to say anything about the value. (Except, of course, that it is between -1 and +1, which is violated by the designers' crazy choice to return the argument as the value). Even if the absolute error is just a non-negligable faction of 2π, there is a non-neglible fraction of the values between -1 and +1 in the corresponding range of function values; any of these values is as good as any other as an answer to the question of the sine of our uncertain argument, so we should be satisfied with any returned value in this non-negligible range.

A contrary view is that it is better to treat all arguments as infinitely precise and return the nearest representable Double to the actual function value under this assumption. Users are unlikely to complain that we returned a more accurate value and this behavior is particularly useful when the argument is an intermediate result that the programmer may not even realize has become large.

For typical arguments, say between 10-4 and 104, the extra cost of this function over Sin(Double) is just a couple of comparisons and a single floating point operation; less than 0.1% of arguments in this range are then routed to our much slower, higher-accuracy algorithm. We therefore suggest that, for general use, you prefer this method over Sin(Double); only in very unusual situations where (i) you are guaranteed never to encounter very large arguments, (ii) full precision values are not required, and (iii) the run-time of your application is critical and dominated by trigonometric calculations, should you prefer the base class library method.

See Also

MoreMath Class
Meta.Numerics Namespace


MoreMath.Sqr Method

F#

Meta.Numerics Library
MoreMath..::Sqr Method
Computes x2.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Sqr(
    double x
)
Public Shared Function Sqr (
    x As Double
) As Double
public:
static double Sqr(
    double x
)
static member Sqr :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The square of the argument.

Remarks

There is nothing numericaly sophisticated inside this function; it exists simply for programmers' convenience. Given a complicated expression that needs to be squared, it is nice to be able to wrap it in a simple function call instead of explicitly assigning its value to a new variable and then multiplying that variable by itself.

See Also

MoreMath Class
Meta.Numerics Namespace


NonconvergenceException Class

F#

| Members | See Also
Meta.Numerics Library
NonconvergenceException Class
The exception that is thrown when an algorithm fails to converge.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class NonconvergenceException : Exception
Public Class NonconvergenceException
    Inherits Exception
public ref class NonconvergenceException : public Exception
type NonconvergenceException =
    class
        inherit Exception
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
NonconvergenceException()()()() | Initializes a new nonconvergence exception.
NonconvergenceException(String) | Inititalizes a new nonconvergence exception with the given exception message.
NonconvergenceException(String, Exception) | Initializes a new nonconvergence exception with the given exception message and inner exception.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Inheritance Hierarchy

System..::..Object
System..::..Exception
Meta.Numerics..::..NonconvergenceException

See Also

Meta.Numerics Namespace


NonconvergenceException Constructor

F#

Meta.Numerics Library
NonconvergenceException Constructor

Overload List

Name | Description
NonconvergenceException()()()() | Initializes a new nonconvergence exception.
NonconvergenceException(String) | Inititalizes a new nonconvergence exception with the given exception message.
NonconvergenceException(String, Exception) | Initializes a new nonconvergence exception with the given exception message and inner exception.

See Also

NonconvergenceException Class
Meta.Numerics Namespace


NonconvergenceException Constructor

F#

Meta.Numerics Library
NonconvergenceException Constructor
Initializes a new nonconvergence exception.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public NonconvergenceException()
Public Sub New
public:
NonconvergenceException()
new : unit -> NonconvergenceException

See Also

NonconvergenceException Class
NonconvergenceException Overload
Meta.Numerics Namespace


NonconvergenceException Constructor (String)

F#

Meta.Numerics Library
NonconvergenceException Constructor (String)
Inititalizes a new nonconvergence exception with the given exception message.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public NonconvergenceException(
    string message
)
Public Sub New (
    message As String
)
public:
NonconvergenceException(
    String^ message
)
new :
        message : string -> NonconvergenceException

Parameters

message
String
The exception message.

See Also

NonconvergenceException Class
NonconvergenceException Overload
Meta.Numerics Namespace


NonconvergenceException Constructor (String, Exception)

F#

Meta.Numerics Library
NonconvergenceException Constructor (String, Exception)
Initializes a new nonconvergence exception with the given exception message and inner exception.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public NonconvergenceException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
NonconvergenceException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> NonconvergenceException

Parameters

message
String
The exeption message.
innerException
Exception
The inner exception.

See Also

NonconvergenceException Class
NonconvergenceException Overload
Meta.Numerics Namespace


NonconvergenceException Methods

F#

Meta.Numerics Library
NonconvergenceException Methods

The NonconvergenceException type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NonconvergenceException Class
Meta.Numerics Namespace


NonconvergenceException Properties

F#

Meta.Numerics Library
NonconvergenceException Properties

The NonconvergenceException type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)

See Also

NonconvergenceException Class
Meta.Numerics Namespace


Polynomial Class

F#

| Members | See Also
Meta.Numerics Library
Polynomial Class
Represents a polynomial with real coefficients.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class Polynomial
Public Class Polynomial
public ref class Polynomial
type Polynomial =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(Polynomial, Polynomial) | Computes the sum of two polynomials.
Coefficient(Int32) | Gets the specificed coefficient.
Degree | Gets the degree of the polynomial.
Differentiate()()()() | Differentiates the polynomial.
Divide(Polynomial, Polynomial, Polynomial%) | Computes the quotient of two polynomials.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate(Double) | Evaluates the polynomial for the given input value.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FromCoefficients(array<Double>[]()[][]) | Initializes a new polynomial with the given coefficients.
FromPoints(array<Double,2>[,](,)[,][,]) | Initializes a new polynomial that passes through the given points.
FromPoints(ICollection<(Of <<'(XY>)>>)) | Initializes a new polynomial that passes through the given points.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Integrate(Double) | Integrates the polynomail.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Multiply(Polynomial, Polynomial) | Computes the product of two polynomials.
Subtraction(Polynomial, Polynomial) | Computes the difference of two polynomials.
ToString()()()() | Generates a string representation of the polynomial. (Overrides Object..::..ToString()()()().)
UnaryNegation(Polynomial) | Negates a polynomial.

Inheritance Hierarchy

System..::..Object
Meta.Numerics..::..Polynomial

See Also

Meta.Numerics Namespace


Polynomial Methods

F#

Meta.Numerics Library
Polynomial Methods

The Polynomial type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Coefficient(Int32) | Gets the specificed coefficient.
Differentiate()()()() | Differentiates the polynomial.
Divide(Polynomial, Polynomial, Polynomial%) | Computes the quotient of two polynomials.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate(Double) | Evaluates the polynomial for the given input value.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FromCoefficients(array<Double>[]()[][]) | Initializes a new polynomial with the given coefficients.
FromPoints(array<Double,2>[,](,)[,][,]) | Initializes a new polynomial that passes through the given points.
FromPoints(ICollection<(Of <<'(XY>)>>)) | Initializes a new polynomial that passes through the given points.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Integrate(Double) | Integrates the polynomail.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Generates a string representation of the polynomial. (Overrides Object..::..ToString()()()().)

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Coefficient Method

F#

Meta.Numerics Library
Polynomial..::Coefficient Method
Gets the specificed coefficient.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Coefficient(
    int n
)
Public Overridable Function Coefficient (
    n As Integer
) As Double
public:
virtual double Coefficient(
    int n
)
abstract Coefficient :
        n : int -> float
override Coefficient :
        n : int -> float

Parameters

n
Int32
The power of the variable for which the coefficient is desired.

Return Value

Double
The coefficient of xn.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Differentiate Method

F#

Meta.Numerics Library
Polynomial..::Differentiate Method
Differentiates the polynomial.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual Polynomial Differentiate()
Public Overridable Function Differentiate As Polynomial
public:
virtual Polynomial^ Differentiate()
abstract Differentiate : unit -> Polynomial
override Differentiate : unit -> Polynomial

Return Value

Polynomial
The derivative of the polynomail.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Divide Method

F#

Meta.Numerics Library
Polynomial..::Divide Method
Computes the quotient of two polynomials.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial Divide(
    Polynomial p1,
    Polynomial p2,
    out Polynomial remainder
)
Public Shared Function Divide (
    p1 As Polynomial,
    p2 As Polynomial,
    <OutAttribute> ByRef remainder As Polynomial
) As Polynomial
public:
static Polynomial^ Divide(
    Polynomial^ p1,
    Polynomial^ p2,
    [OutAttribute] Polynomial^% remainder
)
static member Divide :
        p1 : Polynomial *
        p2 : Polynomial *
        remainder : Polynomial byref -> Polynomial

Parameters

p1
Polynomial
The dividend polynomial.
p2
Polynomial
The divisor polynomial.
remainder
Polynomial %
The remainder polynomial.

Return Value

Polynomial
The quotient polynomial.

Remarks

p1 = q p2 + r

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Evaluate Method

F#

Meta.Numerics Library
Polynomial..::Evaluate Method
Evaluates the polynomial for the given input value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Evaluate(
    double x
)
Public Overridable Function Evaluate (
    x As Double
) As Double
public:
virtual double Evaluate(
    double x
)
abstract Evaluate :
        x : float -> float
override Evaluate :
        x : float -> float

Parameters

x
Double
The value of the variable.

Return Value

Double
The value of the polynomial.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.FromCoefficients Method

F#

Meta.Numerics Library
Polynomial..::FromCoefficients Method
Initializes a new polynomial with the given coefficients.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial FromCoefficients(
    params double[] coefficients
)
Public Shared Function FromCoefficients (
    ParamArray coefficients As Double()
) As Polynomial
public:
static Polynomial^ FromCoefficients(
    ... array<double>^ coefficients
)
static member FromCoefficients :
        coefficients : float[] -> Polynomial

Parameters

coefficients
array< Double >[]()[][]
The coefficients of the polynomial.

Return Value

Polynomial
The specified polynomial.

Remarks

Coefficients should be arranged from low to high order, so that the kth entry is the coefficient of xk. For example, to specify the polynomial 5 - 6 x + 7 x2, give the values 5, -6, 7.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.FromPoints Method

F#

Meta.Numerics Library
Polynomial..::FromPoints Method

Overload List

Name | Description
FromPoints(array<Double,2>[,](,)[,][,]) | Initializes a new polynomial that passes through the given points.
FromPoints(ICollection<(Of <<'(XY>)>>)) | Initializes a new polynomial that passes through the given points.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.FromPoints Method (Double[,])

F#

Meta.Numerics Library
Polynomial..::FromPoints Method (array<Double,2>[,](,)[,][,])
Initializes a new polynomial that passes through the given points.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial FromPoints(
    double[,] points
)
Public Shared Function FromPoints (
    points As Double(,)
) As Polynomial
public:
static Polynomial^ FromPoints(
    array<double,2>^ points
)
static member FromPoints :
        points : float[,] -> Polynomial

Parameters

points
array< Double ,2>[,](,)[,][,]
An N X 2 array whose first column contains the x values of points and whose second column contains the corresponding y values.

Return Value

Polynomial
A polynomial of degree N-1 that passes through all the given points.

See Also

Polynomial Class
FromPoints Overload
Meta.Numerics Namespace


Polynomial.FromPoints Method (ICollection)

F#

Meta.Numerics Library
Polynomial..::FromPoints Method (ICollection<(Of <(<'XY>)>)>)
Initializes a new polynomial that passes through the given points.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial FromPoints(
    ICollection<XY> points
)
Public Shared Function FromPoints (
    points As ICollection(Of XY)
) As Polynomial
public:
static Polynomial^ FromPoints(
    ICollection<XY>^ points
)
static member FromPoints :
        points : ICollection<XY> -> Polynomial

Parameters

points
ICollection <(Of <(<' XY >)>)>
A collection of points.

Return Value

Polynomial
A polynomial that passes through all the given points.

See Also

Polynomial Class
FromPoints Overload
Meta.Numerics Namespace


Polynomial.Integrate Method

F#

Meta.Numerics Library
Polynomial..::Integrate Method
Integrates the polynomail.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual Polynomial Integrate(
    double C
)
Public Overridable Function Integrate (
    C As Double
) As Polynomial
public:
virtual Polynomial^ Integrate(
    double C
)
abstract Integrate :
        C : float -> Polynomial
override Integrate :
        C : float -> Polynomial

Parameters

C
Double
The integration constant.

Return Value

Polynomial
The integral of the polynomial.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.ToString Method

F#

Meta.Numerics Library
Polynomial..::ToString Method
Generates a string representation of the polynomial.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string representation of the polynomial.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial Operators

F#

Meta.Numerics Library
Polynomial Operators

The Polynomial type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(Polynomial, Polynomial) | Computes the sum of two polynomials.
Multiply(Polynomial, Polynomial) | Computes the product of two polynomials.
Subtraction(Polynomial, Polynomial) | Computes the difference of two polynomials.
UnaryNegation(Polynomial) | Negates a polynomial.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Addition Operator

F#

Meta.Numerics Library
Polynomial..::Addition Operator
Computes the sum of two polynomials.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial operator +(
    Polynomial p1,
    Polynomial p2
)
Public Shared Operator + (
    p1 As Polynomial,
    p2 As Polynomial
) As Polynomial
public:
static Polynomial^ operator +(
    Polynomial^ p1,
    Polynomial^ p2
)
static let inline (+)
        p1 : Polynomial *
        p2 : Polynomial  : Polynomial

Parameters

p1
Polynomial
The first polynomial.
p2
Polynomial
The second polynomial.

Return Value

Polynomial
The sum polynomial.

Exceptions

Exception | Condition
System..::..ArgumentNullException | p1 or p2 is null.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Multiply Operator

F#

Meta.Numerics Library
Polynomial..::Multiply Operator
Computes the product of two polynomials.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial operator *(
    Polynomial p1,
    Polynomial p2
)
Public Shared Operator * (
    p1 As Polynomial,
    p2 As Polynomial
) As Polynomial
public:
static Polynomial^ operator *(
    Polynomial^ p1,
    Polynomial^ p2
)
static let inline (*)
        p1 : Polynomial *
        p2 : Polynomial  : Polynomial

Parameters

p1
Polynomial
The first polynomial.
p2
Polynomial
The second polynomial.

Return Value

Polynomial
The product polynomial.

Exceptions

Exception | Condition
System..::..ArgumentNullException | p1 or p2 is null.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Subtraction Operator

F#

Meta.Numerics Library
Polynomial..::Subtraction Operator
Computes the difference of two polynomials.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial operator -(
    Polynomial p1,
    Polynomial p2
)
Public Shared Operator - (
    p1 As Polynomial,
    p2 As Polynomial
) As Polynomial
public:
static Polynomial^ operator -(
    Polynomial^ p1,
    Polynomial^ p2
)
static let inline (-)
        p1 : Polynomial *
        p2 : Polynomial  : Polynomial

Parameters

p1
Polynomial
The first polynomial.
p2
Polynomial
The second polynomial.

Return Value

Polynomial
The difference polynomial.

Exceptions

Exception | Condition
System..::..ArgumentNullException | p1 or p2 is null.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.UnaryNegation Operator

F#

Meta.Numerics Library
Polynomial..::UnaryNegation Operator
Negates a polynomial.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Polynomial operator -(
    Polynomial p
)
Public Shared Operator - (
    p As Polynomial
) As Polynomial
public:
static Polynomial^ operator -(
    Polynomial^ p
)
static let inline (-)
        p : Polynomial  : Polynomial

Parameters

p
Polynomial
The polynomial.

Return Value

Polynomial
The addative inverse of the polynomial.

Exceptions

Exception | Condition
System..::..ArgumentNullException | p is null.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial Properties

F#

Meta.Numerics Library
Polynomial Properties

The Polynomial type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Degree | Gets the degree of the polynomial.

See Also

Polynomial Class
Meta.Numerics Namespace


Polynomial.Degree Property

F#

Meta.Numerics Library
Polynomial..::Degree Property
Gets the degree of the polynomial.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int Degree { get; }
Public Overridable ReadOnly Property Degree As Integer
    Get
public:
virtual property int Degree {
    int get ();
}
abstract Degree : int with get
override Degree : int with get

Property Value

Int32

Remarks

The degree of a polynomial is the highest power of the variable that appears. For example, the degree of 5 + 6 x + 7 x2 is 2.

See Also

Polynomial Class
Meta.Numerics Namespace


UncertainMath Class

F#

| Members | See Also
Meta.Numerics Library
UncertainMath Class
Contains methods for computing basic mathematical functions of uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class UncertainMath
Public NotInheritable Class UncertainMath
public ref class UncertainMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UncertainMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Acos(UncertainValue) | Computes the arccosine of an uncertain value.
Asin(UncertainValue) | Computes the arcsine of an uncertain value.
Atan(UncertainValue) | Computes the arctangent of an uncertain value.
Atan2(UncertainValue, UncertainValue) | Computes the arctangent of the ratio of two uncertain values.
Cos(UncertainValue) | Computes the cosine of an uncertain value.
Cosh(UncertainValue) | Computes the hyperbolic cosine of an uncertain value.
Exp(UncertainValue) | Computes e to the power of an uncertain value.
Log(UncertainValue) | Computes the natural logarithm of an uncertain value.
Pow(UncertainValue, Double) | Computes an uncertain value raised to an arbitrary power.
Sin(UncertainValue) | Computes the sine of an uncertain value.
Sinh(UncertainValue) | Computes the hyperbolic sine of an uncertain value.
Sqrt(UncertainValue) | Computes the square root of an uncertain value.
Tan(UncertainValue) | Computes the tangent of an uncertain value.
Tanh(UncertainValue) | Computes the hyperbolic tangent of an uncertain value.

Remarks

The methods in this static class perform the same basic mathematical operations as the methods of the Math class, accounting for the uncertainty in the inputs to produce a corresponding uncertainty in the output.

As with operations on uncertain values, the methods assume that the uncertainty in input parameters represents the standard deviation of a distribution of measurements, and produce a value for the uncertainty in the output which represent a corresponding standard deviation, under the assumption that the standard deviations are small relative to the best values.

Inheritance Hierarchy

System..::..Object
Meta.Numerics..::..UncertainMath

See Also

Meta.Numerics Namespace


UncertainMath Methods

F#

Meta.Numerics Library
UncertainMath Methods

The UncertainMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Acos(UncertainValue) | Computes the arccosine of an uncertain value.
Asin(UncertainValue) | Computes the arcsine of an uncertain value.
Atan(UncertainValue) | Computes the arctangent of an uncertain value.
Atan2(UncertainValue, UncertainValue) | Computes the arctangent of the ratio of two uncertain values.
Cos(UncertainValue) | Computes the cosine of an uncertain value.
Cosh(UncertainValue) | Computes the hyperbolic cosine of an uncertain value.
Exp(UncertainValue) | Computes e to the power of an uncertain value.
Log(UncertainValue) | Computes the natural logarithm of an uncertain value.
Pow(UncertainValue, Double) | Computes an uncertain value raised to an arbitrary power.
Sin(UncertainValue) | Computes the sine of an uncertain value.
Sinh(UncertainValue) | Computes the hyperbolic sine of an uncertain value.
Sqrt(UncertainValue) | Computes the square root of an uncertain value.
Tan(UncertainValue) | Computes the tangent of an uncertain value.
Tanh(UncertainValue) | Computes the hyperbolic tangent of an uncertain value.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Acos Method

F#

Meta.Numerics Library
UncertainMath..::Acos Method
Computes the arccosine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Acos(
    UncertainValue x
)
Public Shared Function Acos (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Acos(
    UncertainValue x
)
static member Acos :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The arccosine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Asin Method

F#

Meta.Numerics Library
UncertainMath..::Asin Method
Computes the arcsine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Asin(
    UncertainValue x
)
Public Shared Function Asin (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Asin(
    UncertainValue x
)
static member Asin :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The arcsine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Atan Method

F#

Meta.Numerics Library
UncertainMath..::Atan Method
Computes the arctangent of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Atan(
    UncertainValue x
)
Public Shared Function Atan (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Atan(
    UncertainValue x
)
static member Atan :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The arctanget of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Atan2 Method

F#

Meta.Numerics Library
UncertainMath..::Atan2 Method
Computes the arctangent of the ratio of two uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Atan2(
    UncertainValue x,
    UncertainValue y
)
Public Shared Function Atan2 (
    x As UncertainValue,
    y As UncertainValue
) As UncertainValue
public:
static UncertainValue Atan2(
    UncertainValue x,
    UncertainValue y
)
static member Atan2 :
        x : UncertainValue *
        y : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument of the numerator.
y
UncertainValue
The argument of the denominator.

Return Value

UncertainValue
The arctangent of the quotient.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Cos Method

F#

Meta.Numerics Library
UncertainMath..::Cos Method
Computes the cosine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Cos(
    UncertainValue x
)
Public Shared Function Cos (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Cos(
    UncertainValue x
)
static member Cos :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The cosine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Cosh Method

F#

Meta.Numerics Library
UncertainMath..::Cosh Method
Computes the hyperbolic cosine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Cosh(
    UncertainValue x
)
Public Shared Function Cosh (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Cosh(
    UncertainValue x
)
static member Cosh :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The hyperbolic cosine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Exp Method

F#

Meta.Numerics Library
UncertainMath..::Exp Method
Computes e to the power of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Exp(
    UncertainValue x
)
Public Shared Function Exp (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Exp(
    UncertainValue x
)
static member Exp :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The value of e^x1.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Log Method

F#

Meta.Numerics Library
UncertainMath..::Log Method
Computes the natural logarithm of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Log(
    UncertainValue x
)
Public Shared Function Log (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Log(
    UncertainValue x
)
static member Log :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The value of ln(x1).

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Pow Method

F#

Meta.Numerics Library
UncertainMath..::Pow Method
Computes an uncertain value raised to an arbitrary power.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Pow(
    UncertainValue x,
    double p
)
Public Shared Function Pow (
    x As UncertainValue,
    p As Double
) As UncertainValue
public:
static UncertainValue Pow(
    UncertainValue x,
    double p
)
static member Pow :
        x : UncertainValue *
        p : float -> UncertainValue

Parameters

x
UncertainValue
The argument.
p
Double
The power.

Return Value

UncertainValue
The argument raised to the specified power.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Sin Method

F#

Meta.Numerics Library
UncertainMath..::Sin Method
Computes the sine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Sin(
    UncertainValue x
)
Public Shared Function Sin (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Sin(
    UncertainValue x
)
static member Sin :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The sine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Sinh Method

F#

Meta.Numerics Library
UncertainMath..::Sinh Method
Computes the hyperbolic sine of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Sinh(
    UncertainValue x
)
Public Shared Function Sinh (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Sinh(
    UncertainValue x
)
static member Sinh :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The hyperbolic sine of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Sqrt Method

F#

Meta.Numerics Library
UncertainMath..::Sqrt Method
Computes the square root of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Sqrt(
    UncertainValue x
)
Public Shared Function Sqrt (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Sqrt(
    UncertainValue x
)
static member Sqrt :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The square root of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Tan Method

F#

Meta.Numerics Library
UncertainMath..::Tan Method
Computes the tangent of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Tan(
    UncertainValue x
)
Public Shared Function Tan (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Tan(
    UncertainValue x
)
static member Tan :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The tanget of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainMath.Tanh Method

F#

Meta.Numerics Library
UncertainMath..::Tanh Method
Computes the hyperbolic tangent of an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue Tanh(
    UncertainValue x
)
Public Shared Function Tanh (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue Tanh(
    UncertainValue x
)
static member Tanh :
        x : UncertainValue -> UncertainValue

Parameters

x
UncertainValue
The argument.

Return Value

UncertainValue
The hyperbolic tanget of the argument.

See Also

UncertainMath Class
Meta.Numerics Namespace


UncertainValue Structure

F#

| Members | See Also
Meta.Numerics Library
UncertainValue Structure
Represents a value with an associated uncertainty.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct UncertainValue
Public Structure UncertainValue
public value class UncertainValue
[<SealedAttribute>]
type UncertainValue =  struct end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UncertainValue(Double, Double) | Initializes a new uncertain value.
Addition(Double, UncertainValue) | Adds an uncertain value to an certain value.
Addition(UncertainValue, UncertainValue) | Adds two uncertain values.
Addition(UncertainValue, Double) | Adds a certain value to an uncertain value.
ConfidenceInterval(Double) | Returns a confidence interval.
Division(UncertainValue, UncertainValue) | Divides two uncertain values.
Division(UncertainValue, Double) | Divides an uncertain value by a certain value.
Equality(UncertainValue, UncertainValue) | Determines whether two uncertain values are equal.
Equals(Object) | Determines whether the given object represents the same uncertain value. (Overrides ValueType..::..Equals(Object).)
GetHashCode()()()() | Computes a hash code for the uncertain value. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(UncertainValue, UncertainValue) | Determines whether two uncertain values are not equal.
Multiply(Double, UncertainValue) | Multiplies a certain value by an uncertain value.
Multiply(UncertainValue, UncertainValue) | Multiplies two uncertain values.
Multiply(UncertainValue, Double) | Multiplies an uncertain value by a certain value.
RelativeUncertainty | Gets the relative uncertainty.
Subtraction(Double, UncertainValue) | Subtracts an uncertain value from a certain value.
Subtraction(UncertainValue, UncertainValue) | Subtracts two uncertain values.
Subtraction(UncertainValue, Double) | Subtracts a certain value from an uncertain value.
ToString()()()() | Creates a string representation of the uncertain value. (Overrides ValueType..::..ToString()()()().)
UnaryNegation(UncertainValue) | Negates an uncertain value.
Uncertainty | Gets the uncertainty.
Value | Gets the best estimate.

See Also

Meta.Numerics Namespace


UncertainValue Constructor

F#

Meta.Numerics Library
UncertainValue Constructor
Initializes a new uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue(
    double value,
    double uncertainty
)
Public Sub New (
    value As Double,
    uncertainty As Double
)
public:
UncertainValue(
    double value,
    double uncertainty
)
new :
        value : float *
        uncertainty : float -> UncertainValue

Parameters

value
Double
The best estimate of the value.
uncertainty
Double
The uncertainty in the value.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | uncertainty is negative.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue Methods

F#

Meta.Numerics Library
UncertainValue Methods

The UncertainValue type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConfidenceInterval(Double) | Returns a confidence interval.
Equals(Object) | Determines whether the given object represents the same uncertain value. (Overrides ValueType..::..Equals(Object).)
GetHashCode()()()() | Computes a hash code for the uncertain value. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Creates a string representation of the uncertain value. (Overrides ValueType..::..ToString()()()().)

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.ConfidenceInterval Method

F#

Meta.Numerics Library
UncertainValue..::ConfidenceInterval Method
Returns a confidence interval.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Interval ConfidenceInterval(
    double P
)
Public Function ConfidenceInterval (
    P As Double
) As Interval
public:
Interval ConfidenceInterval(
    double P
)
member ConfidenceInterval :
        P : float -> Interval

Parameters

P
Double
The required confidence level.

Return Value

Interval
The associated confidence interval.

Remarks

This method assumes

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Equals Method

F#

Meta.Numerics Library
UncertainValue..::Equals Method
Determines whether the given object represents the same uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object.

Return Value

Boolean
True if the object represents the same reference point, otherwise false.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.GetHashCode Method

F#

Meta.Numerics Library
UncertainValue..::GetHashCode Method
Computes a hash code for the uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A hash code.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.ToString Method

F#

Meta.Numerics Library
UncertainValue..::ToString Method
Creates a string representation of the uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string of the format value ± uncertainty.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue Operators

F#

Meta.Numerics Library
UncertainValue Operators

The UncertainValue type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(Double, UncertainValue) | Adds an uncertain value to an certain value.
Addition(UncertainValue, UncertainValue) | Adds two uncertain values.
Addition(UncertainValue, Double) | Adds a certain value to an uncertain value.
Division(UncertainValue, UncertainValue) | Divides two uncertain values.
Division(UncertainValue, Double) | Divides an uncertain value by a certain value.
Equality(UncertainValue, UncertainValue) | Determines whether two uncertain values are equal.
Inequality(UncertainValue, UncertainValue) | Determines whether two uncertain values are not equal.
Multiply(Double, UncertainValue) | Multiplies a certain value by an uncertain value.
Multiply(UncertainValue, UncertainValue) | Multiplies two uncertain values.
Multiply(UncertainValue, Double) | Multiplies an uncertain value by a certain value.
Subtraction(Double, UncertainValue) | Subtracts an uncertain value from a certain value.
Subtraction(UncertainValue, UncertainValue) | Subtracts two uncertain values.
Subtraction(UncertainValue, Double) | Subtracts a certain value from an uncertain value.
UnaryNegation(UncertainValue) | Negates an uncertain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Addition Method

F#

Meta.Numerics Library
UncertainValue..::Addition Method

Overload List

Name | Description
Addition(Double, UncertainValue) | Adds an uncertain value to an certain value.
Addition(UncertainValue, UncertainValue) | Adds two uncertain values.
Addition(UncertainValue, Double) | Adds a certain value to an uncertain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Addition Operator (Double, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Addition Operator (Double, UncertainValue)
Adds an uncertain value to an certain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator +(
    double v1,
    UncertainValue u2
)
Public Shared Operator + (
    v1 As Double,
    u2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator +(
    double v1,
    UncertainValue u2
)
static let inline (+)
        v1 : float *
        u2 : UncertainValue  : UncertainValue

Parameters

v1
Double
The certain value.
u2
UncertainValue
The uncertain value.

Return Value

UncertainValue
The sum of the two values.

See Also

UncertainValue Structure
Addition Overload
Meta.Numerics Namespace


UncertainValue.Addition Operator (UncertainValue, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Addition Operator (UncertainValue, UncertainValue)
Adds two uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator +(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator + (
    v1 As UncertainValue,
    v2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator +(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (+)
        v1 : UncertainValue *
        v2 : UncertainValue  : UncertainValue

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

UncertainValue
The sum of the two uncertain values.

See Also

UncertainValue Structure
Addition Overload
Meta.Numerics Namespace


UncertainValue.Addition Operator (UncertainValue, Double)

F#

Meta.Numerics Library
UncertainValue..::Addition Operator (UncertainValue, Double)
Adds a certain value to an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator +(
    UncertainValue u1,
    double v2
)
Public Shared Operator + (
    u1 As UncertainValue,
    v2 As Double
) As UncertainValue
public:
static UncertainValue operator +(
    UncertainValue u1,
    double v2
)
static let inline (+)
        u1 : UncertainValue *
        v2 : float  : UncertainValue

Parameters

u1
UncertainValue
The uncertain value.
v2
Double
The certain value.

Return Value

UncertainValue
The sum of the two values.

See Also

UncertainValue Structure
Addition Overload
Meta.Numerics Namespace


UncertainValue.Division Method

F#

Meta.Numerics Library
UncertainValue..::Division Method

Overload List

Name | Description
Division(UncertainValue, UncertainValue) | Divides two uncertain values.
Division(UncertainValue, Double) | Divides an uncertain value by a certain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Division Operator (UncertainValue, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Division Operator (UncertainValue, UncertainValue)
Divides two uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator /(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator / (
    v1 As UncertainValue,
    v2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator /(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (/)
        v1 : UncertainValue *
        v2 : UncertainValue  : UncertainValue

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

UncertainValue
The quotient of the two uncertain values.

See Also

UncertainValue Structure
Division Overload
Meta.Numerics Namespace


UncertainValue.Division Operator (UncertainValue, Double)

F#

Meta.Numerics Library
UncertainValue..::Division Operator (UncertainValue, Double)
Divides an uncertain value by a certain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator /(
    UncertainValue u1,
    double v2
)
Public Shared Operator / (
    u1 As UncertainValue,
    v2 As Double
) As UncertainValue
public:
static UncertainValue operator /(
    UncertainValue u1,
    double v2
)
static let inline (/)
        u1 : UncertainValue *
        v2 : float  : UncertainValue

Parameters

u1
UncertainValue
The uncertain value.
v2
Double
The certain value.

Return Value

UncertainValue
The quotient of the two values.

See Also

UncertainValue Structure
Division Overload
Meta.Numerics Namespace


UncertainValue.Equality Operator

F#

Meta.Numerics Library
UncertainValue..::Equality Operator
Determines whether two uncertain values are equal.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator = (
    v1 As UncertainValue,
    v2 As UncertainValue
) As Boolean
public:
static bool operator ==(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (=)
        v1 : UncertainValue *
        v2 : UncertainValue  : bool

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

Boolean
True if the two uncertain values are equal, otherwise false.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Inequality Operator

F#

Meta.Numerics Library
UncertainValue..::Inequality Operator
Determines whether two uncertain values are not equal.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator <> (
    v1 As UncertainValue,
    v2 As UncertainValue
) As Boolean
public:
static bool operator !=(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (<>)
        v1 : UncertainValue *
        v2 : UncertainValue  : bool

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

Boolean
True if the two uncertain values not are equal, otherwise false.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Multiply Method

F#

Meta.Numerics Library
UncertainValue..::Multiply Method

Overload List

Name | Description
Multiply(Double, UncertainValue) | Multiplies a certain value by an uncertain value.
Multiply(UncertainValue, UncertainValue) | Multiplies two uncertain values.
Multiply(UncertainValue, Double) | Multiplies an uncertain value by a certain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Multiply Operator (Double, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Multiply Operator (Double, UncertainValue)
Multiplies a certain value by an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator *(
    double v1,
    UncertainValue u2
)
Public Shared Operator * (
    v1 As Double,
    u2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator *(
    double v1,
    UncertainValue u2
)
static let inline (*)
        v1 : float *
        u2 : UncertainValue  : UncertainValue

Parameters

v1
Double
The certain value.
u2
UncertainValue
The uncertain value.

Return Value

UncertainValue
The product of the two values.

See Also

UncertainValue Structure
Multiply Overload
Meta.Numerics Namespace


UncertainValue.Multiply Operator (UncertainValue, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Multiply Operator (UncertainValue, UncertainValue)
Multiplies two uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator *(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator * (
    v1 As UncertainValue,
    v2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator *(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (*)
        v1 : UncertainValue *
        v2 : UncertainValue  : UncertainValue

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

UncertainValue
The product of the two uncertain values.

See Also

UncertainValue Structure
Multiply Overload
Meta.Numerics Namespace


UncertainValue.Multiply Operator (UncertainValue, Double)

F#

Meta.Numerics Library
UncertainValue..::Multiply Operator (UncertainValue, Double)
Multiplies an uncertain value by a certain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator *(
    UncertainValue u1,
    double v2
)
Public Shared Operator * (
    u1 As UncertainValue,
    v2 As Double
) As UncertainValue
public:
static UncertainValue operator *(
    UncertainValue u1,
    double v2
)
static let inline (*)
        u1 : UncertainValue *
        v2 : float  : UncertainValue

Parameters

u1
UncertainValue
The uncertain value.
v2
Double
The certain value.

Return Value

UncertainValue
The product of the two values.

See Also

UncertainValue Structure
Multiply Overload
Meta.Numerics Namespace


UncertainValue.Subtraction Method

F#

Meta.Numerics Library
UncertainValue..::Subtraction Method

Overload List

Name | Description
Subtraction(Double, UncertainValue) | Subtracts an uncertain value from a certain value.
Subtraction(UncertainValue, UncertainValue) | Subtracts two uncertain values.
Subtraction(UncertainValue, Double) | Subtracts a certain value from an uncertain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Subtraction Operator (Double, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Subtraction Operator (Double, UncertainValue)
Subtracts an uncertain value from a certain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator -(
    double v1,
    UncertainValue u2
)
Public Shared Operator - (
    v1 As Double,
    u2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator -(
    double v1,
    UncertainValue u2
)
static let inline (-)
        v1 : float *
        u2 : UncertainValue  : UncertainValue

Parameters

v1
Double
The certain value.
u2
UncertainValue
The uncertain vlaue.

Return Value

UncertainValue
The difference between the two values.

See Also

UncertainValue Structure
Subtraction Overload
Meta.Numerics Namespace


UncertainValue.Subtraction Operator (UncertainValue, UncertainValue)

F#

Meta.Numerics Library
UncertainValue..::Subtraction Operator (UncertainValue, UncertainValue)
Subtracts two uncertain values.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator -(
    UncertainValue v1,
    UncertainValue v2
)
Public Shared Operator - (
    v1 As UncertainValue,
    v2 As UncertainValue
) As UncertainValue
public:
static UncertainValue operator -(
    UncertainValue v1,
    UncertainValue v2
)
static let inline (-)
        v1 : UncertainValue *
        v2 : UncertainValue  : UncertainValue

Parameters

v1
UncertainValue
The first uncertain value.
v2
UncertainValue
The second uncertain value.

Return Value

UncertainValue
The difference of the two uncertain values.

See Also

UncertainValue Structure
Subtraction Overload
Meta.Numerics Namespace


UncertainValue.Subtraction Operator (UncertainValue, Double)

F#

Meta.Numerics Library
UncertainValue..::Subtraction Operator (UncertainValue, Double)
Subtracts a certain value from an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator -(
    UncertainValue u1,
    double v2
)
Public Shared Operator - (
    u1 As UncertainValue,
    v2 As Double
) As UncertainValue
public:
static UncertainValue operator -(
    UncertainValue u1,
    double v2
)
static let inline (-)
        u1 : UncertainValue *
        v2 : float  : UncertainValue

Parameters

u1
UncertainValue
The uncertain value.
v2
Double
The certain value.

Return Value

UncertainValue
The difference between the two values.

See Also

UncertainValue Structure
Subtraction Overload
Meta.Numerics Namespace


UncertainValue.UnaryNegation Operator

F#

Meta.Numerics Library
UncertainValue..::UnaryNegation Operator
Negates an uncertain value.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static UncertainValue operator -(
    UncertainValue x
)
Public Shared Operator - (
    x As UncertainValue
) As UncertainValue
public:
static UncertainValue operator -(
    UncertainValue x
)
static let inline (-)
        x : UncertainValue  : UncertainValue

Parameters

x
UncertainValue
The uncertain value.

Return Value

UncertainValue
The negative of the uncertain value.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue Properties

F#

Meta.Numerics Library
UncertainValue Properties

The UncertainValue type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RelativeUncertainty | Gets the relative uncertainty.
Uncertainty | Gets the uncertainty.
Value | Gets the best estimate.

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.RelativeUncertainty Property

F#

Meta.Numerics Library
UncertainValue..::RelativeUncertainty Property
Gets the relative uncertainty.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double RelativeUncertainty { get; }
Public ReadOnly Property RelativeUncertainty As Double
    Get
public:
property double RelativeUncertainty {
    double get ();
}
member RelativeUncertainty : float with get

Property Value

Double

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Uncertainty Property

F#

Meta.Numerics Library
UncertainValue..::Uncertainty Property
Gets the uncertainty.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Uncertainty { get; }
Public ReadOnly Property Uncertainty As Double
    Get
public:
property double Uncertainty {
    double get ();
}
member Uncertainty : float with get

Property Value

Double

See Also

UncertainValue Structure
Meta.Numerics Namespace


UncertainValue.Value Property

F#

Meta.Numerics Library
UncertainValue..::Value Property
Gets the best estimate.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Double

See Also

UncertainValue Structure
Meta.Numerics Namespace


XY Structure

F#

| Members | See Also
Meta.Numerics Library
XY Structure
Represents a two-dimensional point.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct XY
Public Structure XY
public value class XY
[<SealedAttribute>]
type XY =  struct end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
XY(Double, Double) | Initializes a new point with the given coordinates.
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
X | Gets the X-coordinate of the point.
Y | Gets the Y-coordinate of the point.

See Also

Meta.Numerics Namespace


XY Constructor

F#

Meta.Numerics Library
XY Constructor
Initializes a new point with the given coordinates.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public XY(
    double x,
    double y
)
Public Sub New (
    x As Double,
    y As Double
)
public:
XY(
    double x,
    double y
)
new :
        x : float *
        y : float -> XY

Parameters

x
Double
The X-corrdinate.
y
Double
The Y-coordinate.

See Also

XY Structure
Meta.Numerics Namespace


XY Methods

F#

Meta.Numerics Library
XY Methods

The XY type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

XY Structure
Meta.Numerics Namespace


XY Properties

F#

Meta.Numerics Library
XY Properties

The XY type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
X | Gets the X-coordinate of the point.
Y | Gets the Y-coordinate of the point.

See Also

XY Structure
Meta.Numerics Namespace


XY.X Property

F#

Meta.Numerics Library
XY..::X Property
Gets the X-coordinate of the point.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}
member X : float with get

Property Value

Double

See Also

XY Structure
Meta.Numerics Namespace


XY.Y Property

F#

Meta.Numerics Library
XY..::Y Property
Gets the Y-coordinate of the point.

Namespace: Meta.Numerics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}
member Y : float with get

Property Value

Double

See Also

XY Structure
Meta.Numerics Namespace


Meta.Numerics.Analysis Namespace

F#

Meta.Numerics Library
Meta.Numerics.Analysis Namespace
Contains types used to analyze user-supplied functions.

Types

All Types | Classes
Name | Description
EvaluationResult | Represents the result of a function analysis.
EvaluationSettings | Contains settings controling the evaluation of a function.
Extremum | Represents a maximum or minimum of a function of one variable.
FunctionMath | Contains methods for the analysis of functions.
IntegrationResult | Represents the result of a numerical integration.
MultiExtremum | Represents a minimum or maximum of a multidimensional function.
MultiFunctionMath | Contains methods for the analysis of multi-dimensional functions.


EvaluationResult Class

F#

| Members | See Also
Meta.Numerics Library
EvaluationResult Class
Represents the result of a function analysis.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class EvaluationResult
Public Class EvaluationResult
public ref class EvaluationResult
type EvaluationResult =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EvaluationCount | Gets the number of function evaluations performed.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Settings | Gets the settings used for the analysis.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

This is the base class for all function analysis result classes.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..EvaluationResult
Meta.Numerics.Analysis..::..Extremum
Meta.Numerics.Analysis..::..IntegrationResult
Meta.Numerics.Analysis..::..MultiExtremum

See Also

Meta.Numerics.Analysis Namespace


EvaluationResult Methods

F#

Meta.Numerics Library
EvaluationResult Methods

The EvaluationResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

EvaluationResult Class
Meta.Numerics.Analysis Namespace


EvaluationResult Properties

F#

Meta.Numerics Library
EvaluationResult Properties

The EvaluationResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EvaluationCount | Gets the number of function evaluations performed.
Settings | Gets the settings used for the analysis.

See Also

EvaluationResult Class
Meta.Numerics.Analysis Namespace


EvaluationResult.EvaluationCount Property

F#

Meta.Numerics Library
EvaluationResult..::EvaluationCount Property
Gets the number of function evaluations performed.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int EvaluationCount { get; }
Public ReadOnly Property EvaluationCount As Integer
    Get
public:
property int EvaluationCount {
    int get ();
}
member EvaluationCount : int with get

Property Value

Int32

See Also

EvaluationResult Class
Meta.Numerics.Analysis Namespace


EvaluationResult.Settings Property

F#

Meta.Numerics Library
EvaluationResult..::Settings Property
Gets the settings used for the analysis.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public EvaluationSettings Settings { get; }
Public ReadOnly Property Settings As EvaluationSettings
    Get
public:
property EvaluationSettings^ Settings {
    EvaluationSettings^ get ();
}
member Settings : EvaluationSettings with get

Property Value

EvaluationSettings

See Also

EvaluationResult Class
Meta.Numerics.Analysis Namespace


EvaluationSettings Class

F#

| Members | See Also
Meta.Numerics Library
EvaluationSettings Class
Contains settings controling the evaluation of a function.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class EvaluationSettings
Public Class EvaluationSettings
public ref class EvaluationSettings
type EvaluationSettings =  class end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EvaluationSettings()()()() | Initializes a new set of default evaulation settings.
AbsolutePrecision | Gets or sets the targeted absolute precision.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EvaluationBudget | Gets or sets the total number of evaluations allowed.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
RelativePrecision | Gets or sets targeted relative precision.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..EvaluationSettings

See Also

Meta.Numerics.Analysis Namespace


EvaluationSettings Constructor

F#

Meta.Numerics Library
EvaluationSettings Constructor
Initializes a new set of default evaulation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public EvaluationSettings()
Public Sub New
public:
EvaluationSettings()
new : unit -> EvaluationSettings

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


EvaluationSettings Methods

F#

Meta.Numerics Library
EvaluationSettings Methods

The EvaluationSettings type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


EvaluationSettings Properties

F#

Meta.Numerics Library
EvaluationSettings Properties

The EvaluationSettings type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AbsolutePrecision | Gets or sets the targeted absolute precision.
EvaluationBudget | Gets or sets the total number of evaluations allowed.
RelativePrecision | Gets or sets targeted relative precision.

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


EvaluationSettings.AbsolutePrecision Property

F#

Meta.Numerics Library
EvaluationSettings..::AbsolutePrecision Property
Gets or sets the targeted absolute precision.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double AbsolutePrecision { get; set; }
Public Property AbsolutePrecision As Double
    Get
    Set
public:
property double AbsolutePrecision {
    double get ();
    void set (double value);
}
member AbsolutePrecision : float with get, set

Property Value

Double
The absolute precision to which the result should be evaluated, which must be non-negative.

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


EvaluationSettings.EvaluationBudget Property

F#

Meta.Numerics Library
EvaluationSettings..::EvaluationBudget Property
Gets or sets the total number of evaluations allowed.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int EvaluationBudget { get; set; }
Public Property EvaluationBudget As Integer
    Get
    Set
public:
property int EvaluationBudget {
    int get ();
    void set (int value);
}
member EvaluationBudget : int with get, set

Property Value

Int32
The total number of evaluations allowed, which must be non-negative.

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


EvaluationSettings.RelativePrecision Property

F#

Meta.Numerics Library
EvaluationSettings..::RelativePrecision Property
Gets or sets targeted relative precision.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double RelativePrecision { get; set; }
Public Property RelativePrecision As Double
    Get
    Set
public:
property double RelativePrecision {
    double get ();
    void set (double value);
}
member RelativePrecision : float with get, set

Property Value

Double
The relative precision to which the result should be evaluated, which must be between 0 and 1.

See Also

EvaluationSettings Class
Meta.Numerics.Analysis Namespace


Extremum Class

F#

| Members | See Also
Meta.Numerics Library
Extremum Class
Represents a maximum or minimum of a function of one variable.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class Extremum : EvaluationResult
Public NotInheritable Class Extremum
    Inherits EvaluationResult
public ref class Extremum sealed : public EvaluationResult
[<SealedAttribute>]
type Extremum =
    class
        inherit EvaluationResult
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Curvature | Gets the curvature at the extremum.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Location | Gets the location (x-value) of the extremum.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Value | Gets the function value (y-value) at the extremum.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..EvaluationResult
Meta.Numerics.Analysis..::..Extremum

See Also

Meta.Numerics.Analysis Namespace


Extremum Methods

F#

Meta.Numerics Library
Extremum Methods

The Extremum type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

Extremum Class
Meta.Numerics.Analysis Namespace


Extremum Properties

F#

Meta.Numerics Library
Extremum Properties

The Extremum type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Curvature | Gets the curvature at the extremum.
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
Location | Gets the location (x-value) of the extremum.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
Value | Gets the function value (y-value) at the extremum.

See Also

Extremum Class
Meta.Numerics.Analysis Namespace


Extremum.Curvature Property

F#

Meta.Numerics Library
Extremum..::Curvature Property
Gets the curvature at the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Curvature { get; }
Public ReadOnly Property Curvature As Double
    Get
public:
property double Curvature {
    double get ();
}
member Curvature : float with get

Property Value

Double

Remarks

The curvature is the second derivative of the function at the extremum.

At a typical extremum, where the function has vanishing first derivative, the second derivative will be a number whose magnitude characterizes the "steepness" with which the function increases as one moves away from the extremum.

At an atypical extremum, for example at an interval boundary or of a non-smooth function, this value may be meaningless.

Even in the case of a typical extremum, the value of the curvature property will typically be accurate only to a handfull of digits. If you require a highly accurate determination of the curvature, you should compute the second derivative of the minimzed function explicitly.

See Also

Extremum Class
Meta.Numerics.Analysis Namespace


Extremum.Location Property

F#

Meta.Numerics Library
Extremum..::Location Property
Gets the location (x-value) of the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Location { get; }
Public ReadOnly Property Location As Double
    Get
public:
property double Location {
    double get ();
}
member Location : float with get

Property Value

Double

Remarks

Note that numerical methods for finding typical a maximum or minimum cannot usually determine its location to full floating-point precision. Near a quadratic extremum, a change in x of ~ε will change f(x) by ~ε2. Thus the smallest detectable change in f(x) will typically correspond to a change in x of order of the square root of full precision. Full Double precision being ~16 digits, you should expect the location to be accurate only to ~8 digits.

See Also

Extremum Class
Meta.Numerics.Analysis Namespace


Extremum.Value Property

F#

Meta.Numerics Library
Extremum..::Value Property
Gets the function value (y-value) at the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Double

See Also

Extremum Class
Meta.Numerics.Analysis Namespace


FunctionMath Class

F#

| Members | See Also
Meta.Numerics Library
FunctionMath Class
Contains methods for the analysis of functions.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class FunctionMath
Public NotInheritable Class FunctionMath
public ref class FunctionMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FunctionMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval) | Maximizes a function on the given interval.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double) | Maximizes a function in the vicinity of a given point.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Maximizes a function on the given interval, subject to the given evaluation settings.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Maximizes a function in the vicinity of a given point, subject to the given evaluation settings.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval) | Minimizes a function on the given interval.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double) | Minimizes a function in the vicinity of a given point.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Minimizes a function on the given interval, subject to the given evaluation settings.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Minimizes a function in the vicinity of a given point subject to the given evaluation settings.
FindZero(Func<(Of <<'(Double, Double>)>>), Interval) | Isolates a root within a given interval.
FindZero(Func<(Of <<'(Double, Double>)>>), Double) | Isolates a root in the vicinity of a given point.
Integrate(Func<(Of <<'(Double, Double>)>>), Interval) | Evaluates a definite integral.
Integrate(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Evaluates a definite integral with the given evaluation settings.

Remarks

Function analysis includes integration, finding maxima and minima, and finding roots.

This class contains methods for the analysis of functions that both accept a single real argument and return a single real value. For the analysis of multi-dimensional functions, see the MultiFunctionMath class.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..FunctionMath

See Also

Meta.Numerics.Analysis Namespace


FunctionMath Methods

F#

Meta.Numerics Library
FunctionMath Methods

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval) | Maximizes a function on the given interval.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double) | Maximizes a function in the vicinity of a given point.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Maximizes a function on the given interval, subject to the given evaluation settings.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Maximizes a function in the vicinity of a given point, subject to the given evaluation settings.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval) | Minimizes a function on the given interval.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double) | Minimizes a function in the vicinity of a given point.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Minimizes a function on the given interval, subject to the given evaluation settings.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Minimizes a function in the vicinity of a given point subject to the given evaluation settings.
FindZero(Func<(Of <<'(Double, Double>)>>), Interval) | Isolates a root within a given interval.
FindZero(Func<(Of <<'(Double, Double>)>>), Double) | Isolates a root in the vicinity of a given point.
Integrate(Func<(Of <<'(Double, Double>)>>), Interval) | Evaluates a definite integral.
Integrate(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Evaluates a definite integral with the given evaluation settings.

See Also

FunctionMath Class
Meta.Numerics.Analysis Namespace


FunctionMath.FindMaximum Method

F#

Meta.Numerics Library
FunctionMath..::FindMaximum Method

Overload List

Name | Description
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval) | Maximizes a function on the given interval.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double) | Maximizes a function in the vicinity of a given point.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Maximizes a function on the given interval, subject to the given evaluation settings.
FindMaximum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Maximizes a function in the vicinity of a given point, subject to the given evaluation settings.

See Also

FunctionMath Class
Meta.Numerics.Analysis Namespace


FunctionMath.FindMaximum Method (Func, Interval)

F#

Meta.Numerics Library
FunctionMath..::FindMaximum Method (Func<(Of <(<'Double, Double>)>)>, Interval)
Maximizes a function on the given interval.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMaximum(
    Func<double, double> f,
    Interval r
)
Public Shared Function FindMaximum (
    f As Func(Of Double, Double),
    r As Interval
) As Extremum
public:
static Extremum^ FindMaximum(
    Func<double, double>^ f,
    Interval r
)
static member FindMaximum :
        f : Func<float, float> *
        r : Interval -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
r
Interval
The interval.

Return Value

Extremum
The maximum.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a minimum being determined.

See Also

FunctionMath Class
FindMaximum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMaximum Method (Func, Double)

F#

Meta.Numerics Library
FunctionMath..::FindMaximum Method (Func<(Of <(<'Double, Double>)>)>, Double)
Maximizes a function in the vicinity of a given point.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMaximum(
    Func<double, double> f,
    double x
)
Public Shared Function FindMaximum (
    f As Func(Of Double, Double),
    x As Double
) As Extremum
public:
static Extremum^ FindMaximum(
    Func<double, double>^ f,
    double x
)
static member FindMaximum :
        f : Func<float, float> *
        x : float -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
x
Double
A point suspected to be near the maximum. The search begins at this point.

Return Value

Extremum
The maximum.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a maximum being determined.

See Also

FunctionMath Class
FindMaximum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMaximum Method (Func, Interval, EvaluationSettings)

F#

Meta.Numerics Library
FunctionMath..::FindMaximum Method (Func<(Of <(<'Double, Double>)>)>, Interval, EvaluationSettings)
Maximizes a function on the given interval, subject to the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMaximum(
    Func<double, double> f,
    Interval r,
    EvaluationSettings settings
)
Public Shared Function FindMaximum (
    f As Func(Of Double, Double),
    r As Interval,
    settings As EvaluationSettings
) As Extremum
public:
static Extremum^ FindMaximum(
    Func<double, double>^ f,
    Interval r,
    EvaluationSettings^ settings
)
static member FindMaximum :
        f : Func<float, float> *
        r : Interval *
        settings : EvaluationSettings -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
r
Interval
The interval.
settings
EvaluationSettings
The settings used when searching for the maximum.

Return Value

Extremum
The maximum.

Remarks

When you supply settings, note that the supplied RelativePrecision and AbsolutePrecision values refer to argument (i.e. x) values, not function (i.e. f) values. Note also that, for typical functions, the best attainable relative precision is of the order of the square root of machine precision (about 10-7), i.e. half the number of digits in a Double. This is because to identify an extremum we need to resolve changes in the function value, and near an extremum δf ∼ (δx)2, so changes in the function value δf ∼ ε correspond to changes in the argument value δx ∼ √ε. If you supply zero values for both precision settings, the method will adaptively approximate the best attainable precision for the supplied function and locate the extremum to that resolution. This is our suggested practice unless you know that you require a less precise determination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null or settings is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a maximum being determined to the prescribed precision.

See Also

FunctionMath Class
FindMaximum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMaximum Method (Func, Double, EvaluationSettings)

F#

Meta.Numerics Library
FunctionMath..::FindMaximum Method (Func<(Of <(<'Double, Double>)>)>, Double, EvaluationSettings)
Maximizes a function in the vicinity of a given point, subject to the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMaximum(
    Func<double, double> f,
    double x,
    EvaluationSettings settings
)
Public Shared Function FindMaximum (
    f As Func(Of Double, Double),
    x As Double,
    settings As EvaluationSettings
) As Extremum
public:
static Extremum^ FindMaximum(
    Func<double, double>^ f,
    double x,
    EvaluationSettings^ settings
)
static member FindMaximum :
        f : Func<float, float> *
        x : float *
        settings : EvaluationSettings -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
x
Double
A point suspected to be near the maximum. The search begins at this point.
settings
EvaluationSettings
The settings to use when searching for the maximum.

Return Value

Extremum
The maximum.

Remarks

When you supply settings, note that the supplied RelativePrecision and AbsolutePrecision values refer to argument (i.e. x) values, not function (i.e. f) values. Note also that, for typical functions, the best attainable relative precision is of the order of the square root of machine precision (about 10-7), i.e. half the number of digits in a Double. This is because to identify an extremum we need to resolve changes in the function value, and near an extremum δf ∼ (δx)2, so changes in the function value δf ∼ ε correspond to changes in the argument value δx ∼ √ε. If you supply zero values for both precision settings, the method will adaptively approximate the best attainable precision for the supplied function and locate the extremum to that resolution. This is our suggested practice unless you know that you require a less precise determination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null or settings is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a maximum being determined to the prescribed precision.

See Also

FunctionMath Class
FindMaximum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMinimum Method

F#

Meta.Numerics Library
FunctionMath..::FindMinimum Method

Overload List

Name | Description
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval) | Minimizes a function on the given interval.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double) | Minimizes a function in the vicinity of a given point.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Minimizes a function on the given interval, subject to the given evaluation settings.
FindMinimum(Func<(Of <<'(Double, Double>)>>), Double, EvaluationSettings) | Minimizes a function in the vicinity of a given point subject to the given evaluation settings.

See Also

FunctionMath Class
Meta.Numerics.Analysis Namespace


FunctionMath.FindMinimum Method (Func, Interval)

F#

Meta.Numerics Library
FunctionMath..::FindMinimum Method (Func<(Of <(<'Double, Double>)>)>, Interval)
Minimizes a function on the given interval.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMinimum(
    Func<double, double> f,
    Interval r
)
Public Shared Function FindMinimum (
    f As Func(Of Double, Double),
    r As Interval
) As Extremum
public:
static Extremum^ FindMinimum(
    Func<double, double>^ f,
    Interval r
)
static member FindMinimum :
        f : Func<float, float> *
        r : Interval -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
r
Interval
The interval.

Return Value

Extremum
The minimum.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a minimum being determined.

See Also

FunctionMath Class
FindMinimum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMinimum Method (Func, Double)

F#

Meta.Numerics Library
FunctionMath..::FindMinimum Method (Func<(Of <(<'Double, Double>)>)>, Double)
Minimizes a function in the vicinity of a given point.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMinimum(
    Func<double, double> f,
    double x
)
Public Shared Function FindMinimum (
    f As Func(Of Double, Double),
    x As Double
) As Extremum
public:
static Extremum^ FindMinimum(
    Func<double, double>^ f,
    double x
)
static member FindMinimum :
        f : Func<float, float> *
        x : float -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
x
Double
A point suspected to be near the minimum. The search begins at this point.

Return Value

Extremum
The minimum.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a minimum being determined.

See Also

FunctionMath Class
FindMinimum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMinimum Method (Func, Interval, EvaluationSettings)

F#

Meta.Numerics Library
FunctionMath..::FindMinimum Method (Func<(Of <(<'Double, Double>)>)>, Interval, EvaluationSettings)
Minimizes a function on the given interval, subject to the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMinimum(
    Func<double, double> f,
    Interval r,
    EvaluationSettings settings
)
Public Shared Function FindMinimum (
    f As Func(Of Double, Double),
    r As Interval,
    settings As EvaluationSettings
) As Extremum
public:
static Extremum^ FindMinimum(
    Func<double, double>^ f,
    Interval r,
    EvaluationSettings^ settings
)
static member FindMinimum :
        f : Func<float, float> *
        r : Interval *
        settings : EvaluationSettings -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
r
Interval
The interval.
settings
EvaluationSettings
The settings used when searching for the minimum.

Return Value

Extremum
The minimum.

Remarks

When you supply settings, note that the supplied RelativePrecision and AbsolutePrecision values refer to argument (i.e. x) values, not function (i.e. f) values. Note also that, for typical functions, the best attainable relative precision is of the order of the square root of machine precision (about 10-7), i.e. half the number of digits in a Double. This is because to identify an extremum we need to resolve changes in the function value, and near an extremum δf ∼ (δx)2, so changes in the function value δf ∼ ε correspond to changes in the argument value δx ∼ √ε. If you supply zero values for both precision settings, the method will adaptively approximate the best attainable precision for the supplied function and locate the extremum to that resolution. This is our suggested practice unless you know that you require a less precise determination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null or settings is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a minimum being determined to the prescribed precision.

See Also

FunctionMath Class
FindMinimum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindMinimum Method (Func, Double, EvaluationSettings)

F#

Meta.Numerics Library
FunctionMath..::FindMinimum Method (Func<(Of <(<'Double, Double>)>)>, Double, EvaluationSettings)
Minimizes a function in the vicinity of a given point subject to the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Extremum FindMinimum(
    Func<double, double> f,
    double x,
    EvaluationSettings settings
)
Public Shared Function FindMinimum (
    f As Func(Of Double, Double),
    x As Double,
    settings As EvaluationSettings
) As Extremum
public:
static Extremum^ FindMinimum(
    Func<double, double>^ f,
    double x,
    EvaluationSettings^ settings
)
static member FindMinimum :
        f : Func<float, float> *
        x : float *
        settings : EvaluationSettings -> Extremum

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.
x
Double
A point suspected to be near the minimum. The search begins at this point.
settings
EvaluationSettings
The settings to use when searching for the minimum.

Return Value

Extremum
The minimum.

Remarks

When you supply settings, note that the supplied RelativePrecision and AbsolutePrecision values refer to argument (i.e. x) values, not function (i.e. f) values. Note also that, for typical functions, the best attainable relative precision is of the order of the square root of machine precision (about 10-7), i.e. half the number of digits in a Double. This is because to identify an extremum we need to resolve changes in the function value, and near an extremum δf ∼ (δx)2, so changes in the function value δf ∼ ε correspond to changes in the argument value δx ∼ √ε. If you supply zero values for both precision settings, the method will adaptively approximate the best attainable precision for the supplied function and locate the extremum to that resolution. This is our suggested practice unless you know that you require a less precise determination.

Since the search algorithm begins by evaluating f at points near x, it can fail if x is near a singularity or other point at which the evaluation of f could fail. If you can reliably bracket an extremum, the FindMinimum(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) overload of this method is safer and, if your bracket is any good, usually slightly faster.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f is null or settings is null.
Meta.Numerics..::..NonconvergenceException | More than the maximum allowed number of function evaluations occured without a minimum being determined to the prescribed precision.

See Also

FunctionMath Class
FindMinimum Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindZero Method

F#

Meta.Numerics Library
FunctionMath..::FindZero Method

Overload List

Name | Description
FindZero(Func<(Of <<'(Double, Double>)>>), Interval) | Isolates a root within a given interval.
FindZero(Func<(Of <<'(Double, Double>)>>), Double) | Isolates a root in the vicinity of a given point.

See Also

FunctionMath Class
Meta.Numerics.Analysis Namespace


FunctionMath.FindZero Method (Func, Interval)

F#

Meta.Numerics Library
FunctionMath..::FindZero Method (Func<(Of <(<'Double, Double>)>)>, Interval)
Isolates a root within a given interval.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double FindZero(
    Func<double, double> f,
    Interval bracket
)
Public Shared Function FindZero (
    f As Func(Of Double, Double),
    bracket As Interval
) As Double
public:
static double FindZero(
    Func<double, double>^ f,
    Interval bracket
)
static member FindZero :
        f : Func<float, float> *
        bracket : Interval -> float

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function whoose zero is sought.
bracket
Interval
An interval bracketing the root.

Return Value

Double
An ordinate within the bracket at which the function has a zero.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The function does not change sign across the given interval.

See Also

FunctionMath Class
FindZero Overload
Meta.Numerics.Analysis Namespace


FunctionMath.FindZero Method (Func, Double)

F#

Meta.Numerics Library
FunctionMath..::FindZero Method (Func<(Of <(<'Double, Double>)>)>, Double)
Isolates a root in the vicinity of a given point.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double FindZero(
    Func<double, double> f,
    double x
)
Public Shared Function FindZero (
    f As Func(Of Double, Double),
    x As Double
) As Double
public:
static double FindZero(
    Func<double, double>^ f,
    double x
)
static member FindZero :
        f : Func<float, float> *
        x : float -> float

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function whoose zero is sought.
x
Double
A ordinate believed to be near the sought zero.

Return Value

Double
An ordinate at which the function has a zero.

See Also

FunctionMath Class
FindZero Overload
Meta.Numerics.Analysis Namespace


FunctionMath.Integrate Method

F#

Meta.Numerics Library
FunctionMath..::Integrate Method

Overload List

Name | Description
Integrate(Func<(Of <<'(Double, Double>)>>), Interval) | Evaluates a definite integral.
Integrate(Func<(Of <<'(Double, Double>)>>), Interval, EvaluationSettings) | Evaluates a definite integral with the given evaluation settings.

See Also

FunctionMath Class
Meta.Numerics.Analysis Namespace


FunctionMath.Integrate Method (Func, Interval)

F#

Meta.Numerics Library
FunctionMath..::Integrate Method (Func<(Of <(<'Double, Double>)>)>, Interval)
Evaluates a definite integral.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Integrate(
    Func<double, double> integrand,
    Interval range
)
Public Shared Function Integrate (
    integrand As Func(Of Double, Double),
    range As Interval
) As Double
public:
static double Integrate(
    Func<double, double>^ integrand,
    Interval range
)
static member Integrate :
        integrand : Func<float, float> *
        range : Interval -> float

Parameters

integrand
Func <(Of <(<' Double, Double >)>)>
The function to be integrated.
range
Interval
The range of integration.

Return Value

Double
A numerical estimate of the given integral.

Remarks

Integral values are accurate to within about a digit of full double precision.

To do integrals over infinite regions, simply set the lower bound of the range to NegativeInfinity or the upper bound to PositiveInfinity.

Our numerical integrator uses a Gauss-Kronrod rule that can integrate efficiently, combined with an adaptive strategy that limits function evaluations to those regions required to achieve the desired accuracy.

Our integrator handles smooth functions extremely efficiently. It handles integrands with discontinuities, or discontinuities of derivatives, at the price of slightly more evaluations of the integrand. It handles oscilatory functions, so long as not too many periods contribute significantly to the integral. It can integrate logarithmic and mild power-law singularities.

Strong power-law singularities will cause the alrorighm to fail with a NonconvergenceException. This is unavoidable for essentially any double-precision numerical integrator. Consider, for example, the integrable singularity 1/√x. Since ε = ∫0δ x-1/2 dx = 2 δ1/2, points within δ ∼ 10-16 of the end-points, which as a close as you can get to a point in double precision without being on top of it, contribute at the ε ∼ 10-8 level to our integral, well beyond limit that nearly-full double precision requires. Said differently, to know the value of the integral to ε ∼ 10-16 prescision, we would need to evaluate the contributions of points within δ ∼ 10-32 of the endpoints, far closer than we can get.

If you need to evaluate an integral with such a strong singularity, make an analytic change of variable to absorb the singularity before attempting numerical integration. For example, to evaluate I = ∫0b f(x) x-1/2 dx, substitute y = x1/2 to obtain I = 2 ∫0√b f(y2) dy.

See Also

FunctionMath Class
Integrate Overload
Meta.Numerics.Analysis Namespace


FunctionMath.Integrate Method (Func, Interval, EvaluationSettings)

F#

Meta.Numerics Library
FunctionMath..::Integrate Method (Func<(Of <(<'Double, Double>)>)>, Interval, EvaluationSettings)
Evaluates a definite integral with the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IntegrationResult Integrate(
    Func<double, double> integrand,
    Interval range,
    EvaluationSettings settings
)
Public Shared Function Integrate (
    integrand As Func(Of Double, Double),
    range As Interval,
    settings As EvaluationSettings
) As IntegrationResult
public:
static IntegrationResult^ Integrate(
    Func<double, double>^ integrand,
    Interval range,
    EvaluationSettings^ settings
)
static member Integrate :
        integrand : Func<float, float> *
        range : Interval *
        settings : EvaluationSettings -> IntegrationResult

Parameters

integrand
Func <(Of <(<' Double, Double >)>)>
The function to be integrated.
range
Interval
The range of integration.
settings
EvaluationSettings
The settings which control the evaulation of the integal.

Return Value

IntegrationResult
The result of the integral, which includes an estimated value and estimated uncertainty of that value.

See Also

FunctionMath Class
Integrate Overload
Meta.Numerics.Analysis Namespace


IntegrationResult Class

F#

| Members | See Also
Meta.Numerics Library
IntegrationResult Class
Represents the result of a numerical integration.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class IntegrationResult : EvaluationResult
Public NotInheritable Class IntegrationResult
    Inherits EvaluationResult
public ref class IntegrationResult sealed : public EvaluationResult
[<SealedAttribute>]
type IntegrationResult =
    class
        inherit EvaluationResult
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Estimate | Gets the estimated value of the integral and its associated error bar.
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Precision | Gets the estimated precision of the evaluated value.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Value | Gets the estimated value of the integral.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..EvaluationResult
Meta.Numerics.Analysis..::..IntegrationResult

See Also

Meta.Numerics.Analysis Namespace


IntegrationResult Methods

F#

Meta.Numerics Library
IntegrationResult Methods

The IntegrationResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntegrationResult Class
Meta.Numerics.Analysis Namespace


IntegrationResult Properties

F#

Meta.Numerics Library
IntegrationResult Properties

The IntegrationResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Estimate | Gets the estimated value of the integral and its associated error bar.
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
Precision | Gets the estimated precision of the evaluated value.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
Value | Gets the estimated value of the integral.

See Also

IntegrationResult Class
Meta.Numerics.Analysis Namespace


IntegrationResult.Estimate Property

F#

Meta.Numerics Library
IntegrationResult..::Estimate Property
Gets the estimated value of the integral and its associated error bar.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue Estimate { get; }
Public ReadOnly Property Estimate As UncertainValue
    Get
public:
property UncertainValue Estimate {
    UncertainValue get ();
}
member Estimate : UncertainValue with get

Property Value

UncertainValue

Remarks

Note that the associated error estimate represents an expected deviation, not a definitive bound on the deviation.

See Also

IntegrationResult Class
Meta.Numerics.Analysis Namespace


IntegrationResult.Precision Property

F#

Meta.Numerics Library
IntegrationResult..::Precision Property
Gets the estimated precision of the evaluated value.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Precision { get; }
Public ReadOnly Property Precision As Double
    Get
public:
property double Precision {
    double get ();
}
member Precision : float with get

Property Value

Double

See Also

IntegrationResult Class
Meta.Numerics.Analysis Namespace


IntegrationResult.Value Property

F#

Meta.Numerics Library
IntegrationResult..::Value Property
Gets the estimated value of the integral.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Double

See Also

IntegrationResult Class
Meta.Numerics.Analysis Namespace


MultiExtremum Class

F#

| Members | See Also
Meta.Numerics Library
MultiExtremum Class
Represents a minimum or maximum of a multidimensional function.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class MultiExtremum : EvaluationResult
Public Class MultiExtremum
    Inherits EvaluationResult
public ref class MultiExtremum : public EvaluationResult
type MultiExtremum =
    class
        inherit EvaluationResult
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the space on which the function is defined.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HessianMatrix | Gets the Hessian matrix at the extremum.
Location | Gets the location of the extremum.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Precision | Gets the estimated precision of the function value.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Value | Gets the value of the function at the extremum.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..EvaluationResult
Meta.Numerics.Analysis..::..MultiExtremum

See Also

Meta.Numerics.Analysis Namespace


MultiExtremum Methods

F#

Meta.Numerics Library
MultiExtremum Methods

The MultiExtremum type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum Properties

F#

Meta.Numerics Library
MultiExtremum Properties

The MultiExtremum type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the space on which the function is defined.
EvaluationCount | Gets the number of function evaluations performed. (Inherited from EvaluationResult.)
HessianMatrix | Gets the Hessian matrix at the extremum.
Location | Gets the location of the extremum.
Precision | Gets the estimated precision of the function value.
Settings | Gets the settings used for the analysis. (Inherited from EvaluationResult.)
Value | Gets the value of the function at the extremum.

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum.Dimension Property

F#

Meta.Numerics Library
MultiExtremum..::Dimension Property
Gets the dimension of the space on which the function is defined.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum.HessianMatrix Property

F#

Meta.Numerics Library
MultiExtremum..::HessianMatrix Property
Gets the Hessian matrix at the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix HessianMatrix { get; }
Public ReadOnly Property HessianMatrix As SymmetricMatrix
    Get
public:
property SymmetricMatrix^ HessianMatrix {
    SymmetricMatrix^ get ();
}
member HessianMatrix : SymmetricMatrix with get

Property Value

SymmetricMatrix
A read-only matrix of approximate second partial derivaties at the extremum, or null if the algorithm does not provide one.

Remarks

These values, if present, should be considered very approximate. If you require a more precise estimate of second derivatives, use numerical differentiation.

The Hessian matrix is symmetric because the order of differentiation does not affect the result.

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum.Location Property

F#

Meta.Numerics Library
MultiExtremum..::Location Property
Gets the location of the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Location { get; }
Public ReadOnly Property Location As ColumnVector
    Get
public:
property ColumnVector^ Location {
    ColumnVector^ get ();
}
member Location : ColumnVector with get

Property Value

ColumnVector
A read-only vector of the coordinates at which the function reaches its extremum.

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum.Precision Property

F#

Meta.Numerics Library
MultiExtremum..::Precision Property
Gets the estimated precision of the function value.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Precision { get; }
Public ReadOnly Property Precision As Double
    Get
public:
property double Precision {
    double get ();
}
member Precision : float with get

Property Value

Double

Remarks

This should be understood as an estimate of the accuracy of Value as an estimate of the extremum value. It should not be intrepreted as a two-sided error bar, because the true minimum (maximum) value, if different, can only be smaller (larger).

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiExtremum.Value Property

F#

Meta.Numerics Library
MultiExtremum..::Value Property
Gets the value of the function at the extremum.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Double

See Also

MultiExtremum Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath Class

F#

| Members | See Also
Meta.Numerics Library
MultiFunctionMath Class
Contains methods for the analysis of multi-dimensional functions.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class MultiFunctionMath
Public NotInheritable Class MultiFunctionMath
public ref class MultiFunctionMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MultiFunctionMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the maximum of a function within the given volume.
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the maxunyn of a function within the given volume, subject to the given evaluation constraints.
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the minimum of a function within the given volume.
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the minimum of a function within the given volume, subject to the given evaluation constraints.
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.
FindZero(Func<(Of <<'(IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>)>)>>), IList<(Of <<'(Double>)>>)) | Finds a vector argument which makes a vector function zero.
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Estimates a multi-dimensional integral.
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Estimates a multi-dimensional integral using the given evaluation settings.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Analysis..::..MultiFunctionMath

See Also

Meta.Numerics.Analysis Namespace


MultiFunctionMath Methods

F#

Meta.Numerics Library
MultiFunctionMath Methods

The MultiFunctionMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the maximum of a function within the given volume.
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the maxunyn of a function within the given volume, subject to the given evaluation constraints.
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the minimum of a function within the given volume.
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the minimum of a function within the given volume, subject to the given evaluation constraints.
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.
FindZero(Func<(Of <<'(IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>)>)>>), IList<(Of <<'(Double>)>>)) | Finds a vector argument which makes a vector function zero.
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Estimates a multi-dimensional integral.
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Estimates a multi-dimensional integral using the given evaluation settings.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMaximum Method

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMaximum Method

Overload List

Name | Description
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the maximum of a function within the given volume.
FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the maxunyn of a function within the given volume, subject to the given evaluation constraints.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMaximum Method (Func, IList)

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMaximum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>)
Finds the maximum of a function within the given volume.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindGlobalMaximum(
    Func<IList<double>, double> function,
    IList<Interval> volume
)
Public Shared Function FindGlobalMaximum (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval)
) As MultiExtremum
public:
static MultiExtremum^ FindGlobalMaximum(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume
)
static member FindGlobalMaximum :
        function : Func<IList<float>, float> *
        volume : IList<Interval> -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function.
volume
IList <(Of <(<' Interval >)>)>
The volume to search.

Return Value

MultiExtremum
The global maximum.

See Also

MultiFunctionMath Class
FindGlobalMaximum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMaximum Method (Func, IList, EvaluationSettings)

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMaximum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>, EvaluationSettings)
Finds the maxunyn of a function within the given volume, subject to the given evaluation constraints.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindGlobalMaximum(
    Func<IList<double>, double> function,
    IList<Interval> volume,
    EvaluationSettings settings
)
Public Shared Function FindGlobalMaximum (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval),
    settings As EvaluationSettings
) As MultiExtremum
public:
static MultiExtremum^ FindGlobalMaximum(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume,
    EvaluationSettings^ settings
)
static member FindGlobalMaximum :
        function : Func<IList<float>, float> *
        volume : IList<Interval> *
        settings : EvaluationSettings -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function.
volume
IList <(Of <(<' Interval >)>)>
The volume to search.
settings
EvaluationSettings
The evaluation constraints to apply.

Return Value

MultiExtremum
The global maximum.

See Also

MultiFunctionMath Class
FindGlobalMaximum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMinimum Method

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMinimum Method

Overload List

Name | Description
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Finds the minimum of a function within the given volume.
FindGlobalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Finds the minimum of a function within the given volume, subject to the given evaluation constraints.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMinimum Method (Func, IList)

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMinimum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>)
Finds the minimum of a function within the given volume.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindGlobalMinimum(
    Func<IList<double>, double> function,
    IList<Interval> volume
)
Public Shared Function FindGlobalMinimum (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval)
) As MultiExtremum
public:
static MultiExtremum^ FindGlobalMinimum(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume
)
static member FindGlobalMinimum :
        function : Func<IList<float>, float> *
        volume : IList<Interval> -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function.
volume
IList <(Of <(<' Interval >)>)>
The volume to search.

Return Value

MultiExtremum
The global minimum.

See Also

MultiFunctionMath Class
FindGlobalMinimum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindGlobalMinimum Method (Func, IList, EvaluationSettings)

F#

Meta.Numerics Library
MultiFunctionMath..::FindGlobalMinimum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>, EvaluationSettings)
Finds the minimum of a function within the given volume, subject to the given evaluation constraints.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindGlobalMinimum(
    Func<IList<double>, double> function,
    IList<Interval> volume,
    EvaluationSettings settings
)
Public Shared Function FindGlobalMinimum (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval),
    settings As EvaluationSettings
) As MultiExtremum
public:
static MultiExtremum^ FindGlobalMinimum(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume,
    EvaluationSettings^ settings
)
static member FindGlobalMinimum :
        function : Func<IList<float>, float> *
        volume : IList<Interval> *
        settings : EvaluationSettings -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function.
volume
IList <(Of <(<' Interval >)>)>
The volume to search.
settings
EvaluationSettings
The evaluation constraints to apply.

Return Value

MultiExtremum
The global minimum.

Remarks

This algorithm attempts to find the global minimum of the given function within the entire given hyper-cube. It generally requires many more function evaluations than FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)), but is much more likely to find a global minimum in situations where multiple local minima exist.

Unlike FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) method, this method does not return an approximate Hessian matrix near the minimum.

Exceptions

Exception | Condition
Meta.Numerics..::..NonconvergenceException | The minimum could not be found within the given evaluation budget.

See Also

MultiFunctionMath Class
FindGlobalMinimum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMaximum Method

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMaximum Method

Overload List

Name | Description
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMaximum Method (Func, IList)

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMaximum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Double>)>)>)
Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindLocalMaximum(
    Func<IList<double>, double> function,
    IList<double> start
)
Public Shared Function FindLocalMaximum (
    function As Func(Of IList(Of Double), Double),
    start As IList(Of Double)
) As MultiExtremum
public:
static MultiExtremum^ FindLocalMaximum(
    Func<IList<double>^, double>^ function,
    IList<double>^ start
)
static member FindLocalMaximum :
        function : Func<IList<float>, float> *
        start : IList<float> -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The multi-dimensional function to maximize.
start
IList <(Of <(<' Double >)>)>
The starting location for the search.

Return Value

MultiExtremum
The local maximum.

See Also

MultiFunctionMath Class
FindLocalMaximum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMaximum Method (Func, IList, EvaluationSettings)

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMaximum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Double>)>)>, EvaluationSettings)
Finds a local maximum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindLocalMaximum(
    Func<IList<double>, double> function,
    IList<double> start,
    EvaluationSettings settings
)
Public Shared Function FindLocalMaximum (
    function As Func(Of IList(Of Double), Double),
    start As IList(Of Double),
    settings As EvaluationSettings
) As MultiExtremum
public:
static MultiExtremum^ FindLocalMaximum(
    Func<IList<double>^, double>^ function,
    IList<double>^ start,
    EvaluationSettings^ settings
)
static member FindLocalMaximum :
        function : Func<IList<float>, float> *
        start : IList<float> *
        settings : EvaluationSettings -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The multi-dimensional function to maximize.
start
IList <(Of <(<' Double >)>)>
The starting location for the search.
settings
EvaluationSettings
The evaluation settings that govern the search for the maximum.

Return Value

MultiExtremum
The local maximum.

See Also

MultiFunctionMath Class
FindLocalMaximum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMinimum Method

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMinimum Method

Overload List

Name | Description
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>)) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location.
FindLocalMinimum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Double>)>>), EvaluationSettings) | Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMinimum Method (Func, IList)

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMinimum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Double>)>)>)
Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindLocalMinimum(
    Func<IList<double>, double> function,
    IList<double> start
)
Public Shared Function FindLocalMinimum (
    function As Func(Of IList(Of Double), Double),
    start As IList(Of Double)
) As MultiExtremum
public:
static MultiExtremum^ FindLocalMinimum(
    Func<IList<double>^, double>^ function,
    IList<double>^ start
)
static member FindLocalMinimum :
        function : Func<IList<float>, float> *
        start : IList<float> -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The multi-dimensional function to minimize.
start
IList <(Of <(<' Double >)>)>
The starting location for the search.

Return Value

MultiExtremum
The local minimum.

See Also

MultiFunctionMath Class
FindLocalMinimum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindLocalMinimum Method (Func, IList, EvaluationSettings)

F#

Meta.Numerics Library
MultiFunctionMath..::FindLocalMinimum Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Double>)>)>, EvaluationSettings)
Finds a local minimum of a multi-dimensional function in the vincinity of the given starting location, subject to the given evaluation constraints.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static MultiExtremum FindLocalMinimum(
    Func<IList<double>, double> function,
    IList<double> start,
    EvaluationSettings settings
)
Public Shared Function FindLocalMinimum (
    function As Func(Of IList(Of Double), Double),
    start As IList(Of Double),
    settings As EvaluationSettings
) As MultiExtremum
public:
static MultiExtremum^ FindLocalMinimum(
    Func<IList<double>^, double>^ function,
    IList<double>^ start,
    EvaluationSettings^ settings
)
static member FindLocalMinimum :
        function : Func<IList<float>, float> *
        start : IList<float> *
        settings : EvaluationSettings -> MultiExtremum

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The multi-dimensional function to minimize.
start
IList <(Of <(<' Double >)>)>
The starting location for the search.
settings
EvaluationSettings
The evaluation settings that govern the search for the minimum.

Return Value

MultiExtremum
The local minimum.

Remarks

The Hessian (matrix of second derivatives) returned with the minimum is an approximation that is constructed in the course of search. It should be considered a crude approximation, and may not even be that if the minimum is highly non-quadratic.

If you have a constrained minimization problem, require a high-precision solution, and do not have a good initial guess, consider first feeding your constrained problem into FindGlobalMaximum(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)), which supports constraints but gives relatively lower precision solutions, then feeding the result of that method into this method, which finds relatively precision solutions but does not support constraints.

Exceptions

Exception | Condition
Meta.Numerics..::..NonconvergenceException | The number of function evaluations required exceeded the evaluation budget.

See Also

MultiFunctionMath Class
FindLocalMinimum Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.FindZero Method

F#

Meta.Numerics Library
MultiFunctionMath..::FindZero Method
Finds a vector argument which makes a vector function zero.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector FindZero(
    Func<IList<double>, IList<double>> f,
    IList<double> x0
)
Public Shared Function FindZero (
    f As Func(Of IList(Of Double), IList(Of Double)),
    x0 As IList(Of Double)
) As ColumnVector
public:
static ColumnVector^ FindZero(
    Func<IList<double>^, IList<double>^>^ f,
    IList<double>^ x0
)
static member FindZero :
        f : Func<IList<float>, IList<float>> *
        x0 : IList<float> -> ColumnVector

Parameters

f
Func <(Of <(<' IList <(Of <(<' Double >)>)>, IList <(Of <(<' Double >)>)>>)>)>
The vector function.
x0
IList <(Of <(<' Double >)>)>
The vector argument.

Return Value

ColumnVector
The vector argument which makes all components of the vector function zero.

Exceptions

Exception | Condition
System..::..ArgumentNullException | f or x0 is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of f is not equal to the dimension of x0.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.Integrate Method

F#

Meta.Numerics Library
MultiFunctionMath..::Integrate Method

Overload List

Name | Description
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>)) | Estimates a multi-dimensional integral.
Integrate(Func<(Of <<'(IList<(Of <<'(Double>)>>), Double>)>>), IList<(Of <<'(Interval>)>>), EvaluationSettings) | Estimates a multi-dimensional integral using the given evaluation settings.

See Also

MultiFunctionMath Class
Meta.Numerics.Analysis Namespace


MultiFunctionMath.Integrate Method (Func, IList)

F#

Meta.Numerics Library
MultiFunctionMath..::Integrate Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>)
Estimates a multi-dimensional integral.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IntegrationResult Integrate(
    Func<IList<double>, double> function,
    IList<Interval> volume
)
Public Shared Function Integrate (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval)
) As IntegrationResult
public:
static IntegrationResult^ Integrate(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume
)
static member Integrate :
        function : Func<IList<float>, float> *
        volume : IList<Interval> -> IntegrationResult

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function to integrate.
volume
IList <(Of <(<' Interval >)>)>
The volume over which to integrate.

Return Value

IntegrationResult
A numerical estimate of the multi-dimensional integral.

Remarks

By default, our multidimensional integration system targets a relative accuracy of about 10-7 (close to full single precision) for d=2, falling gradually to about 10-2 (1%) for d=12. To achieve that accuracy, it allows up to about 105 evaluations of the integrand for d=2, rising up to about 108 evaluations for d=12.

You can change the accuracy demands and evaluation budget by passing an EvaluationSettings object to the integration method. By decreasing the accuracy you require or increasing the evaluation budget, you may be able to successfully complete integrals that would fail for the default settings.

See Also

MultiFunctionMath Class
Integrate Overload
Meta.Numerics.Analysis Namespace


MultiFunctionMath.Integrate Method (Func, IList, EvaluationSettings)

F#

Meta.Numerics Library
MultiFunctionMath..::Integrate Method (Func<(Of <(<'IList<(Of <(<'Double>)>)>, Double>)>)>, IList<(Of <(<'Interval>)>)>, EvaluationSettings)
Estimates a multi-dimensional integral using the given evaluation settings.

Namespace: Meta.Numerics.Analysis
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IntegrationResult Integrate(
    Func<IList<double>, double> function,
    IList<Interval> volume,
    EvaluationSettings settings
)
Public Shared Function Integrate (
    function As Func(Of IList(Of Double), Double),
    volume As IList(Of Interval),
    settings As EvaluationSettings
) As IntegrationResult
public:
static IntegrationResult^ Integrate(
    Func<IList<double>^, double>^ function,
    IList<Interval>^ volume,
    EvaluationSettings^ settings
)
static member Integrate :
        function : Func<IList<float>, float> *
        volume : IList<Interval> *
        settings : EvaluationSettings -> IntegrationResult

Parameters

function
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Double >)>)>
The function to be integrated.
volume
IList <(Of <(<' Interval >)>)>
The volume over which to integrate.
settings
EvaluationSettings
The integration settings.

Return Value

IntegrationResult
A numerical estimate of the multi-dimensional integral.

Remarks

Note that the integration function must not attempt to modify the argument passed to it.

Note that the integration volume must be a hyper-rectangle. You can integrate over regions with more complex boundaries by specifying the integration volume as a bounding hyper-rectangle that encloses your desired integration region, and returing the value 0 for the integrand outside of the desired integration region. For example, to find the volume of a unit d-sphere, you can integrate a function that is 1 inside the unit d-sphere and 0 outside it over the volume [-1,1]d. You can integrate over infinite volumes by specifing volume endpoints of PositiveInfinity and/or NegativeInfinity. Volumes with dimension greater than 12 are not currently supported.

Integrals with hard boundaries (like our hyper-sphere volume problem) typically require more evaluations than integrals of smooth functions to achieve the same accuracy. Integrals with canceling positive and negative contributions also typically require more evaluations than integtrals of purely positive functions.

Numerical multi-dimensional integration is computationally expensive. To make problems more tractable, keep in mind some rules of thumb:

  • Reduce the required accuracy to the minimum required. Alternatively, if you are willing to wait longer, increase the evaluation budget.
  • Exploit symmetries of the problem to reduce the integration volume. For example, to compute the volume of the unit d-sphere, it is better to integrate over [0,1]d and multiply the result by 2d than to simply integrate over [-1,1]d.
  • Apply analytic techniques to reduce the dimension of the integral. For example, when computing the volume of the unit d-sphere, it is better to do a (d-1)-dimesional integral over the function that is the height of the sphere in the dth dimension than to do a d-dimensional integral over the indicator function that is 1 inside the sphere and 0 outside it.

Exceptions

Exception | Condition
System..::..ArgumentException | function, volume, or settings are null, or the dimension of volume is larger than 12.
Meta.Numerics..::..NonconvergenceException | The prescribed accuracy could not be achieved with the given evaluation budget.

See Also

MultiFunctionMath Class
Integrate Overload
Meta.Numerics.Analysis Namespace


Meta.Numerics.Functions Namespace

F#

Meta.Numerics Library
Meta.Numerics.Functions Namespace
Contains types that evaluate advanced functions.

Types

All Types | Classes | Structures
Name | Description
AdvancedComplexMath | Contains methods that compute advanced functions of complex arguments.
AdvancedIntegerMath | Contains methods that compute advanced functions of integer arguments.
AdvancedMath | Contains methods that compute advanced functions with real arguments.
OrthogonalPolynomials | Contains methods that compute the values of orthogonal polynomials.
Permutation | Represents a permutation.
SolutionPair | Contains a pair of solutions to a differential equation.
Spin | Represents a spinor.
SpinMath | Contains methods for computing functions of spin and spin states.
SpinState | Represents the state of a spinor.


AdvancedComplexMath Class

F#

| Members | See Also
Meta.Numerics Library
AdvancedComplexMath Class
Contains methods that compute advanced functions of complex arguments.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class AdvancedComplexMath
Public NotInheritable Class AdvancedComplexMath
public ref class AdvancedComplexMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdvancedComplexMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DiLog(Complex) | Computes the complex dilogarithm function, also called Spence's function.
Ein(Complex) | Computes the entire complex exponential integral.
Erf(Complex) | Computes the complex error function.
Faddeeva(Complex) | Computes the complex Faddeeva function.
Gamma(Complex) | Computes the complex Gamma function.
LogGamma(Complex) | Compute the complex log Gamma function.
Psi(Complex) | Computes the complex digamma (ψ) function.
RiemannZeta(Complex) | Computes the Riemann zeta function for complex values.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..AdvancedComplexMath

See Also

Meta.Numerics.Functions Namespace


AdvancedComplexMath Methods

F#

Meta.Numerics Library
AdvancedComplexMath Methods

The AdvancedComplexMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DiLog(Complex) | Computes the complex dilogarithm function, also called Spence's function.
Ein(Complex) | Computes the entire complex exponential integral.
Erf(Complex) | Computes the complex error function.
Faddeeva(Complex) | Computes the complex Faddeeva function.
Gamma(Complex) | Computes the complex Gamma function.
LogGamma(Complex) | Compute the complex log Gamma function.
Psi(Complex) | Computes the complex digamma (ψ) function.
RiemannZeta(Complex) | Computes the Riemann zeta function for complex values.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace


AdvancedComplexMath.DiLog Method

F#

Meta.Numerics Library
AdvancedComplexMath..::DiLog Method
Computes the complex dilogarithm function, also called Spence's function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex DiLog(
    Complex z
)
Public Shared Function DiLog (
    z As Complex
) As Complex
public:
static Complex DiLog(
    Complex z
)
static member DiLog :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The value Li2(z).

Remarks

This function is the analyic continuation of the dilogarithm function (DiLog(Double)) into the complex plane.

The image below shows the complex dilogarithm function near the origin, using domain coloring.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..DiLog(Double)
http://mathworld.wolfram.com/Dilogarithm.html


AdvancedComplexMath.Ein Method

F#

Meta.Numerics Library
AdvancedComplexMath..::Ein Method
Computes the entire complex exponential integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Ein(
    Complex z
)
Public Shared Function Ein (
    z As Complex
) As Complex
public:
static Complex Ein(
    Complex z
)
static member Ein :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The value of Ein(z).

Remarks

The entire exponential integral function can be defined by an integral or an equivalent series.

Both Ei(z) and E1(x) and be obtained from Ein(z).

Unlike either Ei(z) or E1(z), Ein(z) is entire, that is, it has no poles or cuts anywhere in the complex plane.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace


AdvancedComplexMath.Erf Method

F#

Meta.Numerics Library
AdvancedComplexMath..::Erf Method
Computes the complex error function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Erf(
    Complex z
)
Public Shared Function Erf (
    z As Complex
) As Complex
public:
static Complex Erf(
    Complex z
)
static member Erf :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The value of erf(z).

Remarks

This function is the analytic continuation of the error function (Erf(Double)) to the complex plane.

The image below shows the complex error function near the origin, using domain coloring.

The complex error function is entire: it has no poles, cuts, or discontinuities anywhere in the complex plane.

For pure imaginary arguments, erf(z) reduces to the Dawson integral (Dawson(Double)).

Away from the origin near the real axis, the real part of erf(z) quickly approaches ±1. To accurately determine the small difference erf(z) ∓ 1 in this region, use the Faddeeva(Complex) function. Away from the origin near the imaginary axis, the magnitude of erf(z) increases very quickly. Although erf(z) may overflow in this region, you can still accurately determine the value of the product erf(z) exp(z2) using the Faddeeva(Complex) function.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Erf(Double)
AdvancedMath..::..Dawson(Double)
AdvancedComplexMath..::..Faddeeva(Complex)


AdvancedComplexMath.Faddeeva Method

F#

Meta.Numerics Library
AdvancedComplexMath..::Faddeeva Method
Computes the complex Faddeeva function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Faddeeva(
    Complex z
)
Public Shared Function Faddeeva (
    z As Complex
) As Complex
public:
static Complex Faddeeva(
    Complex z
)
static member Faddeeva :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The complex value of w(z).

Remarks

The Faddeeva function w(z) is related to the error function with a complex argument.

It also has an integral representation.

For purely imaginary values, it reduces to the complementary error function (Erfc(Double)). For purely real values, it reduces to Dawson's integral (Dawson(Double)).

It appears in the computation of the Voigt line profile function V(x;σ,γ).

Near the origin, w(z) ≈ 1. To accurately determine w(z) - 1 in this region, use the Erf(Complex) function. Away from the origin near the large negative imaginary axis, the magnitude w(z) increases rapidly and may overflow.

The image below shows the complex Faddeeva function near the origin, using domain coloring.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedComplexMath..::..Erf(Complex)
AdvancedMath..::..Erf(Double)
AdvancedMath..::..Erfc(Double)
AdvancedMath..::..Dawson(Double)
http://en.wikipedia.org/wiki/Voigt_profile


AdvancedComplexMath.Gamma Method

F#

Meta.Numerics Library
AdvancedComplexMath..::Gamma Method
Computes the complex Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Gamma(
    Complex z
)
Public Shared Function Gamma (
    z As Complex
) As Complex
public:
static Complex Gamma(
    Complex z
)
static member Gamma :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The complex value of Γ(z).

Remarks

The image below shows the complex Γ function near the origin using domain coloring.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Gamma(Double)
http://en.wikipedia.org/wiki/Gamma_function
http://mathworld.wolfram.com/GammaFunction.html


AdvancedComplexMath.LogGamma Method

F#

Meta.Numerics Library
AdvancedComplexMath..::LogGamma Method
Compute the complex log Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex LogGamma(
    Complex z
)
Public Shared Function LogGamma (
    z As Complex
) As Complex
public:
static Complex LogGamma(
    Complex z
)
static member LogGamma :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument, which must have a non-negative real part.

Return Value

Complex
The complex value ln(Γ(z)).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The real part of z is negative.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..LogGamma(Double)


AdvancedComplexMath.Psi Method

F#

Meta.Numerics Library
AdvancedComplexMath..::Psi Method
Computes the complex digamma (ψ) function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Psi(
    Complex z
)
Public Shared Function Psi (
    z As Complex
) As Complex
public:
static Complex Psi(
    Complex z
)
static member Psi :
        z : Complex -> Complex

Parameters

z
Complex
The complex argument.

Return Value

Complex
The value of ψ(z).

Remarks

The image below shows the complex ψ function near the origin using domain coloring.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Psi(Double)


AdvancedComplexMath.RiemannZeta Method

F#

Meta.Numerics Library
AdvancedComplexMath..::RiemannZeta Method
Computes the Riemann zeta function for complex values.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex RiemannZeta(
    Complex z
)
Public Shared Function RiemannZeta (
    z As Complex
) As Complex
public:
static Complex RiemannZeta(
    Complex z
)
static member RiemannZeta :
        z : Complex -> Complex

Parameters

z
Complex
The argument.

Return Value

Complex
The value of ζ(z).

Remarks

As the imaginary part of the argument increases, the computation of the zeta function becomes slower and more difficult. The computation time is approximately proprotional to the imaginary part of z. The result also slowly looses accuracy for arguments with very large imaginary parts; for arguments with z.Im of order 10^d, approximately the last d digits of the result are suspect.

The image below shows the complex Γ function near the origin using domain coloring. You can see the first non-trivial zeros at (1/2, ±14.13...) as well as the trivial zeros along the negative real axis.

See Also

AdvancedComplexMath Class
Meta.Numerics.Functions Namespace


AdvancedIntegerMath Class

F#

| Members | See Also
Meta.Numerics Library
AdvancedIntegerMath Class
Contains methods that compute advanced functions of integer arguments.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class AdvancedIntegerMath
Public NotInheritable Class AdvancedIntegerMath
public ref class AdvancedIntegerMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdvancedIntegerMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BellNumber(Int32) | Computes the given Bell number.
BernoulliNumber(Int32) | Computes the given Bernoulli number.
BinomialCoefficient(Int32, Int32) | Computes a binomial coefficient.
BinomialCoefficients(Int32) | Enumerates the binomial coefficients of a given order.
DoubleFactorial(Int32) | Computes the double factorial of the given integer.
Factorial(Int32) | Computes the factorial of an integer.
FibonacciNumber(Int32) | Computes a Fibonacci number.
GCF(Int64, Int64) | Computes the greatest common factor of two integers.
HarmonicNumber(Int32) | Computes the given harmonic number.
IsPrime(Int32) | Determines whether the given integer is prime.
LCM(Int64, Int64) | Computes the least common multiple of two integers.
LogDoubleFactorial(Int32) | Computes the natural logarithm of the double factorial of the given number.
LogFactorial(Int32) | Computes the logrithm of the factorial of an integer.
Partitions(Int32) | Enumerates all partitions of the given integer
PowMod(Int32, Int32, Int32) | Computes a power of an integer in modular arithmetic.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..AdvancedIntegerMath

See Also

Meta.Numerics.Functions Namespace


AdvancedIntegerMath Methods

F#

Meta.Numerics Library
AdvancedIntegerMath Methods

The AdvancedIntegerMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BellNumber(Int32) | Computes the given Bell number.
BernoulliNumber(Int32) | Computes the given Bernoulli number.
BinomialCoefficient(Int32, Int32) | Computes a binomial coefficient.
BinomialCoefficients(Int32) | Enumerates the binomial coefficients of a given order.
DoubleFactorial(Int32) | Computes the double factorial of the given integer.
Factorial(Int32) | Computes the factorial of an integer.
FibonacciNumber(Int32) | Computes a Fibonacci number.
GCF(Int64, Int64) | Computes the greatest common factor of two integers.
HarmonicNumber(Int32) | Computes the given harmonic number.
IsPrime(Int32) | Determines whether the given integer is prime.
LCM(Int64, Int64) | Computes the least common multiple of two integers.
LogDoubleFactorial(Int32) | Computes the natural logarithm of the double factorial of the given number.
LogFactorial(Int32) | Computes the logrithm of the factorial of an integer.
Partitions(Int32) | Enumerates all partitions of the given integer
PowMod(Int32, Int32, Int32) | Computes a power of an integer in modular arithmetic.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace


AdvancedIntegerMath.BellNumber Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::BellNumber Method
Computes the given Bell number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BellNumber(
    int n
)
Public Shared Function BellNumber (
    n As Integer
) As Double
public:
static double BellNumber(
    int n
)
static member BellNumber :
        n : int -> float

Parameters

n
Int32
The index of the Bell number to compute, which must be non-negative.

Return Value

Double
The Bell number Bn.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bell_number


AdvancedIntegerMath.BernoulliNumber Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::BernoulliNumber Method
Computes the given Bernoulli number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BernoulliNumber(
    int n
)
Public Shared Function BernoulliNumber (
    n As Integer
) As Double
public:
static double BernoulliNumber(
    int n
)
static member BernoulliNumber :
        n : int -> float

Parameters

n
Int32
The index of the Bernoulli number to compute, which must be non-negative.

Return Value

Double
The Bernoulli number Bn.

Remarks

Bn vanishes for all odd n except n=1. For n about 260 or larger, Bn overflows a double.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bernoulli_number
http://mathworld.wolfram.com/BernoulliNumber.html


AdvancedIntegerMath.BinomialCoefficient Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::BinomialCoefficient Method
Computes a binomial coefficient.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BinomialCoefficient(
    int n,
    int m
)
Public Shared Function BinomialCoefficient (
    n As Integer,
    m As Integer
) As Double
public:
static double BinomialCoefficient(
    int n,
    int m
)
static member BinomialCoefficient :
        n : int *
        m : int -> float

Parameters

n
Int32
The upper argument, which must be non-negative.
m
Int32
The lower argument, which must be non-negative and less than or equal to n.

Return Value

Double
The binomial coefficent C(n,m), also denoted "n choose m".

Remarks

The binomial coefficient C(n,m) is the coefficient of xm in the expansion of (1+x)n.

C(n,m) can also be given a combinatoric intrepretation as the total number of ways to pick m items from a set of n distinct items.

For example C(4,2) = 6. This can be seen by expanding (1+x)4 = 1 + 4 x + 6 x2 + 4 x3 + x4 and noting that the coefficient of the x2 term is 6. It can also be seen by considering the four-member set (abcd) and noting that there are 6 possible two-member subests: (ab), (ac), (ad), (bc), (bd), (cd).

Pascal's triangle is a classic representation of binomial coefficients.

 |  |  | C(0,0)
 |  | C(1,0) |  | C(1,1)
 | C(2,0) |  | C(2,1) |  | C(2,2)
C(3,0) |  | C(3,1) |  | C(3,2) |  | C(3,3)

The relation of an element in Pascal's triangle to its two parent elements is C(n+1,m) = C(n,m-1) + C(n,m). There are many other relationships among binomial coefficients. Among the most computationally useful is B(n,m+1) = (n-m)/(m+1) B(n,m), which can be used to generate all the binomial coefficients in a row of Pascal's triangle (i.e., all the coefficients for a given order polynomial) starting from an outer values B(n,0) = 1 = B(n,n). If you need a series of binomial coefficients, using a recursion will be more computationally efficient than calling this method for each one. The BinomialCoefficients(Int32) method provides a fast enumeration of all the binomial coefficients in a given row of Pascal's triangle.

Binomial coefficients are always integers, but we return the result as double because the value can exceed the capacity of an int or even a long for even quite moderate values of n and m.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative, or m lies outside [0,n].

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Binomial_coefficient


AdvancedIntegerMath.BinomialCoefficients Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::BinomialCoefficients Method
Enumerates the binomial coefficients of a given order.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IEnumerable<double> BinomialCoefficients(
    int n
)
Public Shared Function BinomialCoefficients (
    n As Integer
) As IEnumerable(Of Double)
public:
static IEnumerable<double>^ BinomialCoefficients(
    int n
)
static member BinomialCoefficients :
        n : int -> IEnumerable<float>

Parameters

n
Int32
The upper argument, which must be non-negative.

Return Value

IEnumerable <(Of <(<' Double >)>)>
An enumeration of the binomial coefficients in the nth row of Pascal's triangle.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace


AdvancedIntegerMath.DoubleFactorial Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::DoubleFactorial Method
Computes the double factorial of the given integer.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double DoubleFactorial(
    int n
)
Public Shared Function DoubleFactorial (
    n As Integer
) As Double
public:
static double DoubleFactorial(
    int n
)
static member DoubleFactorial :
        n : int -> float

Parameters

n
Int32
The argument, which must be positive.

Return Value

Double
The value of n!!.

Remarks

The double factorial of an integer is the product all integers of the same parity, up to and including the integer. Thus 5! = 5 * 3 * 1 = 15 and 6! = 6 * 4 * 2 = 48.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://mathworld.wolfram.com/DoubleFactorial.html


AdvancedIntegerMath.Factorial Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::Factorial Method
Computes the factorial of an integer.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Factorial(
    int n
)
Public Shared Function Factorial (
    n As Integer
) As Double
public:
static double Factorial(
    int n
)
static member Factorial :
        n : int -> float

Parameters

n
Int32
The argument, which must be non-negative.

Return Value

Double
The value of n!.

Remarks

The factorial of an integer n is the product of all integers from 1 to n. For example, 4! = 4 * 3 * 2 * 1 = 24.

n! also has a combinatorial intrepretation as the number of permutations of n objects. For example, a set of 3 objects (abc) has 3! = 6 permutations: (abc), (bac), (cba), (acb), (cab), (bca).

Because n! grows extremely quickly with increasing n, we return the result as a double, even though the value is always an integer. (13! would overlow an int, 21! would overflow a long, 171! overflows even a double.)

In order to deal with factorials of larger numbers, you can use the LogFactorial(Int32) method, which returns accurate values of ln(n!) even for values of n for which n! would overflow a double.

The factorial is generalized to non-integer arguments by the Γ function (Gamma(Double)).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..LogFactorial(Int32)
AdvancedMath..::..Gamma(Double)
http://en.wikipedia.org/wiki/Factorial


AdvancedIntegerMath.FibonacciNumber Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::FibonacciNumber Method
Computes a Fibonacci number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double FibonacciNumber(
    int n
)
Public Shared Function FibonacciNumber (
    n As Integer
) As Double
public:
static double FibonacciNumber(
    int n
)
static member FibonacciNumber :
        n : int -> float

Parameters

n
Int32
The index of the Fibonacci number to compute, which must be non-negative.

Return Value

Double
The nth Fibonacci number Fn.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace


AdvancedIntegerMath.GCF Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::GCF Method
Computes the greatest common factor of two integers.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static long GCF(
    long u,
    long v
)
Public Shared Function GCF (
    u As Long,
    v As Long
) As Long
public:
static long long GCF(
    long long u,
    long long v
)
static member GCF :
        u : int64 *
        v : int64 -> int64

Parameters

u
Int64
The first integer.
v
Int64
The second integer.

Return Value

Int64
The greatest common factor of u and v.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..LCM(Int64, Int64)


AdvancedIntegerMath.HarmonicNumber Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::HarmonicNumber Method
Computes the given harmonic number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double HarmonicNumber(
    int n
)
Public Shared Function HarmonicNumber (
    n As Integer
) As Double
public:
static double HarmonicNumber(
    int n
)
static member HarmonicNumber :
        n : int -> float

Parameters

n
Int32
The index of the harmonic number to compute, which must be non-negative.

Return Value

Double
The harmonic number Hn.

Remarks

Hn is the nth partial sum of the harmonic series.

Since the harmonic series diverges, Hn grows without bound as n increases, but it does so extremely slowly, approximately as log(n).

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Harmonic_series_(mathematics)


AdvancedIntegerMath.IsPrime Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::IsPrime Method
Determines whether the given integer is prime.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool IsPrime(
    int n
)
Public Shared Function IsPrime (
    n As Integer
) As Boolean
public:
static bool IsPrime(
    int n
)
static member IsPrime :
        n : int -> bool

Parameters

n
Int32
The integer, which must be positive.

Return Value

Boolean
True if the integer is prime, otherwise false.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Prime_number
http://mathworld.wolfram.com/PrimeNumber.html


AdvancedIntegerMath.LCM Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::LCM Method
Computes the least common multiple of two integers.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static long LCM(
    long u,
    long v
)
Public Shared Function LCM (
    u As Long,
    v As Long
) As Long
public:
static long long LCM(
    long long u,
    long long v
)
static member LCM :
        u : int64 *
        v : int64 -> int64

Parameters

u
Int64
The first integer.
v
Int64
The second integer.

Return Value

Int64
The least common multiple of u and v.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..GCF(Int64, Int64)


AdvancedIntegerMath.LogDoubleFactorial Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::LogDoubleFactorial Method
Computes the natural logarithm of the double factorial of the given number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LogDoubleFactorial(
    int n
)
Public Shared Function LogDoubleFactorial (
    n As Integer
) As Double
public:
static double LogDoubleFactorial(
    int n
)
static member LogDoubleFactorial :
        n : int -> float

Parameters

n
Int32
The argument.

Return Value

Double
The value of ln(n!!).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..DoubleFactorial(Int32)


AdvancedIntegerMath.LogFactorial Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::LogFactorial Method
Computes the logrithm of the factorial of an integer.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LogFactorial(
    int n
)
Public Shared Function LogFactorial (
    n As Integer
) As Double
public:
static double LogFactorial(
    int n
)
static member LogFactorial :
        n : int -> float

Parameters

n
Int32
The argument, which must be non-negative.

Return Value

Double
The value of ln(n!).

Remarks

This function provides accurate values of ln(n!) even for values of n which would cause n! to overflow.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..Factorial(Int32)


AdvancedIntegerMath.Partitions Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::Partitions Method
Enumerates all partitions of the given integer

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IEnumerable<int[]> Partitions(
    int n
)
Public Shared Function Partitions (
    n As Integer
) As IEnumerable(Of Integer())
public:
static IEnumerable<array<int>^>^ Partitions(
    int n
)
static member Partitions :
        n : int -> IEnumerable<int[]>

Parameters

n
Int32
The integer to partition, which must be positive.

Return Value

IEnumerable <(Of <(<'array< Int32 >[]()[][]>)>)>
An enumeration of all partitions of the given integer.

Remarks

Integer partitions are ways to write an integer as a sum of smaller integers. For example, the integer 4 has 5 partitions: 4, 3 + 1, 2 + 2, 2 + 1 + 1, and 1 + 1 + 1 + 1.

Integer partitions appear in combinatoric problems and solutions to problems that may be mapped into combinatoric problems. For example, the terms which appear in Faà di Bruno's formula correspond to integer partitions.

The number of partitions grows very rapidly with n. Since enumerating through partitions does not require us to count them, no overflows will occur even for large values of n. However, completing the enumeration of such a large number of paritions will take a long time, even though our algorithm produces each partition very quickly. For example, there are about two hundred million partitions of the integer 100.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is not positive.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Integer_partition


AdvancedIntegerMath.PowMod Method

F#

Meta.Numerics Library
AdvancedIntegerMath..::PowMod Method
Computes a power of an integer in modular arithmetic.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static int PowMod(
    int b,
    int e,
    int m
)
Public Shared Function PowMod (
    b As Integer,
    e As Integer,
    m As Integer
) As Integer
public:
static int PowMod(
    int b,
    int e,
    int m
)
static member PowMod :
        b : int *
        e : int *
        m : int -> int

Parameters

b
Int32
The base, which must be positive.
e
Int32
The exponent, which must be positive.
m
Int32
The modulus, which must be positive.

Return Value

Int32
The value of be mod m.

Remarks

Modular exponentiation is used in many number-theory applications, including primality testing, prime factorization, and cryptography.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | b, e, or m is not positive.

See Also

AdvancedIntegerMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Modular_exponentiation


AdvancedMath Class

F#

| Members | See Also
Meta.Numerics Library
AdvancedMath Class
Contains methods that compute advanced functions with real arguments.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class AdvancedMath
Public NotInheritable Class AdvancedMath
public ref class AdvancedMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdvancedMath =  class end

Members

All Members | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Airy(Double) | Computes both Airy functions and their derivatives.
AiryAi(Double) | Computes the Airy function of the first kind.
AiryBi(Double) | Computes the Airy function of the second kind.
Bessel(Double, Double) | Computes both solutions of the Bessel differential equation.
BesselJ(Double, Double) | Computes the regular Bessel function for real orders.
BesselJ(Int32, Double) | Computes the regular Bessel function for integer orders.
BesselY(Double, Double) | Computes the irregual Bessel function for real orders.
BesselY(Int32, Double) | Computes the irregular Bessel function for integer orders.
Beta(Double, Double) | Computes the Beta function.
Beta(Double, Double, Double) | Computes the incomplete Beta function.
CarlsonD(Double, Double, Double) | Computes the Carlson integral RD.
CarlsonF(Double, Double, Double) | Computes the Carslon elliptic integral RF.
Catalan | Catalan's constant.
Clausen(Double) | Computes the Clausen integral.
CoulombF(Int32, Double, Double) | Computes the regular Coulomb wave function.
CoulombG(Int32, Double, Double) | Computes the irregular Coulomb wave function.
Dawson(Double) | Computes the Dawson integral.
DiLog(Double) | Computes the dilogarathm function, also called Spence's function.
DirichletEta(Double) | Computes the Dirichlet eta function.
EllipticE(Double) | Computes the complete elliptic integral of the second kind.
EllipticE(Double, Double) | Computes the incomplete elliptic integral of the second kind.
EllipticF(Double, Double) | Computes the incomplete elliptic integral of the first kind.
EllipticK(Double) | Computes the complete elliptic integral of the first kind.
Erf(Double) | Computes the error function.
Erfc(Double) | Computes the complementary error function.
EulerGamma | The Euler constant.
Fresnel(Double) | Computes the Fresnel cosine and sine integrals.
FresnelC(Double) | Computes the Fresnel cosine integral.
FresnelS(Double) | Computes the Fresnel sine integral.
Gamma(Double) | Computes the Gamma function.
Gamma(Double, Double) | Computes the upper incomplete Gamma function.
GoldenRatio | The golden ratio.
IntegralCi(Double) | Computes the cosine integral.
IntegralE(Int32, Double) | Computes the exponential integral.
IntegralEi(Double) | Computes the principal value of the exponential integral.
IntegralSi(Double) | Computes the sine integral.
IntegralTi(Double) | Computes the inverse tangent integral.
InverseErf(Double) | Computes the inverse error function.
InverseErfc(Double) | Computes the inverse complementary error function.
LambertW(Double) | Computes the Lambert W function.
LeftRegularizedBeta(Double, Double, Double) | Computes the regularized incomplete Beta function.
LeftRegularizedGamma(Double, Double) | Computes the normalized lower (left) incomplete Gamma function.
LogBeta(Double, Double) | Computes the lograrithm of the Beta function.
LogGamma(Double) | Computes the natural logrithm of the Gamma function.
ModifiedBessel(Double, Double) | Computes modified cylindrical Bessel functions.
ModifiedBesselI(Double, Double) | Computes the regular modified cynlindrical Bessel function.
ModifiedBesselK(Double, Double) | Computes the irregular modified cynlindrical Bessel function.
PolyLog(Int32, Double) | Computes the polylogarithm function.
Psi(Double) | Computes the digamma function.
Psi(Int32, Double) | Computes the polygamma function.
RiemannZeta(Double) | Computes the Riemann zeta function.
RightRegularizedGamma(Double, Double) | Computes the normalized upper (right) incomplete Gamma function.
SphericalBesselJ(Int32, Double) | Computes the regular spherical Bessel function of integer order.
SphericalBesselY(Int32, Double) | Computes the irregular spherical Bessel function of integer order.
SphericalHarmonic(Int32, Int32, Double, Double) | Computes the value of a spherical harmonic function.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..AdvancedMath

See Also

Meta.Numerics.Functions Namespace


AdvancedMath Fields

F#

Meta.Numerics Library
AdvancedMath Fields

The AdvancedMath type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Catalan | Catalan's constant.
EulerGamma | The Euler constant.
GoldenRatio | The golden ratio.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Catalan Field

F#

Meta.Numerics Library
AdvancedMath..::Catalan Field
Catalan's constant.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public const double Catalan
Public Const Catalan As Double
public:
literal double Catalan
static val mutable Catalan: float

Field Value

Double

Remarks

Catalan's constant 0.9159...

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Catalan_constant


AdvancedMath.EulerGamma Field

F#

Meta.Numerics Library
AdvancedMath..::EulerGamma Field
The Euler constant.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public const double EulerGamma
Public Const EulerGamma As Double
public:
literal double EulerGamma
static val mutable EulerGamma: float

Field Value

Double

Remarks

The Euler constant γ = 0.5772...

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Euler_gamma
http://mathworld.wolfram.com/Euler-MascheroniConstant.html


AdvancedMath.GoldenRatio Field

F#

Meta.Numerics Library
AdvancedMath..::GoldenRatio Field
The golden ratio.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static readonly double GoldenRatio
Public Shared ReadOnly GoldenRatio As Double
public:
static initonly double GoldenRatio
static val GoldenRatio: float

Field Value

Double

Remarks

The golden ratio φ = 1.1618...

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Golden_ratio
http://mathworld.wolfram.com/GoldenRatio.html


AdvancedMath Methods

F#

Meta.Numerics Library
AdvancedMath Methods

The AdvancedMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Airy(Double) | Computes both Airy functions and their derivatives.
AiryAi(Double) | Computes the Airy function of the first kind.
AiryBi(Double) | Computes the Airy function of the second kind.
Bessel(Double, Double) | Computes both solutions of the Bessel differential equation.
BesselJ(Double, Double) | Computes the regular Bessel function for real orders.
BesselJ(Int32, Double) | Computes the regular Bessel function for integer orders.
BesselY(Double, Double) | Computes the irregual Bessel function for real orders.
BesselY(Int32, Double) | Computes the irregular Bessel function for integer orders.
Beta(Double, Double) | Computes the Beta function.
Beta(Double, Double, Double) | Computes the incomplete Beta function.
CarlsonD(Double, Double, Double) | Computes the Carlson integral RD.
CarlsonF(Double, Double, Double) | Computes the Carslon elliptic integral RF.
Clausen(Double) | Computes the Clausen integral.
CoulombF(Int32, Double, Double) | Computes the regular Coulomb wave function.
CoulombG(Int32, Double, Double) | Computes the irregular Coulomb wave function.
Dawson(Double) | Computes the Dawson integral.
DiLog(Double) | Computes the dilogarathm function, also called Spence's function.
DirichletEta(Double) | Computes the Dirichlet eta function.
EllipticE(Double) | Computes the complete elliptic integral of the second kind.
EllipticE(Double, Double) | Computes the incomplete elliptic integral of the second kind.
EllipticF(Double, Double) | Computes the incomplete elliptic integral of the first kind.
EllipticK(Double) | Computes the complete elliptic integral of the first kind.
Erf(Double) | Computes the error function.
Erfc(Double) | Computes the complementary error function.
Fresnel(Double) | Computes the Fresnel cosine and sine integrals.
FresnelC(Double) | Computes the Fresnel cosine integral.
FresnelS(Double) | Computes the Fresnel sine integral.
Gamma(Double) | Computes the Gamma function.
Gamma(Double, Double) | Computes the upper incomplete Gamma function.
IntegralCi(Double) | Computes the cosine integral.
IntegralE(Int32, Double) | Computes the exponential integral.
IntegralEi(Double) | Computes the principal value of the exponential integral.
IntegralSi(Double) | Computes the sine integral.
IntegralTi(Double) | Computes the inverse tangent integral.
InverseErf(Double) | Computes the inverse error function.
InverseErfc(Double) | Computes the inverse complementary error function.
LambertW(Double) | Computes the Lambert W function.
LeftRegularizedBeta(Double, Double, Double) | Computes the regularized incomplete Beta function.
LeftRegularizedGamma(Double, Double) | Computes the normalized lower (left) incomplete Gamma function.
LogBeta(Double, Double) | Computes the lograrithm of the Beta function.
LogGamma(Double) | Computes the natural logrithm of the Gamma function.
ModifiedBessel(Double, Double) | Computes modified cylindrical Bessel functions.
ModifiedBesselI(Double, Double) | Computes the regular modified cynlindrical Bessel function.
ModifiedBesselK(Double, Double) | Computes the irregular modified cynlindrical Bessel function.
PolyLog(Int32, Double) | Computes the polylogarithm function.
Psi(Double) | Computes the digamma function.
Psi(Int32, Double) | Computes the polygamma function.
RiemannZeta(Double) | Computes the Riemann zeta function.
RightRegularizedGamma(Double, Double) | Computes the normalized upper (right) incomplete Gamma function.
SphericalBesselJ(Int32, Double) | Computes the regular spherical Bessel function of integer order.
SphericalBesselY(Int32, Double) | Computes the irregular spherical Bessel function of integer order.
SphericalHarmonic(Int32, Int32, Double, Double) | Computes the value of a spherical harmonic function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Airy Method

F#

Meta.Numerics Library
AdvancedMath..::Airy Method
Computes both Airy functions and their derivatives.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SolutionPair Airy(
    double x
)
Public Shared Function Airy (
    x As Double
) As SolutionPair
public:
static SolutionPair Airy(
    double x
)
static member Airy :
        x : float -> SolutionPair

Parameters

x
Double
The argument.

Return Value

SolutionPair
The values of Ai(x), Ai'(x), Bi(x), and Bi'(x).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.AiryAi Method

F#

Meta.Numerics Library
AdvancedMath..::AiryAi Method
Computes the Airy function of the first kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double AiryAi(
    double x
)
Public Shared Function AiryAi (
    x As Double
) As Double
public:
static double AiryAi(
    double x
)
static member AiryAi :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value Ai(x).

Remarks

Airy functions are solutions to the Airy differential equation:

The Airy functions appear in quantum mechanics in the semiclassical WKB solution to the wave functions in a potential.

For negative arguments, Ai(x) is oscilatory. For positive arguments, it decreases exponentially with increasing x.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..AiryBi(Double)
http://en.wikipedia.org/wiki/Airy_functions


AdvancedMath.AiryBi Method

F#

Meta.Numerics Library
AdvancedMath..::AiryBi Method
Computes the Airy function of the second kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double AiryBi(
    double x
)
Public Shared Function AiryBi (
    x As Double
) As Double
public:
static double AiryBi(
    double x
)
static member AiryBi :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value Bi(x).

Remarks

The Airy functions appear in quantum mechanics in the semiclassical WKB solution to the wave functions in a potential.

For negative arguments, Bi(x) is oscilatory. For positive arguments, it increases exponentially with increasing x.

While the notation Bi(x) was chosen simply as a natural complement to Ai(x), it has influenced the common nomenclature for this function, which is now often called the "Bairy function".

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..AiryAi(Double)
http://en.wikipedia.org/wiki/Airy_functions


AdvancedMath.Bessel Method

F#

Meta.Numerics Library
AdvancedMath..::Bessel Method
Computes both solutions of the Bessel differential equation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SolutionPair Bessel(
    double nu,
    double x
)
Public Shared Function Bessel (
    nu As Double,
    x As Double
) As SolutionPair
public:
static SolutionPair Bessel(
    double nu,
    double x
)
static member Bessel :
        nu : float *
        x : float -> SolutionPair

Parameters

nu
Double
The order, which must be non-negative.
x
Double
The argument, which must be non-negative.

Return Value

SolutionPair
The values of Jnu(x), J'nu(x), Ynu(x), and Y'nu(x).

Remarks

Bessel functions often occur in physical phenomenon with cylindrical symmetry. They satisfy the differential equation

Since this is second order linear equation, is has two linearly independent solutions. The regular Bessel function Jν(x), which is regular at the origin, and the irregular Bessel function Yν(x), which diverges at the origin. Far from the origin, both functions are oscilatory.

This method simultaneously computes both Bessel functions and their derivatives. If you need both J and Y, it is faster to call this method once than to call BesselJ(Double, Double) and BesselY(Double, Double) seperately. If on, the other hand, you need only J or only Y, it is faster to call the appropriate method to compute the one you need.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | nu or x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bessel_function


AdvancedMath.BesselJ Method

F#

Meta.Numerics Library
AdvancedMath..::BesselJ Method

Overload List

Name | Description
BesselJ(Double, Double) | Computes the regular Bessel function for real orders.
BesselJ(Int32, Double) | Computes the regular Bessel function for integer orders.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.BesselJ Method (Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::BesselJ Method (Double, Double)
Computes the regular Bessel function for real orders.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BesselJ(
    double nu,
    double x
)
Public Shared Function BesselJ (
    nu As Double,
    x As Double
) As Double
public:
static double BesselJ(
    double nu,
    double x
)
static member BesselJ :
        nu : float *
        x : float -> float

Parameters

nu
Double
The order parameter.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Jν(x).

Remarks

For information on the cylindrical Bessel functions, see Bessel(Double, Double).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
BesselJ Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bessel_function


AdvancedMath.BesselJ Method (Int32, Double)

F#

Meta.Numerics Library
AdvancedMath..::BesselJ Method (Int32, Double)
Computes the regular Bessel function for integer orders.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BesselJ(
    int n,
    double x
)
Public Shared Function BesselJ (
    n As Integer,
    x As Double
) As Double
public:
static double BesselJ(
    int n,
    double x
)
static member BesselJ :
        n : int *
        x : float -> float

Parameters

n
Int32
The order parameter.
x
Double
The argument.

Return Value

Double
The value of Jn(x).

Remarks

For information on the cylindrical Bessel functions, see Bessel(Double, Double).

See Also

AdvancedMath Class
BesselJ Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bessel_function


AdvancedMath.BesselY Method

F#

Meta.Numerics Library
AdvancedMath..::BesselY Method

Overload List

Name | Description
BesselY(Double, Double) | Computes the irregual Bessel function for real orders.
BesselY(Int32, Double) | Computes the irregular Bessel function for integer orders.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.BesselY Method (Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::BesselY Method (Double, Double)
Computes the irregual Bessel function for real orders.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BesselY(
    double nu,
    double x
)
Public Shared Function BesselY (
    nu As Double,
    x As Double
) As Double
public:
static double BesselY(
    double nu,
    double x
)
static member BesselY :
        nu : float *
        x : float -> float

Parameters

nu
Double
The order parameter.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Yν(x).

Remarks

For information on the cylindrical Bessel functions, see Bessel(Double, Double).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
BesselY Overload
Meta.Numerics.Functions Namespace
AdvancedMath..::..Bessel(Double, Double)
http://en.wikipedia.org/wiki/Bessel_function


AdvancedMath.BesselY Method (Int32, Double)

F#

Meta.Numerics Library
AdvancedMath..::BesselY Method (Int32, Double)
Computes the irregular Bessel function for integer orders.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double BesselY(
    int n,
    double x
)
Public Shared Function BesselY (
    n As Integer,
    x As Double
) As Double
public:
static double BesselY(
    int n,
    double x
)
static member BesselY :
        n : int *
        x : float -> float

Parameters

n
Int32
The order parameter.
x
Double
The argument.

Return Value

Double
The value of Yn(x).

Remarks

For information on the cylindrical Bessel functions, see Bessel(Double, Double).

See Also

AdvancedMath Class
BesselY Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Bessel_function


AdvancedMath.Beta Method

F#

Meta.Numerics Library
AdvancedMath..::Beta Method

Overload List

Name | Description
Beta(Double, Double) | Computes the Beta function.
Beta(Double, Double, Double) | Computes the incomplete Beta function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Beta Method (Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::Beta Method (Double, Double)
Computes the Beta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Beta(
    double a,
    double b
)
Public Shared Function Beta (
    a As Double,
    b As Double
) As Double
public:
static double Beta(
    double a,
    double b
)
static member Beta :
        a : float *
        b : float -> float

Parameters

a
Double
The first parameter, which must be positive.
b
Double
The second parameter, which must be positive.

Return Value

Double
The beta function B(a,b).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | a or b is non-positive.

See Also

AdvancedMath Class
Beta Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Beta_function


AdvancedMath.Beta Method (Double, Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::Beta Method (Double, Double, Double)
Computes the incomplete Beta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Beta(
    double a,
    double b,
    double x
)
Public Shared Function Beta (
    a As Double,
    b As Double,
    x As Double
) As Double
public:
static double Beta(
    double a,
    double b,
    double x
)
static member Beta :
        a : float *
        b : float *
        x : float -> float

Parameters

a
Double
The left shape parameter, which must be non-negative.
b
Double
The right shape paraemter, which must be non-negative.
x
Double
The integral endpoint, which must lie in [0,1].

Return Value

Double
The value of Bx(a, b).

See Also

AdvancedMath Class
Beta Overload
Meta.Numerics.Functions Namespace


AdvancedMath.CarlsonD Method

F#

Meta.Numerics Library
AdvancedMath..::CarlsonD Method
Computes the Carlson integral RD.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double CarlsonD(
    double x,
    double y,
    double z
)
Public Shared Function CarlsonD (
    x As Double,
    y As Double,
    z As Double
) As Double
public:
static double CarlsonD(
    double x,
    double y,
    double z
)
static member CarlsonD :
        x : float *
        y : float *
        z : float -> float

Parameters

x
Double
The first parameter, which must be non-negative.
y
Double
The second parameter, which must be non-negative.
z
Double
The third parameter, which must be non-negative.

Return Value

Double
The value of RD(x, y, z)

Remarks

The Carlson D integral is:

It is symmetric with respect to the interchange of the first two parameters, but not the third parameter.

The Carlson integrals can be used to express integrals of rational functions. In that sense, they are replacements for the Legendre elliptic functions.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Carlson_symmetric_form


AdvancedMath.CarlsonF Method

F#

Meta.Numerics Library
AdvancedMath..::CarlsonF Method
Computes the Carslon elliptic integral RF.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double CarlsonF(
    double x,
    double y,
    double z
)
Public Shared Function CarlsonF (
    x As Double,
    y As Double,
    z As Double
) As Double
public:
static double CarlsonF(
    double x,
    double y,
    double z
)
static member CarlsonF :
        x : float *
        y : float *
        z : float -> float

Parameters

x
Double
The first parameter, which must be non-negative.
y
Double
The second parameter, which must be non-negative.
z
Double
The third parameter, which must be non-negative.

Return Value

Double
The value of RF(x,y,z).

Remarks

The Carlson F integral is:

As can be seen from the integral, all three parameters are equivilent, so RF is symmetric with respect to any permutation of the parameters.

The Carlson integrals can be used to express integrals of rational functions. In that sense, they are replacements for the Legendre elliptic functions.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..EllipticK(Double)
AdvancedMath..::..EllipticF(Double, Double)
http://en.wikipedia.org/wiki/Carlson_symmetric_form


AdvancedMath.Clausen Method

F#

Meta.Numerics Library
AdvancedMath..::Clausen Method
Computes the Clausen integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Clausen(
    double t
)
Public Shared Function Clausen (
    t As Double
) As Double
public:
static double Clausen(
    double t
)
static member Clausen :
        t : float -> float

Parameters

t
Double
The argument.

Return Value

Double
The value of Cl2(t).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Clausen%27s_function


AdvancedMath.CoulombF Method

F#

Meta.Numerics Library
AdvancedMath..::CoulombF Method
Computes the regular Coulomb wave function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double CoulombF(
    int L,
    double eta,
    double rho
)
Public Shared Function CoulombF (
    L As Integer,
    eta As Double,
    rho As Double
) As Double
public:
static double CoulombF(
    int L,
    double eta,
    double rho
)
static member CoulombF :
        L : int *
        eta : float *
        rho : float -> float

Parameters

L
Int32
The angular momentum number, which must be non-negative.
eta
Double
The charge parameter, which can be postive or negative.
rho
Double
The radial distance parameter, which must be non-negative.

Return Value

Double
The value of FL(η,ρ).

Remarks

The Coulomb wave functions are the radial wave functions of a non-relativistic particle in a Coulomb potential.

They satisfy the differential equation:

A repulsive potential is represented by η > 0, an attractive potential by η < 0.

F is oscilatory in the region beyond the classical turning point. In the quantum tunneling region inside the classical turning point, F is exponentially supressed.

Many numerical libraries compute Coulomb wave functions in the quantum tunneling region using a WKB approximation, which accurately determine only the first handfull of digits; our library computes Coulomb wave functions even in this computationaly difficult region to nearly full precision -- all but the last 3-4 digits can be trusted.

The irregular Coulomb wave functions GL(η,ρ) are the complementary independent solutions of the same differential equation.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | L or rho is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..CoulombG(Int32, Double, Double)
http://en.wikipedia.org/wiki/Coulomb_wave_function
http://mathworld.wolfram.com/CoulombWaveFunction.html


AdvancedMath.CoulombG Method

F#

Meta.Numerics Library
AdvancedMath..::CoulombG Method
Computes the irregular Coulomb wave function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double CoulombG(
    int L,
    double eta,
    double rho
)
Public Shared Function CoulombG (
    L As Integer,
    eta As Double,
    rho As Double
) As Double
public:
static double CoulombG(
    int L,
    double eta,
    double rho
)
static member CoulombG :
        L : int *
        eta : float *
        rho : float -> float

Parameters

L
Int32
The angular momentum number, which must be non-negative.
eta
Double
The charge parameter, which can be postive or negative.
rho
Double
The radial distance parameter, which must be non-negative.

Return Value

Double
The value of GL(η,ρ).

Remarks

For information on the Coulomb wave functions, see the remarks on CoulombF(Int32, Double, Double).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | L or rho is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..CoulombF(Int32, Double, Double)
http://en.wikipedia.org/wiki/Coulomb_wave_function
http://mathworld.wolfram.com/CoulombWaveFunction.html


AdvancedMath.Dawson Method

F#

Meta.Numerics Library
AdvancedMath..::Dawson Method
Computes the Dawson integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Dawson(
    double x
)
Public Shared Function Dawson (
    x As Double
) As Double
public:
static double Dawson(
    double x
)
static member Dawson :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of F(x).

Remarks

The Dawson function is defined by the integral:

It is related to the error function for purely imaginary arguments.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Dawson_function


AdvancedMath.DiLog Method

F#

Meta.Numerics Library
AdvancedMath..::DiLog Method
Computes the dilogarathm function, also called Spence's function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double DiLog(
    double x
)
Public Shared Function DiLog (
    x As Double
) As Double
public:
static double DiLog(
    double x
)
static member DiLog :
        x : float -> float

Parameters

x
Double
The argument, which must be less than or equal to unity.

Return Value

Double
The value Li2(x).

Remarks

The dilogarithm can be defined by an infinite sum.

The function gets is name from the similiarity of this series to the expansion of ln(1-x), the difference being that the integer in the denominator is raised to the second power.

Li2(x) is real for -∞ < x ≤ 1; for values outside this range, use the complex version DiLog(Complex).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedComplexMath..::..DiLog(Complex)
http://en.wikipedia.org/wiki/Dilogarithm


AdvancedMath.DirichletEta Method

F#

Meta.Numerics Library
AdvancedMath..::DirichletEta Method
Computes the Dirichlet eta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double DirichletEta(
    double x
)
Public Shared Function DirichletEta (
    x As Double
) As Double
public:
static double DirichletEta(
    double x
)
static member DirichletEta :
        x : float -> float

Parameters

x
Double
The argument, which must be non-negative.

Return Value

Double
The value of η(s).

Remarks

The Dirichlet eta function is the sum of the xth inverse power of the natural numbers, with alternating signs.

Because these are just the terms of the Riemann zeta function (RiemannZeta(Double)) with alternating signs, it is also called the alternating zeta function.

It can be related to the Riemann ζ function.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..RiemannZeta(Double)
http://en.wikipedia.org/wiki/Dirichlet_eta_function


AdvancedMath.EllipticE Method

F#

Meta.Numerics Library
AdvancedMath..::EllipticE Method

Overload List

Name | Description
EllipticE(Double) | Computes the complete elliptic integral of the second kind.
EllipticE(Double, Double) | Computes the incomplete elliptic integral of the second kind.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.EllipticE Method (Double)

F#

Meta.Numerics Library
AdvancedMath..::EllipticE Method (Double)
Computes the complete elliptic integral of the second kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double EllipticE(
    double k
)
Public Shared Function EllipticE (
    k As Double
) As Double
public:
static double EllipticE(
    double k
)
static member EllipticE :
        k : float -> float

Parameters

k
Double
The elliptic modulus, which must lie between zero and one.

Return Value

Double
The value of the Legendre integral E(k).

Remarks

E(k) is defined as the complete elliptic integral:

It appears in the Legendre reduction of integrals of rational funtions.

The perimeter of an ellipse with major axis a and eccentricity e is 4 a E(e).

Be aware that some authors use the the parameter m = k2 instead of the modulus k.

See Also

AdvancedMath Class
EllipticE Overload
Meta.Numerics.Functions Namespace
AdvancedMath..::..EllipticE(Double, Double)
http://en.wikipedia.org/wiki/Elliptic_integral


AdvancedMath.EllipticE Method (Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::EllipticE Method (Double, Double)
Computes the incomplete elliptic integral of the second kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double EllipticE(
    double phi,
    double k
)
Public Shared Function EllipticE (
    phi As Double,
    k As Double
) As Double
public:
static double EllipticE(
    double phi,
    double k
)
static member EllipticE :
        phi : float *
        k : float -> float

Parameters

phi
Double
The integration angle (in radians).
k
Double
The elliptic modulus, which must lie between zero and one.

Return Value

Double
The value of E(phi,k).

Remarks

The incomplete elliptic integral of the second kind is:

It appears in the Legendre reduction of integrals of rational funtions.

Be aware that some authors use the the parameter m = k2 instead of the modulus k.

See Also

AdvancedMath Class
EllipticE Overload
Meta.Numerics.Functions Namespace
AdvancedMath..::..EllipticE(Double)
http://en.wikipedia.org/wiki/Elliptic_integral


AdvancedMath.EllipticF Method

F#

Meta.Numerics Library
AdvancedMath..::EllipticF Method
Computes the incomplete elliptic integral of the first kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double EllipticF(
    double phi,
    double k
)
Public Shared Function EllipticF (
    phi As Double,
    k As Double
) As Double
public:
static double EllipticF(
    double phi,
    double k
)
static member EllipticF :
        phi : float *
        k : float -> float

Parameters

phi
Double
The integration angle (in radians).
k
Double
The elliptic modulus, which must lie between zero and one.

Return Value

Double
The value of the Legendre integral F(k).

Remarks

Legendre's first incomplete elliptic integral is:

When the integral angle is π, this function reduces to the complete elliptic integral of the first kind (EllipticK(Double).

Be aware that some authors use the the parameter m = k2 instead of the modulus k.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..EllipticK(Double)


AdvancedMath.EllipticK Method

F#

Meta.Numerics Library
AdvancedMath..::EllipticK Method
Computes the complete elliptic integral of the first kind.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double EllipticK(
    double k
)
Public Shared Function EllipticK (
    k As Double
) As Double
public:
static double EllipticK(
    double k
)
static member EllipticK :
        k : float -> float

Parameters

k
Double
The elliptic modulus, which must lie between zero and one.

Return Value

Double
The value of the Legendre integral K(k).

Remarks

K(k) is defined as the complete elliptic integral:

It appears in the Legendre reduction of integrals of rational funtions.

Be aware that some authors use the the parameter m = k2 instead of the modulus k.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..EllipticF(Double, Double)
http://en.wikipedia.org/wiki/Elliptic_integral


AdvancedMath.Erf Method

F#

Meta.Numerics Library
AdvancedMath..::Erf Method
Computes the error function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Erf(
    double x
)
Public Shared Function Erf (
    x As Double
) As Double
public:
static double Erf(
    double x
)
static member Erf :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of erf(x).

Remarks

The error can be defined via a Gaussian integral.

The area under a bell curve (NormalDistribution) within ∓z standard deviations of the mean is given by erf(z/√2).

For large values of x, erf(x) ≈ 1 to within floating-point accuracy. To obtain accurate values of erfc(x) = 1 - erf(x) in this range, use the Erfc(Double) function.

The inverse of the error function is implemented as InverseErf(Double).

Values of the error function for complex arguments can be obtained using Erf(Complex) method, or using the equivalent but re-parameterized Faddeeva(Complex) function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Erfc(Double)
http://en.wikipedia.org/wiki/Error_function
http://mathworld.wolfram.com/Erf.html


AdvancedMath.Erfc Method

F#

Meta.Numerics Library
AdvancedMath..::Erfc Method
Computes the complementary error function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Erfc(
    double x
)
Public Shared Function Erfc (
    x As Double
) As Double
public:
static double Erfc(
    double x
)
static member Erfc :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of erfc(x) = 1 - erf(x).

Remarks

The complementary error function can be used to express the area in the tails of a Bell curve beyond a given distance from its center.

It can be defined via an integral:

For small values of x, erfc(x) ≈ 1 to within floating-point accuracy. To obtain accurate values of erfc(x) = 1 - erf(x) in this region, use the Erf(Double) function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Erf(Double)


AdvancedMath.Fresnel Method

F#

Meta.Numerics Library
AdvancedMath..::Fresnel Method
Computes the Fresnel cosine and sine integrals.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex Fresnel(
    double x
)
Public Shared Function Fresnel (
    x As Double
) As Complex
public:
static Complex Fresnel(
    double x
)
static member Fresnel :
        x : float -> Complex

Parameters

x
Double
The argument.

Return Value

Complex
The value C(x) + i S(x).

Remarks

A plot of all values of this function in the complex plane as x ranges from negative infinity to positive infinity is called a Cornu spiral.

The Fresnel function can be related to the complex error function along the line (1-I).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..FresnelS(Double)
AdvancedMath..::..FresnelC(Double)
http://en.wikipedia.org/wiki/Fresnel_integral
http://mathworld.wolfram.com/CornuSpiral.html


AdvancedMath.FresnelC Method

F#

Meta.Numerics Library
AdvancedMath..::FresnelC Method
Computes the Fresnel cosine integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double FresnelC(
    double x
)
Public Shared Function FresnelC (
    x As Double
) As Double
public:
static double FresnelC(
    double x
)
static member FresnelC :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of C(x).

Remarks

The Fresnel cosine integral is defined as:

It appears in wave optics in the calculation of diffraction patterns.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..FresnelS(Double)
AdvancedMath..::..Fresnel(Double)
http://en.wikipedia.org/wiki/Fresnel_integral


AdvancedMath.FresnelS Method

F#

Meta.Numerics Library
AdvancedMath..::FresnelS Method
Computes the Fresnel sine integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double FresnelS(
    double x
)
Public Shared Function FresnelS (
    x As Double
) As Double
public:
static double FresnelS(
    double x
)
static member FresnelS :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of S(x).

Remarks

The Fresnel sine integral is defined as:

It appears in wave optics in the calculation of diffraction patterns.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..FresnelC(Double)
AdvancedMath..::..Fresnel(Double)
http://en.wikipedia.org/wiki/Fresnel_integral


AdvancedMath.Gamma Method

F#

Meta.Numerics Library
AdvancedMath..::Gamma Method

Overload List

Name | Description
Gamma(Double) | Computes the Gamma function.
Gamma(Double, Double) | Computes the upper incomplete Gamma function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Gamma Method (Double)

F#

Meta.Numerics Library
AdvancedMath..::Gamma Method (Double)
Computes the Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Gamma(
    double x
)
Public Shared Function Gamma (
    x As Double
) As Double
public:
static double Gamma(
    double x
)
static member Gamma :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of Γ(x).

Remarks

The Gamma function is a generalization of the factorial (see Factorial(Int32)) to arbitrary real values.

For positive integer arguments, this integral evaluates to Γ(n+1)=n!, but it can also be evaluated for non-integer z.

Because Γ(x) grows beyond the largest value that can be represented by a Double at quite moderate values of x, you may find it useful to work with the LogGamma(Double) method, which returns ln(Γ(x)).

To evaluate the Gamma function for a complex argument, use Gamma(Complex).

Domain, Range, and Accuracy

The function is defined for all x. It has poles at all negative integers and at zero; the method returns NaN for these arguments. For positive arguments, the value of the function increases rapidly with increasing argument. For values of x greater than about 170, the value of the function exceeds MaxValue; for these arguments the method returns PositiveInfinity. The method is accurate to full precision over its entire domain.

See Also

AdvancedMath Class
Gamma Overload
Meta.Numerics.Functions Namespace
AdvancedIntegerMath..::..Factorial(Int32)
AdvancedMath..::..LogGamma(Double)
AdvancedComplexMath..::..Gamma(Complex)
http://en.wikipedia.org/wiki/Gamma_function
http://mathworld.wolfram.com/GammaFunction.html
DLMF on the Gamma Function


AdvancedMath.Gamma Method (Double, Double)

F#

Meta.Numerics Library
AdvancedMath..::Gamma Method (Double, Double)
Computes the upper incomplete Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Gamma(
    double a,
    double x
)
Public Shared Function Gamma (
    a As Double,
    x As Double
) As Double
public:
static double Gamma(
    double a,
    double x
)
static member Gamma :
        a : float *
        x : float -> float

Parameters

a
Double
The shape parameter, which must be positive.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Γ(a,x).

Remarks

The incomplete Gamma function is defined by the same integrand as the Gamma function (Gamma(Double)), but the integral is not taken over the full positive real axis.

Like the Γ function itself, this function gets large very quickly. For most purposes, you will prefer to use the regularized incomplete gamma functions LeftRegularizedGamma(Double, Double) and RightRegularizedGamma(Double, Double).

See Also

AdvancedMath Class
Gamma Overload
Meta.Numerics.Functions Namespace
AdvancedMath..::..Gamma(Double)
http://en.wikipedia.org/wiki/Incomplete_Gamma_function


AdvancedMath.IntegralCi Method

F#

Meta.Numerics Library
AdvancedMath..::IntegralCi Method
Computes the cosine integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double IntegralCi(
    double x
)
Public Shared Function IntegralCi (
    x As Double
) As Double
public:
static double IntegralCi(
    double x
)
static member IntegralCi :
        x : float -> float

Parameters

x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Ci(x).

Remarks

The cosine integral is defined as:

The cosine integral diverges logrithmically to negative inifity at the origin and executes a damped oscilation arround zero as its argument increases.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.IntegralE Method

F#

Meta.Numerics Library
AdvancedMath..::IntegralE Method
Computes the exponential integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double IntegralE(
    int n,
    double x
)
Public Shared Function IntegralE (
    n As Integer,
    x As Double
) As Double
public:
static double IntegralE(
    int n,
    double x
)
static member IntegralE :
        n : int *
        x : float -> float

Parameters

n
Int32
The order parameter.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of En(x).

Remarks

The exponential integral is defined as:

It is related to the incomplete Gamma function for negative, integer shape parameters by Γ(-k, x) = Eik+1(x) / xk.

In hydrology, E1(x) is sometimes called the Well function.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.IntegralEi Method

F#

Meta.Numerics Library
AdvancedMath..::IntegralEi Method
Computes the principal value of the exponential integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double IntegralEi(
    double x
)
Public Shared Function IntegralEi (
    x As Double
) As Double
public:
static double IntegralEi(
    double x
)
static member IntegralEi :
        x : float -> float

Parameters

x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Ei(x).

Remarks

The function Ei(x) appears in the evaluation of some indefinite integrals involving exponents and in number theory in the approximation li(x) = Ei(ln x) to the cumulative distribution of primes.

It is related to the real part of the exponential integral for negative arguments by E1(-x ± iε) = -Ei(x) ∓ iπ.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.IntegralSi Method

F#

Meta.Numerics Library
AdvancedMath..::IntegralSi Method
Computes the sine integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double IntegralSi(
    double x
)
Public Shared Function IntegralSi (
    x As Double
) As Double
public:
static double IntegralSi(
    double x
)
static member IntegralSi :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of Si(x).

Remarks

The sine integral is defined as:

The sine integral is zero at the origin and executes a damped oscilation arround π/2 as its argument increases.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.IntegralTi Method

F#

Meta.Numerics Library
AdvancedMath..::IntegralTi Method
Computes the inverse tangent integral.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double IntegralTi(
    double x
)
Public Shared Function IntegralTi (
    x As Double
) As Double
public:
static double IntegralTi(
    double x
)
static member IntegralTi :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of Ti2(x).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://mathworld.wolfram.com/InverseTangentIntegral.html


AdvancedMath.InverseErf Method

F#

Meta.Numerics Library
AdvancedMath..::InverseErf Method
Computes the inverse error function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double InverseErf(
    double y
)
Public Shared Function InverseErf (
    y As Double
) As Double
public:
static double InverseErf(
    double y
)
static member InverseErf :
        y : float -> float

Parameters

y
Double
The error function value erf(x), which must lie between -1 and 1.

Return Value

Double
The corresponding argument x.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | y is outside [-1,1].

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Erf(Double)
AdvancedMath..::..Erfc(Double)
AdvancedMath..::..InverseErfc(Double)


AdvancedMath.InverseErfc Method

F#

Meta.Numerics Library
AdvancedMath..::InverseErfc Method
Computes the inverse complementary error function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double InverseErfc(
    double y
)
Public Shared Function InverseErfc (
    y As Double
) As Double
public:
static double InverseErfc(
    double y
)
static member InverseErfc :
        y : float -> float

Parameters

y
Double
The value of erfc(x), which must lie between 0 and 1.

Return Value

Double
The corresponding argument x.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | y lies outside [0,1].

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Erf(Double)
AdvancedMath..::..Erfc(Double)
AdvancedMath..::..InverseErf(Double)


AdvancedMath.LambertW Method

F#

Meta.Numerics Library
AdvancedMath..::LambertW Method
Computes the Lambert W function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LambertW(
    double x
)
Public Shared Function LambertW (
    x As Double
) As Double
public:
static double LambertW(
    double x
)
static member LambertW :
        x : float -> float

Parameters

x
Double
The argument, which must be greater than or equal to -1/e.

Return Value

Double
The value W(x).

Remarks

The Lambert W function solves the transcendental equation W eW = x. The function appears in a number of contexts, including the solution of differential equations and the enumeration of trees.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Lambert_W_function
http://www.apmaths.uwo.ca/~djeffrey/Offprints/W-adv-cm.pdf


AdvancedMath.LeftRegularizedBeta Method

F#

Meta.Numerics Library
AdvancedMath..::LeftRegularizedBeta Method
Computes the regularized incomplete Beta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LeftRegularizedBeta(
    double a,
    double b,
    double x
)
Public Shared Function LeftRegularizedBeta (
    a As Double,
    b As Double,
    x As Double
) As Double
public:
static double LeftRegularizedBeta(
    double a,
    double b,
    double x
)
static member LeftRegularizedBeta :
        a : float *
        b : float *
        x : float -> float

Parameters

a
Double
The left shape parameter, which must be non-negative.
b
Double
The right shape paraemter, which must be non-negative.
x
Double
The integral endpoint, which must lie in [0,1].

Return Value

Double
The value of Ix(a, b) = Bx(a, b) / B(a, b).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.LeftRegularizedGamma Method

F#

Meta.Numerics Library
AdvancedMath..::LeftRegularizedGamma Method
Computes the normalized lower (left) incomplete Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LeftRegularizedGamma(
    double a,
    double x
)
Public Shared Function LeftRegularizedGamma (
    a As Double,
    x As Double
) As Double
public:
static double LeftRegularizedGamma(
    double a,
    double x
)
static member LeftRegularizedGamma :
        a : float *
        x : float -> float

Parameters

a
Double
The shape parameter, which must be positive.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of γ(a,x)/Γ(x).

Remarks

The incomplete Gamma function is obtained by carrying out the Gamma function integration from zero to some finite value x, instead of to infinity. The function is normalized by dividing by the complete integral, so the function ranges from 0 to 1 as x ranges from 0 to infinity.

For large values of x, this function becomes 1 within floating point precision. To determine its deviation from 1 in this region, use the complementary function RightRegularizedGamma(Double, Double).

For a=ν/2 and x=χ2/2, this function is the CDF of the χ2 distribution with ν degrees of freedom.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | a is negative or zero.
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..RightRegularizedGamma(Double, Double)


AdvancedMath.LogBeta Method

F#

Meta.Numerics Library
AdvancedMath..::LogBeta Method
Computes the lograrithm of the Beta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LogBeta(
    double a,
    double b
)
Public Shared Function LogBeta (
    a As Double,
    b As Double
) As Double
public:
static double LogBeta(
    double a,
    double b
)
static member LogBeta :
        a : float *
        b : float -> float

Parameters

a
Double
The first parameter, which must be positive.
b
Double
The second parameter, which must be positive.

Return Value

Double
The value of ln(B(a,b)).

Remarks

This function accurately computes ln(B(a,b)) even for values of a and b for which B(a,b) is too small or large to be represented by a double.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | a or b is non-positive.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Beta(Double, Double)


AdvancedMath.LogGamma Method

F#

Meta.Numerics Library
AdvancedMath..::LogGamma Method
Computes the natural logrithm of the Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LogGamma(
    double x
)
Public Shared Function LogGamma (
    x As Double
) As Double
public:
static double LogGamma(
    double x
)
static member LogGamma :
        x : float -> float

Parameters

x
Double
The argument, which must be positive.

Return Value

Double
The log Gamma function ln(Γ(x)).

Remarks

Because Γ(x) grows rapidly for increasing positive x, it is often necessary to work with its logarithm in order to avoid overflow. This function returns accurate values of ln(Γ(x)) even for values of x which would cause Γ(x) to overflow.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x is negative or zero.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..Gamma(Double)


AdvancedMath.ModifiedBessel Method

F#

Meta.Numerics Library
AdvancedMath..::ModifiedBessel Method
Computes modified cylindrical Bessel functions.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SolutionPair ModifiedBessel(
    double nu,
    double x
)
Public Shared Function ModifiedBessel (
    nu As Double,
    x As Double
) As SolutionPair
public:
static SolutionPair ModifiedBessel(
    double nu,
    double x
)
static member ModifiedBessel :
        nu : float *
        x : float -> SolutionPair

Parameters

nu
Double
The order, which must be non-negative.
x
Double
The argument, which must be non-negative.

Return Value

SolutionPair
The values of I, I', K, and K' for the given order and argument.

Remarks

The modified bessel functions fufill a differential equation similiar to the bessel differential equation.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.ModifiedBesselI Method

F#

Meta.Numerics Library
AdvancedMath..::ModifiedBesselI Method
Computes the regular modified cynlindrical Bessel function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ModifiedBesselI(
    double nu,
    double x
)
Public Shared Function ModifiedBesselI (
    nu As Double,
    x As Double
) As Double
public:
static double ModifiedBesselI(
    double nu,
    double x
)
static member ModifiedBesselI :
        nu : float *
        x : float -> float

Parameters

nu
Double
The order parameter.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Iν(x).

Remarks

The modified Bessel functions appear as the solutions of hyperbolic differential equations with cylindrical or circular symmetry, for example the conduction of heat through a cylindrical pipe.

The regular modified Bessel functions are related to the Bessel fuctions with pure imaginary arguments.

The regular modified Bessel functions increase monotonically and exponentially from the origin.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..ModifiedBesselK(Double, Double)


AdvancedMath.ModifiedBesselK Method

F#

Meta.Numerics Library
AdvancedMath..::ModifiedBesselK Method
Computes the irregular modified cynlindrical Bessel function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ModifiedBesselK(
    double nu,
    double x
)
Public Shared Function ModifiedBesselK (
    nu As Double,
    x As Double
) As Double
public:
static double ModifiedBesselK(
    double nu,
    double x
)
static member ModifiedBesselK :
        nu : float *
        x : float -> float

Parameters

nu
Double
The order parameter.
x
Double
The argument.

Return Value

Double
The value of Kν(x).

Remarks

The modified Bessel functions are related to the Bessel fuctions with pure imaginary arguments.

The irregular modified Bessel function decreases monotonically and exponentially from the origin.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.PolyLog Method

F#

Meta.Numerics Library
AdvancedMath..::PolyLog Method
Computes the polylogarithm function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double PolyLog(
    int n,
    double x
)
Public Shared Function PolyLog (
    n As Integer,
    x As Double
) As Double
public:
static double PolyLog(
    int n,
    double x
)
static member PolyLog :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument, which must be less than or equal to one.

Return Value

Double
The value of Lin(x).

Remarks

The nth polylog of x is defined via the series:

Its name comes from the fact that this is a generalization of the logarithm series. For n = 1 it reduces to -log(1-x). For n = 2 it reduces to the DiLog(Double) function.

The polylogarithm function becomes complex for arguments larger than one.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Psi Method

F#

Meta.Numerics Library
AdvancedMath..::Psi Method

Overload List

Name | Description
Psi(Double) | Computes the digamma function.
Psi(Int32, Double) | Computes the polygamma function.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


AdvancedMath.Psi Method (Double)

F#

Meta.Numerics Library
AdvancedMath..::Psi Method (Double)
Computes the digamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Psi(
    double x
)
Public Shared Function Psi (
    x As Double
) As Double
public:
static double Psi(
    double x
)
static member Psi :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value of ψ(x).

Remarks

The psi function, also called the digamma function, is the logrithmic derivative of the Γ function.

To evaluate the Psi function for complex arguments, use Psi(Complex).

See Also

AdvancedMath Class
Psi Overload
Meta.Numerics.Functions Namespace
AdvancedMath..::..Gamma(Double)
AdvancedComplexMath..::..Psi(Complex)
http://en.wikipedia.org/wiki/Digamma_function
http://mathworld.wolfram.com/DigammaFunction.html


AdvancedMath.Psi Method (Int32, Double)

F#

Meta.Numerics Library
AdvancedMath..::Psi Method (Int32, Double)
Computes the polygamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double Psi(
    int n,
    double x
)
Public Shared Function Psi (
    n As Integer,
    x As Double
) As Double
public:
static double Psi(
    int n,
    double x
)
static member Psi :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument.

Return Value

Double
The value of ψn(x).

Remarks

The polygamma function gives higher logarithmic derivatives of the Gamma function.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

AdvancedMath Class
Psi Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Polygamma_function
http://mathworld.wolfram.com/PolygammaFunction.html


AdvancedMath.RiemannZeta Method

F#

Meta.Numerics Library
AdvancedMath..::RiemannZeta Method
Computes the Riemann zeta function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double RiemannZeta(
    double x
)
Public Shared Function RiemannZeta (
    x As Double
) As Double
public:
static double RiemannZeta(
    double x
)
static member RiemannZeta :
        x : float -> float

Parameters

x
Double
The argument.

Return Value

Double
The value ζ(s).

Remarks

The Riemann ζ function can be defined as the sum of the xth inverse power of the natural numbers.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Riemann_zeta_function


AdvancedMath.RightRegularizedGamma Method

F#

Meta.Numerics Library
AdvancedMath..::RightRegularizedGamma Method
Computes the normalized upper (right) incomplete Gamma function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double RightRegularizedGamma(
    double a,
    double x
)
Public Shared Function RightRegularizedGamma (
    a As Double,
    x As Double
) As Double
public:
static double RightRegularizedGamma(
    double a,
    double x
)
static member RightRegularizedGamma :
        a : float *
        x : float -> float

Parameters

a
Double
The shape paraemter, which must be positive.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value of Γ(a,x)/Γ(x).

Remarks

This function is the complement of the left incomplete Gamma function LeftRegularizedGamma(Double, Double).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | a is negative or zero.
System..::..ArgumentOutOfRangeException | x is negative.

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..LeftRegularizedGamma(Double, Double)


AdvancedMath.SphericalBesselJ Method

F#

Meta.Numerics Library
AdvancedMath..::SphericalBesselJ Method
Computes the regular spherical Bessel function of integer order.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double SphericalBesselJ(
    int n,
    double x
)
Public Shared Function SphericalBesselJ (
    n As Integer,
    x As Double
) As Double
public:
static double SphericalBesselJ(
    int n,
    double x
)
static member SphericalBesselJ :
        n : int *
        x : float -> float

Parameters

n
Int32
The order parameter.
x
Double
The argument.

Return Value

Double
The value of jn(x).

Remarks

The spherical Bessel functions occur in solutions to the wave equations with spherical symmetry. The regular sperhical Bessel functions are finite at the origin, and thus occur in situations where the wave equation is satisfied at the origin.

The regular spherical Bessel functions are related to the regular Bessel functions of half-integer order by jn(x) = Sqrt(π/2x) Jn+1/2(x).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..SphericalBesselY(Int32, Double)
AdvancedMath..::..BesselJ(Double, Double)
http://mathworld.wolfram.com/SphericalBesselFunctionoftheFirstKind.html


AdvancedMath.SphericalBesselY Method

F#

Meta.Numerics Library
AdvancedMath..::SphericalBesselY Method
Computes the irregular spherical Bessel function of integer order.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double SphericalBesselY(
    int n,
    double x
)
Public Shared Function SphericalBesselY (
    n As Integer,
    x As Double
) As Double
public:
static double SphericalBesselY(
    int n,
    double x
)
static member SphericalBesselY :
        n : int *
        x : float -> float

Parameters

n
Int32
The order parameter.
x
Double
The argument.

Return Value

Double
The value of yn(x).

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace
AdvancedMath..::..SphericalBesselJ(Int32, Double)
http://mathworld.wolfram.com/SphericalBesselFunctionoftheSecondKind.html


AdvancedMath.SphericalHarmonic Method

F#

Meta.Numerics Library
AdvancedMath..::SphericalHarmonic Method
Computes the value of a spherical harmonic function.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Complex SphericalHarmonic(
    int l,
    int m,
    double theta,
    double phi
)
Public Shared Function SphericalHarmonic (
    l As Integer,
    m As Integer,
    theta As Double,
    phi As Double
) As Complex
public:
static Complex SphericalHarmonic(
    int l,
    int m,
    double theta,
    double phi
)
static member SphericalHarmonic :
        l : int *
        m : int *
        theta : float *
        phi : float -> Complex

Parameters

l
Int32
The order, which must be non-negative.
m
Int32
The sub-order, which must lie between -l and l inclusive.
theta
Double
The azimuthal angle θ. This angle is usually expressed as between -π/2 and +π/2, with positive values representing the upper hemisphere and negative values representing the lower hemisphere.
phi
Double
The cylindrical angle φ. This angle is usually expressed as between 0 and 2π, measured counter-clockwise (as seen from above) from the positive x-axis. It is also possible to use negative values to represent clockwise movement.

Return Value

Complex
The value of Yl,m(θ,φ).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | l is negative, or m lies outside the range [-l, l].

See Also

AdvancedMath Class
Meta.Numerics.Functions Namespace


OrthogonalPolynomials Class

F#

| Members | See Also
Meta.Numerics Library
OrthogonalPolynomials Class
Contains methods that compute the values of orthogonal polynomials.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class OrthogonalPolynomials
Public NotInheritable Class OrthogonalPolynomials
public ref class OrthogonalPolynomials abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OrthogonalPolynomials =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChebyshevT(Int32, Double) | Computes the value of a Cebyshev polynomial.
HermiteH(Int32, Double) | Computes the value of a (physicists') Hermite polynomial.
HermiteHe(Int32, Double) | Computes the value of a (statisticians') Hermite polynomial.
LaguerreL(Int32, Double) | Computes the value of a Laguerre polynomial.
LaguerreL(Int32, Double, Double) | Computes the value of an associated Laguerre polynomial.
LegendreP(Int32, Double) | Computes the value of a Legendre polynomial.
LegendreP(Int32, Int32, Double) | Computes the value of an associated Legendre polynomial.
ZernikeR(Int32, Int32, Double) | Computes the value of a Zernike polynomial.

Remarks

Orthogonal polynomials are complete families of polynomials that are orthogonal on a given interval with a given integration weight. Because of this property, any function on the interval can be expanded in the polynomials in a unique way.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..OrthogonalPolynomials

See Also

Meta.Numerics.Functions Namespace


OrthogonalPolynomials Methods

F#

Meta.Numerics Library
OrthogonalPolynomials Methods

The OrthogonalPolynomials type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChebyshevT(Int32, Double) | Computes the value of a Cebyshev polynomial.
HermiteH(Int32, Double) | Computes the value of a (physicists') Hermite polynomial.
HermiteHe(Int32, Double) | Computes the value of a (statisticians') Hermite polynomial.
LaguerreL(Int32, Double) | Computes the value of a Laguerre polynomial.
LaguerreL(Int32, Double, Double) | Computes the value of an associated Laguerre polynomial.
LegendreP(Int32, Double) | Computes the value of a Legendre polynomial.
LegendreP(Int32, Int32, Double) | Computes the value of an associated Legendre polynomial.
ZernikeR(Int32, Int32, Double) | Computes the value of a Zernike polynomial.

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace


OrthogonalPolynomials.ChebyshevT Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::ChebyshevT Method
Computes the value of a Cebyshev polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ChebyshevT(
    int n,
    double x
)
Public Shared Function ChebyshevT (
    n As Integer,
    x As Double
) As Double
public:
static double ChebyshevT(
    int n,
    double x
)
static member ChebyshevT :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument, which must lie in the closed interval between -1 and +1.

Return Value

Double
The value of Tn(x).

Remarks

Chebyshev polynomials are orthogonal on the interval [-1,1] with the weight (1-x2)-1/2.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative, or x lies outside [-1,+1].

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Chebyshev_polynomials
http://mathworld.wolfram.com/ChebyshevPolynomialoftheFirstKind.html


OrthogonalPolynomials.HermiteH Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::HermiteH Method
Computes the value of a (physicists') Hermite polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double HermiteH(
    int n,
    double x
)
Public Shared Function HermiteH (
    n As Integer,
    x As Double
) As Double
public:
static double HermiteH(
    int n,
    double x
)
static member HermiteH :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument.

Return Value

Double
The value Hn(x).

Remarks

Hermite polynomials are orthogonal on the interval (-∞,+∞) with the weight e-x2.

They appear in the solution of the one-dimensional, quantum mehanical, harmonic oscilator.

Statisticans' Hermite polynomials (see HermiteHe(Int32, Double)) are related to physicists' Hermite polynomials via Hn(x) = 2nHn(x √2). Staticians' Hermite polynomials do not grow as quickly as physicists', and may therefore be preferable for large values of n and x which could overflow Double.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace
OrthogonalPolynomials..::..HermiteHe(Int32, Double)
http://mathworld.wolfram.com/HermitePolynomial.html


OrthogonalPolynomials.HermiteHe Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::HermiteHe Method
Computes the value of a (statisticians') Hermite polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double HermiteHe(
    int n,
    double x
)
Public Shared Function HermiteHe (
    n As Integer,
    x As Double
) As Double
public:
static double HermiteHe(
    int n,
    double x
)
static member HermiteHe :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument.

Return Value

Double
The value Hen(x).

Remarks

Hermite polynomials are orthogonal on the interval (-∞,+∞) with a weight function equal to the standard normal probability distribution.

Their orthonormality relation makes them a useful basis for expressing pertubations arround a normal distribution.

Physicists' Hermite polynomials (see HermiteH(Int32, Double)) are related to statisticians' Hermite polynomials via Hn(x) = 2nHn(x √2).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace
OrthogonalPolynomials..::..HermiteH(Int32, Double)
http://en.wikipedia.org/wiki/Hermite_polynomial


OrthogonalPolynomials.LaguerreL Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::LaguerreL Method

Overload List

Name | Description
LaguerreL(Int32, Double) | Computes the value of a Laguerre polynomial.
LaguerreL(Int32, Double, Double) | Computes the value of an associated Laguerre polynomial.

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace


OrthogonalPolynomials.LaguerreL Method (Int32, Double)

F#

Meta.Numerics Library
OrthogonalPolynomials..::LaguerreL Method (Int32, Double)
Computes the value of a Laguerre polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LaguerreL(
    int n,
    double x
)
Public Shared Function LaguerreL (
    n As Integer,
    x As Double
) As Double
public:
static double LaguerreL(
    int n,
    double x
)
static member LaguerreL :
        n : int *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
x
Double
The argument, which must be non-negative.

Return Value

Double
The value Ln(x).

Remarks

Laguerre functions are orthogonal on the interval [0,+∞) with the weight e-x.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n or x is negative.

See Also

OrthogonalPolynomials Class
LaguerreL Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Laguerre_polynomial
http://mathworld.wolfram.com/LaguerrePolynomial.html
OrthogonalPolynomials..::..LaguerreL(Int32, Double, Double)


OrthogonalPolynomials.LaguerreL Method (Int32, Double, Double)

F#

Meta.Numerics Library
OrthogonalPolynomials..::LaguerreL Method (Int32, Double, Double)
Computes the value of an associated Laguerre polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LaguerreL(
    int n,
    double a,
    double x
)
Public Shared Function LaguerreL (
    n As Integer,
    a As Double,
    x As Double
) As Double
public:
static double LaguerreL(
    int n,
    double a,
    double x
)
static member LaguerreL :
        n : int *
        a : float *
        x : float -> float

Parameters

n
Int32
The order, which must be non-negative.
a
Double
The associated order, which must be greater than -1.
x
Double
The argument.

Return Value

Double
The value Lna(x).

Remarks

The associated Laguerre polynomials are orthonogal on the interval [0,+∞) with the weight xa e-x.

See Also

OrthogonalPolynomials Class
LaguerreL Overload
Meta.Numerics.Functions Namespace
http://mathworld.wolfram.com/LaguerrePolynomial.html


OrthogonalPolynomials.LegendreP Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::LegendreP Method

Overload List

Name | Description
LegendreP(Int32, Double) | Computes the value of a Legendre polynomial.
LegendreP(Int32, Int32, Double) | Computes the value of an associated Legendre polynomial.

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace


OrthogonalPolynomials.LegendreP Method (Int32, Double)

F#

Meta.Numerics Library
OrthogonalPolynomials..::LegendreP Method (Int32, Double)
Computes the value of a Legendre polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LegendreP(
    int l,
    double x
)
Public Shared Function LegendreP (
    l As Integer,
    x As Double
) As Double
public:
static double LegendreP(
    int l,
    double x
)
static member LegendreP :
        l : int *
        x : float -> float

Parameters

l
Int32
The order, which must be non-negative.
x
Double
The argument, which must lie on the closed interval between -1 and +1.

Return Value

Double
The value of Pl(x).

Remarks

Legendre polynomials are orthogonal on the interval [-1,1].

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | x lies outside [-1,+1].

See Also

OrthogonalPolynomials Class
LegendreP Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Legendre_polynomial
http://mathworld.wolfram.com/LegendrePolynomial.html


OrthogonalPolynomials.LegendreP Method (Int32, Int32, Double)

F#

Meta.Numerics Library
OrthogonalPolynomials..::LegendreP Method (Int32, Int32, Double)
Computes the value of an associated Legendre polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double LegendreP(
    int l,
    int m,
    double x
)
Public Shared Function LegendreP (
    l As Integer,
    m As Integer,
    x As Double
) As Double
public:
static double LegendreP(
    int l,
    int m,
    double x
)
static member LegendreP :
        l : int *
        m : int *
        x : float -> float

Parameters

l
Int32
The order, which must be non-negative.
m
Int32
The associated order, which must lie between -l and l inclusive.
x
Double
The argument, which must lie on the closed interval betwen -1 and +1.

Return Value

Double
The value of Pl,m(x).

Remarks

Associated Legendre polynomials appear in the definition of the SphericalHarmonic(Int32, Int32, Double, Double) functions.

For values of l and m over about 150, values of this polynomial can exceed the capacity of double-wide floating point numbers.

See Also

OrthogonalPolynomials Class
LegendreP Overload
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Associated_Legendre_polynomials


OrthogonalPolynomials.ZernikeR Method

F#

Meta.Numerics Library
OrthogonalPolynomials..::ZernikeR Method
Computes the value of a Zernike polynomial.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ZernikeR(
    int n,
    int m,
    double rho
)
Public Shared Function ZernikeR (
    n As Integer,
    m As Integer,
    rho As Double
) As Double
public:
static double ZernikeR(
    int n,
    int m,
    double rho
)
static member ZernikeR :
        n : int *
        m : int *
        rho : float -> float

Parameters

n
Int32
The order paramter, which must be non-negative.
m
Int32
The index parameter, which must lie between 0 and n.
rho
Double
The argument, which must lie between 0 and 1.

Return Value

Double
The value of Rnm(ρ).

Remarks

Zernike polynomials are orthononal on the interval [0,1] with the weight ρ.

They are often used in optics to characterize the imperfections in a lens. In this context, the amplitude of each is associated with a name given in the following table.

n | m | name
1 | 1 | tilt
2 | 0 | defocus
2 | 2 | astigmatism
3 | 1 | coma
3 | 3 | trefoil

See Also

OrthogonalPolynomials Class
Meta.Numerics.Functions Namespace


Permutation Class

F#

| Members | See Also
Meta.Numerics Library
Permutation Class
Represents a permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class Permutation : IEquatable<Permutation>,
    IFormattable
Public NotInheritable Class Permutation
    Implements IEquatable(Of Permutation), IFormattable
public ref class Permutation sealed : IEquatable<Permutation^>,
    IFormattable
[<SealedAttribute>]
type Permutation =
    class
        interface IEquatable<Permutation>
        interface IFormattable
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Apply<(Of <<'(T>)>>)(IList<(Of <<'(T>)>>)) | Applies the permutation to a list.
Dimension | Gets the dimension of the permutation.
Equality(Permutation, Permutation) | Determines whether two permutations are equal.
Equals(Object) | Determines whether the given object is equal to the permutation. (Overrides Object..::..Equals(Object).)
Equals(Permutation) | Determines whether the given permutation is equal to the permutation instance.
GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
GetRandomPermutation(Int32, Random) | Get a random permutation.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Identity(Int32) | Returns the identity permutation of the given dimension.
Inequality(Permutation, Permutation) | Determines whether two permutations are not equal.
Inverse()()()() | Gets the inverse of the permutation.
IsDerangement | Gets a Boolean flag indicating whether the permutation is a derangement.
IsEven | Gets a Boolean value that is true if the permutation is even and false if the permutation is odd.
IsIdentity | Gets a Boolean value indicating whether the permutation is the identity.
IsInvolution | Gets a Boolean flag indicating whether the permutation is an involution.
Multiply(Permutation, Permutation) | Multiplies two permutations.
Order | Gets the order of the permutation.
Parse(String) | Converts a text representation into a permutation.
Permutations(Int32) | Generates all permutations of the given dimension.
ToString()()()() | Returns a string that represents the current object. (Overrides Object..::..ToString()()()().)
ToString(String) | Converts the permutation to its string representation in the given format.
ToString(String, IFormatProvider) | Converts the permutation to its string representation in the given format.
TryParse(String, Permutation%) | Attempts to convert a text representation into a permutation.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..Permutation

See Also

Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Permutation


Permutation Methods

F#

Meta.Numerics Library
Permutation Methods

The Permutation type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Apply<(Of <<'(T>)>>)(IList<(Of <<'(T>)>>)) | Applies the permutation to a list.
Equals(Object) | Determines whether the given object is equal to the permutation. (Overrides Object..::..Equals(Object).)
Equals(Permutation) | Determines whether the given permutation is equal to the permutation instance.
GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
GetRandomPermutation(Int32, Random) | Get a random permutation.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Identity(Int32) | Returns the identity permutation of the given dimension.
Inverse()()()() | Gets the inverse of the permutation.
Parse(String) | Converts a text representation into a permutation.
Permutations(Int32) | Generates all permutations of the given dimension.
ToString()()()() | Returns a string that represents the current object. (Overrides Object..::..ToString()()()().)
ToString(String) | Converts the permutation to its string representation in the given format.
ToString(String, IFormatProvider) | Converts the permutation to its string representation in the given format.
TryParse(String, Permutation%) | Attempts to convert a text representation into a permutation.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Apply Generic Method

F#

Meta.Numerics Library
Permutation..::Apply<(Of <(<'T>)>)> Method
Applies the permutation to a list.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Apply<T>(
    IList<T> x
)

Public Sub Apply(Of T) (
    x As IList(Of T)
)
public:
generic<typename T>
void Apply(
    IList<T>^ x
)
member Apply :
        x : IList<'T> -> unit

Parameters

x
IList <(Of <(<'T>)>)>
The list.

Type Parameters

T
The type of the list.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Equals Method

F#

Meta.Numerics Library
Permutation..::Equals Method

Overload List

Name | Description
Equals(Object) | Determines whether the given object is equal to the permutation. (Overrides Object.Equals(Object).)
Equals(Permutation) | Determines whether the given permutation is equal to the permutation instance.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Equals Method (Object)

F#

Meta.Numerics Library
Permutation..::Equals Method (Object)
Determines whether the given object is equal to the permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object to compare.

Return Value

Boolean
True if obj is a permutation equal to the permutation instance, otherwise false.

See Also

Permutation Class
Equals Overload
Meta.Numerics.Functions Namespace


Permutation.Equals Method (Permutation)

F#

Meta.Numerics Library
Permutation..::Equals Method (Permutation)
Determines whether the given permutation is equal to the permutation instance.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Equals(
    Permutation other
)
Public Function Equals (
    other As Permutation
) As Boolean
public:
virtual bool Equals(
    Permutation^ other
) sealed
abstract Equals :
        other : Permutation -> bool
override Equals :
        other : Permutation -> bool

Parameters

other
Permutation
The permutation to compare.

Return Value

Boolean
True if other equals the permutation instance, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

Permutation Class
Equals Overload
Meta.Numerics.Functions Namespace


Permutation.GetHashCode Method

F#

Meta.Numerics Library
Permutation..::GetHashCode Method
Serves as a hash function for a particular type.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A hash code for the current Object.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.GetRandomPermutation Method

F#

Meta.Numerics Library
Permutation..::GetRandomPermutation Method
Get a random permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Permutation GetRandomPermutation(
    int dimension,
    Random rng
)
Public Shared Function GetRandomPermutation (
    dimension As Integer,
    rng As Random
) As Permutation
public:
static Permutation^ GetRandomPermutation(
    int dimension,
    Random^ rng
)
static member GetRandomPermutation :
        dimension : int *
        rng : Random -> Permutation

Parameters

dimension
Int32
The number of elements on which the permutation acts.
rng
Random
A random number generator.

Return Value

Permutation
A random permutation of the specified dimension. All permutations of the specified dimension are equally likely.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Identity Method

F#

Meta.Numerics Library
Permutation..::Identity Method
Returns the identity permutation of the given dimension.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Permutation Identity(
    int dimension
)
Public Shared Function Identity (
    dimension As Integer
) As Permutation
public:
static Permutation^ Identity(
    int dimension
)
static member Identity :
        dimension : int -> Permutation

Parameters

dimension
Int32
The number of elements on which the permutation acts.

Return Value

Permutation
The identity permutation of the requested dimension.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Inverse Method

F#

Meta.Numerics Library
Permutation..::Inverse Method
Gets the inverse of the permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Permutation Inverse()
Public Function Inverse As Permutation
public:
Permutation^ Inverse()
member Inverse : unit -> Permutation

Return Value

Permutation
The inverse of the permutation.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Parse Method

F#

Meta.Numerics Library
Permutation..::Parse Method
Converts a text representation into a permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Permutation Parse(
    string text
)
Public Shared Function Parse (
    text As String
) As Permutation
public:
static Permutation^ Parse(
    String^ text
)
static member Parse :
        text : string -> Permutation

Parameters

text
String
A text representation of the permutation.

Return Value

Permutation
The corresponding permutation.

Remarks

This method is able to parse both map representations and cycle representations of permutations.

A map representation of an n-dimensional permutation is a space-seperated list of all integers between 0 and n-1, enclosed in square brackets. Each number indicates the index of the location to which the object that appears at that location is mapped by the permutation. For example, [2 1 0] denotes the permutation that moves the object at index 0 to index 2, does not move the object at index 1, and moves the object at index 2 to index 0. Note that the numbers in the map representation are the same as the numbers on the second line of Cauchy's two-line notation.

A cycle representation of an n-dimensional representation is a space-seperated list of all integers between 0 and n-1, grouped into cycles by parenthesis. Each cycle indicates that the element at the location with the first index in the cycle is moved to the location with the second index in the cycle, the element at the location with the second index in the cycle is moved to the location with the third index in the cycle, and so on, until the element at the location with the last index is moved to the location with the first index. Thus (0 2)(1) indicates that the elements at locations 0 and 2 change places and the element at location 1 is left there.

Note that (0 2)(1) and [2 1 0] represent the same permutation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | text is null.
System..::..FormatException | text is not a valid text representation of a permutation.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Permutations Method

F#

Meta.Numerics Library
Permutation..::Permutations Method
Generates all permutations of the given dimension.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static IEnumerable<Permutation> Permutations(
    int dimension
)
Public Shared Function Permutations (
    dimension As Integer
) As IEnumerable(Of Permutation)
public:
static IEnumerable<Permutation^>^ Permutations(
    int dimension
)
static member Permutations :
        dimension : int -> IEnumerable<Permutation>

Parameters

dimension
Int32
The number of elements on which the permutations act.

Return Value

IEnumerable <(Of <(<' Permutation >)>)>
All permutations of the given dimension.

Remarks

The number of permutations of dimension n is n!, which increases very rapidly as n increases. Even in cases where n! would overflow a Int32 or Int64, we do successfully produce all permutations. Of course, in such cases, it will take a long time to enumerate them all.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | dimension is negative.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.ToString Method

F#

Meta.Numerics Library
Permutation..::ToString Method

Overload List

Name | Description
ToString()()()() | Returns a string that represents the current object. (Overrides Object.ToString()()()().)
ToString(String) | Converts the permutation to its string representation in the given format.
ToString(String, IFormatProvider) | Converts the permutation to its string representation in the given format.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.ToString Method

F#

Meta.Numerics Library
Permutation..::ToString Method
Returns a string that represents the current object.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string that represents the current object.

See Also

Permutation Class
ToString Overload
Meta.Numerics.Functions Namespace


Permutation.ToString Method (String)

F#

Meta.Numerics Library
Permutation..::ToString Method (String)
Converts the permutation to its string representation in the given format.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
public:
String^ ToString(
    String^ format
)
member ToString :
        format : string -> string

Parameters

format
String
A standard or custom permutation format string.

Return Value

String
The requested string representation of the permutation.

Remarks

The standard permutation format strings are "M", which produces a map representation, and "C", which produces a cycle representation. For explanations of the map and cycle representations of a permutation, see Parse(String).

See Also

Permutation Class
ToString Overload
Meta.Numerics.Functions Namespace


Permutation.ToString Method (String, IFormatProvider)

F#

Meta.Numerics Library
Permutation..::ToString Method (String, IFormatProvider)
Converts the permutation to its string representation in the given format.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string

Parameters

format
String
A standard or custom permutation format string.
formatProvider
IFormatProvider
An object that provides culture-specific formatting information.

Return Value

String
The requested string represenation of the permutation.

Implements

IFormattable..::..ToString(String, IFormatProvider)

Remarks

The standard permutation format strings are "M", which produces a map representation, and "C", which produces a cycle representation. For explanations of the map and cycle representations of a permutation, see Parse(String).

See Also

Permutation Class
ToString Overload
Meta.Numerics.Functions Namespace


Permutation.TryParse Method

F#

Meta.Numerics Library
Permutation..::TryParse Method
Attempts to convert a text representation into a permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool TryParse(
    string text,
    out Permutation output
)
Public Shared Function TryParse (
    text As String,
    <OutAttribute> ByRef output As Permutation
) As Boolean
public:
static bool TryParse(
    String^ text,
    [OutAttribute] Permutation^% output
)
static member TryParse :
        text : string *
        output : Permutation byref -> bool

Parameters

text
String
A text representaiton of the permutation.
output
Permutation %
The corresponding permutation.

Return Value

Boolean
True if the conversion succeeded, otherwise false.

Remarks

For information on supported text representations, see Parse(String).

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation Operators

F#

Meta.Numerics Library
Permutation Operators

The Permutation type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equality(Permutation, Permutation) | Determines whether two permutations are equal.
Inequality(Permutation, Permutation) | Determines whether two permutations are not equal.
Multiply(Permutation, Permutation) | Multiplies two permutations.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Equality Operator

F#

Meta.Numerics Library
Permutation..::Equality Operator
Determines whether two permutations are equal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    Permutation a,
    Permutation b
)
Public Shared Operator = (
    a As Permutation,
    b As Permutation
) As Boolean
public:
static bool operator ==(
    Permutation^ a,
    Permutation^ b
)
static let inline (=)
        a : Permutation *
        b : Permutation  : bool

Parameters

a
Permutation
The first permutation.
b
Permutation
The second permutation.

Return Value

Boolean
True if the two permutations are equal, otherwise false.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Inequality Operator

F#

Meta.Numerics Library
Permutation..::Inequality Operator
Determines whether two permutations are not equal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    Permutation a,
    Permutation b
)
Public Shared Operator <> (
    a As Permutation,
    b As Permutation
) As Boolean
public:
static bool operator !=(
    Permutation^ a,
    Permutation^ b
)
static let inline (<>)
        a : Permutation *
        b : Permutation  : bool

Parameters

a
Permutation
The first permutation.
b
Permutation
The second permutation.

Return Value

Boolean
True if the two permutations are not equal, otherwise true.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Multiply Operator

F#

Meta.Numerics Library
Permutation..::Multiply Operator
Multiplies two permutations.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Permutation operator *(
    Permutation a,
    Permutation b
)
Public Shared Operator * (
    a As Permutation,
    b As Permutation
) As Permutation
public:
static Permutation^ operator *(
    Permutation^ a,
    Permutation^ b
)
static let inline (*)
        a : Permutation *
        b : Permutation  : Permutation

Parameters

a
Permutation
The first permutation.
b
Permutation
The second permutation.

Return Value

Permutation
The product permutation ab.

Remarks

The product ab means first applying b, then applying a. This right-to-left convention arises from the convention that operators are applied to the right.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation Properties

F#

Meta.Numerics Library
Permutation Properties

The Permutation type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the permutation.
IsDerangement | Gets a Boolean flag indicating whether the permutation is a derangement.
IsEven | Gets a Boolean value that is true if the permutation is even and false if the permutation is odd.
IsIdentity | Gets a Boolean value indicating whether the permutation is the identity.
IsInvolution | Gets a Boolean flag indicating whether the permutation is an involution.
Order | Gets the order of the permutation.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Dimension Property

F#

Meta.Numerics Library
Permutation..::Dimension Property
Gets the dimension of the permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

Remarks

The dimension of a permutation is the number of elements to which the permutation applies.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.IsDerangement Property

F#

Meta.Numerics Library
Permutation..::IsDerangement Property
Gets a Boolean flag indicating whether the permutation is a derangement.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsDerangement { get; }
Public ReadOnly Property IsDerangement As Boolean
    Get
public:
property bool IsDerangement {
    bool get ();
}
member IsDerangement : bool with get

Property Value

Boolean
True if the permutation is a derangement, otherwise false.

Remarks

A derangement is a permutation that leaves no element in its original position.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.IsEven Property

F#

Meta.Numerics Library
Permutation..::IsEven Property
Gets a Boolean value that is true if the permutation is even and false if the permutation is odd.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsEven { get; }
Public ReadOnly Property IsEven As Boolean
    Get
public:
property bool IsEven {
    bool get ();
}
member IsEven : bool with get

Property Value

Boolean

Remarks

An even permutation moves an even number of elements; an odd permutation moves an odd number of elements.

See Also

Permutation Class
Meta.Numerics.Functions Namespace
http://en.wikipedia.org/wiki/Even_and_odd_permutations


Permutation.IsIdentity Property

F#

Meta.Numerics Library
Permutation..::IsIdentity Property
Gets a Boolean value indicating whether the permutation is the identity.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsIdentity { get; }
Public ReadOnly Property IsIdentity As Boolean
    Get
public:
property bool IsIdentity {
    bool get ();
}
member IsIdentity : bool with get

Property Value

Boolean
True if the permutation is the identity, otherwise false.

Remarks

The identity permutation is the permutation that leaves all elements in their original positions.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.IsInvolution Property

F#

Meta.Numerics Library
Permutation..::IsInvolution Property
Gets a Boolean flag indicating whether the permutation is an involution.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsInvolution { get; }
Public ReadOnly Property IsInvolution As Boolean
    Get
public:
property bool IsInvolution {
    bool get ();
}
member IsInvolution : bool with get

Property Value

Boolean
True if the permutation is an involution, otherwise false.

Remarks

An involution is a permutation that is its own inverse.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


Permutation.Order Property

F#

Meta.Numerics Library
Permutation..::Order Property
Gets the order of the permutation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public long Order { get; }
Public ReadOnly Property Order As Long
    Get
public:
property long long Order {
    long long get ();
}
member Order : int64 with get

Property Value

Int64

Remarks

The order of a permutation is the number of times it must be applied in order to return all elements to their original position. Stated differently, the order of a permutation is the smallest power to which it must be raised to obtain the identity permutation.

Some permutations with dimension greater than about 300 have an order larger than MaxValue; for these permutations the returned value will overflow.

Note that the word order is also used to refer to the number of distinct permutations of a given dimension. That "order" is a property of the permutation group. This "order" is a property of each permutation.

See Also

Permutation Class
Meta.Numerics.Functions Namespace


SolutionPair Structure

F#

| Members | See Also
Meta.Numerics Library
SolutionPair Structure
Contains a pair of solutions to a differential equation.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct SolutionPair
Public Structure SolutionPair
public value class SolutionPair
[<SealedAttribute>]
type SolutionPair =  struct end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
FirstSolutionDerivative | Gets the derivative of the first solution.
FirstSolutionValue | Gets the value of the first solution.
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SecondSolutionDerivative | Gets the derivative of the second solution.
SecondSolutionValue | Gets the value of the second solution.
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Remarks

Any linear second order differential equation has two independent solutions. For example, the Bessel differential equation (Bessel(Double, Double)) has solutions J and Y, the Coulomb wave equation has solutions F and G, and the Airy differential equation has solutions Ai and Bi.

A solution pair structure contains values for both solutions and for their derivatives. It is often useful to have all this information together when fitting boundary conditions.

Which solution is considered the first and which is considered the second is a matter of convention. When one solution is regular (finite) at the origin and the other is not, we take the regular solution to be the first.

See Also

Meta.Numerics.Functions Namespace


SolutionPair Methods

F#

Meta.Numerics Library
SolutionPair Methods

The SolutionPair type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


SolutionPair Properties

F#

Meta.Numerics Library
SolutionPair Properties

The SolutionPair type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FirstSolutionDerivative | Gets the derivative of the first solution.
FirstSolutionValue | Gets the value of the first solution.
SecondSolutionDerivative | Gets the derivative of the second solution.
SecondSolutionValue | Gets the value of the second solution.

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


SolutionPair.FirstSolutionDerivative Property

F#

Meta.Numerics Library
SolutionPair..::FirstSolutionDerivative Property
Gets the derivative of the first solution.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double FirstSolutionDerivative { get; }
Public ReadOnly Property FirstSolutionDerivative As Double
    Get
public:
property double FirstSolutionDerivative {
    double get ();
}
member FirstSolutionDerivative : float with get

Property Value

Double

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


SolutionPair.FirstSolutionValue Property

F#

Meta.Numerics Library
SolutionPair..::FirstSolutionValue Property
Gets the value of the first solution.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double FirstSolutionValue { get; }
Public ReadOnly Property FirstSolutionValue As Double
    Get
public:
property double FirstSolutionValue {
    double get ();
}
member FirstSolutionValue : float with get

Property Value

Double

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


SolutionPair.SecondSolutionDerivative Property

F#

Meta.Numerics Library
SolutionPair..::SecondSolutionDerivative Property
Gets the derivative of the second solution.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double SecondSolutionDerivative { get; }
Public ReadOnly Property SecondSolutionDerivative As Double
    Get
public:
property double SecondSolutionDerivative {
    double get ();
}
member SecondSolutionDerivative : float with get

Property Value

Double

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


SolutionPair.SecondSolutionValue Property

F#

Meta.Numerics Library
SolutionPair..::SecondSolutionValue Property
Gets the value of the second solution.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double SecondSolutionValue { get; }
Public ReadOnly Property SecondSolutionValue As Double
    Get
public:
property double SecondSolutionValue {
    double get ();
}
member SecondSolutionValue : float with get

Property Value

Double

See Also

SolutionPair Structure
Meta.Numerics.Functions Namespace


Spin Structure

F#

| Members | See Also
Meta.Numerics Library
Spin Structure
Represents a spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct Spin : IEquatable<Spin>
Public Structure Spin
    Implements IEquatable(Of Spin)
public value class Spin : IEquatable<Spin>
[<SealedAttribute>]
type Spin =
    struct
        interface IEquatable<Spin>
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Spin(Double) | Instantiates a new spinor.
Dimension | Gets the dimension of the spinor.
Equality(Spin, Spin) | Determines whether two spinors are equal.
Equals(Object) | Determines whether the given object represents the same spinor. (Overrides ValueType..::..Equals(Object).)
Equals(Spin) | Determines whether the given spinor is equal to this one.
Equals(Spin, Spin) | Determines whether two spinors are equal.
GetHashCode()()()() | Computes a hash function for the spinor. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(Spin, Spin) | Determines whether two spinors are unequal.
J | Gets the spin of the spinor.
SpinOne | Gets a spin-1 spinor.
SpinOneHalf | Gets a spin-1/2 spinor.
SpinZero | Gets a spin-0 spinor.
States()()()() | Returns the set of spinor states.
ToString()()()() | Produces a string representation of the spinor. (Overrides ValueType..::..ToString()()()().)

Remarks

From a physicist's point of view, a spinor is an object with a particular quantum-mechanical spin. The quantum state of such an object is represented by a SpinState object.

From a mathematician's point of view, a spinor labels an irreducible representation of the SO(3) or SU(2) Lie group. Individual vectors within each irreducible representation are represented by SpinState objects.

See Also

Meta.Numerics.Functions Namespace


Spin Constructor

F#

Meta.Numerics Library
Spin Constructor
Instantiates a new spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Spin(
    double j
)
Public Sub New (
    j As Double
)
public:
Spin(
    double j
)
new :
        j : float -> Spin

Parameters

j
Double
The spin, which must be an integer or half-integer.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin Methods

F#

Meta.Numerics Library
Spin Methods

The Spin type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the given object represents the same spinor. (Overrides ValueType..::..Equals(Object).)
Equals(Spin) | Determines whether the given spinor is equal to this one.
Equals(Spin, Spin) | Determines whether two spinors are equal.
GetHashCode()()()() | Computes a hash function for the spinor. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
States()()()() | Returns the set of spinor states.
ToString()()()() | Produces a string representation of the spinor. (Overrides ValueType..::..ToString()()()().)

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.Equals Method

F#

Meta.Numerics Library
Spin..::Equals Method

Overload List

Name | Description
Equals(Object) | Determines whether the given object represents the same spinor. (Overrides ValueType.Equals(Object).)
Equals(Spin) | Determines whether the given spinor is equal to this one.
Equals(Spin, Spin) | Determines whether two spinors are equal.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.Equals Method (Object)

F#

Meta.Numerics Library
Spin..::Equals Method (Object)
Determines whether the given object represents the same spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object to compare.

Return Value

Boolean
True if obj is an equal spin, otherwise false.

See Also

Spin Structure
Equals Overload
Meta.Numerics.Functions Namespace


Spin.Equals Method (Spin)

F#

Meta.Numerics Library
Spin..::Equals Method (Spin)
Determines whether the given spinor is equal to this one.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Equals(
    Spin s
)
Public Function Equals (
    s As Spin
) As Boolean
public:
virtual bool Equals(
    Spin s
) sealed
abstract Equals :
        s : Spin -> bool
override Equals :
        s : Spin -> bool

Parameters

s
Spin
The spinor to compare.

Return Value

Boolean
True if s is equal to this one, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

Spin Structure
Equals Overload
Meta.Numerics.Functions Namespace


Spin.Equals Method (Spin, Spin)

F#

Meta.Numerics Library
Spin..::Equals Method (Spin, Spin)
Determines whether two spinors are equal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool Equals(
    Spin a,
    Spin b
)
Public Shared Function Equals (
    a As Spin,
    b As Spin
) As Boolean
public:
static bool Equals(
    Spin a,
    Spin b
)
static member Equals :
        a : Spin *
        b : Spin -> bool

Parameters

a
Spin
The first spin.
b
Spin
The second spin.

Return Value

Boolean
True if a and b are equal, otherwise false.

See Also

Spin Structure
Equals Overload
Meta.Numerics.Functions Namespace


Spin.GetHashCode Method

F#

Meta.Numerics Library
Spin..::GetHashCode Method
Computes a hash function for the spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
An integer which is guaranteed equal for equal spinors, an unlikely to be equal for unequal spinors.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.States Method

F#

Meta.Numerics Library
Spin..::States Method
Returns the set of spinor states.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SpinState[] States()
Public Function States As SpinState()
public:
array<SpinState>^ States()
member States : unit -> SpinState[]

Return Value

array< SpinState >[]()[][]
An array of spin states that spans the spinor subspace.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.ToString Method

F#

Meta.Numerics Library
Spin..::ToString Method
Produces a string representation of the spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string representation of the spinor.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin Operators

F#

Meta.Numerics Library
Spin Operators

The Spin type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equality(Spin, Spin) | Determines whether two spinors are equal.
Inequality(Spin, Spin) | Determines whether two spinors are unequal.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.Equality Operator

F#

Meta.Numerics Library
Spin..::Equality Operator
Determines whether two spinors are equal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    Spin a,
    Spin b
)
Public Shared Operator = (
    a As Spin,
    b As Spin
) As Boolean
public:
static bool operator ==(
    Spin a,
    Spin b
)
static let inline (=)
        a : Spin *
        b : Spin  : bool

Parameters

a
Spin
The first spin.
b
Spin
The second spin.

Return Value

Boolean
True if a and b are equal, otherwise false.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.Inequality Operator

F#

Meta.Numerics Library
Spin..::Inequality Operator
Determines whether two spinors are unequal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    Spin a,
    Spin b
)
Public Shared Operator <> (
    a As Spin,
    b As Spin
) As Boolean
public:
static bool operator !=(
    Spin a,
    Spin b
)
static let inline (<>)
        a : Spin *
        b : Spin  : bool

Parameters

a
Spin
The first spin.
b
Spin
The second spin.

Return Value

Boolean
False if a and b are equal, otherwise true.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin Properties

F#

Meta.Numerics Library
Spin Properties

The Spin type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the spinor.
J | Gets the spin of the spinor.
SpinOne | Gets a spin-1 spinor.
SpinOneHalf | Gets a spin-1/2 spinor.
SpinZero | Gets a spin-0 spinor.

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.Dimension Property

F#

Meta.Numerics Library
Spin..::Dimension Property
Gets the dimension of the spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.J Property

F#

Meta.Numerics Library
Spin..::J Property
Gets the spin of the spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double J { get; }
Public ReadOnly Property J As Double
    Get
public:
property double J {
    double get ();
}
member J : float with get

Property Value

Double

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.SpinOne Property

F#

Meta.Numerics Library
Spin..::SpinOne Property
Gets a spin-1 spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Spin SpinOne { get; }
Public Shared ReadOnly Property SpinOne As Spin
    Get
public:
static property Spin SpinOne {
    Spin get ();
}
static member SpinOne : Spin with get

Property Value

Spin

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.SpinOneHalf Property

F#

Meta.Numerics Library
Spin..::SpinOneHalf Property
Gets a spin-1/2 spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Spin SpinOneHalf { get; }
Public Shared ReadOnly Property SpinOneHalf As Spin
    Get
public:
static property Spin SpinOneHalf {
    Spin get ();
}
static member SpinOneHalf : Spin with get

Property Value

Spin

See Also

Spin Structure
Meta.Numerics.Functions Namespace


Spin.SpinZero Property

F#

Meta.Numerics Library
Spin..::SpinZero Property
Gets a spin-0 spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Spin SpinZero { get; }
Public Shared ReadOnly Property SpinZero As Spin
    Get
public:
static property Spin SpinZero {
    Spin get ();
}
static member SpinZero : Spin with get

Property Value

Spin

See Also

Spin Structure
Meta.Numerics.Functions Namespace


SpinMath Class

F#

| Members | See Also
Meta.Numerics Library
SpinMath Class
Contains methods for computing functions of spin and spin states.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class SpinMath
Public NotInheritable Class SpinMath
public ref class SpinMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpinMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClebschGodron(SpinState, SpinState, SpinState) | Computes a Clebsch-Gordon coefficient.
Combine(Spin, Spin) | Enumerates all the spins that can be obtained by combining two spins.
Combine(SpinState, SpinState) | Enumerates all spin states that may be obtained by combining two spin states.
SixJ(Spin, Spin, Spin, Spin, Spin, Spin) | Computes the value of the 6j symbol for the six given spins.
ThreeJ(SpinState, SpinState, SpinState) | Computes a 3j symbol.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Functions..::..SpinMath

See Also

Meta.Numerics.Functions Namespace


SpinMath Methods

F#

Meta.Numerics Library
SpinMath Methods

The SpinMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClebschGodron(SpinState, SpinState, SpinState) | Computes a Clebsch-Gordon coefficient.
Combine(Spin, Spin) | Enumerates all the spins that can be obtained by combining two spins.
Combine(SpinState, SpinState) | Enumerates all spin states that may be obtained by combining two spin states.
SixJ(Spin, Spin, Spin, Spin, Spin, Spin) | Computes the value of the 6j symbol for the six given spins.
ThreeJ(SpinState, SpinState, SpinState) | Computes a 3j symbol.

See Also

SpinMath Class
Meta.Numerics.Functions Namespace


SpinMath.ClebschGodron Method

F#

Meta.Numerics Library
SpinMath..::ClebschGodron Method
Computes a Clebsch-Gordon coefficient.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ClebschGodron(
    SpinState s1,
    SpinState s2,
    SpinState s
)
Public Shared Function ClebschGodron (
    s1 As SpinState,
    s2 As SpinState,
    s As SpinState
) As Double
public:
static double ClebschGodron(
    SpinState s1,
    SpinState s2,
    SpinState s
)
static member ClebschGodron :
        s1 : SpinState *
        s2 : SpinState *
        s : SpinState -> float

Parameters

s1
SpinState
The first spin state.
s2
SpinState
The second spin state.
s
SpinState
The total spin state.

Return Value

Double
The Clebsch-Gordon coefficient measuring the contribution of the given first and second spin states to the given total spin state.

See Also

SpinMath Class
Meta.Numerics.Functions Namespace


SpinMath.Combine Method

F#

Meta.Numerics Library
SpinMath..::Combine Method

Overload List

Name | Description
Combine(Spin, Spin) | Enumerates all the spins that can be obtained by combining two spins.
Combine(SpinState, SpinState) | Enumerates all spin states that may be obtained by combining two spin states.

See Also

SpinMath Class
Meta.Numerics.Functions Namespace


SpinMath.Combine Method (Spin, Spin)

F#

Meta.Numerics Library
SpinMath..::Combine Method (Spin, Spin)
Enumerates all the spins that can be obtained by combining two spins.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static Spin[] Combine(
    Spin j1,
    Spin j2
)
Public Shared Function Combine (
    j1 As Spin,
    j2 As Spin
) As Spin()
public:
static array<Spin>^ Combine(
    Spin j1,
    Spin j2
)
static member Combine :
        j1 : Spin *
        j2 : Spin -> Spin[]

Parameters

j1
Spin
The first spin.
j2
Spin
The second spin.

Return Value

array< Spin >[]()[][]
A list of spins which may be obtained.

See Also

SpinMath Class
Combine Overload
Meta.Numerics.Functions Namespace


SpinMath.Combine Method (SpinState, SpinState)

F#

Meta.Numerics Library
SpinMath..::Combine Method (SpinState, SpinState)
Enumerates all spin states that may be obtained by combining two spin states.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SpinState[] Combine(
    SpinState s1,
    SpinState s2
)
Public Shared Function Combine (
    s1 As SpinState,
    s2 As SpinState
) As SpinState()
public:
static array<SpinState>^ Combine(
    SpinState s1,
    SpinState s2
)
static member Combine :
        s1 : SpinState *
        s2 : SpinState -> SpinState[]

Parameters

s1
SpinState
The first spin state.
s2
SpinState
The second spin state.

Return Value

array< SpinState >[]()[][]
A list of spin states which may be obtained.

See Also

SpinMath Class
Combine Overload
Meta.Numerics.Functions Namespace


SpinMath.SixJ Method

F#

Meta.Numerics Library
SpinMath..::SixJ Method
Computes the value of the 6j symbol for the six given spins.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double SixJ(
    Spin j1,
    Spin j2,
    Spin j3,
    Spin j4,
    Spin j5,
    Spin j6
)
Public Shared Function SixJ (
    j1 As Spin,
    j2 As Spin,
    j3 As Spin,
    j4 As Spin,
    j5 As Spin,
    j6 As Spin
) As Double
public:
static double SixJ(
    Spin j1,
    Spin j2,
    Spin j3,
    Spin j4,
    Spin j5,
    Spin j6
)
static member SixJ :
        j1 : Spin *
        j2 : Spin *
        j3 : Spin *
        j4 : Spin *
        j5 : Spin *
        j6 : Spin -> float

Parameters

j1
Spin
Upper left spin.
j2
Spin
Upper middle spin.
j3
Spin
Upper right spin.
j4
Spin
Lower left spin.
j5
Spin
Lower middle spin.
j6
Spin
Lower right spin.

Return Value

Double
The value of {{j1,j2,j3},{j4,j5,j6}}.

See Also

SpinMath Class
Meta.Numerics.Functions Namespace


SpinMath.ThreeJ Method

F#

Meta.Numerics Library
SpinMath..::ThreeJ Method
Computes a 3j symbol.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double ThreeJ(
    SpinState s1,
    SpinState s2,
    SpinState s3
)
Public Shared Function ThreeJ (
    s1 As SpinState,
    s2 As SpinState,
    s3 As SpinState
) As Double
public:
static double ThreeJ(
    SpinState s1,
    SpinState s2,
    SpinState s3
)
static member ThreeJ :
        s1 : SpinState *
        s2 : SpinState *
        s3 : SpinState -> float

Parameters

s1
SpinState
The first column spin state.
s2
SpinState
The second column spin state.
s3
SpinState
The third column spin state.

Return Value

Double
The 3j symbol.

See Also

SpinMath Class
Meta.Numerics.Functions Namespace


SpinState Structure

F#

| Members | See Also
Meta.Numerics Library
SpinState Structure
Represents the state of a spinor.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct SpinState
Public Structure SpinState
public value class SpinState
[<SealedAttribute>]
type SpinState =  struct end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SpinState(Double, Double) | Instantiates a new SpinState with the given spin and magnetic quantum numbers.
SpinState(Spin, Double) | Instantiates a new SpinState with the given spin and magnetic quantum number.
Equality(SpinState, SpinState) | Determines whether two spin states are equal.
Equals(Object) | Determines whether the given object represents the same spin state. (Overrides ValueType..::..Equals(Object).)
GetHashCode()()()() | Computes a hash function for the spin state. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(SpinState, SpinState) | Determines whether two spin states are unequal.
J | Gets the spin value of the spin state.
M | Gets the magnetic substate value of the spin state.
Representation | Gets the spinor representation to which the spin state belongs.
ToString()()()() | Produces a string representation of the spin state. (Overrides ValueType..::..ToString()()()().)

See Also

Meta.Numerics.Functions Namespace


SpinState Constructor

F#

Meta.Numerics Library
SpinState Constructor

Overload List

Name | Description
SpinState(Double, Double) | Instantiates a new SpinState with the given spin and magnetic quantum numbers.
SpinState(Spin, Double) | Instantiates a new SpinState with the given spin and magnetic quantum number.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState Constructor (Double, Double)

F#

Meta.Numerics Library
SpinState Constructor (Double, Double)
Instantiates a new SpinState with the given spin and magnetic quantum numbers.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SpinState(
    double j,
    double m
)
Public Sub New (
    j As Double,
    m As Double
)
public:
SpinState(
    double j,
    double m
)
new :
        j : float *
        m : float -> SpinState

Parameters

j
Double
The spin number.
m
Double
The magnetic number.

See Also

SpinState Structure
SpinState Overload
Meta.Numerics.Functions Namespace


SpinState Constructor (Spin, Double)

F#

Meta.Numerics Library
SpinState Constructor (Spin, Double)
Instantiates a new SpinState with the given spin and magnetic quantum number.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SpinState(
    Spin s,
    double m
)
Public Sub New (
    s As Spin,
    m As Double
)
public:
SpinState(
    Spin s,
    double m
)
new :
        s : Spin *
        m : float -> SpinState

Parameters

s
Spin
The spin.
m
Double
The magnetic quantum number.

See Also

SpinState Structure
SpinState Overload
Meta.Numerics.Functions Namespace


SpinState Methods

F#

Meta.Numerics Library
SpinState Methods

The SpinState type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the given object represents the same spin state. (Overrides ValueType..::..Equals(Object).)
GetHashCode()()()() | Computes a hash function for the spin state. (Overrides ValueType..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Produces a string representation of the spin state. (Overrides ValueType..::..ToString()()()().)

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.Equals Method

F#

Meta.Numerics Library
SpinState..::Equals Method
Determines whether the given object represents the same spin state.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object to compare.

Return Value

Boolean
True if obj is an equal spin state, otherwise false.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.GetHashCode Method

F#

Meta.Numerics Library
SpinState..::GetHashCode Method
Computes a hash function for the spin state.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
An integer which is guaranteed equal for equal spin states, an unlikely to be equal for unequal spin states.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.ToString Method

F#

Meta.Numerics Library
SpinState..::ToString Method
Produces a string representation of the spin state.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
A string representation of the spin state.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState Operators

F#

Meta.Numerics Library
SpinState Operators

The SpinState type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equality(SpinState, SpinState) | Determines whether two spin states are equal.
Inequality(SpinState, SpinState) | Determines whether two spin states are unequal.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.Equality Operator

F#

Meta.Numerics Library
SpinState..::Equality Operator
Determines whether two spin states are equal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    SpinState s1,
    SpinState s2
)
Public Shared Operator = (
    s1 As SpinState,
    s2 As SpinState
) As Boolean
public:
static bool operator ==(
    SpinState s1,
    SpinState s2
)
static let inline (=)
        s1 : SpinState *
        s2 : SpinState  : bool

Parameters

s1
SpinState
The first spin state.
s2
SpinState
The second spin state.

Return Value

Boolean
True if s1 and s2 are equal, otherwise false.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.Inequality Operator

F#

Meta.Numerics Library
SpinState..::Inequality Operator
Determines whether two spin states are unequal.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    SpinState s1,
    SpinState s2
)
Public Shared Operator <> (
    s1 As SpinState,
    s2 As SpinState
) As Boolean
public:
static bool operator !=(
    SpinState s1,
    SpinState s2
)
static let inline (<>)
        s1 : SpinState *
        s2 : SpinState  : bool

Parameters

s1
SpinState
The first spin state.
s2
SpinState
The second spin state.

Return Value

Boolean
False if s1 and s2 are equal, otherwise true.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState Properties

F#

Meta.Numerics Library
SpinState Properties

The SpinState type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
J | Gets the spin value of the spin state.
M | Gets the magnetic substate value of the spin state.
Representation | Gets the spinor representation to which the spin state belongs.

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.J Property

F#

Meta.Numerics Library
SpinState..::J Property
Gets the spin value of the spin state.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double J { get; }
Public ReadOnly Property J As Double
    Get
public:
property double J {
    double get ();
}
member J : float with get

Property Value

Double

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.M Property

F#

Meta.Numerics Library
SpinState..::M Property
Gets the magnetic substate value of the spin state.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double M { get; }
Public ReadOnly Property M As Double
    Get
public:
property double M {
    double get ();
}
member M : float with get

Property Value

Double

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


SpinState.Representation Property

F#

Meta.Numerics Library
SpinState..::Representation Property
Gets the spinor representation to which the spin state belongs.

Namespace: Meta.Numerics.Functions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Spin Representation { get; }
Public ReadOnly Property Representation As Spin
    Get
public:
property Spin Representation {
    Spin get ();
}
member Representation : Spin with get

Property Value

Spin

See Also

SpinState Structure
Meta.Numerics.Functions Namespace


Meta.Numerics.Matrices Namespace

F#

Meta.Numerics Library
Meta.Numerics.Matrices Namespace
Contains types that store and operate on matrices.

Types

All Types | Classes
Name | Description
AnyMatrix<(Of <(<'T>)>)> | Describes the form of all matrices.
AnyRectangularMatrix | Describes the form of all real matrices.
AnySquareMatrix | Describes the form of all real, square matrices.
CholeskyDecomposition | Represents the Cholesky Decomposition of a symmetric, positive definite matrix.
ColumnVector | A column vector of real numbers.
ComplexEigensystem | Represents a collection of complex eigenvalues and eigenvectors.
LUDecomposition | Represents the LU decomposition of a square matrix.
QRDecomposition | Represents a QR decomposition of a matrix.
RealEigensystem | Represents a collection of real eigenvalues and eigenvectors.
RectangularMatrix | A rectangular matrix of real numbers.
RowVector | A row vector of real numbers.
SingularValueDecomposition | Stores the singular value decomposition of a matrix.
SparseSquareMatrix | Represents a sparse, square matrix.
SquareMatrix | Represents a square matrix.
SquareQRDecomposition | Represents the QR decomposition of a square matrix.
SymmetricMatrix | Represents a symmetric matrix.
TridiagonalLUDecomposition | Represents the LU decomposition of a tridiagonal matrix.
TridiagonalMatrix | Represents a tridiagonal matrix.
VectorBase | Implements functionality shared between row and column vectors.


AnyMatrix Generic Class

F#

| Members | See Also
Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)> Class
Describes the form of all matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class AnyMatrix<T>

Public MustInherit Class AnyMatrix(Of T)
generic<typename T>
public ref class AnyMatrix abstract
[<AbstractClassAttribute>]
type AnyMatrix<'T> =  class end

Type Parameters

T
The type of the matrix entries.

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AnyMatrix<(Of <(<'T>)>)>()()()() | Initializes a new instance of the AnyMatrix class.
ColumnCount | Gets the number of matrix columns.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
RowCount | Gets the number of matrix rows.
ToArray()()()() | Copies the matrix into an array.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix<(Of <(<'T>)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix

See Also

Meta.Numerics.Matrices Namespace


AnyMatrix Constructor

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)> Constructor
Initializes a new instance of the AnyMatrix class.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected AnyMatrix()
Protected Sub New
protected:
AnyMatrix()
new : unit -> AnyMatrix

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix Methods

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)> Methods

The AnyMatrix<(Of <(<'T>)>)> generic type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToArray()()()() | Copies the matrix into an array.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.Fill Method

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::Fill Method
Sets all matrix entries according to a supplied fill function.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual void Fill(
    Func<int, int, T> f
)
Public Overridable Sub Fill (
    f As Func(Of Integer, Integer, T)
)
public:
virtual void Fill(
    Func<int, int, T>^ f
)
abstract Fill :
        f : Func<int, int, 'T> -> unit
override Fill :
        f : Func<int, int, 'T> -> unit

Parameters

f
Func <(Of <(<' Int32, Int32, T >)>)>
The fill function.

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.ToArray Method

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::ToArray Method
Copies the matrix into an array.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual T[,] ToArray()
Public Overridable Function ToArray As T(,)
public:
virtual array<T,2>^ ToArray()
abstract ToArray : unit -> 'T[,]
override ToArray : unit -> 'T[,]

Return Value

array< T ,2>[,](,)[,][,]
A two-dimensional .NET array containing the matrix entries.

Remarks

The output array is independent of the matrix. Changes to its elements will not change the elements of the matrix, and changes to the matrix elements will not be reflected in the array.

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix Properties

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)> Properties

The AnyMatrix<(Of <(<'T>)>)> generic type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns.
IsReadOnly | Gets a flag indicating whether the matrix is read-only.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry.
RowCount | Gets the number of matrix rows.

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.ColumnCount Property

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::ColumnCount Property
Gets the number of matrix columns.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract int ColumnCount { get; }
Public MustOverride ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () abstract;
}
abstract ColumnCount : int with get

Property Value

Int32

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.IsReadOnly Property

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::IsReadOnly Property
Gets a flag indicating whether the matrix is read-only.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Property Value

Boolean

Remarks

Although you can't change the values in a read-only matrix, you can make a writable copy of it.

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.Item Property

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::Item Property
Gets or sets the value of a matrix entry.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract T this[
    int r,
    int c
] { get; set; }
Public MustOverride Default Property Item (
    r As Integer,
    c As Integer
) As T
    Get
    Set
public:
virtual property T default[int r, int c] {
    T get (int r, int c) abstract;
    void set (int r, int c, T value) abstract;
}
abstract Item : 'T with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

T
The value of the r,c matrix entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | r or c is outside the valid range.

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyMatrix.RowCount Property

F#

Meta.Numerics Library
AnyMatrix<(Of <(<'T>)>)>..::RowCount Property
Gets the number of matrix rows.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract int RowCount { get; }
Public MustOverride ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () abstract;
}
abstract RowCount : int with get

Property Value

Int32

See Also

AnyMatrix<(Of <(<'T>)>)> Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix Class

F#

| Members | See Also
Meta.Numerics Library
AnyRectangularMatrix Class
Describes the form of all real matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class AnyRectangularMatrix : AnyMatrix<double>,
    IEquatable<AnyRectangularMatrix>
Public MustInherit Class AnyRectangularMatrix
    Inherits AnyMatrix(Of Double)
    Implements IEquatable(Of AnyRectangularMatrix)
public ref class AnyRectangularMatrix abstract : public AnyMatrix<double>,
    IEquatable<AnyRectangularMatrix^>
[<AbstractClassAttribute>]
type AnyRectangularMatrix =
    class
        inherit AnyMatrix<float>
        interface IEquatable<AnyRectangularMatrix>
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AnyRectangularMatrix()()()() | Initializes a new instance of the AnyRectangularMatrix class.
Addition(AnyRectangularMatrix, AnyRectangularMatrix) | Adds any two real, rectangular matrices.
Column(Int32) | Gets a copy of the specified column.
ColumnCount | Gets the number of matrix columns. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Equality(AnyRectangularMatrix, AnyRectangularMatrix) | Determines whether two matrices are equal.
Equals(Object) | Determines whether the given object is an equal matrix. (Overrides Object..::..Equals(Object).)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix.
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix.
GetHashCode()()()() | Not a valid operation. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(AnyRectangularMatrix, AnyRectangularMatrix) | Determines whether two matrices are not equal.
InfinityNorm()()()() | Computes the ∞-norm of the matrix.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Multiply(Double, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a real constant.
Multiply(AnyRectangularMatrix, AnyRectangularMatrix) | Multiplies any two real, rectangular matrices.
Multiply(AnyRectangularMatrix, ColumnVector) | Multiplies any real, rectangular matrix with a real column vector.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose.
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself.
OneNorm()()()() | Computes the 1-norm of the matrix.
Row(Int32) | Gets a copy of the specified row.
RowCount | Gets the number of matrix rows. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Subtraction(AnyRectangularMatrix, AnyRectangularMatrix) | Subtracts any two real, rectangular matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

This is an abstract class that describes any real matrix. If you wish to create a concrete instance of a real, non-square matrix, use the RectangularMatrix class. If, on the other hand, you wish to write a function that can operate on any real matrix, it's probably a good idea to accept a AnyRectangularMatrix, so that any concrete implementation can also be passed into your function.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..RectangularMatrix
Meta.Numerics.Matrices..::..VectorBase

See Also

Meta.Numerics.Matrices Namespace


AnyRectangularMatrix Constructor

F#

Meta.Numerics Library
AnyRectangularMatrix Constructor
Initializes a new instance of the AnyRectangularMatrix class.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected AnyRectangularMatrix()
Protected Sub New
protected:
AnyRectangularMatrix()
new : unit -> AnyRectangularMatrix

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix Methods

F#

Meta.Numerics Library
AnyRectangularMatrix Methods

The AnyRectangularMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column.
Equals(Object) | Determines whether the given object is an equal matrix. (Overrides Object..::..Equals(Object).)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix.
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix.
GetHashCode()()()() | Not a valid operation. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose.
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself.
OneNorm()()()() | Computes the 1-norm of the matrix.
Row(Int32) | Gets a copy of the specified row.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Column Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::Column Method
Gets a copy of the specified column.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual ColumnVector Column(
    int c
)
Public Overridable Function Column (
    c As Integer
) As ColumnVector
public:
virtual ColumnVector^ Column(
    int c
)
abstract Column :
        c : int -> ColumnVector
override Column :
        c : int -> ColumnVector

Parameters

c
Int32
The (zero-based) column index.

Return Value

ColumnVector
An independent copy of the specified column.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Equals Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::Equals Method

Overload List

Name | Description
Equals(Object) | Determines whether the given object is an equal matrix. (Overrides Object.Equals(Object).)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Equals Method (Object)

F#

Meta.Numerics Library
AnyRectangularMatrix..::Equals Method (Object)
Determines whether the given object is an equal matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object to compare.

Return Value

Boolean
True if obj is an equal matrix, otherwise false.

See Also

AnyRectangularMatrix Class
Equals Overload
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Equals Method (AnyRectangularMatrix)

F#

Meta.Numerics Library
AnyRectangularMatrix..::Equals Method (AnyRectangularMatrix)
Determines whether the given matrix equals the current matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Equals(
    AnyRectangularMatrix other
)
Public Function Equals (
    other As AnyRectangularMatrix
) As Boolean
public:
virtual bool Equals(
    AnyRectangularMatrix^ other
) sealed
abstract Equals :
        other : AnyRectangularMatrix -> bool
override Equals :
        other : AnyRectangularMatrix -> bool

Parameters

other
AnyRectangularMatrix
The matrix to compare.

Return Value

Boolean
True if the other is equal to the current matrix, otherwise false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

AnyRectangularMatrix Class
Equals Overload
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.FrobeniusNorm Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::FrobeniusNorm Method
Computes the Frobenius-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double FrobeniusNorm()
Public Overridable Function FrobeniusNorm As Double
public:
virtual double FrobeniusNorm()
abstract FrobeniusNorm : unit -> float
override FrobeniusNorm : unit -> float

Return Value

Double
||M||F

Remarks

The Frobenius-norm of a matrix the square root of the sum of the squares of all the elements. In the case of a row or column vector, this reduces to the Euclidean vector norm.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.GetHashCode Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::GetHashCode Method
Not a valid operation.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
Throws an NotSupportedException.

Remarks

The GetHashCode()()()() method is used to provide a quick equality test when an object is used as a key in a Dictionary<(Of <(<'TKey, TValue>)>)> or [!:System.Collections.Hashtable]. Since a useful hash code of a matrix would need to involve all its elements, it is not possible to make this a fast operation. Also, since matrices are not immutable, they should not be used as hash keys. (A matrix might be changed after it had already been used as a key.) For these reasons, requesting a hash code for a matrix is not supported.

Exceptions

Exception | Condition
System..::..NotSupportedException | This method always throws this exception.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.InfinityNorm Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::InfinityNorm Method
Computes the ∞-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double InfinityNorm()
Public Overridable Function InfinityNorm As Double
public:
virtual double InfinityNorm()
abstract InfinityNorm : unit -> float
override InfinityNorm : unit -> float

Return Value

Double
||M||∞

Remarks

The ∞-norm of a matrix is the largest row sum.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.MultiplySelfByTranspose Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::MultiplySelfByTranspose Method
Computes the product of the matrix and its transpose.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual SymmetricMatrix MultiplySelfByTranspose()
Public Overridable Function MultiplySelfByTranspose As SymmetricMatrix
public:
virtual SymmetricMatrix^ MultiplySelfByTranspose()
abstract MultiplySelfByTranspose : unit -> SymmetricMatrix
override MultiplySelfByTranspose : unit -> SymmetricMatrix

Return Value

SymmetricMatrix
The product matrix A AT.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.MultiplyTransposeBySelf Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::MultiplyTransposeBySelf Method
Computes the product of the matrix's transpose and itself.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual SymmetricMatrix MultiplyTransposeBySelf()
Public Overridable Function MultiplyTransposeBySelf As SymmetricMatrix
public:
virtual SymmetricMatrix^ MultiplyTransposeBySelf()
abstract MultiplyTransposeBySelf : unit -> SymmetricMatrix
override MultiplyTransposeBySelf : unit -> SymmetricMatrix

Return Value

SymmetricMatrix
The product matrix AT A.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.OneNorm Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::OneNorm Method
Computes the 1-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double OneNorm()
Public Overridable Function OneNorm As Double
public:
virtual double OneNorm()
abstract OneNorm : unit -> float
override OneNorm : unit -> float

Return Value

Double
||M||1

Remarks

The 1-norm of a matrix is the largest column sum.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Row Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::Row Method
Gets a copy of the specified row.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual RowVector Row(
    int r
)
Public Overridable Function Row (
    r As Integer
) As RowVector
public:
virtual RowVector^ Row(
    int r
)
abstract Row :
        r : int -> RowVector
override Row :
        r : int -> RowVector

Parameters

r
Int32
The (zero-based) row index.

Return Value

RowVector
An independent copy of the specified row.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix Operators

F#

Meta.Numerics Library
AnyRectangularMatrix Operators

The AnyRectangularMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(AnyRectangularMatrix, AnyRectangularMatrix) | Adds any two real, rectangular matrices.
Equality(AnyRectangularMatrix, AnyRectangularMatrix) | Determines whether two matrices are equal.
Inequality(AnyRectangularMatrix, AnyRectangularMatrix) | Determines whether two matrices are not equal.
Multiply(Double, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a real constant.
Multiply(AnyRectangularMatrix, AnyRectangularMatrix) | Multiplies any two real, rectangular matrices.
Multiply(AnyRectangularMatrix, ColumnVector) | Multiplies any real, rectangular matrix with a real column vector.
Subtraction(AnyRectangularMatrix, AnyRectangularMatrix) | Subtracts any two real, rectangular matrices.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Addition Operator

F#

Meta.Numerics Library
AnyRectangularMatrix..::Addition Operator
Adds any two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator +(
    AnyRectangularMatrix A,
    AnyRectangularMatrix B
)
Public Shared Operator + (
    A As AnyRectangularMatrix,
    B As AnyRectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator +(
    AnyRectangularMatrix^ A,
    AnyRectangularMatrix^ B
)
static let inline (+)
        A : AnyRectangularMatrix *
        B : AnyRectangularMatrix  : RectangularMatrix

Parameters

A
AnyRectangularMatrix
The first matrix.
B
AnyRectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The sum matrix A + B.

Remarks

Matrix addition is an O(N2) process.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Equality Operator

F#

Meta.Numerics Library
AnyRectangularMatrix..::Equality Operator
Determines whether two matrices are equal.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    AnyRectangularMatrix A,
    AnyRectangularMatrix B
)
Public Shared Operator = (
    A As AnyRectangularMatrix,
    B As AnyRectangularMatrix
) As Boolean
public:
static bool operator ==(
    AnyRectangularMatrix^ A,
    AnyRectangularMatrix^ B
)
static let inline (=)
        A : AnyRectangularMatrix *
        B : AnyRectangularMatrix  : bool

Parameters

A
AnyRectangularMatrix
The first matrix.
B
AnyRectangularMatrix
The second matrix.

Return Value

Boolean
True if A and B are equal, otherwise false.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Inequality Operator

F#

Meta.Numerics Library
AnyRectangularMatrix..::Inequality Operator
Determines whether two matrices are not equal.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    AnyRectangularMatrix A,
    AnyRectangularMatrix B
)
Public Shared Operator <> (
    A As AnyRectangularMatrix,
    B As AnyRectangularMatrix
) As Boolean
public:
static bool operator !=(
    AnyRectangularMatrix^ A,
    AnyRectangularMatrix^ B
)
static let inline (<>)
        A : AnyRectangularMatrix *
        B : AnyRectangularMatrix  : bool

Parameters

A
AnyRectangularMatrix
The first matrix.
B
AnyRectangularMatrix
The second matrix.

Return Value

Boolean
False if A and B are equal, otherwise true.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Multiply Method

F#

Meta.Numerics Library
AnyRectangularMatrix..::Multiply Method

Overload List

Name | Description
Multiply(Double, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a real constant.
Multiply(AnyRectangularMatrix, AnyRectangularMatrix) | Multiplies any two real, rectangular matrices.
Multiply(AnyRectangularMatrix, ColumnVector) | Multiplies any real, rectangular matrix with a real column vector.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Multiply Operator (Double, AnyRectangularMatrix)

F#

Meta.Numerics Library
AnyRectangularMatrix..::Multiply Operator (Double, AnyRectangularMatrix)
Multiplies any real, rectangular matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator *(
    double alpha,
    AnyRectangularMatrix A
)
Public Shared Operator * (
    alpha As Double,
    A As AnyRectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator *(
    double alpha,
    AnyRectangularMatrix^ A
)
static let inline (*)
        alpha : float *
        A : AnyRectangularMatrix  : RectangularMatrix

Parameters

alpha
Double
The constant.
A
AnyRectangularMatrix
The matrix.

Return Value

RectangularMatrix
The product matrix.

See Also

AnyRectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Multiply Operator (AnyRectangularMatrix, AnyRectangularMatrix)

F#

Meta.Numerics Library
AnyRectangularMatrix..::Multiply Operator (AnyRectangularMatrix, AnyRectangularMatrix)
Multiplies any two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator *(
    AnyRectangularMatrix A,
    AnyRectangularMatrix B
)
Public Shared Operator * (
    A As AnyRectangularMatrix,
    B As AnyRectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator *(
    AnyRectangularMatrix^ A,
    AnyRectangularMatrix^ B
)
static let inline (*)
        A : AnyRectangularMatrix *
        B : AnyRectangularMatrix  : RectangularMatrix

Parameters

A
AnyRectangularMatrix
The first matrix.
B
AnyRectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The product matrix AB.

Remarks

For matrix multiplication, the column count of the first matrix must equal the row count of the second matrix.

Matrix multiplication is an O(N3) process.

See Also

AnyRectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Multiply Operator (AnyRectangularMatrix, ColumnVector)

F#

Meta.Numerics Library
AnyRectangularMatrix..::Multiply Operator (AnyRectangularMatrix, ColumnVector)
Multiplies any real, rectangular matrix with a real column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator *(
    AnyRectangularMatrix A,
    ColumnVector v
)
Public Shared Operator * (
    A As AnyRectangularMatrix,
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator *(
    AnyRectangularMatrix^ A,
    ColumnVector^ v
)
static let inline (*)
        A : AnyRectangularMatrix *
        v : ColumnVector  : ColumnVector

Parameters

A
AnyRectangularMatrix
The matrix.
v
ColumnVector
The column vector.

Return Value

ColumnVector
The product column vector.

See Also

AnyRectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix.Subtraction Operator

F#

Meta.Numerics Library
AnyRectangularMatrix..::Subtraction Operator
Subtracts any two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator -(
    AnyRectangularMatrix A,
    AnyRectangularMatrix B
)
Public Shared Operator - (
    A As AnyRectangularMatrix,
    B As AnyRectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator -(
    AnyRectangularMatrix^ A,
    AnyRectangularMatrix^ B
)
static let inline (-)
        A : AnyRectangularMatrix *
        B : AnyRectangularMatrix  : RectangularMatrix

Parameters

A
AnyRectangularMatrix
The first matrix.
B
AnyRectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The difference matrix A - B.

Remarks

Matrix subtraction is an O(N2) process.

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnyRectangularMatrix Properties

F#

Meta.Numerics Library
AnyRectangularMatrix Properties

The AnyRectangularMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
RowCount | Gets the number of matrix rows. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)

See Also

AnyRectangularMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix Class

F#

| Members | See Also
Meta.Numerics Library
AnySquareMatrix Class
Describes the form of all real, square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class AnySquareMatrix : AnyRectangularMatrix
Public MustInherit Class AnySquareMatrix
    Inherits AnyRectangularMatrix
public ref class AnySquareMatrix abstract : public AnyRectangularMatrix
[<AbstractClassAttribute>]
type AnySquareMatrix =
    class
        inherit AnyRectangularMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AnySquareMatrix()()()() | Initializes a new instance of the AnySquareMatrix class
Addition(AnySquareMatrix, AnySquareMatrix) | Adds any two real, square matrices.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Dimension | Gets or sets the dimension of the square matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Multiply(AnySquareMatrix, AnySquareMatrix) | Multiplies any two real, square matrices.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)
Subtraction(AnySquareMatrix, AnySquareMatrix) | Subtracts any two real, square matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix.

Remarks

This is an abstract class that describes any real, square matrix. If you wish to create a concrete instance of a real, non-square matrix, use the SquareMatrix class. If, on the other hand, you wish to write a function that can operate on any real, square matrix, it's probably a good idea to accept a AnySquareMatrix, so that your function could operate on any concrete implementation.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..SparseSquareMatrix
Meta.Numerics.Matrices..::..SquareMatrix
Meta.Numerics.Matrices..::..SymmetricMatrix
Meta.Numerics.Matrices..::..TridiagonalMatrix

See Also

Meta.Numerics.Matrices Namespace


AnySquareMatrix Constructor

F#

Meta.Numerics Library
AnySquareMatrix Constructor
Initializes a new instance of the AnySquareMatrix class

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected AnySquareMatrix()
Protected Sub New
protected:
AnySquareMatrix()
new : unit -> AnySquareMatrix

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix Methods

F#

Meta.Numerics Library
AnySquareMatrix Methods

The AnySquareMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.Trace Method

F#

Meta.Numerics Library
AnySquareMatrix..::Trace Method
Computes the trace of the square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Trace()
Public Overridable Function Trace As Double
public:
virtual double Trace()
abstract Trace : unit -> float
override Trace : unit -> float

Return Value

Double
tr(M)

Remarks

The trace of a square matrix is the sum of its diagonal elements.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix Operators

F#

Meta.Numerics Library
AnySquareMatrix Operators

The AnySquareMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(AnySquareMatrix, AnySquareMatrix) | Adds any two real, square matrices.
Multiply(AnySquareMatrix, AnySquareMatrix) | Multiplies any two real, square matrices.
Subtraction(AnySquareMatrix, AnySquareMatrix) | Subtracts any two real, square matrices.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.Addition Operator

F#

Meta.Numerics Library
AnySquareMatrix..::Addition Operator
Adds any two real, square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator +(
    AnySquareMatrix A,
    AnySquareMatrix B
)
Public Shared Operator + (
    A As AnySquareMatrix,
    B As AnySquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator +(
    AnySquareMatrix^ A,
    AnySquareMatrix^ B
)
static let inline (+)
        A : AnySquareMatrix *
        B : AnySquareMatrix  : SquareMatrix

Parameters

A
AnySquareMatrix
The first matrix.
B
AnySquareMatrix
The second matrix.

Return Value

SquareMatrix
The sum matrix A + B.

Remarks

Matrix addition is an O(N2) process.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.Multiply Operator

F#

Meta.Numerics Library
AnySquareMatrix..::Multiply Operator
Multiplies any two real, square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator *(
    AnySquareMatrix A,
    AnySquareMatrix B
)
Public Shared Operator * (
    A As AnySquareMatrix,
    B As AnySquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator *(
    AnySquareMatrix^ A,
    AnySquareMatrix^ B
)
static let inline (*)
        A : AnySquareMatrix *
        B : AnySquareMatrix  : SquareMatrix

Parameters

A
AnySquareMatrix
The first matrix.
B
AnySquareMatrix
The second matrix.

Return Value

SquareMatrix
The product matrix AB.

Remarks

Matrix multiplication is an O(N3) process.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.Subtraction Operator

F#

Meta.Numerics Library
AnySquareMatrix..::Subtraction Operator
Subtracts any two real, square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator -(
    AnySquareMatrix A,
    AnySquareMatrix B
)
Public Shared Operator - (
    A As AnySquareMatrix,
    B As AnySquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator -(
    AnySquareMatrix^ A,
    AnySquareMatrix^ B
)
static let inline (-)
        A : AnySquareMatrix *
        B : AnySquareMatrix  : SquareMatrix

Parameters

A
AnySquareMatrix
The first matrix.
B
AnySquareMatrix
The second matrix.

Return Value

SquareMatrix
The difference matrix A - B.

Remarks

Matrix addition is an O(N2) process.

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix Properties

F#

Meta.Numerics Library
AnySquareMatrix Properties

The AnySquareMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Dimension | Gets or sets the dimension of the square matrix.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.ColumnCount Property

F#

Meta.Numerics Library
AnySquareMatrix..::ColumnCount Property
Gets the number of matrix columns.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Int32

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.Dimension Property

F#

Meta.Numerics Library
AnySquareMatrix..::Dimension Property
Gets or sets the dimension of the square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract int Dimension { get; }
Public MustOverride ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () abstract;
}
abstract Dimension : int with get

Property Value

Int32

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


AnySquareMatrix.RowCount Property

F#

Meta.Numerics Library
AnySquareMatrix..::RowCount Property
Gets the number of matrix rows.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () override;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Int32

See Also

AnySquareMatrix Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition Class

F#

| Example | Members | See Also
Meta.Numerics Library
CholeskyDecomposition Class
Represents the Cholesky Decomposition of a symmetric, positive definite matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class CholeskyDecomposition
Public NotInheritable Class CholeskyDecomposition
public ref class CholeskyDecomposition sealed
[<SealedAttribute>]
type CholeskyDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Dimension | Gets the dimension of the system.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
Solve(IList<(Of <<'(Double>)>>)) | Computes the solution vector that, when multiplied by the original matrix, produces the given left-hand side vector.
SquareRootMatrix()()()() | Returns the Cholesky square root matrix.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

A Cholesky decomposition represents a matrix as the product of a lower-left triangular matrix and its transpose. For example:

The Choleksy decomposition of a symmetric, positive definite matrix can be obtained using the CholeskyDecomposition()()()() method of the SymmetricMatrix class.

Examples

Here is an example that uses a Cholesky decomposition to solve a linear algebra problem.

C# Copy image Copy
// Solve Ax = b via Cholesky decomposition
CholeskyDecomposition CD = A.CholsekyDecomposition();
ColumnVector b = new ColumnVector(1.0, 2.0, 3.0);
ColumnVector x CD.Solve(b);

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..CholeskyDecomposition

See Also

Meta.Numerics.Matrices Namespace
SymmetricMatrix..::..CholeskyDecomposition()()()()


CholeskyDecomposition Methods

F#

Meta.Numerics Library
CholeskyDecomposition Methods

The CholeskyDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
Solve(IList<(Of <<'(Double>)>>)) | Computes the solution vector that, when multiplied by the original matrix, produces the given left-hand side vector.
SquareRootMatrix()()()() | Returns the Cholesky square root matrix.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition.Determinant Method

F#

Meta.Numerics Library
CholeskyDecomposition..::Determinant Method
Computes the determinant of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Double
det M

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition.Inverse Method

F#

Meta.Numerics Library
CholeskyDecomposition..::Inverse Method
Computes the inverse of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix Inverse()
Public Function Inverse As SymmetricMatrix
public:
SymmetricMatrix^ Inverse()
member Inverse : unit -> SymmetricMatrix

Return Value

SymmetricMatrix
M-1

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition.Solve Method

F#

Meta.Numerics Library
CholeskyDecomposition..::Solve Method
Computes the solution vector that, when multiplied by the original matrix, produces the given left-hand side vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    IList<double> rhs
)
Public Function Solve (
    rhs As IList(Of Double)
) As ColumnVector
public:
ColumnVector^ Solve(
    IList<double>^ rhs
)
member Solve :
        rhs : IList<float> -> ColumnVector

Parameters

rhs
IList <(Of <(<' Double >)>)>
The right-hand-side vector.

Return Value

ColumnVector
The left-hand-side (solution) vector.

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition.SquareRootMatrix Method

F#

Meta.Numerics Library
CholeskyDecomposition..::SquareRootMatrix Method
Returns the Cholesky square root matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix SquareRootMatrix()
Public Function SquareRootMatrix As SquareMatrix
public:
SquareMatrix^ SquareRootMatrix()
member SquareRootMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
A lower-left triangular matrix A, such that A AT = M.

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition Properties

F#

Meta.Numerics Library
CholeskyDecomposition Properties

The CholeskyDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the system.

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


CholeskyDecomposition.Dimension Property

F#

Meta.Numerics Library
CholeskyDecomposition..::Dimension Property
Gets the dimension of the system.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

CholeskyDecomposition Class
Meta.Numerics.Matrices Namespace


ColumnVector Class

F#

| Members | See Also
Meta.Numerics Library
ColumnVector Class
A column vector of real numbers.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class ColumnVector : VectorBase
Public NotInheritable Class ColumnVector
    Inherits VectorBase
public ref class ColumnVector sealed : public VectorBase
[<SealedAttribute>]
type ColumnVector =
    class
        inherit VectorBase
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnVector(IList<(Of <<'(Double>)>>)) | Initializes a new column vector from the given component list.
ColumnVector(array<Double>[]()[][]) | Initializes a new column vector with the given components.
ColumnVector(Int32) | Initializes a new column vector with the given dimension.
Addition(ColumnVector, ColumnVector) | Computes the sum of two column vectors.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Copy()()()() | Returns a copy of the column vector.
Dimension | Gets the dimension of the vector. (Inherited from VectorBase.)
Division(ColumnVector, Double) | Divides a column vector by a real, scalar constant.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components. (Inherited from VectorBase.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component. (Inherited from VectorBase.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
Multiply(Double, ColumnVector) | Multiplies a column vector by a real, scalar constant.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector. (Inherited from VectorBase.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)
Subtraction(ColumnVector, ColumnVector) | Computes the difference of two column vectors.
ToArray()()()() | Returns the vector elements in an independent array. (Inherited from VectorBase.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the column vector.
UnaryNegation(ColumnVector) | Negates a column vector.

Remarks

An N-dimensional column vector is an N X 1 dimensional matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..VectorBase
Meta.Numerics.Matrices..::..ColumnVector

See Also

Meta.Numerics.Matrices Namespace


ColumnVector Constructor

F#

Meta.Numerics Library
ColumnVector Constructor

Overload List

Name | Description
ColumnVector(IList<(Of <<'(Double>)>>)) | Initializes a new column vector from the given component list.
ColumnVector(array<Double>[]()[][]) | Initializes a new column vector with the given components.
ColumnVector(Int32) | Initializes a new column vector with the given dimension.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector Constructor (IList)

F#

Meta.Numerics Library
ColumnVector Constructor (IList<(Of <(<'Double>)>)>)
Initializes a new column vector from the given component list.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector(
    IList<double> list
)
Public Sub New (
    list As IList(Of Double)
)
public:
ColumnVector(
    IList<double>^ list
)
new :
        list : IList<float> -> ColumnVector

Parameters

list
IList <(Of <(<' Double >)>)>
A list of vector components.

See Also

ColumnVector Class
ColumnVector Overload
Meta.Numerics.Matrices Namespace


ColumnVector Constructor (Double[])

F#

Meta.Numerics Library
ColumnVector Constructor (array<Double>[]()[][])
Initializes a new column vector with the given components.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector(
    params double[] list
)
Public Sub New (
    ParamArray list As Double()
)
public:
ColumnVector(
    ... array<double>^ list
)
new :
        list : float[] -> ColumnVector

Parameters

list
array< Double >[]()[][]
A list of vector components.

See Also

ColumnVector Class
ColumnVector Overload
Meta.Numerics.Matrices Namespace


ColumnVector Constructor (Int32)

F#

Meta.Numerics Library
ColumnVector Constructor (Int32)
Initializes a new column vector with the given dimension.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
ColumnVector(
    int dimension
)
new :
        dimension : int -> ColumnVector

Parameters

dimension
Int32
The dimension of the vector, which must be positive.

See Also

ColumnVector Class
ColumnVector Overload
Meta.Numerics.Matrices Namespace


ColumnVector Methods

F#

Meta.Numerics Library
ColumnVector Methods

The ColumnVector type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Copy()()()() | Returns a copy of the column vector.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components. (Inherited from VectorBase.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector. (Inherited from VectorBase.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Returns the vector elements in an independent array. (Inherited from VectorBase.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the column vector.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Copy Method

F#

Meta.Numerics Library
ColumnVector..::Copy Method
Returns a copy of the column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Copy()
Public Function Copy As ColumnVector
public:
ColumnVector^ Copy()
member Copy : unit -> ColumnVector

Return Value

ColumnVector
An independent copy of the column vector.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Transpose Method

F#

Meta.Numerics Library
ColumnVector..::Transpose Method
Returns the transpose of the column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector Transpose()
Public Function Transpose As RowVector
public:
RowVector^ Transpose()
member Transpose : unit -> RowVector

Return Value

RowVector
An independent row vector with the same components as the column vector.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector Operators

F#

Meta.Numerics Library
ColumnVector Operators

The ColumnVector type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(ColumnVector, ColumnVector) | Computes the sum of two column vectors.
Division(ColumnVector, Double) | Divides a column vector by a real, scalar constant.
Multiply(Double, ColumnVector) | Multiplies a column vector by a real, scalar constant.
Subtraction(ColumnVector, ColumnVector) | Computes the difference of two column vectors.
UnaryNegation(ColumnVector) | Negates a column vector.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Addition Operator

F#

Meta.Numerics Library
ColumnVector..::Addition Operator
Computes the sum of two column vectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator +(
    ColumnVector v1,
    ColumnVector v2
)
Public Shared Operator + (
    v1 As ColumnVector,
    v2 As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator +(
    ColumnVector^ v1,
    ColumnVector^ v2
)
static let inline (+)
        v1 : ColumnVector *
        v2 : ColumnVector  : ColumnVector

Parameters

v1
ColumnVector
The first column vector.
v2
ColumnVector
The second column vector.

Return Value

ColumnVector
The sum v1 + v2.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Division Operator

F#

Meta.Numerics Library
ColumnVector..::Division Operator
Divides a column vector by a real, scalar constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator /(
    ColumnVector v,
    double alpha
)
Public Shared Operator / (
    v As ColumnVector,
    alpha As Double
) As ColumnVector
public:
static ColumnVector^ operator /(
    ColumnVector^ v,
    double alpha
)
static let inline (/)
        v : ColumnVector *
        alpha : float  : ColumnVector

Parameters

v
ColumnVector
The column vector.
alpha
Double
The real, scalar constant.

Return Value

ColumnVector
The product.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Multiply Operator

F#

Meta.Numerics Library
ColumnVector..::Multiply Operator
Multiplies a column vector by a real, scalar constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator *(
    double alpha,
    ColumnVector v
)
Public Shared Operator * (
    alpha As Double,
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator *(
    double alpha,
    ColumnVector^ v
)
static let inline (*)
        alpha : float *
        v : ColumnVector  : ColumnVector

Parameters

alpha
Double
The real, scalar constant.
v
ColumnVector
The column vector.

Return Value

ColumnVector
The product.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Subtraction Operator

F#

Meta.Numerics Library
ColumnVector..::Subtraction Operator
Computes the difference of two column vectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator -(
    ColumnVector v1,
    ColumnVector v2
)
Public Shared Operator - (
    v1 As ColumnVector,
    v2 As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator -(
    ColumnVector^ v1,
    ColumnVector^ v2
)
static let inline (-)
        v1 : ColumnVector *
        v2 : ColumnVector  : ColumnVector

Parameters

v1
ColumnVector
The first column vector.
v2
ColumnVector
The second column vector.

Return Value

ColumnVector
The difference v1 - v2.

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.UnaryNegation Operator

F#

Meta.Numerics Library
ColumnVector..::UnaryNegation Operator
Negates a column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator -(
    ColumnVector v
)
Public Shared Operator - (
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator -(
    ColumnVector^ v
)
static let inline (-)
        v : ColumnVector  : ColumnVector

Parameters

v
ColumnVector
The column vector.

Return Value

ColumnVector
-v

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector Properties

F#

Meta.Numerics Library
ColumnVector Properties

The ColumnVector type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Dimension | Gets the dimension of the vector. (Inherited from VectorBase.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component. (Inherited from VectorBase.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.ColumnCount Property

F#

Meta.Numerics Library
ColumnVector..::ColumnCount Property
Gets the number of matrix columns.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Int32

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Item Property

F#

Meta.Numerics Library
ColumnVector..::Item Property

Overload List

Name | Description
Item[([( Int32])]) | Gets or sets the specified vector component.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix <(Of <(<' Double >)>)>.Item[([( Int32, Int32])]) .)

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ColumnVector.Item Property (Int32, Int32)

F#

Meta.Numerics Library
ColumnVector..::Item Property (Int32, Int32)
Gets or sets the value of a matrix entry.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

Double
The value of the r,c matrix entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | r or c is outside the valid range.

See Also

ColumnVector Class
Item Overload
Meta.Numerics.Matrices Namespace


ColumnVector.RowCount Property

F#

Meta.Numerics Library
ColumnVector..::RowCount Property
Gets the number of matrix rows.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () override;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Int32

See Also

ColumnVector Class
Meta.Numerics.Matrices Namespace


ComplexEigensystem Class

F#

| Members | See Also
Meta.Numerics Library
ComplexEigensystem Class
Represents a collection of complex eigenvalues and eigenvectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class ComplexEigensystem
Public NotInheritable Class ComplexEigensystem
public ref class ComplexEigensystem sealed
[<SealedAttribute>]
type ComplexEigensystem =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the eigensystem.
Eigenvalue(Int32) | Gets the specified eigenvalue.
Eigenvector(Int32) | Gets the specified eigenvector.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..ComplexEigensystem

See Also

Meta.Numerics.Matrices Namespace


ComplexEigensystem Methods

F#

Meta.Numerics Library
ComplexEigensystem Methods

The ComplexEigensystem type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Eigenvalue(Int32) | Gets the specified eigenvalue.
Eigenvector(Int32) | Gets the specified eigenvector.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ComplexEigensystem Class
Meta.Numerics.Matrices Namespace


ComplexEigensystem.Eigenvalue Method

F#

Meta.Numerics Library
ComplexEigensystem..::Eigenvalue Method
Gets the specified eigenvalue.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex Eigenvalue(
    int n
)
Public Function Eigenvalue (
    n As Integer
) As Complex
public:
Complex Eigenvalue(
    int n
)
member Eigenvalue :
        n : int -> Complex

Parameters

n
Int32
The number of the eigenvalue.

Return Value

Complex
The nth eigenvalue.

See Also

ComplexEigensystem Class
Meta.Numerics.Matrices Namespace


ComplexEigensystem.Eigenvector Method

F#

Meta.Numerics Library
ComplexEigensystem..::Eigenvector Method
Gets the specified eigenvector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex[] Eigenvector(
    int n
)
Public Function Eigenvector (
    n As Integer
) As Complex()
public:
array<Complex>^ Eigenvector(
    int n
)
member Eigenvector :
        n : int -> Complex[]

Parameters

n
Int32
The number of the eigenvector.

Return Value

array< Complex >[]()[][]
The nth eigenvector.

See Also

ComplexEigensystem Class
Meta.Numerics.Matrices Namespace


ComplexEigensystem Properties

F#

Meta.Numerics Library
ComplexEigensystem Properties

The ComplexEigensystem type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the eigensystem.

See Also

ComplexEigensystem Class
Meta.Numerics.Matrices Namespace


ComplexEigensystem.Dimension Property

F#

Meta.Numerics Library
ComplexEigensystem..::Dimension Property
Gets the dimension of the eigensystem.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

ComplexEigensystem Class
Meta.Numerics.Matrices Namespace


LUDecomposition Class

F#

| Members | See Also
Meta.Numerics Library
LUDecomposition Class
Represents the LU decomposition of a square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class LUDecomposition
Public NotInheritable Class LUDecomposition
public ref class LUDecomposition sealed
[<SealedAttribute>]
type LUDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Dimension | Gets the dimension of the system.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the the inverse of the original matrix.
LMatrix()()()() | Gets the L factor.
PMatrix()()()() | Gets the permutation matrix.
Solve(IList<(Of <<'(Double>)>>)) | Solves A x = b.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UMatrix()()()() | Gets the U factor.

Remarks

An LU decomposition is a representation of a matrix M as the product of a lower-left-triagular matrix L and and an upper-right-triangular matrix U. To reduce numerical instabilities, we actually decompose a row-wise permutation of a matrix, so that we have P A = L U, where P is a permutation matrix.

For example, here is an LU decomposition of a permutation of a simple 3 X 3 matrix:

Given an LU decomposition of a permutation A, we can solve systems of linear equations or compute the determinant or inverse of A. LU decomposition is the fastest way to solve an arbitrary system of linear equations. It is much faster, and less subject to rounding errors, to solve Ax=b by LU decomposition than than by inverting A and multiplying A-1b.

You can use the LUDecomposition()()()() method to obtain the LU decomposition of any non-singular square matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..LUDecomposition

See Also

Meta.Numerics.Matrices Namespace
Meta.Numerics.Matrices..::..SquareMatrix


LUDecomposition Methods

F#

Meta.Numerics Library
LUDecomposition Methods

The LUDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the the inverse of the original matrix.
LMatrix()()()() | Gets the L factor.
PMatrix()()()() | Gets the permutation matrix.
Solve(IList<(Of <<'(Double>)>>)) | Solves A x = b.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
UMatrix()()()() | Gets the U factor.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.Determinant Method

F#

Meta.Numerics Library
LUDecomposition..::Determinant Method
Computes the determinant of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Double
The determinant of the original matrix.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.Inverse Method

F#

Meta.Numerics Library
LUDecomposition..::Inverse Method
Computes the the inverse of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Inverse()
Public Function Inverse As SquareMatrix
public:
SquareMatrix^ Inverse()
member Inverse : unit -> SquareMatrix

Return Value

SquareMatrix
The independent inverse of the original matrix.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.LMatrix Method

F#

Meta.Numerics Library
LUDecomposition..::LMatrix Method
Gets the L factor.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix LMatrix()
Public Function LMatrix As SquareMatrix
public:
SquareMatrix^ LMatrix()
member LMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The lower-left trangular factor L of the LU decomposition.

Remarks

The pivoted LU decomposition algorithm guarantees that the diagonal entries of this matrix are all one, and that the magnitudes of the sub-diagonal entries are all less than or equal to one.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.PMatrix Method

F#

Meta.Numerics Library
LUDecomposition..::PMatrix Method
Gets the permutation matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix PMatrix()
Public Function PMatrix As SquareMatrix
public:
SquareMatrix^ PMatrix()
member PMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The permutation matrix P in the PA = LU decomposition.

Remarks

A permutation matrix is just a "scrambled" identity matrix: 1 appears exactly once in each row and column, but not necessarily in the diagonal position.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.Solve Method

F#

Meta.Numerics Library
LUDecomposition..::Solve Method
Solves A x = b.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    IList<double> rhs
)
Public Function Solve (
    rhs As IList(Of Double)
) As ColumnVector
public:
ColumnVector^ Solve(
    IList<double>^ rhs
)
member Solve :
        rhs : IList<float> -> ColumnVector

Parameters

rhs
IList <(Of <(<' Double >)>)>
The right-hand side vector b.

Return Value

ColumnVector
The solution vector x.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rhs is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of rhs is not the same as the dimension of the matrix.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.UMatrix Method

F#

Meta.Numerics Library
LUDecomposition..::UMatrix Method
Gets the U factor.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix UMatrix()
Public Function UMatrix As SquareMatrix
public:
SquareMatrix^ UMatrix()
member UMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The upper-right triangular factor U of the LU decomposition.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition Properties

F#

Meta.Numerics Library
LUDecomposition Properties

The LUDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the system.

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


LUDecomposition.Dimension Property

F#

Meta.Numerics Library
LUDecomposition..::Dimension Property
Gets the dimension of the system.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

LUDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition Class

F#

| Members | See Also
Meta.Numerics Library
QRDecomposition Class
Represents a QR decomposition of a matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class QRDecomposition
Public NotInheritable Class QRDecomposition
public ref class QRDecomposition sealed
[<SealedAttribute>]
type QRDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
QMatrix()()()() | The orthogonal matrix Q.
RMatrix()()()() | The upper-right triangular matrix R.
RowCount | Get the number of rows in the original matrix.
Solve(IList<(Of <<'(Double>)>>)) | Solve the system A x = b.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

A QR decomposition represents a rectangular matrix as the product of a square, orthogonal matrix Q and a rectangular, right-upper-triangular matrix R. For example:

The method QRDecomposition()()()() of the RectangularMatrix class can be used to QR decompose a rectangular matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..QRDecomposition

See Also

Meta.Numerics.Matrices Namespace


QRDecomposition Methods

F#

Meta.Numerics Library
QRDecomposition Methods

The QRDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
QMatrix()()()() | The orthogonal matrix Q.
RMatrix()()()() | The upper-right triangular matrix R.
Solve(IList<(Of <<'(Double>)>>)) | Solve the system A x = b.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition.QMatrix Method

F#

Meta.Numerics Library
QRDecomposition..::QMatrix Method
The orthogonal matrix Q.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix QMatrix()
Public Function QMatrix As SquareMatrix
public:
SquareMatrix^ QMatrix()
member QMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The orthogonal matrix Q.

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition.RMatrix Method

F#

Meta.Numerics Library
QRDecomposition..::RMatrix Method
The upper-right triangular matrix R.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RectangularMatrix RMatrix()
Public Function RMatrix As RectangularMatrix
public:
RectangularMatrix^ RMatrix()
member RMatrix : unit -> RectangularMatrix

Return Value

RectangularMatrix
The upper-right triangular matrix R.

Remarks

The returned matrix is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition.Solve Method

F#

Meta.Numerics Library
QRDecomposition..::Solve Method
Solve the system A x = b.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    IList<double> rhs
)
Public Function Solve (
    rhs As IList(Of Double)
) As ColumnVector
public:
ColumnVector^ Solve(
    IList<double>^ rhs
)
member Solve :
        rhs : IList<float> -> ColumnVector

Parameters

rhs
IList <(Of <(<' Double >)>)>
The right-hand-side b.

Return Value

ColumnVector
The column vector x for which A x is closest to b.

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition Properties

F#

Meta.Numerics Library
QRDecomposition Properties

The QRDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the original matrix.
RowCount | Get the number of rows in the original matrix.

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition.ColumnCount Property

F#

Meta.Numerics Library
QRDecomposition..::ColumnCount Property
Gets the number of columns in the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
property int ColumnCount {
    int get ();
}
member ColumnCount : int with get

Property Value

Int32

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


QRDecomposition.RowCount Property

F#

Meta.Numerics Library
QRDecomposition..::RowCount Property
Get the number of rows in the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
property int RowCount {
    int get ();
}
member RowCount : int with get

Property Value

Int32

See Also

QRDecomposition Class
Meta.Numerics.Matrices Namespace


RealEigensystem Class

F#

| Members | See Also
Meta.Numerics Library
RealEigensystem Class
Represents a collection of real eigenvalues and eigenvectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class RealEigensystem
Public NotInheritable Class RealEigensystem
public ref class RealEigensystem sealed
[<SealedAttribute>]
type RealEigensystem =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the eigensystem.
Eigenvalue(Int32) | Gets a specified eigenvalue.
Eigenvector(Int32) | Gets a specified eigenvector.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TransformMatrix | Gets the transformation matrix that diagonalizes the original matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..RealEigensystem

See Also

Meta.Numerics.Matrices Namespace


RealEigensystem Methods

F#

Meta.Numerics Library
RealEigensystem Methods

The RealEigensystem type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Eigenvalue(Int32) | Gets a specified eigenvalue.
Eigenvector(Int32) | Gets a specified eigenvector.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RealEigensystem.Eigenvalue Method

F#

Meta.Numerics Library
RealEigensystem..::Eigenvalue Method
Gets a specified eigenvalue.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Eigenvalue(
    int n
)
Public Function Eigenvalue (
    n As Integer
) As Double
public:
double Eigenvalue(
    int n
)
member Eigenvalue :
        n : int -> float

Parameters

n
Int32
The (zero-based) index of the eigenvalue.

Return Value

Double
The nth eigenvalue.

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RealEigensystem.Eigenvector Method

F#

Meta.Numerics Library
RealEigensystem..::Eigenvector Method
Gets a specified eigenvector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Eigenvector(
    int n
)
Public Function Eigenvector (
    n As Integer
) As ColumnVector
public:
ColumnVector^ Eigenvector(
    int n
)
member Eigenvector :
        n : int -> ColumnVector

Parameters

n
Int32
The (zero-based) index of the eigenvector.

Return Value

ColumnVector
The nth eigenvector.

Remarks

The returned vector is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RealEigensystem Properties

F#

Meta.Numerics Library
RealEigensystem Properties

The RealEigensystem type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the eigensystem.
TransformMatrix | Gets the transformation matrix that diagonalizes the original matrix.

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RealEigensystem.Dimension Property

F#

Meta.Numerics Library
RealEigensystem..::Dimension Property
Gets the dimension of the eigensystem.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RealEigensystem.TransformMatrix Property

F#

Meta.Numerics Library
RealEigensystem..::TransformMatrix Property
Gets the transformation matrix that diagonalizes the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix TransformMatrix { get; }
Public ReadOnly Property TransformMatrix As SquareMatrix
    Get
public:
property SquareMatrix^ TransformMatrix {
    SquareMatrix^ get ();
}
member TransformMatrix : SquareMatrix with get

Property Value

SquareMatrix
The orthogonal matrix V such that VTAV = D, where A is the orignal matrix and D is diagonal.

Remarks

The returned matrix is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

See Also

RealEigensystem Class
Meta.Numerics.Matrices Namespace


RectangularMatrix Class

F#

| Members | See Also
Meta.Numerics Library
RectangularMatrix Class
A rectangular matrix of real numbers.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class RectangularMatrix : AnyRectangularMatrix
Public NotInheritable Class RectangularMatrix
    Inherits AnyRectangularMatrix
public ref class RectangularMatrix sealed : public AnyRectangularMatrix
[<SealedAttribute>]
type RectangularMatrix =
    class
        inherit AnyRectangularMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RectangularMatrix(array<Double,2>[,](,)[,][,]) | Initializes a rectangular matrix from the given 2D array.
RectangularMatrix(Int32, Int32) | Initializes a rectangular matrix with the given dimensions.
Addition(RectangularMatrix, RectangularMatrix) | Adds two real, rectangular matrices.
Column(Int32) | Gets a copy of the specified column. (Overrides AnyRectangularMatrix..::..Column(Int32).)
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Copy()()()() | Copies the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
ExplicitNarrowingExplicitExplicitExplicit(RectangularMatrix to SquareMatrix) | Casts a rectangular matrix to a square matrix.
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Overrides AnyRectangularMatrix..::..InfinityNorm()()()().)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
Multiply(Double, RectangularMatrix) | Multiply a real, rectangular matrix by a real constant.
Multiply(RectangularMatrix, ColumnVector) | Computes the product of a rectangular matrix and a column vector.
Multiply(RectangularMatrix, RectangularMatrix) | Multiplies two real, rectangular matrices.
Multiply(RectangularMatrix, Double) | Divides a real, rectangular matrix by a real constant.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Overrides AnyRectangularMatrix..::..OneNorm()()()().)
QRDecomposition()()()() | Computes the QR decomposition of the matrix.
Row(Int32) | Gets a copy of the specified row. (Overrides AnyRectangularMatrix..::..Row(Int32).)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)
SingularValueDecomposition()()()() | Computes the singular value decomposition of the matrix.
Subtraction(RectangularMatrix, RectangularMatrix) | Subtracts two real, rectangular matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the matrix.
UnaryNegation(RectangularMatrix) | Negates a real, rectangular matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..RectangularMatrix

See Also

Meta.Numerics.Matrices Namespace


RectangularMatrix Constructor

F#

Meta.Numerics Library
RectangularMatrix Constructor

Overload List

Name | Description
RectangularMatrix(array<Double,2>[,](,)[,][,]) | Initializes a rectangular matrix from the given 2D array.
RectangularMatrix(Int32, Int32) | Initializes a rectangular matrix with the given dimensions.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix Constructor (Double[,])

F#

Meta.Numerics Library
RectangularMatrix Constructor (array<Double,2>[,](,)[,][,])
Initializes a rectangular matrix from the given 2D array.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RectangularMatrix(
    double[,] source
)
Public Sub New (
    source As Double(,)
)
public:
RectangularMatrix(
    array<double,2>^ source
)
new :
        source : float[,] -> RectangularMatrix

Parameters

source
array< Double ,2>[,](,)[,][,]
The source 2D array.

See Also

RectangularMatrix Class
RectangularMatrix Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix Constructor (Int32, Int32)

F#

Meta.Numerics Library
RectangularMatrix Constructor (Int32, Int32)
Initializes a rectangular matrix with the given dimensions.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RectangularMatrix(
    int rowCount,
    int columnCount
)
Public Sub New (
    rowCount As Integer,
    columnCount As Integer
)
public:
RectangularMatrix(
    int rowCount,
    int columnCount
)
new :
        rowCount : int *
        columnCount : int -> RectangularMatrix

Parameters

rowCount
Int32
The number of rows.
columnCount
Int32
The number of columns.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | rowCount or columnCount is less than one.

See Also

RectangularMatrix Class
RectangularMatrix Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix Methods

F#

Meta.Numerics Library
RectangularMatrix Methods

The RectangularMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Overrides AnyRectangularMatrix..::..Column(Int32).)
Copy()()()() | Copies the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Overrides AnyRectangularMatrix..::..InfinityNorm()()()().)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Overrides AnyRectangularMatrix..::..OneNorm()()()().)
QRDecomposition()()()() | Computes the QR decomposition of the matrix.
Row(Int32) | Gets a copy of the specified row. (Overrides AnyRectangularMatrix..::..Row(Int32).)
SingularValueDecomposition()()()() | Computes the singular value decomposition of the matrix.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the matrix.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Column Method

F#

Meta.Numerics Library
RectangularMatrix..::Column Method
Gets a copy of the specified column.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override ColumnVector Column(
    int c
)
Public Overrides Function Column (
    c As Integer
) As ColumnVector
public:
virtual ColumnVector^ Column(
    int c
) override
abstract Column :
        c : int -> ColumnVector
override Column :
        c : int -> ColumnVector

Parameters

c
Int32
The (zero-based) column index.

Return Value

ColumnVector
An independent copy of the specified column.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Copy Method

F#

Meta.Numerics Library
RectangularMatrix..::Copy Method
Copies the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RectangularMatrix Copy()
Public Function Copy As RectangularMatrix
public:
RectangularMatrix^ Copy()
member Copy : unit -> RectangularMatrix

Return Value

RectangularMatrix
An indpendent copy of the matrix.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.InfinityNorm Method

F#

Meta.Numerics Library
RectangularMatrix..::InfinityNorm Method
Computes the ∞-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InfinityNorm()
Public Overrides Function InfinityNorm As Double
public:
virtual double InfinityNorm() override
abstract InfinityNorm : unit -> float
override InfinityNorm : unit -> float

Return Value

Double
||M||∞

Remarks

The ∞-norm of a matrix is the largest row sum.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.OneNorm Method

F#

Meta.Numerics Library
RectangularMatrix..::OneNorm Method
Computes the 1-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double OneNorm()
Public Overrides Function OneNorm As Double
public:
virtual double OneNorm() override
abstract OneNorm : unit -> float
override OneNorm : unit -> float

Return Value

Double
||M||1

Remarks

The 1-norm of a matrix is the largest column sum.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.QRDecomposition Method

F#

Meta.Numerics Library
RectangularMatrix..::QRDecomposition Method
Computes the QR decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public QRDecomposition QRDecomposition()
Public Function QRDecomposition As QRDecomposition
public:
QRDecomposition^ QRDecomposition()
member QRDecomposition : unit -> QRDecomposition

Return Value

QRDecomposition
The QR decomposition of the matrix.

Remarks

Only matrices with a number of rows greater than or equal to the number of columns can be QR decomposed. If your matrix has more columns than rows, you can QR decompose its transpose.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace
RectangularMatrix..::..QRDecomposition()()()()


RectangularMatrix.Row Method

F#

Meta.Numerics Library
RectangularMatrix..::Row Method
Gets a copy of the specified row.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override RowVector Row(
    int r
)
Public Overrides Function Row (
    r As Integer
) As RowVector
public:
virtual RowVector^ Row(
    int r
) override
abstract Row :
        r : int -> RowVector
override Row :
        r : int -> RowVector

Parameters

r
Int32
The (zero-based) row index.

Return Value

RowVector
An independent copy of the specified row.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.SingularValueDecomposition Method

F#

Meta.Numerics Library
RectangularMatrix..::SingularValueDecomposition Method
Computes the singular value decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SingularValueDecomposition SingularValueDecomposition()
Public Function SingularValueDecomposition As SingularValueDecomposition
public:
SingularValueDecomposition^ SingularValueDecomposition()
member SingularValueDecomposition : unit -> SingularValueDecomposition

Return Value

SingularValueDecomposition
The SVD of the matrix.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Transpose Method

F#

Meta.Numerics Library
RectangularMatrix..::Transpose Method
Returns the transpose of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RectangularMatrix Transpose()
Public Function Transpose As RectangularMatrix
public:
RectangularMatrix^ Transpose()
member Transpose : unit -> RectangularMatrix

Return Value

RectangularMatrix
MT

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix Operators

F#

Meta.Numerics Library
RectangularMatrix Operators

The RectangularMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(RectangularMatrix, RectangularMatrix) | Adds two real, rectangular matrices.
ExplicitNarrowingExplicitExplicitExplicit(RectangularMatrix to SquareMatrix) | Casts a rectangular matrix to a square matrix.
Multiply(Double, RectangularMatrix) | Multiply a real, rectangular matrix by a real constant.
Multiply(RectangularMatrix, ColumnVector) | Computes the product of a rectangular matrix and a column vector.
Multiply(RectangularMatrix, RectangularMatrix) | Multiplies two real, rectangular matrices.
Multiply(RectangularMatrix, Double) | Divides a real, rectangular matrix by a real constant.
Subtraction(RectangularMatrix, RectangularMatrix) | Subtracts two real, rectangular matrices.
UnaryNegation(RectangularMatrix) | Negates a real, rectangular matrix.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Addition Operator

F#

Meta.Numerics Library
RectangularMatrix..::Addition Operator
Adds two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator +(
    RectangularMatrix A,
    RectangularMatrix B
)
Public Shared Operator + (
    A As RectangularMatrix,
    B As RectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator +(
    RectangularMatrix^ A,
    RectangularMatrix^ B
)
static let inline (+)
        A : RectangularMatrix *
        B : RectangularMatrix  : RectangularMatrix

Parameters

A
RectangularMatrix
The first matrix.
B
RectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The sum matrix A + B.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Explicit Operator

F#

Meta.Numerics Library
RectangularMatrix..::Explicit Operator
Casts a rectangular matrix to a square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static explicit operator SquareMatrix (
    RectangularMatrix A
)
Public Shared Narrowing Operator CType (
    A As RectangularMatrix
) As SquareMatrix
static explicit operator SquareMatrix^ (
    RectangularMatrix^ A
)
F# does not support the declaration of new casting operators.

Parameters

A
RectangularMatrix
The matrix to cast, which must have an equal number of rows and columns.

Return Value

SquareMatrix
A square matrix, not independent of the original matrix.

Remarks

It can occur that the mode of construction of a RectangularMatrix guarantees that it is actually square. For example, if you multiply an N X M rectangular matrix by an M X N rectangular matrix, the result is an N X N square matrix. However, when determining the type of the product, the .NET compiler considers only the types of the multiplicants. Since a RectangularMatrix times a RectangularMatrix yields a RectangularMatrix, it will consider the type of the product to be RetangularMatrix, even though its rows and column dimensions will be equal. You can use this explicit cast to obtain a SquareMatrix type.

Note that the output of the cast is not independent of the original matrix. This makes the cast operation fast, but changes to the resulting SquareMatrix will also change the original RectangularMatrix. To obtain an independent matrix, use the Copy()()()() method.

Exceptions

Exception | Condition
System..::..InvalidCastException | The row and column dimensions of the matrix are not equal.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Multiply Method

F#

Meta.Numerics Library
RectangularMatrix..::Multiply Method

Overload List

Name | Description
Multiply(Double, RectangularMatrix) | Multiply a real, rectangular matrix by a real constant.
Multiply(RectangularMatrix, ColumnVector) | Computes the product of a rectangular matrix and a column vector.
Multiply(RectangularMatrix, RectangularMatrix) | Multiplies two real, rectangular matrices.
Multiply(RectangularMatrix, Double) | Divides a real, rectangular matrix by a real constant.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Multiply Operator (Double, RectangularMatrix)

F#

Meta.Numerics Library
RectangularMatrix..::Multiply Operator (Double, RectangularMatrix)
Multiply a real, rectangular matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator *(
    double alpha,
    RectangularMatrix A
)
Public Shared Operator * (
    alpha As Double,
    A As RectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator *(
    double alpha,
    RectangularMatrix^ A
)
static let inline (*)
        alpha : float *
        A : RectangularMatrix  : RectangularMatrix

Parameters

alpha
Double
The constant.
A
RectangularMatrix
The matrix.

Return Value

RectangularMatrix
The product aA.

See Also

RectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix.Multiply Operator (RectangularMatrix, ColumnVector)

F#

Meta.Numerics Library
RectangularMatrix..::Multiply Operator (RectangularMatrix, ColumnVector)
Computes the product of a rectangular matrix and a column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator *(
    RectangularMatrix A,
    ColumnVector v
)
Public Shared Operator * (
    A As RectangularMatrix,
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator *(
    RectangularMatrix^ A,
    ColumnVector^ v
)
static let inline (*)
        A : RectangularMatrix *
        v : ColumnVector  : ColumnVector

Parameters

A
RectangularMatrix
The matrix.
v
ColumnVector
The column vector.

Return Value

ColumnVector
The column vector Av.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A or v is null.
Meta.Numerics..::..DimensionMismatchException | The column count of A is not the same as the dimension of v.

See Also

RectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix.Multiply Operator (RectangularMatrix, RectangularMatrix)

F#

Meta.Numerics Library
RectangularMatrix..::Multiply Operator (RectangularMatrix, RectangularMatrix)
Multiplies two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator *(
    RectangularMatrix A,
    RectangularMatrix B
)
Public Shared Operator * (
    A As RectangularMatrix,
    B As RectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator *(
    RectangularMatrix^ A,
    RectangularMatrix^ B
)
static let inline (*)
        A : RectangularMatrix *
        B : RectangularMatrix  : RectangularMatrix

Parameters

A
RectangularMatrix
The first matrix.
B
RectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The product matrix AB.

See Also

RectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix.Multiply Operator (RectangularMatrix, Double)

F#

Meta.Numerics Library
RectangularMatrix..::Multiply Operator (RectangularMatrix, Double)
Divides a real, rectangular matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator *(
    RectangularMatrix A,
    double alpha
)
Public Shared Operator * (
    A As RectangularMatrix,
    alpha As Double
) As RectangularMatrix
public:
static RectangularMatrix^ operator *(
    RectangularMatrix^ A,
    double alpha
)
static let inline (*)
        A : RectangularMatrix *
        alpha : float  : RectangularMatrix

Parameters

A
RectangularMatrix
The matrix.
alpha
Double
The constant.

Return Value

RectangularMatrix
The quotient A/a.

See Also

RectangularMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RectangularMatrix.Subtraction Operator

F#

Meta.Numerics Library
RectangularMatrix..::Subtraction Operator
Subtracts two real, rectangular matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator -(
    RectangularMatrix A,
    RectangularMatrix B
)
Public Shared Operator - (
    A As RectangularMatrix,
    B As RectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator -(
    RectangularMatrix^ A,
    RectangularMatrix^ B
)
static let inline (-)
        A : RectangularMatrix *
        B : RectangularMatrix  : RectangularMatrix

Parameters

A
RectangularMatrix
The first matrix.
B
RectangularMatrix
The second matrix.

Return Value

RectangularMatrix
The sum matrix A - B.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.UnaryNegation Operator

F#

Meta.Numerics Library
RectangularMatrix..::UnaryNegation Operator
Negates a real, rectangular matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RectangularMatrix operator -(
    RectangularMatrix A
)
Public Shared Operator - (
    A As RectangularMatrix
) As RectangularMatrix
public:
static RectangularMatrix^ operator -(
    RectangularMatrix^ A
)
static let inline (-)
        A : RectangularMatrix  : RectangularMatrix

Parameters

A
RectangularMatrix
The matrix.

Return Value

RectangularMatrix
The matrix -A.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix Properties

F#

Meta.Numerics Library
RectangularMatrix Properties

The RectangularMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.ColumnCount Property

F#

Meta.Numerics Library
RectangularMatrix..::ColumnCount Property
Gets the number of matrix columns.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Int32

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.Item Property

F#

Meta.Numerics Library
RectangularMatrix..::Item Property
Gets or sets the value of a matrix entry.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

Double
The value of the r,c matrix entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | r or c is outside the valid range.

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RectangularMatrix.RowCount Property

F#

Meta.Numerics Library
RectangularMatrix..::RowCount Property
Gets the number of matrix rows.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () override;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Int32

See Also

RectangularMatrix Class
Meta.Numerics.Matrices Namespace


RowVector Class

F#

| Members | See Also
Meta.Numerics Library
RowVector Class
A row vector of real numbers.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class RowVector : VectorBase
Public NotInheritable Class RowVector
    Inherits VectorBase
public ref class RowVector sealed : public VectorBase
[<SealedAttribute>]
type RowVector =
    class
        inherit VectorBase
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RowVector(IList<(Of <<'(Double>)>>)) | Initializes a new row vector from the given component list.
RowVector(array<Double>[]()[][]) | Initializes a new row vector with the given components.
RowVector(Int32) | Initializes a new row vector with the given dimension.
Addition(RowVector, RowVector) | Computes the sum of two row vectors.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Copy()()()() | Returns a copy of the row vector.
Dimension | Gets the dimension of the vector. (Inherited from VectorBase.)
Division(RowVector, Double) | Divides a row vector by a real, scalar constant.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components. (Inherited from VectorBase.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component. (Inherited from VectorBase.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
Multiply(Double, RowVector) | Multiplies a row vector by a real, scalar constant.
Multiply(RowVector, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a row vector.
Multiply(RowVector, ColumnVector) | Computes the inner (scalar or dot) product of a row and a column vector.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector. (Inherited from VectorBase.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)
Subtraction(RowVector, RowVector) | Computes the difference of two column vectors.
ToArray()()()() | Returns the vector elements in an independent array. (Inherited from VectorBase.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the row vector.
UnaryNegation(RowVector) | Negates a row vector.

Remarks

An N-dimensional row vector is an 1 X N dimensional matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..VectorBase
Meta.Numerics.Matrices..::..RowVector

See Also

Meta.Numerics.Matrices Namespace


RowVector Constructor

F#

Meta.Numerics Library
RowVector Constructor

Overload List

Name | Description
RowVector(IList<(Of <<'(Double>)>>)) | Initializes a new row vector from the given component list.
RowVector(array<Double>[]()[][]) | Initializes a new row vector with the given components.
RowVector(Int32) | Initializes a new row vector with the given dimension.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector Constructor (IList)

F#

Meta.Numerics Library
RowVector Constructor (IList<(Of <(<'Double>)>)>)
Initializes a new row vector from the given component list.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector(
    IList<double> list
)
Public Sub New (
    list As IList(Of Double)
)
public:
RowVector(
    IList<double>^ list
)
new :
        list : IList<float> -> RowVector

Parameters

list
IList <(Of <(<' Double >)>)>
A list of vector components.

See Also

RowVector Class
RowVector Overload
Meta.Numerics.Matrices Namespace


RowVector Constructor (Double[])

F#

Meta.Numerics Library
RowVector Constructor (array<Double>[]()[][])
Initializes a new row vector with the given components.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector(
    params double[] list
)
Public Sub New (
    ParamArray list As Double()
)
public:
RowVector(
    ... array<double>^ list
)
new :
        list : float[] -> RowVector

Parameters

list
array< Double >[]()[][]
A list of vector components.

See Also

RowVector Class
RowVector Overload
Meta.Numerics.Matrices Namespace


RowVector Constructor (Int32)

F#

Meta.Numerics Library
RowVector Constructor (Int32)
Initializes a new row vector with the given dimension.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
RowVector(
    int dimension
)
new :
        dimension : int -> RowVector

Parameters

dimension
Int32
The dimension of the vector, which must be positive.

See Also

RowVector Class
RowVector Overload
Meta.Numerics.Matrices Namespace


RowVector Methods

F#

Meta.Numerics Library
RowVector Methods

The RowVector type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Copy()()()() | Returns a copy of the row vector.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components. (Inherited from VectorBase.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector. (Inherited from VectorBase.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Returns the vector elements in an independent array. (Inherited from VectorBase.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transpose()()()() | Returns the transpose of the row vector.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Copy Method

F#

Meta.Numerics Library
RowVector..::Copy Method
Returns a copy of the row vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector Copy()
Public Function Copy As RowVector
public:
RowVector^ Copy()
member Copy : unit -> RowVector

Return Value

RowVector
An independent copy of the row vector.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Transpose Method

F#

Meta.Numerics Library
RowVector..::Transpose Method
Returns the transpose of the row vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Transpose()
Public Function Transpose As ColumnVector
public:
ColumnVector^ Transpose()
member Transpose : unit -> ColumnVector

Return Value

ColumnVector
An independent column vector with the same components as the row vector.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector Operators

F#

Meta.Numerics Library
RowVector Operators

The RowVector type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(RowVector, RowVector) | Computes the sum of two row vectors.
Division(RowVector, Double) | Divides a row vector by a real, scalar constant.
Multiply(Double, RowVector) | Multiplies a row vector by a real, scalar constant.
Multiply(RowVector, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a row vector.
Multiply(RowVector, ColumnVector) | Computes the inner (scalar or dot) product of a row and a column vector.
Subtraction(RowVector, RowVector) | Computes the difference of two column vectors.
UnaryNegation(RowVector) | Negates a row vector.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Addition Operator

F#

Meta.Numerics Library
RowVector..::Addition Operator
Computes the sum of two row vectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator +(
    RowVector v1,
    RowVector v2
)
Public Shared Operator + (
    v1 As RowVector,
    v2 As RowVector
) As RowVector
public:
static RowVector^ operator +(
    RowVector^ v1,
    RowVector^ v2
)
static let inline (+)
        v1 : RowVector *
        v2 : RowVector  : RowVector

Parameters

v1
RowVector
The first row vector.
v2
RowVector
The second row vector.

Return Value

RowVector
The sum v1 + v2.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Division Operator

F#

Meta.Numerics Library
RowVector..::Division Operator
Divides a row vector by a real, scalar constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator /(
    RowVector v,
    double alpha
)
Public Shared Operator / (
    v As RowVector,
    alpha As Double
) As RowVector
public:
static RowVector^ operator /(
    RowVector^ v,
    double alpha
)
static let inline (/)
        v : RowVector *
        alpha : float  : RowVector

Parameters

v
RowVector
The row vector.
alpha
Double
The real, scalar constant.

Return Value

RowVector
The result.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Multiply Method

F#

Meta.Numerics Library
RowVector..::Multiply Method

Overload List

Name | Description
Multiply(Double, RowVector) | Multiplies a row vector by a real, scalar constant.
Multiply(RowVector, AnyRectangularMatrix) | Multiplies any real, rectangular matrix by a row vector.
Multiply(RowVector, ColumnVector) | Computes the inner (scalar or dot) product of a row and a column vector.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Multiply Operator (Double, RowVector)

F#

Meta.Numerics Library
RowVector..::Multiply Operator (Double, RowVector)
Multiplies a row vector by a real, scalar constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator *(
    double alpha,
    RowVector v
)
Public Shared Operator * (
    alpha As Double,
    v As RowVector
) As RowVector
public:
static RowVector^ operator *(
    double alpha,
    RowVector^ v
)
static let inline (*)
        alpha : float *
        v : RowVector  : RowVector

Parameters

alpha
Double
The real, scalar constant.
v
RowVector
The row vector.

Return Value

RowVector
The product.

See Also

RowVector Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RowVector.Multiply Operator (RowVector, AnyRectangularMatrix)

F#

Meta.Numerics Library
RowVector..::Multiply Operator (RowVector, AnyRectangularMatrix)
Multiplies any real, rectangular matrix by a row vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator *(
    RowVector v,
    AnyRectangularMatrix A
)
Public Shared Operator * (
    v As RowVector,
    A As AnyRectangularMatrix
) As RowVector
public:
static RowVector^ operator *(
    RowVector^ v,
    AnyRectangularMatrix^ A
)
static let inline (*)
        v : RowVector *
        A : AnyRectangularMatrix  : RowVector

Parameters

v
RowVector
The row vector.
A
AnyRectangularMatrix
The matrix.

Return Value

RowVector
The product row vector.

See Also

RowVector Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RowVector.Multiply Operator (RowVector, ColumnVector)

F#

Meta.Numerics Library
RowVector..::Multiply Operator (RowVector, ColumnVector)
Computes the inner (scalar or dot) product of a row and a column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double operator *(
    RowVector v,
    ColumnVector u
)
Public Shared Operator * (
    v As RowVector,
    u As ColumnVector
) As Double
public:
static double operator *(
    RowVector^ v,
    ColumnVector^ u
)
static let inline (*)
        v : RowVector *
        u : ColumnVector  : float

Parameters

v
RowVector
The row vector.
u
ColumnVector
The column vector.

Return Value

Double
The value of the scalar product.

See Also

RowVector Class
Multiply Overload
Meta.Numerics.Matrices Namespace


RowVector.Subtraction Operator

F#

Meta.Numerics Library
RowVector..::Subtraction Operator
Computes the difference of two column vectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator -(
    RowVector v1,
    RowVector v2
)
Public Shared Operator - (
    v1 As RowVector,
    v2 As RowVector
) As RowVector
public:
static RowVector^ operator -(
    RowVector^ v1,
    RowVector^ v2
)
static let inline (-)
        v1 : RowVector *
        v2 : RowVector  : RowVector

Parameters

v1
RowVector
The first column vector.
v2
RowVector
The second column vector.

Return Value

RowVector
The difference v1 - v2.

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.UnaryNegation Operator

F#

Meta.Numerics Library
RowVector..::UnaryNegation Operator
Negates a row vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator -(
    RowVector v
)
Public Shared Operator - (
    v As RowVector
) As RowVector
public:
static RowVector^ operator -(
    RowVector^ v
)
static let inline (-)
        v : RowVector  : RowVector

Parameters

v
RowVector
The row vector.

Return Value

RowVector
-v

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector Properties

F#

Meta.Numerics Library
RowVector Properties

The RowVector type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..ColumnCount.)
Dimension | Gets the dimension of the vector. (Inherited from VectorBase.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component. (Inherited from VectorBase.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..RowCount.)

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.ColumnCount Property

F#

Meta.Numerics Library
RowVector..::ColumnCount Property
Gets the number of matrix columns.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Int32

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Item Property

F#

Meta.Numerics Library
RowVector..::Item Property

Overload List

Name | Description
Item[([( Int32])]) | Gets or sets the specified vector component.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix <(Of <(<' Double >)>)>.Item[([( Int32, Int32])]) .)

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


RowVector.Item Property (Int32, Int32)

F#

Meta.Numerics Library
RowVector..::Item Property (Int32, Int32)
Gets or sets the value of a matrix entry.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

Double
The value of the r,c matrix entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | r or c is outside the valid range.

See Also

RowVector Class
Item Overload
Meta.Numerics.Matrices Namespace


RowVector.RowCount Property

F#

Meta.Numerics Library
RowVector..::RowCount Property
Gets the number of matrix rows.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () override;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Int32

See Also

RowVector Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition Class

F#

| Members | See Also
Meta.Numerics Library
SingularValueDecomposition Class
Stores the singular value decomposition of a matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class SingularValueDecomposition
Public NotInheritable Class SingularValueDecomposition
public ref class SingularValueDecomposition sealed
[<SealedAttribute>]
type SingularValueDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the original matrix.
ConditionNumber | Returns the condition number of the matrix.
Dimension | Gets the number of singular values.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LeftSingularVector(Int32) | Returns the specified left singular vector.
LeftTransformMatrix()()()() | Returns the left transform matrix.
Rank | Computes the rank of the original matrix.
RightSingularVector(Int32) | Returns the specified right singular vector.
RightTransformMatrix()()()() | Returns the right transform matrix.
RowCount | Gets the number of rows in the original matrix.
SingularValue(Int32) | Gets the specificed singular value.
Tolerance | Gets or sets the tolerance with which singular values are distinguished from zero.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

The singular value decomposition of a matrix represents it as a product of a left orthogonal matrix U, a quasi-diagonal Σ matrix, and a right orthogonal matrix V.

Any rectangular matrix has an SVD decomposition. The matrix need not be square. If square, it need not be invertable. The dimensions of the decomposition factors are illustrated in the following diagram.

The elements of the Σ are called the singular values of the original matrix.

Viewing A as a linear operator, the rows of VT (columns of V) form an orthonormal basis for the domain of the operator, while the columns of U form an orthonormal basis for the range of the operator. These rows and columns are called, respectively, the right and left singular vectors of the matrix.

The right singular vectors corresponding to zero singular values span the nullspace of A, that is the set of all x for which Ax = 0. The left singular vectors corresponding to non-zero singular values span the range of A, that is the space into which all Ax fall; the left singular vectors corresponding to zero singular values span the complementary space into which no Ax fall. The total number of non-zero singular values is the rank of A.

The SVD can be used to approximate the action of a high-dimensional matrix operator by a lower-rank one. By keeping only the largest singular values and setting the remaining ones to zero, one obtains a operator that can applied with fewer operations and approximates the properties of the original operator.

Notice that elements in the last columns of U do not contribute to A since they will be multiplied with elements of zero rows of Σ. Many applications use a "thin" or "reduced" form of the SVD, in which the last columns of U and the last rows of Σ are omitted; this makes U not square (and therefore not orthogonal) and Σ square (and diagonal). Since the remaining elements are the same, you can obtain the thin SVD from this object by simply ignoring the irrelevent elements.

Use the SingularValueDecomposition()()()() of the RectangularMatrix class to obtain the SVD of an rectangular matrix, or the corresponding SingularValueDecomposition()()()() method of the SquareMatrix class to obtain the SVD of a square matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..SingularValueDecomposition

See Also

Meta.Numerics.Matrices Namespace


SingularValueDecomposition Methods

F#

Meta.Numerics Library
SingularValueDecomposition Methods

The SingularValueDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LeftSingularVector(Int32) | Returns the specified left singular vector.
LeftTransformMatrix()()()() | Returns the left transform matrix.
RightSingularVector(Int32) | Returns the specified right singular vector.
RightTransformMatrix()()()() | Returns the right transform matrix.
SingularValue(Int32) | Gets the specificed singular value.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.LeftSingularVector Method

F#

Meta.Numerics Library
SingularValueDecomposition..::LeftSingularVector Method
Returns the specified left singular vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector LeftSingularVector(
    int n
)
Public Function LeftSingularVector (
    n As Integer
) As ColumnVector
public:
ColumnVector^ LeftSingularVector(
    int n
)
member LeftSingularVector :
        n : int -> ColumnVector

Parameters

n
Int32
The (zero-based) index.

Return Value

ColumnVector
The nth left singular vector.

Remarks

The returned vector is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n lies outside the range [0, Dimension - 1].

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.LeftTransformMatrix Method

F#

Meta.Numerics Library
SingularValueDecomposition..::LeftTransformMatrix Method
Returns the left transform matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix LeftTransformMatrix()
Public Function LeftTransformMatrix As SquareMatrix
public:
SquareMatrix^ LeftTransformMatrix()
member LeftTransformMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The matrix U, such that A = U S VT.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.RightSingularVector Method

F#

Meta.Numerics Library
SingularValueDecomposition..::RightSingularVector Method
Returns the specified right singular vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector RightSingularVector(
    int n
)
Public Function RightSingularVector (
    n As Integer
) As ColumnVector
public:
ColumnVector^ RightSingularVector(
    int n
)
member RightSingularVector :
        n : int -> ColumnVector

Parameters

n
Int32
The (zero-based) index.

Return Value

ColumnVector
The nth right singular vector.

Remarks

The returned vector is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n lies outside the range [0, Dimension - 1].

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.RightTransformMatrix Method

F#

Meta.Numerics Library
SingularValueDecomposition..::RightTransformMatrix Method
Returns the right transform matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix RightTransformMatrix()
Public Function RightTransformMatrix As SquareMatrix
public:
SquareMatrix^ RightTransformMatrix()
member RightTransformMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The matrix V, such that A = U S VT.

Remarks

The returned matrix is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.SingularValue Method

F#

Meta.Numerics Library
SingularValueDecomposition..::SingularValue Method
Gets the specificed singular value.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double SingularValue(
    int n
)
Public Function SingularValue (
    n As Integer
) As Double
public:
double SingularValue(
    int n
)
member SingularValue :
        n : int -> float

Parameters

n
Int32
The (zero-based) index.

Return Value

Double
The nth singular value.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n lies outside the range [0, Dimension - 1].

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition Properties

F#

Meta.Numerics Library
SingularValueDecomposition Properties

The SingularValueDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the original matrix.
ConditionNumber | Returns the condition number of the matrix.
Dimension | Gets the number of singular values.
Rank | Computes the rank of the original matrix.
RowCount | Gets the number of rows in the original matrix.
Tolerance | Gets or sets the tolerance with which singular values are distinguished from zero.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.ColumnCount Property

F#

Meta.Numerics Library
SingularValueDecomposition..::ColumnCount Property
Gets the number of columns in the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
property int ColumnCount {
    int get ();
}
member ColumnCount : int with get

Property Value

Int32

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.ConditionNumber Property

F#

Meta.Numerics Library
SingularValueDecomposition..::ConditionNumber Property
Returns the condition number of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ConditionNumber { get; }
Public ReadOnly Property ConditionNumber As Double
    Get
public:
property double ConditionNumber {
    double get ();
}
member ConditionNumber : float with get

Property Value

Double

Remarks

The conidition number is the ratio of the largest singular value to smallest singular value. It is therefore always larger than one.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.Dimension Property

F#

Meta.Numerics Library
SingularValueDecomposition..::Dimension Property
Gets the number of singular values.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

Remarks

For a square matrix, the number of singular values is equal to the dimension of the matrix. For a rectangular matrix with more rows than columns, the number of singular values is equal to the number of columns.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.Rank Property

F#

Meta.Numerics Library
SingularValueDecomposition..::Rank Property
Computes the rank of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Rank { get; }
Public ReadOnly Property Rank As Integer
    Get
public:
property int Rank {
    int get ();
}
member Rank : int with get

Property Value

Int32

Remarks

The rank of a matrix is the dimension of the space of input vectors which produce non-zero output vectors upon multiplication by the original matrix.

Since this operation depends on identifying zero singular values, the result will depend on the value of the Tolerance property.

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.RowCount Property

F#

Meta.Numerics Library
SingularValueDecomposition..::RowCount Property
Gets the number of rows in the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
property int RowCount {
    int get ();
}
member RowCount : int with get

Property Value

Int32

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SingularValueDecomposition.Tolerance Property

F#

Meta.Numerics Library
SingularValueDecomposition..::Tolerance Property
Gets or sets the tolerance with which singular values are distinguished from zero.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set
public:
property double Tolerance {
    double get ();
    void set (double value);
}
member Tolerance : float with get, set

Property Value

Double

Remarks

Some operations offered by singular value decompositions, including rank determination and computation of the pseudo-inverse matrix, depend on determining whether or not a singular value is zero. Since floating point numbers are only approximate representations of real numbers, singular values will usually not be exactly zero even for matrices for which they should be, but will instead be very tiny numbers, on the order of floating point precision (about 10-16) as a fraction of the largest singular value. The value of this property is used to determine how small a singular value must be, as a fraction of the largest singular value, to be considered zero for these purposes. Usually you will want to maintain its default value.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The assigned value is outside the range [0,1).

See Also

SingularValueDecomposition Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix Class

F#

| Members | See Also
Meta.Numerics Library
SparseSquareMatrix Class
Represents a sparse, square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class SparseSquareMatrix : AnySquareMatrix
Public NotInheritable Class SparseSquareMatrix
    Inherits AnySquareMatrix
public ref class SparseSquareMatrix sealed : public AnySquareMatrix
[<SealedAttribute>]
type SparseSquareMatrix =
    class
        inherit AnySquareMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SparseSquareMatrix(Int32) | Initializes a new sparse, square matrix.
Column(Int32) | Gets a copy of the specified column. (Overrides AnyRectangularMatrix..::..Column(Int32).)
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Copy()()()() | Copies the matrix.
Dimension | Gets or sets the dimension of the square matrix. (Overrides AnySquareMatrix..::..Dimension.)
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FillCount | Gets the number of non-zero matrix entries.
FillFraction | Gets the fraction of matrix entries that are non-zero.
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
Multiply(Double, SparseSquareMatrix) | Multiplies a sparse matrix by a real scalar.
Multiply(RowVector, SparseSquareMatrix) | Multiplies a sparse matrix by a row vector.
Multiply(SparseSquareMatrix, ColumnVector) | Multiplies a column vector by a sparse matrix.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Overrides AnyRectangularMatrix..::..Row(Int32).)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)
Solve(ColumnVector) | Solves Ax = b using iterative methods.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)

Remarks

Many applications give rise to very large matrices which consist mostly of zero elements.

When working with sparse matrices, it is important to keep in mind that many operations do not respect sparsity. For example, the product of two sparse matrices is not necessarily sparse, nor is the inverse of a sparse matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..SparseSquareMatrix

See Also

Meta.Numerics.Matrices Namespace


SparseSquareMatrix Constructor

F#

Meta.Numerics Library
SparseSquareMatrix Constructor
Initializes a new sparse, square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SparseSquareMatrix(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
SparseSquareMatrix(
    int dimension
)
new :
        dimension : int -> SparseSquareMatrix

Parameters

dimension
Int32
The dimension of the matrix, which must be positive.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix Methods

F#

Meta.Numerics Library
SparseSquareMatrix Methods

The SparseSquareMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Overrides AnyRectangularMatrix..::..Column(Int32).)
Copy()()()() | Copies the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Overrides AnyRectangularMatrix..::..Row(Int32).)
Solve(ColumnVector) | Solves Ax = b using iterative methods.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Column Method

F#

Meta.Numerics Library
SparseSquareMatrix..::Column Method
Gets a copy of the specified column.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override ColumnVector Column(
    int c
)
Public Overrides Function Column (
    c As Integer
) As ColumnVector
public:
virtual ColumnVector^ Column(
    int c
) override
abstract Column :
        c : int -> ColumnVector
override Column :
        c : int -> ColumnVector

Parameters

c
Int32
The (zero-based) column index.

Return Value

ColumnVector
An independent copy of the specified column.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Copy Method

F#

Meta.Numerics Library
SparseSquareMatrix..::Copy Method
Copies the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SparseSquareMatrix Copy()
Public Function Copy As SparseSquareMatrix
public:
SparseSquareMatrix^ Copy()
member Copy : unit -> SparseSquareMatrix

Return Value

SparseSquareMatrix
An independent copy of the matrix.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Row Method

F#

Meta.Numerics Library
SparseSquareMatrix..::Row Method
Gets a copy of the specified row.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override RowVector Row(
    int r
)
Public Overrides Function Row (
    r As Integer
) As RowVector
public:
virtual RowVector^ Row(
    int r
) override
abstract Row :
        r : int -> RowVector
override Row :
        r : int -> RowVector

Parameters

r
Int32
The (zero-based) row index.

Return Value

RowVector
An independent copy of the specified row.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Solve Method

F#

Meta.Numerics Library
SparseSquareMatrix..::Solve Method
Solves Ax = b using iterative methods.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    ColumnVector rhs
)
Public Function Solve (
    rhs As ColumnVector
) As ColumnVector
public:
ColumnVector^ Solve(
    ColumnVector^ rhs
)
member Solve :
        rhs : ColumnVector -> ColumnVector

Parameters

rhs
ColumnVector
The right-hand side vector b.

Return Value

ColumnVector
The solution vector x.

Remarks

In general, neither the inverse nor any decomposition of a sparse matrix is itself sparse. Therefore, to solve large, sparse linear systems, iterative methods are employed. An iterative method begins with an approximate or guessed solution vector and progresses toward an improved solution. Iterative methods are often successful at converging to a sufficiently accurate solution vector, but this is not guaranteed. If this method fails to converge, it throws a NonconvergenceException.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rhs is null.
Meta.Numerics..::..DimensionMismatchException | rhs's dimension does not equal the matrix's dimension.
Meta.Numerics..::..NonconvergenceException | The method did not converge to a solution.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix Operators

F#

Meta.Numerics Library
SparseSquareMatrix Operators

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Multiply(Double, SparseSquareMatrix) | Multiplies a sparse matrix by a real scalar.
Multiply(RowVector, SparseSquareMatrix) | Multiplies a sparse matrix by a row vector.
Multiply(SparseSquareMatrix, ColumnVector) | Multiplies a column vector by a sparse matrix.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Multiply Method

F#

Meta.Numerics Library
SparseSquareMatrix..::Multiply Method

Overload List

Name | Description
Multiply(Double, SparseSquareMatrix) | Multiplies a sparse matrix by a real scalar.
Multiply(RowVector, SparseSquareMatrix) | Multiplies a sparse matrix by a row vector.
Multiply(SparseSquareMatrix, ColumnVector) | Multiplies a column vector by a sparse matrix.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Multiply Operator (Double, SparseSquareMatrix)

F#

Meta.Numerics Library
SparseSquareMatrix..::Multiply Operator (Double, SparseSquareMatrix)
Multiplies a sparse matrix by a real scalar.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SparseSquareMatrix operator *(
    double alpha,
    SparseSquareMatrix A
)
Public Shared Operator * (
    alpha As Double,
    A As SparseSquareMatrix
) As SparseSquareMatrix
public:
static SparseSquareMatrix^ operator *(
    double alpha,
    SparseSquareMatrix^ A
)
static let inline (*)
        alpha : float *
        A : SparseSquareMatrix  : SparseSquareMatrix

Parameters

alpha
Double
The scalar value.
A
SparseSquareMatrix
The sparse matrix.

Return Value

SparseSquareMatrix
The product sparse matrix.

See Also

SparseSquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Multiply Operator (RowVector, SparseSquareMatrix)

F#

Meta.Numerics Library
SparseSquareMatrix..::Multiply Operator (RowVector, SparseSquareMatrix)
Multiplies a sparse matrix by a row vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static RowVector operator *(
    RowVector v,
    SparseSquareMatrix A
)
Public Shared Operator * (
    v As RowVector,
    A As SparseSquareMatrix
) As RowVector
public:
static RowVector^ operator *(
    RowVector^ v,
    SparseSquareMatrix^ A
)
static let inline (*)
        v : RowVector *
        A : SparseSquareMatrix  : RowVector

Parameters

v
RowVector
The row vector.
A
SparseSquareMatrix
The matrix.

Return Value

RowVector
The product row vector.

See Also

SparseSquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Multiply Operator (SparseSquareMatrix, ColumnVector)

F#

Meta.Numerics Library
SparseSquareMatrix..::Multiply Operator (SparseSquareMatrix, ColumnVector)
Multiplies a column vector by a sparse matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator *(
    SparseSquareMatrix A,
    ColumnVector v
)
Public Shared Operator * (
    A As SparseSquareMatrix,
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator *(
    SparseSquareMatrix^ A,
    ColumnVector^ v
)
static let inline (*)
        A : SparseSquareMatrix *
        v : ColumnVector  : ColumnVector

Parameters

A
SparseSquareMatrix
The matrix.
v
ColumnVector
The column vector.

Return Value

ColumnVector
The product column vector.

See Also

SparseSquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SparseSquareMatrix Properties

F#

Meta.Numerics Library
SparseSquareMatrix Properties

The SparseSquareMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Dimension | Gets or sets the dimension of the square matrix. (Overrides AnySquareMatrix..::..Dimension.)
FillCount | Gets the number of non-zero matrix entries.
FillFraction | Gets the fraction of matrix entries that are non-zero.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Dimension Property

F#

Meta.Numerics Library
SparseSquareMatrix..::Dimension Property
Gets or sets the dimension of the square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Dimension { get; }
Public Overrides ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () override;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Int32

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.FillCount Property

F#

Meta.Numerics Library
SparseSquareMatrix..::FillCount Property
Gets the number of non-zero matrix entries.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int FillCount { get; }
Public ReadOnly Property FillCount As Integer
    Get
public:
property int FillCount {
    int get ();
}
member FillCount : int with get

Property Value

Int32

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.FillFraction Property

F#

Meta.Numerics Library
SparseSquareMatrix..::FillFraction Property
Gets the fraction of matrix entries that are non-zero.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double FillFraction { get; }
Public ReadOnly Property FillFraction As Double
    Get
public:
property double FillFraction {
    double get ();
}
member FillFraction : float with get

Property Value

Double

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SparseSquareMatrix.Item Property

F#

Meta.Numerics Library
SparseSquareMatrix..::Item Property
Gets or sets the value of a matrix entry.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

Double
The value of the r,c matrix entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | r or c is outside the valid range.

See Also

SparseSquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix Class

F#

| Members | See Also
Meta.Numerics Library
SquareMatrix Class
Represents a square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class SquareMatrix : AnySquareMatrix
Public NotInheritable Class SquareMatrix
    Inherits AnySquareMatrix
public ref class SquareMatrix sealed : public AnySquareMatrix
[<SealedAttribute>]
type SquareMatrix =
    class
        inherit AnySquareMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SquareMatrix(array<Double,2>[,](,)[,][,]) | Initializes a new square matrix from the given 2D array.
SquareMatrix(Int32) | Initializes a new square matrix.
Addition(SquareMatrix, SquareMatrix) | Adds two real, square matrices.
Column(Int32) | Gets a copy of one column of the the matrix. (Overrides AnyRectangularMatrix..::..Column(Int32).)
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Copy()()()() | Copies the matrix.
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
Eigensystem()()()() | Computes the eigenvalues and eigenvectors of the matrix.
Eigenvalues()()()() | Computes the eigenvalues of the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Overrides AnyRectangularMatrix..::..InfinityNorm()()()().)
Inverse()()()() | Computes the inverse of the matrix.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets an entry of the matrix. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
LUDecomposition()()()() | Computes the LU decomposition of the matrix.
Multiply(Double, SquareMatrix) | Multiply a real, square matrix by a real constant.
Multiply(SquareMatrix, ColumnVector) | Computes the product of a square matrix and a column vector.
Multiply(SquareMatrix, SquareMatrix) | Computes the product of two square matrices.
Multiply(SquareMatrix, Double) | Divides a real, square matrix by a real constant.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Overrides AnyRectangularMatrix..::..OneNorm()()()().)
Power(Int32) | Computes the matrix raised to the given power.
QRDecomposition()()()() | Computes a QR decomposition of the matrix.
Row(Int32) | Returns a vector representing a given row of the matrix. (Overrides AnyRectangularMatrix..::..Row(Int32).)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)
SingularValueDecomposition()()()() | Computes the singular value decomposition of the square matrix.
Subtraction(SquareMatrix, SquareMatrix) | Computes the difference of two square matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)
Transpose()()()() | Creates a transpose of the matrix.
UnaryNegation(SquareMatrix) | Negates a real, square matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..SquareMatrix

See Also

Meta.Numerics.Matrices Namespace


SquareMatrix Constructor

F#

Meta.Numerics Library
SquareMatrix Constructor

Overload List

Name | Description
SquareMatrix(array<Double,2>[,](,)[,][,]) | Initializes a new square matrix from the given 2D array.
SquareMatrix(Int32) | Initializes a new square matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix Constructor (Double[,])

F#

Meta.Numerics Library
SquareMatrix Constructor (array<Double,2>[,](,)[,][,])
Initializes a new square matrix from the given 2D array.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix(
    double[,] entries
)
Public Sub New (
    entries As Double(,)
)
public:
SquareMatrix(
    array<double,2>^ entries
)
new :
        entries : float[,] -> SquareMatrix

Parameters

entries
array< Double ,2>[,](,)[,][,]
The source 2D array.

Exceptions

Exception | Condition
System..::..ArgumentNullException | entries is null.
Meta.Numerics..::..DimensionMismatchException | The first and second dimensions of entries are not equal.

See Also

SquareMatrix Class
SquareMatrix Overload
Meta.Numerics.Matrices Namespace


SquareMatrix Constructor (Int32)

F#

Meta.Numerics Library
SquareMatrix Constructor (Int32)
Initializes a new square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
SquareMatrix(
    int dimension
)
new :
        dimension : int -> SquareMatrix

Parameters

dimension
Int32
The dimension of the matrix, which must be positive.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | Thrown when dimension < 1.

See Also

SquareMatrix Class
SquareMatrix Overload
Meta.Numerics.Matrices Namespace


SquareMatrix Methods

F#

Meta.Numerics Library
SquareMatrix Methods

The SquareMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of one column of the the matrix. (Overrides AnyRectangularMatrix..::..Column(Int32).)
Copy()()()() | Copies the matrix.
Eigensystem()()()() | Computes the eigenvalues and eigenvectors of the matrix.
Eigenvalues()()()() | Computes the eigenvalues of the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Overrides AnyRectangularMatrix..::..InfinityNorm()()()().)
Inverse()()()() | Computes the inverse of the matrix.
LUDecomposition()()()() | Computes the LU decomposition of the matrix.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Overrides AnyRectangularMatrix..::..OneNorm()()()().)
Power(Int32) | Computes the matrix raised to the given power.
QRDecomposition()()()() | Computes a QR decomposition of the matrix.
Row(Int32) | Returns a vector representing a given row of the matrix. (Overrides AnyRectangularMatrix..::..Row(Int32).)
SingularValueDecomposition()()()() | Computes the singular value decomposition of the square matrix.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)
Transpose()()()() | Creates a transpose of the matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Column Method

F#

Meta.Numerics Library
SquareMatrix..::Column Method
Gets a copy of one column of the the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override ColumnVector Column(
    int c
)
Public Overrides Function Column (
    c As Integer
) As ColumnVector
public:
virtual ColumnVector^ Column(
    int c
) override
abstract Column :
        c : int -> ColumnVector
override Column :
        c : int -> ColumnVector

Parameters

c
Int32
The (zero-based) column number to return.

Return Value

ColumnVector
An independent copy of the specificed column.

Remarks

The returned vector is not linked to the matrix. If an entry in the matrix is updated after this method is called, the returned object will continue to represent a row of the original, not the updated, matrix. Similiarly, updates to the elements of the returned vector will not update the original matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Copy Method

F#

Meta.Numerics Library
SquareMatrix..::Copy Method
Copies the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Copy()
Public Function Copy As SquareMatrix
public:
SquareMatrix^ Copy()
member Copy : unit -> SquareMatrix

Return Value

SquareMatrix
An independent copy of the matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Eigensystem Method

F#

Meta.Numerics Library
SquareMatrix..::Eigensystem Method
Computes the eigenvalues and eigenvectors of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ComplexEigensystem Eigensystem()
Public Function Eigensystem As ComplexEigensystem
public:
ComplexEigensystem^ Eigensystem()
member Eigensystem : unit -> ComplexEigensystem

Return Value

ComplexEigensystem
A representation of the eigenvalues and eigenvectors of the matrix.

Remarks

For a generic vector v and matrix M, Mv = u will point in some direction with no particular relationship to v. The eigenvectors of a matrix M are vectors z that satisfy Mz = λz, i.e. multiplying an eigenvector by a matrix reproduces the same vector, up to a prortionality constant λ called the eigenvalue.

For v to be an eigenvector of M with eigenvalue λ, (M - λI)z = 0. But for a matrix to anihilate any non-zero vector, that matrix must have determinant, so det(M - λI)=0. For a matrix of order N, this is an equation for the roots of a polynomial of order N. Since an order-N polynomial always has exactly N roots, an order-N matrix always has exactly N eigenvalues.

Since a polynomial with real coefficients can still have complex roots, a real square matrix can nonetheless have complex eigenvalues (and correspondly complex eigenvectors). However, again like the complex roots of a real polynomial, such eigenvalues will always occurs in complex-conjugate pairs.

Although the eigenvalue polynomial ensures that an order-N matrix has N eigenvalues, it can occur that there are not N corresponding independent eigenvectors. A matrix with fewer eigenvectors than eigenvalues is called defective. Like singularity, defectiveness represents a delecate balance between the elements of a matrix that can typically be disturbed by just an infinitesimal perturbation of elements. Because of round-off-error, then, floating-point algorithms cannot reliably identify defective matrices. Instead, this method will return a full set of eigenvectors, but some eigenvectors, corresponding to very nearly equal eigenvalues, will be very nearly parallel.

While a generic square matrix can be defective, many subspecies of square matrices are guaranteed not to be. This includes Markov matrices, orthogonal matrices, and symmetric matrices.

Determining the eigenvalues and eigenvectors of a matrix is an O(N3) operation. If you need only the eigenvalues of a matrix, the Eigenvalues()()()() method is more efficient.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Eigenvalues Method

F#

Meta.Numerics Library
SquareMatrix..::Eigenvalues Method
Computes the eigenvalues of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex[] Eigenvalues()
Public Function Eigenvalues As Complex()
public:
array<Complex>^ Eigenvalues()
member Eigenvalues : unit -> Complex[]

Return Value

array< Complex >[]()[][]
The eigenvalues of the matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace
SquareMatrix..::..Eigensystem()()()()


SquareMatrix.InfinityNorm Method

F#

Meta.Numerics Library
SquareMatrix..::InfinityNorm Method
Computes the ∞-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InfinityNorm()
Public Overrides Function InfinityNorm As Double
public:
virtual double InfinityNorm() override
abstract InfinityNorm : unit -> float
override InfinityNorm : unit -> float

Return Value

Double
||M||∞

Remarks

The ∞-norm of a matrix is the largest row sum.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Inverse Method

F#

Meta.Numerics Library
SquareMatrix..::Inverse Method
Computes the inverse of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Inverse()
Public Function Inverse As SquareMatrix
public:
SquareMatrix^ Inverse()
member Inverse : unit -> SquareMatrix

Return Value

SquareMatrix
The matrix inverse M-1.

Remarks

The inverse of a matrix M is a matrix M-1 such that M-1M = I, whhere I is the identity matrix.

If the matrix is singular, inversion is not possible. In that case, this method will fail with a DivideByZeroException.

The inversion of a matrix is an O(N3) operation.

Exceptions

Exception | Condition
System..::..DivideByZeroException | The matrix is singular.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.LUDecomposition Method

F#

Meta.Numerics Library
SquareMatrix..::LUDecomposition Method
Computes the LU decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public LUDecomposition LUDecomposition()
Public Function LUDecomposition As LUDecomposition
public:
LUDecomposition^ LUDecomposition()
member LUDecomposition : unit -> LUDecomposition

Return Value

LUDecomposition
The LU decomposition of the matrix.

Remarks

The LU decomposition of a matrix M is a set of matrices L, U, and P such that LU = PM, where L is lower-left triangular, U is upper-right triangular, and P is a permutation matrix (so that PM is a row-wise permutation of M).

The LU decomposition of a square matrix is an O(N3) operation.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.OneNorm Method

F#

Meta.Numerics Library
SquareMatrix..::OneNorm Method
Computes the 1-norm of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double OneNorm()
Public Overrides Function OneNorm As Double
public:
virtual double OneNorm() override
abstract OneNorm : unit -> float
override OneNorm : unit -> float

Return Value

Double
||M||1

Remarks

The 1-norm of a matrix is the largest column sum.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Power Method

F#

Meta.Numerics Library
SquareMatrix..::Power Method
Computes the matrix raised to the given power.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Power(
    int n
)
Public Function Power (
    n As Integer
) As SquareMatrix
public:
SquareMatrix^ Power(
    int n
)
member Power :
        n : int -> SquareMatrix

Parameters

n
Int32
The power to which to raise the matrix, which must be positive.

Return Value

SquareMatrix
The matrix An.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.QRDecomposition Method

F#

Meta.Numerics Library
SquareMatrix..::QRDecomposition Method
Computes a QR decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareQRDecomposition QRDecomposition()
Public Function QRDecomposition As SquareQRDecomposition
public:
SquareQRDecomposition^ QRDecomposition()
member QRDecomposition : unit -> SquareQRDecomposition

Return Value

SquareQRDecomposition
A QR decomposition of the matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Row Method

F#

Meta.Numerics Library
SquareMatrix..::Row Method
Returns a vector representing a given row of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override RowVector Row(
    int r
)
Public Overrides Function Row (
    r As Integer
) As RowVector
public:
virtual RowVector^ Row(
    int r
) override
abstract Row :
        r : int -> RowVector
override Row :
        r : int -> RowVector

Parameters

r
Int32
The (zero-based) row number to return.

Return Value

RowVector
An independent copy of the specified row.

Remarks

The returned vector is not linked to the matrix. If an entry in the matrix is updated after this method is called, the returned object will continue to represent a row of the original, not the updated, matrix. Similiarly, updates to the elements of the returned vector will not update the original matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.SingularValueDecomposition Method

F#

Meta.Numerics Library
SquareMatrix..::SingularValueDecomposition Method
Computes the singular value decomposition of the square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SingularValueDecomposition SingularValueDecomposition()
Public Function SingularValueDecomposition As SingularValueDecomposition
public:
SingularValueDecomposition^ SingularValueDecomposition()
member SingularValueDecomposition : unit -> SingularValueDecomposition

Return Value

SingularValueDecomposition
The singular value decomposition of the matrix.

Remarks

Singular value decomposition is an advanced matrix decomposition technique that can be applied to all matrices, including non-square and singular square matrices.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Transpose Method

F#

Meta.Numerics Library
SquareMatrix..::Transpose Method
Creates a transpose of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Transpose()
Public Function Transpose As SquareMatrix
public:
SquareMatrix^ Transpose()
member Transpose : unit -> SquareMatrix

Return Value

SquareMatrix
The matrix transpose MT.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix Operators

F#

Meta.Numerics Library
SquareMatrix Operators

The SquareMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(SquareMatrix, SquareMatrix) | Adds two real, square matrices.
Multiply(Double, SquareMatrix) | Multiply a real, square matrix by a real constant.
Multiply(SquareMatrix, ColumnVector) | Computes the product of a square matrix and a column vector.
Multiply(SquareMatrix, SquareMatrix) | Computes the product of two square matrices.
Multiply(SquareMatrix, Double) | Divides a real, square matrix by a real constant.
Subtraction(SquareMatrix, SquareMatrix) | Computes the difference of two square matrices.
UnaryNegation(SquareMatrix) | Negates a real, square matrix.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Addition Operator

F#

Meta.Numerics Library
SquareMatrix..::Addition Operator
Adds two real, square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator +(
    SquareMatrix A,
    SquareMatrix B
)
Public Shared Operator + (
    A As SquareMatrix,
    B As SquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator +(
    SquareMatrix^ A,
    SquareMatrix^ B
)
static let inline (+)
        A : SquareMatrix *
        B : SquareMatrix  : SquareMatrix

Parameters

A
SquareMatrix
The first matrix.
B
SquareMatrix
The second matrix.

Return Value

SquareMatrix
The sum matrix A + B.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A or B is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of A is not the same as the dimension of B.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Multiply Method

F#

Meta.Numerics Library
SquareMatrix..::Multiply Method

Overload List

Name | Description
Multiply(Double, SquareMatrix) | Multiply a real, square matrix by a real constant.
Multiply(SquareMatrix, ColumnVector) | Computes the product of a square matrix and a column vector.
Multiply(SquareMatrix, SquareMatrix) | Computes the product of two square matrices.
Multiply(SquareMatrix, Double) | Divides a real, square matrix by a real constant.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Multiply Operator (Double, SquareMatrix)

F#

Meta.Numerics Library
SquareMatrix..::Multiply Operator (Double, SquareMatrix)
Multiply a real, square matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator *(
    double alpha,
    SquareMatrix A
)
Public Shared Operator * (
    alpha As Double,
    A As SquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator *(
    double alpha,
    SquareMatrix^ A
)
static let inline (*)
        alpha : float *
        A : SquareMatrix  : SquareMatrix

Parameters

alpha
Double
The constant.
A
SquareMatrix
The matrix.

Return Value

SquareMatrix
The product aA.

See Also

SquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SquareMatrix.Multiply Operator (SquareMatrix, ColumnVector)

F#

Meta.Numerics Library
SquareMatrix..::Multiply Operator (SquareMatrix, ColumnVector)
Computes the product of a square matrix and a column vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static ColumnVector operator *(
    SquareMatrix A,
    ColumnVector v
)
Public Shared Operator * (
    A As SquareMatrix,
    v As ColumnVector
) As ColumnVector
public:
static ColumnVector^ operator *(
    SquareMatrix^ A,
    ColumnVector^ v
)
static let inline (*)
        A : SquareMatrix *
        v : ColumnVector  : ColumnVector

Parameters

A
SquareMatrix
The matrix.
v
ColumnVector
The column vector.

Return Value

ColumnVector
The column vector Av.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A or v is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of A is not the same as the dimension of v.

See Also

SquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SquareMatrix.Multiply Operator (SquareMatrix, SquareMatrix)

F#

Meta.Numerics Library
SquareMatrix..::Multiply Operator (SquareMatrix, SquareMatrix)
Computes the product of two square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator *(
    SquareMatrix A,
    SquareMatrix B
)
Public Shared Operator * (
    A As SquareMatrix,
    B As SquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator *(
    SquareMatrix^ A,
    SquareMatrix^ B
)
static let inline (*)
        A : SquareMatrix *
        B : SquareMatrix  : SquareMatrix

Parameters

A
SquareMatrix
The first matrix.
B
SquareMatrix
The second matrix.

Return Value

SquareMatrix
The product A * B.

Remarks

Note that matrix multiplication is not commutative, i.e. M1*M2 is generally not the same as M2*M1.

Matrix multiplication is an O(N3) process.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A or B is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of A is not the same as the dimension of B.

See Also

SquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SquareMatrix.Multiply Operator (SquareMatrix, Double)

F#

Meta.Numerics Library
SquareMatrix..::Multiply Operator (SquareMatrix, Double)
Divides a real, square matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator *(
    SquareMatrix A,
    double alpha
)
Public Shared Operator * (
    A As SquareMatrix,
    alpha As Double
) As SquareMatrix
public:
static SquareMatrix^ operator *(
    SquareMatrix^ A,
    double alpha
)
static let inline (*)
        A : SquareMatrix *
        alpha : float  : SquareMatrix

Parameters

A
SquareMatrix
The matrix.
alpha
Double
The constant.

Return Value

SquareMatrix
The quotient A/a.

See Also

SquareMatrix Class
Multiply Overload
Meta.Numerics.Matrices Namespace


SquareMatrix.Subtraction Operator

F#

Meta.Numerics Library
SquareMatrix..::Subtraction Operator
Computes the difference of two square matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator -(
    SquareMatrix A,
    SquareMatrix B
)
Public Shared Operator - (
    A As SquareMatrix,
    B As SquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator -(
    SquareMatrix^ A,
    SquareMatrix^ B
)
static let inline (-)
        A : SquareMatrix *
        B : SquareMatrix  : SquareMatrix

Parameters

A
SquareMatrix
The first matrix.
B
SquareMatrix
The second matrix.

Return Value

SquareMatrix
The difference A - B.

Remarks

Matrix subtraction is an O(N2) process.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A or B is null.
Meta.Numerics..::..DimensionMismatchException | The dimension of A is not the same as the dimension of B.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.UnaryNegation Operator

F#

Meta.Numerics Library
SquareMatrix..::UnaryNegation Operator
Negates a real, square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SquareMatrix operator -(
    SquareMatrix A
)
Public Shared Operator - (
    A As SquareMatrix
) As SquareMatrix
public:
static SquareMatrix^ operator -(
    SquareMatrix^ A
)
static let inline (-)
        A : SquareMatrix  : SquareMatrix

Parameters

A
SquareMatrix
The matrix.

Return Value

SquareMatrix
The matrix -A.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A is null.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix Properties

F#

Meta.Numerics Library
SquareMatrix Properties

The SquareMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets an entry of the matrix. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Dimension Property

F#

Meta.Numerics Library
SquareMatrix..::Dimension Property
Gets the dimension of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Dimension { get; }
Public Overrides ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () override;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Int32

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareMatrix.Item Property

F#

Meta.Numerics Library
SquareMatrix..::Item Property
Gets or sets an entry of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row number.
c
Int32
The (zero-based) column number.

Return Value

Double
The value of the specified matrix entry Mr c.

See Also

SquareMatrix Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition Class

F#

| Members | See Also
Meta.Numerics Library
SquareQRDecomposition Class
Represents the QR decomposition of a square matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class SquareQRDecomposition
Public NotInheritable Class SquareQRDecomposition
public ref class SquareQRDecomposition sealed
[<SealedAttribute>]
type SquareQRDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Dimension | Gets the dimension of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
QMatrix()()()() | The orthogonal matrix Q.
RMatrix()()()() | The upper-right triangular matrix R.
Solve(IList<(Of <<'(Double>)>>)) | Solve the system of equations Ax=b, where A is the original matrix.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

A QR decomposition represents a matrix as the product of an orthogonal matrix Q and an upper-right-triangular matrix R.

Like a LU decomposition (LUDecomposition, a QR decomposition can be used to solve systems of equations, or compute a determinant or matrix inverse.

To obtain the QR decomposition of a square matrix, use the QRDecomposition()()()() method of the SquareMatrix class.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..SquareQRDecomposition

See Also

Meta.Numerics.Matrices Namespace


SquareQRDecomposition Methods

F#

Meta.Numerics Library
SquareQRDecomposition Methods

The SquareQRDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
QMatrix()()()() | The orthogonal matrix Q.
RMatrix()()()() | The upper-right triangular matrix R.
Solve(IList<(Of <<'(Double>)>>)) | Solve the system of equations Ax=b, where A is the original matrix.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.Determinant Method

F#

Meta.Numerics Library
SquareQRDecomposition..::Determinant Method
Computes the determinant of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Double
det A

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.Inverse Method

F#

Meta.Numerics Library
SquareQRDecomposition..::Inverse Method
Computes the inverse of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Inverse()
Public Function Inverse As SquareMatrix
public:
SquareMatrix^ Inverse()
member Inverse : unit -> SquareMatrix

Return Value

SquareMatrix
A-1

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.QMatrix Method

F#

Meta.Numerics Library
SquareQRDecomposition..::QMatrix Method
The orthogonal matrix Q.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix QMatrix()
Public Function QMatrix As SquareMatrix
public:
SquareMatrix^ QMatrix()
member QMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The orthogonal matrix Q.

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.RMatrix Method

F#

Meta.Numerics Library
SquareQRDecomposition..::RMatrix Method
The upper-right triangular matrix R.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix RMatrix()
Public Function RMatrix As SquareMatrix
public:
SquareMatrix^ RMatrix()
member RMatrix : unit -> SquareMatrix

Return Value

SquareMatrix
The upper-right triangular matrix R.

Remarks

The returned matrix is read-only. If you need to make changes to it, you can call Copy()()()() to obtain a writable copy.

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.Solve Method

F#

Meta.Numerics Library
SquareQRDecomposition..::Solve Method
Solve the system of equations Ax=b, where A is the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    IList<double> rhs
)
Public Function Solve (
    rhs As IList(Of Double)
) As ColumnVector
public:
ColumnVector^ Solve(
    IList<double>^ rhs
)
member Solve :
        rhs : IList<float> -> ColumnVector

Parameters

rhs
IList <(Of <(<' Double >)>)>
The right-hand-side vector b.

Return Value

ColumnVector
The solution vector x.

Remarks

The components of rhs are not modified.

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition Properties

F#

Meta.Numerics Library
SquareQRDecomposition Properties

The SquareQRDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the original matrix.

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SquareQRDecomposition.Dimension Property

F#

Meta.Numerics Library
SquareQRDecomposition..::Dimension Property
Gets the dimension of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

SquareQRDecomposition Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix Class

F#

| Members | See Also
Meta.Numerics Library
SymmetricMatrix Class
Represents a symmetric matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class SymmetricMatrix : AnySquareMatrix
Public NotInheritable Class SymmetricMatrix
    Inherits AnySquareMatrix
public ref class SymmetricMatrix sealed : public AnySquareMatrix
[<SealedAttribute>]
type SymmetricMatrix =
    class
        inherit AnySquareMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SymmetricMatrix(Int32) | Initializes a new symmetric matrix.
Addition(SymmetricMatrix, SymmetricMatrix) | Adds two symmetric matrices.
CholeskyDecomposition()()()() | Returns the Cholesky decomposition of the matrix.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Copy()()()() | Copies the matrix.
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
Eigensystem()()()() | Computes the eigenvalues and eigenvectors of the matrix.
Eigenvalues()()()() | Computes the eigenvalues of the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, Double>)>>)) | Sets all matrix entries according to a supplied fill function. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Fill(Func<(Of <<'(Int32, Int32, T>)>>)).)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Inverse()()()() | Computes the inverse of the matrix.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets an element of the matrix. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
Multiply(Double, SymmetricMatrix) | Multiplies a symmetric matrix by a real factor.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)
Subtraction(SymmetricMatrix, SymmetricMatrix) | Subtracts two symmetric matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the matrix. (Overrides AnySquareMatrix..::..Trace()()()().)
UnaryNegation(SymmetricMatrix) | Negates a symmetric matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..SymmetricMatrix

See Also

Meta.Numerics.Matrices Namespace


SymmetricMatrix Constructor

F#

Meta.Numerics Library
SymmetricMatrix Constructor
Initializes a new symmetric matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
SymmetricMatrix(
    int dimension
)
new :
        dimension : int -> SymmetricMatrix

Parameters

dimension
Int32
The dimension of the matrix, which must be positive.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix Methods

F#

Meta.Numerics Library
SymmetricMatrix Methods

The SymmetricMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CholeskyDecomposition()()()() | Returns the Cholesky decomposition of the matrix.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Copy()()()() | Copies the matrix.
Eigensystem()()()() | Computes the eigenvalues and eigenvectors of the matrix.
Eigenvalues()()()() | Computes the eigenvalues of the matrix.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, Double>)>>)) | Sets all matrix entries according to a supplied fill function. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Fill(Func<(Of <<'(Int32, Int32, T>)>>)).)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Inverse()()()() | Computes the inverse of the matrix.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the matrix. (Overrides AnySquareMatrix..::..Trace()()()().)

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.CholeskyDecomposition Method

F#

Meta.Numerics Library
SymmetricMatrix..::CholeskyDecomposition Method
Returns the Cholesky decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public CholeskyDecomposition CholeskyDecomposition()
Public Function CholeskyDecomposition As CholeskyDecomposition
public:
CholeskyDecomposition^ CholeskyDecomposition()
member CholeskyDecomposition : unit -> CholeskyDecomposition

Return Value

CholeskyDecomposition
The Cholesky decomposition of the matrix, or null if the matrix is not positive definite.

Remarks

A Cholesky decomposition is a special decomposition that is possible only for positive definite matrices. (A positive definite matrix M has xTMx > 0 for any vector x. Equivilently, M is positive definite if all its eigenvalues are positive.)

The Cholesky decomposition represents M = C CT, where C is lower-left triangular (and thus CT is upper-right triangular. It is basically an LU decomposition where the L and U factors are related by transposition. Since the M is produced by multiplying C "by itself", the matrix C is sometimes call the "square root" of M.

Cholesky decomposition is an O(N3) operation. It is about a factor of two faster than LU decomposition, so it is a faster way to obtain inverses, determinates, etc. if you know that M is positive definite.

The fastest way to test whether your matrix is positive definite is attempt a Cholesky decomposition. If this method returns null, M is not positive definite.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace
Meta.Numerics.Matrices..::..CholeskyDecomposition


SymmetricMatrix.Copy Method

F#

Meta.Numerics Library
SymmetricMatrix..::Copy Method
Copies the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix Copy()
Public Function Copy As SymmetricMatrix
public:
SymmetricMatrix^ Copy()
member Copy : unit -> SymmetricMatrix

Return Value

SymmetricMatrix
An independent copy of the matrix.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Eigensystem Method

F#

Meta.Numerics Library
SymmetricMatrix..::Eigensystem Method
Computes the eigenvalues and eigenvectors of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RealEigensystem Eigensystem()
Public Function Eigensystem As RealEigensystem
public:
RealEigensystem^ Eigensystem()
member Eigensystem : unit -> RealEigensystem

Return Value

RealEigensystem
A representation of the eigenvalues and eigenvectors of the matrix.

Remarks

For a generic vector v and matrix M, Mv = u will point in some direction with no particular relationship to v. The eigenvectors of a matrix M are vectors z that satisfy Mz = λz, i.e. multiplying an eigenvector by a matrix reproduces the same vector, up to a prortionality constant λ called the eigenvalue.

For v to be an eigenvector of M with eigenvalue λ, (M - λI)z = 0. But for a matrix to anihilate any non-zero vector, that matrix must have determinant, so det(M - λI)=0. For a matrix of order N, this is an equation for the roots of a polynomial of order N. Since an order-N polynomial always has exactly N roots, an order-N matrix always has exactly N eigenvalues.

An alternative way of expressing the same relationship is to say that the eigenvalues of a matrix are its diagonal elements when the matrix is expressed in a basis that diagonalizes it. That is, given Z such that Z-1MZ = D, where D is diagonal, the columns of Z are the eigenvectors of M and the diagonal elements of D are the eigenvalues.

Note that the eigenvectors of a matrix are not entirely unique. Given an eigenvector z, any scaled vector αz is an eigenvector with the same eigenvalue, so eigenvectors are at most unique up to a rescaling. If an eigenvalue is degenerate, i.e. there are two or more linearly independent eigenvectors with the same eigenvalue, then any linear combination of the eigenvectors is also an eigenvector with that eigenvalue, and in fact any set of vectors that span the same subspace could be taken as the eigenvector set corresponding to that eigenvalue.

The eigenvectors of a symmetric matrix are always orthogonal and the eigenvalues are always real. The transformation matrix Z is thus orthogonal (Z-1 = ZT).

Finding the eigenvalues and eigenvectors of a symmetric matrix is an O(N3) operation.

If you require only the eigenvalues, not the eigenvectors, of the matrix, the Eigenvalues()()()() method will produce them faster than this method.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Eigenvalues Method

F#

Meta.Numerics Library
SymmetricMatrix..::Eigenvalues Method
Computes the eigenvalues of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double[] Eigenvalues()
Public Function Eigenvalues As Double()
public:
array<double>^ Eigenvalues()
member Eigenvalues : unit -> float[]

Return Value

array< Double >[]()[][]
An array containing the matrix eigenvalues.

Remarks

If you require only the eigenvalues of the matrix, not its eigenvectors, this method will return them faster than the Eigensystem()()()() method. If you do need the eigenvectors as well as the eigenvalues, use the Eigensystem()()()() method instead.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Fill Method

F#

Meta.Numerics Library
SymmetricMatrix..::Fill Method
Sets all matrix entries according to a supplied fill function.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override void Fill(
    Func<int, int, double> f
)
Public Overrides Sub Fill (
    f As Func(Of Integer, Integer, Double)
)
public:
virtual void Fill(
    Func<int, int, double>^ f
) override
abstract Fill :
        f : Func<int, int, float> -> unit
override Fill :
        f : Func<int, int, float> -> unit

Parameters

f
Func <(Of <(<' Int32, Int32, Double >)>)>
The fill function.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Inverse Method

F#

Meta.Numerics Library
SymmetricMatrix..::Inverse Method
Computes the inverse of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix Inverse()
Public Function Inverse As SymmetricMatrix
public:
SymmetricMatrix^ Inverse()
member Inverse : unit -> SymmetricMatrix

Return Value

SymmetricMatrix
The matrix inverse M-1.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Trace Method

F#

Meta.Numerics Library
SymmetricMatrix..::Trace Method
Computes the trace of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Trace()
Public Overrides Function Trace As Double
public:
virtual double Trace() override
abstract Trace : unit -> float
override Trace : unit -> float

Return Value

Double
The trace of the matrix tr(M).

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix Operators

F#

Meta.Numerics Library
SymmetricMatrix Operators

The SymmetricMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(SymmetricMatrix, SymmetricMatrix) | Adds two symmetric matrices.
Multiply(Double, SymmetricMatrix) | Multiplies a symmetric matrix by a real factor.
Subtraction(SymmetricMatrix, SymmetricMatrix) | Subtracts two symmetric matrices.
UnaryNegation(SymmetricMatrix) | Negates a symmetric matrix.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Addition Operator

F#

Meta.Numerics Library
SymmetricMatrix..::Addition Operator
Adds two symmetric matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SymmetricMatrix operator +(
    SymmetricMatrix A,
    SymmetricMatrix B
)
Public Shared Operator + (
    A As SymmetricMatrix,
    B As SymmetricMatrix
) As SymmetricMatrix
public:
static SymmetricMatrix^ operator +(
    SymmetricMatrix^ A,
    SymmetricMatrix^ B
)
static let inline (+)
        A : SymmetricMatrix *
        B : SymmetricMatrix  : SymmetricMatrix

Parameters

A
SymmetricMatrix
The first matrix.
B
SymmetricMatrix
The second matrix.

Return Value

SymmetricMatrix
The sum A + B.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Multiply Operator

F#

Meta.Numerics Library
SymmetricMatrix..::Multiply Operator
Multiplies a symmetric matrix by a real factor.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SymmetricMatrix operator *(
    double alpha,
    SymmetricMatrix A
)
Public Shared Operator * (
    alpha As Double,
    A As SymmetricMatrix
) As SymmetricMatrix
public:
static SymmetricMatrix^ operator *(
    double alpha,
    SymmetricMatrix^ A
)
static let inline (*)
        alpha : float *
        A : SymmetricMatrix  : SymmetricMatrix

Parameters

alpha
Double
The factor.
A
SymmetricMatrix
The matrix.

Return Value

SymmetricMatrix
The product of the matrix and the factor.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Subtraction Operator

F#

Meta.Numerics Library
SymmetricMatrix..::Subtraction Operator
Subtracts two symmetric matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SymmetricMatrix operator -(
    SymmetricMatrix A,
    SymmetricMatrix B
)
Public Shared Operator - (
    A As SymmetricMatrix,
    B As SymmetricMatrix
) As SymmetricMatrix
public:
static SymmetricMatrix^ operator -(
    SymmetricMatrix^ A,
    SymmetricMatrix^ B
)
static let inline (-)
        A : SymmetricMatrix *
        B : SymmetricMatrix  : SymmetricMatrix

Parameters

A
SymmetricMatrix
The first matrix.
B
SymmetricMatrix
The second matrix.

Return Value

SymmetricMatrix
The difference A - B.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.UnaryNegation Operator

F#

Meta.Numerics Library
SymmetricMatrix..::UnaryNegation Operator
Negates a symmetric matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static SymmetricMatrix operator -(
    SymmetricMatrix A
)
Public Shared Operator - (
    A As SymmetricMatrix
) As SymmetricMatrix
public:
static SymmetricMatrix^ operator -(
    SymmetricMatrix^ A
)
static let inline (-)
        A : SymmetricMatrix  : SymmetricMatrix

Parameters

A
SymmetricMatrix
The matrix.

Return Value

SymmetricMatrix
The matrix -A.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix Properties

F#

Meta.Numerics Library
SymmetricMatrix Properties

The SymmetricMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets an element of the matrix. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Dimension Property

F#

Meta.Numerics Library
SymmetricMatrix..::Dimension Property
Gets the dimension of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Dimension { get; }
Public Overrides ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () override;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Int32

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


SymmetricMatrix.Item Property

F#

Meta.Numerics Library
SymmetricMatrix..::Item Property
Gets or sets an element of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row number.
c
Int32
The (zero-based) column number.

Return Value

Double
The value of the specified matrix entry Mr c.

Remarks

The set operation preserves the symmetry of the matrix; when entry Mr c is changed, entry Mc r is updated automatically.

See Also

SymmetricMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition Class

F#

| Members | See Also
Meta.Numerics Library
TridiagonalLUDecomposition Class
Represents the LU decomposition of a tridiagonal matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class TridiagonalLUDecomposition
Public Class TridiagonalLUDecomposition
public ref class TridiagonalLUDecomposition
type TridiagonalLUDecomposition =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Dimension | Gets the dimension of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Solve(IList<(Of <<'(Double>)>>)) | Solves a tridiagonal system of linear equations.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..TridiagonalLUDecomposition

See Also

Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition Methods

F#

Meta.Numerics Library
TridiagonalLUDecomposition Methods

The TridiagonalLUDecomposition type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Determinant()()()() | Computes the determinant of the original matrix.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inverse()()()() | Computes the inverse of the original matrix.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Solve(IList<(Of <<'(Double>)>>)) | Solves a tridiagonal system of linear equations.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition.Determinant Method

F#

Meta.Numerics Library
TridiagonalLUDecomposition..::Determinant Method
Computes the determinant of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Double
The determinant det M.

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition.Inverse Method

F#

Meta.Numerics Library
TridiagonalLUDecomposition..::Inverse Method
Computes the inverse of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SquareMatrix Inverse()
Public Function Inverse As SquareMatrix
public:
SquareMatrix^ Inverse()
member Inverse : unit -> SquareMatrix

Return Value

SquareMatrix
The matrix M-1.

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition.Solve Method

F#

Meta.Numerics Library
TridiagonalLUDecomposition..::Solve Method
Solves a tridiagonal system of linear equations.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Solve(
    IList<double> rhs
)
Public Function Solve (
    rhs As IList(Of Double)
) As ColumnVector
public:
ColumnVector^ Solve(
    IList<double>^ rhs
)
member Solve :
        rhs : IList<float> -> ColumnVector

Parameters

rhs
IList <(Of <(<' Double >)>)>
The right-hand side vector b.

Return Value

ColumnVector
A vector x which satisties Ax = b.

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition Properties

F#

Meta.Numerics Library
TridiagonalLUDecomposition Properties

The TridiagonalLUDecomposition type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dimension | Gets the dimension of the original matrix.

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalLUDecomposition.Dimension Property

F#

Meta.Numerics Library
TridiagonalLUDecomposition..::Dimension Property
Gets the dimension of the original matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

TridiagonalLUDecomposition Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix Class

F#

| Members | See Also
Meta.Numerics Library
TridiagonalMatrix Class
Represents a tridiagonal matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class TridiagonalMatrix : AnySquareMatrix
Public NotInheritable Class TridiagonalMatrix
    Inherits AnySquareMatrix
public ref class TridiagonalMatrix sealed : public AnySquareMatrix
[<SealedAttribute>]
type TridiagonalMatrix =
    class
        inherit AnySquareMatrix
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
TridiagonalMatrix(Int32) | Initializes a new tridiagonal matrix of the given dimension.
Addition(TridiagonalMatrix, TridiagonalMatrix) | Adds two tridiagonal matrices.
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Copy()()()() | Copies the matrix.
Determinant()()()() | Computes the determinant of the matrxi.
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets a matrix element. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
LUDecomposition()()()() | Computes the LU decomposition of the matrix.
Multiply(Double, TridiagonalMatrix) | Multiplies a tridiagonal matrix by a real constant.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)
Subtraction(TridiagonalMatrix, TridiagonalMatrix) | Subtracts two tridiagonal matrices.
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)
Transpose()()()() | Creates a transpose of the matrix.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..AnySquareMatrix
Meta.Numerics.Matrices..::..TridiagonalMatrix

See Also

Meta.Numerics.Matrices Namespace


TridiagonalMatrix Constructor

F#

Meta.Numerics Library
TridiagonalMatrix Constructor
Initializes a new tridiagonal matrix of the given dimension.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TridiagonalMatrix(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
TridiagonalMatrix(
    int dimension
)
new :
        dimension : int -> TridiagonalMatrix

Parameters

dimension
Int32
The dimension of the matrix, which must be positive.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix Methods

F#

Meta.Numerics Library
TridiagonalMatrix Methods

The TridiagonalMatrix type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Copy()()()() | Copies the matrix.
Determinant()()()() | Computes the determinant of the matrxi.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
LUDecomposition()()()() | Computes the LU decomposition of the matrix.
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Copies the matrix into an array. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Trace()()()() | Computes the trace of the square matrix. (Inherited from AnySquareMatrix.)
Transpose()()()() | Creates a transpose of the matrix.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Copy Method

F#

Meta.Numerics Library
TridiagonalMatrix..::Copy Method
Copies the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TridiagonalMatrix Copy()
Public Function Copy As TridiagonalMatrix
public:
TridiagonalMatrix^ Copy()
member Copy : unit -> TridiagonalMatrix

Return Value

TridiagonalMatrix
An independent copy of the matrix.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Determinant Method

F#

Meta.Numerics Library
TridiagonalMatrix..::Determinant Method
Computes the determinant of the matrxi.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Double
The determinant det M.

Remarks

Computing the determinant of a tridiagonal matrix is an O(N) operation.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.LUDecomposition Method

F#

Meta.Numerics Library
TridiagonalMatrix..::LUDecomposition Method
Computes the LU decomposition of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TridiagonalLUDecomposition LUDecomposition()
Public Function LUDecomposition As TridiagonalLUDecomposition
public:
TridiagonalLUDecomposition^ LUDecomposition()
member LUDecomposition : unit -> TridiagonalLUDecomposition

Return Value

TridiagonalLUDecomposition
The LU decomposition of the matrix.

Remarks

Computiong the LU decomposition of a tridiagonal matrix is an O(N) operation.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Transpose Method

F#

Meta.Numerics Library
TridiagonalMatrix..::Transpose Method
Creates a transpose of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TridiagonalMatrix Transpose()
Public Function Transpose As TridiagonalMatrix
public:
TridiagonalMatrix^ Transpose()
member Transpose : unit -> TridiagonalMatrix

Return Value

TridiagonalMatrix
The matrix transpose MT.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix Operators

F#

Meta.Numerics Library
TridiagonalMatrix Operators

The TridiagonalMatrix type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Addition(TridiagonalMatrix, TridiagonalMatrix) | Adds two tridiagonal matrices.
Multiply(Double, TridiagonalMatrix) | Multiplies a tridiagonal matrix by a real constant.
Subtraction(TridiagonalMatrix, TridiagonalMatrix) | Subtracts two tridiagonal matrices.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Addition Operator

F#

Meta.Numerics Library
TridiagonalMatrix..::Addition Operator
Adds two tridiagonal matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TridiagonalMatrix operator +(
    TridiagonalMatrix T1,
    TridiagonalMatrix T2
)
Public Shared Operator + (
    T1 As TridiagonalMatrix,
    T2 As TridiagonalMatrix
) As TridiagonalMatrix
public:
static TridiagonalMatrix^ operator +(
    TridiagonalMatrix^ T1,
    TridiagonalMatrix^ T2
)
static let inline (+)
        T1 : TridiagonalMatrix *
        T2 : TridiagonalMatrix  : TridiagonalMatrix

Parameters

T1
TridiagonalMatrix
The first matrix M1.
T2
TridiagonalMatrix
The first matrix M2.

Return Value

TridiagonalMatrix
The sum M1 + M2.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Multiply Operator

F#

Meta.Numerics Library
TridiagonalMatrix..::Multiply Operator
Multiplies a tridiagonal matrix by a real constant.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TridiagonalMatrix operator *(
    double f,
    TridiagonalMatrix T
)
Public Shared Operator * (
    f As Double,
    T As TridiagonalMatrix
) As TridiagonalMatrix
public:
static TridiagonalMatrix^ operator *(
    double f,
    TridiagonalMatrix^ T
)
static let inline (*)
        f : float *
        T : TridiagonalMatrix  : TridiagonalMatrix

Parameters

f
Double
The constant.
T
TridiagonalMatrix
The matrix.

Return Value

TridiagonalMatrix
The product matrix.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Subtraction Operator

F#

Meta.Numerics Library
TridiagonalMatrix..::Subtraction Operator
Subtracts two tridiagonal matrices.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TridiagonalMatrix operator -(
    TridiagonalMatrix T1,
    TridiagonalMatrix T2
)
Public Shared Operator - (
    T1 As TridiagonalMatrix,
    T2 As TridiagonalMatrix
) As TridiagonalMatrix
public:
static TridiagonalMatrix^ operator -(
    TridiagonalMatrix^ T1,
    TridiagonalMatrix^ T2
)
static let inline (-)
        T1 : TridiagonalMatrix *
        T2 : TridiagonalMatrix  : TridiagonalMatrix

Parameters

T1
TridiagonalMatrix
The first matrix M1.
T2
TridiagonalMatrix
The first matrix M2.

Return Value

TridiagonalMatrix
The difference M1 - M2.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix Properties

F#

Meta.Numerics Library
TridiagonalMatrix Properties

The TridiagonalMatrix type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnySquareMatrix.)
Dimension | Gets the dimension of the matrix. (Overrides AnySquareMatrix..::..Dimension.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32, Int32])]) | Gets or sets a matrix element. (Overrides AnyMatrix<(Of <(<'T>)>)>..::..Item[([( Int32, Int32])]) .)
RowCount | Gets the number of matrix rows. (Inherited from AnySquareMatrix.)

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Dimension Property

F#

Meta.Numerics Library
TridiagonalMatrix..::Dimension Property
Gets the dimension of the matrix.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Dimension { get; }
Public Overrides ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get () override;
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Int32

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


TridiagonalMatrix.Item Property

F#

Meta.Numerics Library
TridiagonalMatrix..::Item Property
Gets or sets a matrix element.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double this[
    int r,
    int c
] { get; set; }
Public Overrides Default Property Item (
    r As Integer,
    c As Integer
) As Double
    Get
    Set
public:
virtual property double default[int r, int c] {
    double get (int r, int c) override;
    void set (int r, int c, double value) override;
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

r
Int32
The (zero-based) row number of the element.
c
Int32
The (zero-based) column number of the element.

Return Value

Double
Mr,c

Remarks

Elements on the tridiagonal strip can be set and gotten normally. Other elements will always have the value zero, and any attempt to set them to a non-zero value will result in an InvalidOperationException.

See Also

TridiagonalMatrix Class
Meta.Numerics.Matrices Namespace


VectorBase Class

F#

| Members | See Also
Meta.Numerics Library
VectorBase Class
Implements functionality shared between row and column vectors.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class VectorBase : AnyRectangularMatrix,
    IList<double>, ICollection<double>, IEnumerable<double>,
    IEnumerable
Public MustInherit Class VectorBase
    Inherits AnyRectangularMatrix
    Implements IList(Of Double), ICollection(Of Double),
    IEnumerable(Of Double), IEnumerable
public ref class VectorBase abstract : public AnyRectangularMatrix,
    IList<double>, ICollection<double>, IEnumerable<double>,
    IEnumerable
[<AbstractClassAttribute>]
type VectorBase =
    class
        inherit AnyRectangularMatrix
        interface IList<float>
        interface ICollection<float>
        interface IEnumerable<float>
        interface IEnumerable
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
ColumnCount | Gets the number of matrix columns. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Dimension | Gets the dimension of the vector.
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components.
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector.
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
RowCount | Gets the number of matrix rows. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
ToArray()()()() | Returns the vector elements in an independent array.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Matrices..::..AnyMatrix <(Of <(<' Double >)>)>
Meta.Numerics.Matrices..::..AnyRectangularMatrix
Meta.Numerics.Matrices..::..VectorBase
Meta.Numerics.Matrices..::..ColumnVector
Meta.Numerics.Matrices..::..RowVector

See Also

Meta.Numerics.Matrices Namespace
Meta.Numerics.Matrices..::..RowVector
Meta.Numerics.Matrices..::..ColumnVector


VectorBase Methods

F#

Meta.Numerics Library
VectorBase Methods

The VectorBase type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Column(Int32) | Gets a copy of the specified column. (Inherited from AnyRectangularMatrix.)
Equals(Object) | Determines whether the given object is an equal matrix. (Inherited from AnyRectangularMatrix.)
Equals(AnyRectangularMatrix) | Determines whether the given matrix equals the current matrix. (Inherited from AnyRectangularMatrix.)
Fill(Func<(Of <<'(Int32, Int32, T>)>>)) | Sets all matrix entries according to a supplied fill function. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrobeniusNorm()()()() | Computes the Frobenius-norm of the matrix. (Inherited from AnyRectangularMatrix.)
GetEnumerator()()()() | Gets an enumerator of the vector components.
GetHashCode()()()() | Not a valid operation. (Inherited from AnyRectangularMatrix.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfinityNorm()()()() | Computes the ∞-norm of the matrix. (Inherited from AnyRectangularMatrix.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MultiplySelfByTranspose()()()() | Computes the product of the matrix and its transpose. (Inherited from AnyRectangularMatrix.)
MultiplyTransposeBySelf()()()() | Computes the product of the matrix's transpose and itself. (Inherited from AnyRectangularMatrix.)
Norm()()()() | Computes the magnitude of the vector.
OneNorm()()()() | Computes the 1-norm of the matrix. (Inherited from AnyRectangularMatrix.)
Row(Int32) | Gets a copy of the specified row. (Inherited from AnyRectangularMatrix.)
ToArray()()()() | Returns the vector elements in an independent array.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.GetEnumerator Method

F#

Meta.Numerics Library
VectorBase..::GetEnumerator Method
Gets an enumerator of the vector components.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public IEnumerator<double> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Double)
public:
virtual IEnumerator<double>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<float>
override GetEnumerator : unit -> IEnumerator<float>

Return Value

IEnumerator <(Of <(<' Double >)>)>
An enumerator of the vector components.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.Norm Method

F#

Meta.Numerics Library
VectorBase..::Norm Method
Computes the magnitude of the vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Norm()
Public Overridable Function Norm As Double
public:
virtual double Norm()
abstract Norm : unit -> float
override Norm : unit -> float

Return Value

Double
The Euclidean norm of the vector.

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.ToArray Method

F#

Meta.Numerics Library
VectorBase..::ToArray Method
Returns the vector elements in an independent array.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double[] ToArray()
Public Overridable Function ToArray As Double()
public:
virtual array<double>^ ToArray()
abstract ToArray : unit -> float[]
override ToArray : unit -> float[]

Return Value

array< Double >[]()[][]
An array containing the vector element values.

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase Properties

F#

Meta.Numerics Library
VectorBase Properties

The VectorBase type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of matrix columns. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Dimension | Gets the dimension of the vector.
IsReadOnly | Gets a flag indicating whether the matrix is read-only. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
Item[([( Int32])]) | Gets or sets the specified vector component.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)
RowCount | Gets the number of matrix rows. (Inherited from AnyMatrix<(Of <(<'T>)>)>.)

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.Dimension Property

F#

Meta.Numerics Library
VectorBase..::Dimension Property
Gets the dimension of the vector.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int Dimension { get; }
Public Overridable ReadOnly Property Dimension As Integer
    Get
public:
virtual property int Dimension {
    int get ();
}
abstract Dimension : int with get
override Dimension : int with get

Property Value

Int32

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.Item Property

F#

Meta.Numerics Library
VectorBase..::Item Property

Overload List

Name | Description
Item[([( Int32])]) | Gets or sets the specified vector component.
Item[([( Int32, Int32])]) | Gets or sets the value of a matrix entry.

See Also

VectorBase Class
Meta.Numerics.Matrices Namespace


VectorBase.Item Property (Int32)

F#

Meta.Numerics Library
VectorBase..::Item Property (Int32)
Gets or sets the specified vector component.

Namespace: Meta.Numerics.Matrices
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As Double
    Get
    Set
public:
virtual property double default[int index] {
    double get (int index);
    void set (int index, double value);
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

index
Int32
The (zero-based) component index.

Return Value

Double
The value of the specified vector component.

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

VectorBase Class
Item Overload
Meta.Numerics.Matrices Namespace


Meta.Numerics.SignalProcessing Namespace

F#

Meta.Numerics Library
Meta.Numerics.SignalProcessing Namespace
Contains types supporting Fourier and related transformation used in signal processing applications.

Types

All Types | Classes | Enumerations
Name | Description
FourierNormalization | Specifies the normalization convention to be used in a forward Fourier transform.
FourierSign | Specifies the sign convention to be used in the exponent of a forward Fourier transform.
FourierTransformer | An engine for performing Fourier transforms on complex series.


FourierNormalization Enumeration

F#

Meta.Numerics Library
FourierNormalization Enumeration
Specifies the normalization convention to be used in a forward Fourier transform.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public enum FourierNormalization
Public Enumeration FourierNormalization
public enum class FourierNormalization
type FourierNormalization

Members

Member | Value | Description
None | 0 | The series is not normalized.
Unitary | 1 | The series is multiplied by 1/N1/2.
Inverse | 2 | The series is multiplied by 1/N.

Remarks

The most common convention in signal processing applications is None.

See Also

Meta.Numerics.SignalProcessing Namespace


FourierSign Enumeration

F#

Meta.Numerics Library
FourierSign Enumeration
Specifies the sign convention to be used in the exponent of a forward Fourier transform.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public enum FourierSign
Public Enumeration FourierSign
public enum class FourierSign
type FourierSign

Members

Member | Value | Description
Positive | 0 | The exponent has positive imaginary values.
Negative | 1 | The exponent has negative imaginary values.

Remarks

The most common convention in signal processing applications is Negative.

See Also

Meta.Numerics.SignalProcessing Namespace


FourierTransformer Class

F#

| Example | Members | See Also
Meta.Numerics Library
FourierTransformer Class
An engine for performing Fourier transforms on complex series.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class FourierTransformer
Public NotInheritable Class FourierTransformer
public ref class FourierTransformer sealed
[<SealedAttribute>]
type FourierTransformer =  class end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FourierTransformer(Int32) | Initializes a new instance of the Fourier transformer.
FourierTransformer(Int32, FourierSign, FourierNormalization) | Initializes a new instance of the Fourier transformer with the given sign and normalization conventions.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseTransform(IList<(Of <<'(Complex>)>>)) | Computes the inverse Fourier transform of the given series.
Length | The series length for which the transformer is specialized.
NormalizationConvention | Gets the normalization convention used by the transformer.
SignConvention | Gets the normalization convention used by the transformer.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transform(IList<(Of <<'(Complex>)>>)) | Computes the Fourier transform of the given series.

Remarks

A Fourier transform decomposes a function into a sum of different frequency components. This is useful for a wide array of applications.

Mathematically, the DFT is an N-dimensional linear transfromation with coefficients that are the Nth complex roots of unity.

An instance of the FourierTransformer class performs DFTs on series of a particular length, given by its Length property. This specialization allows certain parts of the DFT calculation, which are indepdent of the transformed series but dependent on the length of the series, to be performed only once and then re-used for all transforms of that length. This saves time and improves performance. If you need to perform DFTs on series with different lengths, simply create a seperate instance of the FourierTransform class for each required length.

Many simple DFT implementations require that the series length be a power of two (2, 4, 8, 16, etc.). Meta.Numerics supports DFTs of any length. Our DFT implementation is fast -- order O(N log N) -- for all lengths, including lengths that have large prime factors.

Examples

The following code performs a simple DFT and then inverts it to re-obtain the original data.

C# Copy image Copy
// Create a Fourier transformer for length-6 series
FourierTransformer ft = new FourierTransformer(6);
// Create a length-6 series and transform it
Complex[] x = new Complex[] { 0.0, 1.0, 0.0, 0.0, 0.0, 0.0 };
Complex[] xt = ft.Transform(x);
// Re-use the same transformer to transform a different  series
Complex[] y = new Complex[] { 1.0, 1.0, 1.0, 1.0, 1.0, 1.0 };
Complex[] yt = ft.Transform(y);
// Transform them back
Complex[] xtt = ft.InverseTransform(xt);
Complex[] ytt = ft.InverseTransform(yt);

Inheritance Hierarchy

System..::..Object
Meta.Numerics.SignalProcessing..::..FourierTransformer

See Also

Meta.Numerics.SignalProcessing Namespace
http://en.wikipedia.org/wiki/Discrete-time_Fourier_transform


FourierTransformer Constructor

F#

Meta.Numerics Library
FourierTransformer Constructor

Overload List

Name | Description
FourierTransformer(Int32) | Initializes a new instance of the Fourier transformer.
FourierTransformer(Int32, FourierSign, FourierNormalization) | Initializes a new instance of the Fourier transformer with the given sign and normalization conventions.

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer Constructor (Int32)

F#

Meta.Numerics Library
FourierTransformer Constructor (Int32)
Initializes a new instance of the Fourier transformer.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FourierTransformer(
    int size
)
Public Sub New (
    size As Integer
)
public:
FourierTransformer(
    int size
)
new :
        size : int -> FourierTransformer

Parameters

size
Int32
The series length of the transformer, which must be positive.

See Also

FourierTransformer Class
FourierTransformer Overload
Meta.Numerics.SignalProcessing Namespace


FourierTransformer Constructor (Int32, FourierSign, FourierNormalization)

F#

Meta.Numerics Library
FourierTransformer Constructor (Int32, FourierSign, FourierNormalization)
Initializes a new instance of the Fourier transformer with the given sign and normalization conventions.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FourierTransformer(
    int size,
    FourierSign signConvention,
    FourierNormalization normalizationConvention
)
Public Sub New (
    size As Integer,
    signConvention As FourierSign,
    normalizationConvention As FourierNormalization
)
public:
FourierTransformer(
    int size,
    FourierSign signConvention,
    FourierNormalization normalizationConvention
)
new :
        size : int *
        signConvention : FourierSign *
        normalizationConvention : FourierNormalization -> FourierTransformer

Parameters

size
Int32
The series length of the transformer, which must be positive.
signConvention
FourierSign
The sign convention of the transformer.
normalizationConvention
FourierNormalization
The normalization convention of the transformer.

Remarks

There are multiple conventions for both the sign of the exponent and the overall normalization of Fourier transforms. The default conventions for some widely used software packages are summarized in the following table.

Software | Sign | Normalization
Meta.Numerics | Negative | None
Matlab | Negative | None
Mathmatica | Positive | Unitary
Numerical Recipies | Positive | None

See Also

FourierTransformer Class
FourierTransformer Overload
Meta.Numerics.SignalProcessing Namespace


FourierTransformer Methods

F#

Meta.Numerics Library
FourierTransformer Methods

The FourierTransformer type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseTransform(IList<(Of <<'(Complex>)>>)) | Computes the inverse Fourier transform of the given series.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transform(IList<(Of <<'(Complex>)>>)) | Computes the Fourier transform of the given series.

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer.InverseTransform Method

F#

Meta.Numerics Library
FourierTransformer..::InverseTransform Method
Computes the inverse Fourier transform of the given series.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex[] InverseTransform(
    IList<Complex> values
)
Public Function InverseTransform (
    values As IList(Of Complex)
) As Complex()
public:
array<Complex>^ InverseTransform(
    IList<Complex>^ values
)
member InverseTransform :
        values : IList<Complex> -> Complex[]

Parameters

values
IList <(Of <(<' Complex >)>)>
The series to invert.

Return Value

array< Complex >[]()[][]
The inverse discrete Fourier transform of the series.

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer.Transform Method

F#

Meta.Numerics Library
FourierTransformer..::Transform Method
Computes the Fourier transform of the given series.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Complex[] Transform(
    IList<Complex> values
)
Public Function Transform (
    values As IList(Of Complex)
) As Complex()
public:
array<Complex>^ Transform(
    IList<Complex>^ values
)
member Transform :
        values : IList<Complex> -> Complex[]

Parameters

values
IList <(Of <(<' Complex >)>)>
The series to transform.

Return Value

array< Complex >[]()[][]
The discrete Fourier transform of the series.

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer Properties

F#

Meta.Numerics Library
FourierTransformer Properties

The FourierTransformer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Length | The series length for which the transformer is specialized.
NormalizationConvention | Gets the normalization convention used by the transformer.
SignConvention | Gets the normalization convention used by the transformer.

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer.Length Property

F#

Meta.Numerics Library
FourierTransformer..::Length Property
The series length for which the transformer is specialized.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Property Value

Int32

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer.NormalizationConvention Property

F#

Meta.Numerics Library
FourierTransformer..::NormalizationConvention Property
Gets the normalization convention used by the transformer.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FourierNormalization NormalizationConvention { get; }
Public ReadOnly Property NormalizationConvention As FourierNormalization
    Get
public:
property FourierNormalization NormalizationConvention {
    FourierNormalization get ();
}
member NormalizationConvention : FourierNormalization with get

Property Value

FourierNormalization

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


FourierTransformer.SignConvention Property

F#

Meta.Numerics Library
FourierTransformer..::SignConvention Property
Gets the normalization convention used by the transformer.

Namespace: Meta.Numerics.SignalProcessing
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FourierSign SignConvention { get; }
Public ReadOnly Property SignConvention As FourierSign
    Get
public:
property FourierSign SignConvention {
    FourierSign get ();
}
member SignConvention : FourierSign with get

Property Value

FourierSign

See Also

FourierTransformer Class
Meta.Numerics.SignalProcessing Namespace


Meta.Numerics.Statistics Namespace

F#

Meta.Numerics Library
Meta.Numerics.Statistics Namespace
Contains types that store and analyze statistical data.

Types

All Types | Classes | Structures
Name | Description
AnovaRow | A row in an ANOVA table.
AnovaTestRow | A row in an ANOVA table for which an F-test is available.
BinaryContingencyTable | Represents a 2 X 2 contingency table.
BivariateSample | Represents a set of data points, where each data point is described by a pair of real numbers.
ContingencyTable | Represents a contingency table.
FitResult | Represents the result of a fit procedure.
Histogram | Represents a histogram.
HistogramBin | Represents one bin in a histogram.
HistogramBinsCollection | Represents a collection of histogram bins.
InsufficientDataException | The exception that is thrown when an operation is attempted with less than the minimum required data.
MultivariateSample | Represents a multivariate sample.
OneWayAnovaResult | The result of a one-way ANOVA test.
PrincipalComponent | Represents a component of a principal component analysis.
PrincipalComponentAnalysis | Represents a principal component analysis.
Sample | Represents a set of data points, where each data point consists of a single real number.
TestResult | Represents the result of a statistical test.
UncertainMeasurement<(Of <(<'T>)>)> | Represents an experimental data point that is a function of an arbitrary variable.
UncertainMeasurementSample<(Of <(<'T>)>)> | Represents a set of measurements.
UncertainMeasurementSample | Represents a set of UncertainMeasurement<(Of <(<'T>)>)> measurements.


AnovaRow Class

F#

| Members | See Also
Meta.Numerics Library
AnovaRow Class
A row in an ANOVA table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class AnovaRow
Public Class AnovaRow
public ref class AnovaRow
type AnovaRow =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the degrees of freedom associated with the row.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
SumOfSquares | Gets the sum of squares contributed by the row.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

An ANOVA seperates the variance associated with one or more sources into "rows", each of which has an associated sum of square deviations and number of degrees of freedom.

It is used in properties of the OneWayAnovaResult class.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..AnovaRow
Meta.Numerics.Statistics..::..AnovaTestRow

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..OneWayAnovaResult


AnovaRow Methods

F#

Meta.Numerics Library
AnovaRow Methods

The AnovaRow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnovaRow Class
Meta.Numerics.Statistics Namespace


AnovaRow Properties

F#

Meta.Numerics Library
AnovaRow Properties

The AnovaRow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the degrees of freedom associated with the row.
SumOfSquares | Gets the sum of squares contributed by the row.

See Also

AnovaRow Class
Meta.Numerics.Statistics Namespace


AnovaRow.DegreesOfFreedom Property

F#

Meta.Numerics Library
AnovaRow..::DegreesOfFreedom Property
Gets the degrees of freedom associated with the row.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int DegreesOfFreedom { get; }
Public ReadOnly Property DegreesOfFreedom As Integer
    Get
public:
property int DegreesOfFreedom {
    int get ();
}
member DegreesOfFreedom : int with get

Property Value

Int32

See Also

AnovaRow Class
Meta.Numerics.Statistics Namespace


AnovaRow.SumOfSquares Property

F#

Meta.Numerics Library
AnovaRow..::SumOfSquares Property
Gets the sum of squares contributed by the row.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double SumOfSquares { get; }
Public ReadOnly Property SumOfSquares As Double
    Get
public:
property double SumOfSquares {
    double get ();
}
member SumOfSquares : float with get

Property Value

Double

See Also

AnovaRow Class
Meta.Numerics.Statistics Namespace


AnovaTestRow Class

F#

| Members | See Also
Meta.Numerics Library
AnovaTestRow Class
A row in an ANOVA table for which an F-test is available.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class AnovaTestRow : AnovaRow
Public Class AnovaTestRow
    Inherits AnovaRow
public ref class AnovaTestRow : public AnovaRow
type AnovaTestRow =
    class
        inherit AnovaRow
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the degrees of freedom associated with the row. (Inherited from AnovaRow.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Result | Gets the result of an F-test measuring the significance of the row.
SumOfSquares | Gets the sum of squares contributed by the row. (Inherited from AnovaRow.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..AnovaRow
Meta.Numerics.Statistics..::..AnovaTestRow

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..OneWayAnovaResult


AnovaTestRow Methods

F#

Meta.Numerics Library
AnovaTestRow Methods

The AnovaTestRow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnovaTestRow Class
Meta.Numerics.Statistics Namespace


AnovaTestRow Properties

F#

Meta.Numerics Library
AnovaTestRow Properties

The AnovaTestRow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the degrees of freedom associated with the row. (Inherited from AnovaRow.)
Result | Gets the result of an F-test measuring the significance of the row.
SumOfSquares | Gets the sum of squares contributed by the row. (Inherited from AnovaRow.)

See Also

AnovaTestRow Class
Meta.Numerics.Statistics Namespace


AnovaTestRow.Result Property

F#

Meta.Numerics Library
AnovaTestRow..::Result Property
Gets the result of an F-test measuring the significance of the row.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult Result { get; }
Public ReadOnly Property Result As TestResult
    Get
public:
property TestResult^ Result {
    TestResult^ get ();
}
member Result : TestResult with get

Property Value

TestResult

See Also

AnovaTestRow Class
Meta.Numerics.Statistics Namespace


BinaryContingencyTable Class

F#

| Members | See Also
Meta.Numerics Library
BinaryContingencyTable Class
Represents a 2 X 2 contingency table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class BinaryContingencyTable : ContingencyTable
Public Class BinaryContingencyTable
    Inherits ContingencyTable
public ref class BinaryContingencyTable : public ContingencyTable
type BinaryContingencyTable =
    class
        inherit ContingencyTable
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BinaryContingencyTable()()()() | Initializes a new binary contingency table.
BinaryContingencyTable(array<Int32,2>[,](,)[,][,]) | Initializes a new binary contingency table with the given entries.
ColumnCount | Gets the number of columns in the table. (Inherited from ContingencyTable.)
ColumnTotal(Int32) | Gets the total counts in the specified column. (Inherited from ContingencyTable.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FisherExactTest()()()() | Performs a Fisher exact test.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment(Int32, Int32) | Increments the count in the specifed cel. (Inherited from ContingencyTable.)
Item[([( Int32, Int32])]) | Gets or sets the count in the specified cell. (Inherited from ContingencyTable.)
LogOddsRatio | Computes the log of the odds ratio.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Name | Gets or sets the name of the table. (Inherited from ContingencyTable.)
OddsRatio | Computes the odds ratio of table.
PearsonChiSquaredTest()()()() | Performs a Pearson χ2 test for correlation in the table. (Inherited from ContingencyTable.)
Probability(Int32, Int32) | Estimates the probability of the given cell in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfColumn(Int32) | Estimates the marginal probility of the given column in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfColumnConditionalOnRow(Int32, Int32) | Estimates the probability of the given row, conditional on the given column. (Inherited from ContingencyTable.)
ProbabilityOfRow(Int32) | Estimates the marginal probility of the given row in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfRowConditionalOnColumn(Int32, Int32) | Estimates the probability of the given row, conditional on the given column. (Inherited from ContingencyTable.)
RowCount | Gets the number of rows in the table. (Inherited from ContingencyTable.)
RowTotal(Int32) | Gets the total counts in the specified row. (Inherited from ContingencyTable.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Total | Gets the total counts in the table. (Inherited from ContingencyTable.)

Remarks

Binary contingency tables are the most common kind of contingency table. Any experiment with a treatment and a control group, and binary measured outcome, can be represented by a binary contingency table.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..ContingencyTable
Meta.Numerics.Statistics..::..BinaryContingencyTable

See Also

Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Contingency_table


BinaryContingencyTable Constructor

F#

Meta.Numerics Library
BinaryContingencyTable Constructor

Overload List

Name | Description
BinaryContingencyTable()()()() | Initializes a new binary contingency table.
BinaryContingencyTable(array<Int32,2>[,](,)[,][,]) | Initializes a new binary contingency table with the given entries.

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace


BinaryContingencyTable Constructor

F#

Meta.Numerics Library
BinaryContingencyTable Constructor
Initializes a new binary contingency table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BinaryContingencyTable()
Public Sub New
public:
BinaryContingencyTable()
new : unit -> BinaryContingencyTable

See Also

BinaryContingencyTable Class
BinaryContingencyTable Overload
Meta.Numerics.Statistics Namespace


BinaryContingencyTable Constructor (Int32[,])

F#

Meta.Numerics Library
BinaryContingencyTable Constructor (array<Int32,2>[,](,)[,][,])
Initializes a new binary contingency table with the given entries.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BinaryContingencyTable(
    int[,] data
)
Public Sub New (
    data As Integer(,)
)
public:
BinaryContingencyTable(
    array<int,2>^ data
)
new :
        data : int[,] -> BinaryContingencyTable

Parameters

data
array< Int32 ,2>[,](,)[,][,]
A two-dimensional matrix of table entries.

See Also

BinaryContingencyTable Class
BinaryContingencyTable Overload
Meta.Numerics.Statistics Namespace


BinaryContingencyTable Methods

F#

Meta.Numerics Library
BinaryContingencyTable Methods

The BinaryContingencyTable type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnTotal(Int32) | Gets the total counts in the specified column. (Inherited from ContingencyTable.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FisherExactTest()()()() | Performs a Fisher exact test.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment(Int32, Int32) | Increments the count in the specifed cel. (Inherited from ContingencyTable.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
PearsonChiSquaredTest()()()() | Performs a Pearson χ2 test for correlation in the table. (Inherited from ContingencyTable.)
Probability(Int32, Int32) | Estimates the probability of the given cell in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfColumn(Int32) | Estimates the marginal probility of the given column in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfColumnConditionalOnRow(Int32, Int32) | Estimates the probability of the given row, conditional on the given column. (Inherited from ContingencyTable.)
ProbabilityOfRow(Int32) | Estimates the marginal probility of the given row in the underlying population. (Inherited from ContingencyTable.)
ProbabilityOfRowConditionalOnColumn(Int32, Int32) | Estimates the probability of the given row, conditional on the given column. (Inherited from ContingencyTable.)
RowTotal(Int32) | Gets the total counts in the specified row. (Inherited from ContingencyTable.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace


BinaryContingencyTable.FisherExactTest Method

F#

Meta.Numerics Library
BinaryContingencyTable..::FisherExactTest Method
Performs a Fisher exact test.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult FisherExactTest()
Public Function FisherExactTest As TestResult
public:
TestResult^ FisherExactTest()
member FisherExactTest : unit -> TestResult

Return Value

TestResult
The results of the test. The test statistic is the summed probability of all tables exhibiting equal or stronger correlations, and its likelyhood under the null hypothesis is the (left) probability to obtain a smaller value. Note that, in this case, the test statistic itself is the likelyhood.

Remarks

The Fisher exact test tests for correlations between row and column entries. It is a robust, non-parametric test, which, unlike the χ2 test (see PearsonChiSquaredTest()()()()), can safely be used for tables with small, even zero-valued, entries.

The Fisher test computes, under the null hypothesis of no correlation, the exact probability of all 2 X 2 tables with the same row and column totals as the given table. It then sums the probabilities of all tables that are as or less probable than the given table. In this way it determines the total probability of obtaining a 2 X 2 table which is at least as improbable as the given one.

The test is two-sided, i.e. when considering less probable tables it does not distinguish between tables exhibiting the same and the opposite correlation as the given one.

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Fisher_exact_test


BinaryContingencyTable Properties

F#

Meta.Numerics Library
BinaryContingencyTable Properties

The BinaryContingencyTable type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the table. (Inherited from ContingencyTable.)
Item[([( Int32, Int32])]) | Gets or sets the count in the specified cell. (Inherited from ContingencyTable.)
LogOddsRatio | Computes the log of the odds ratio.
Name | Gets or sets the name of the table. (Inherited from ContingencyTable.)
OddsRatio | Computes the odds ratio of table.
RowCount | Gets the number of rows in the table. (Inherited from ContingencyTable.)
Total | Gets the total counts in the table. (Inherited from ContingencyTable.)

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace


BinaryContingencyTable.LogOddsRatio Property

F#

Meta.Numerics Library
BinaryContingencyTable..::LogOddsRatio Property
Computes the log of the odds ratio.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue LogOddsRatio { get; }
Public ReadOnly Property LogOddsRatio As UncertainValue
    Get
public:
property UncertainValue LogOddsRatio {
    UncertainValue get ();
}
member LogOddsRatio : UncertainValue with get

Property Value

UncertainValue

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace
BinaryContingencyTable..::..OddsRatio


BinaryContingencyTable.OddsRatio Property

F#

Meta.Numerics Library
BinaryContingencyTable..::OddsRatio Property
Computes the odds ratio of table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue OddsRatio { get; }
Public ReadOnly Property OddsRatio As UncertainValue
    Get
public:
property UncertainValue OddsRatio {
    UncertainValue get ();
}
member OddsRatio : UncertainValue with get

Property Value

UncertainValue

Remarks

For entries in the first row, the odds of landing in the first column are given by N[0,0] / N[0,1]. For entries in the second row, the odds of landing in the first column are given by N[1,0] / N[1,1]. The odds ratio is the ratio of these two odds. An odds ratio significantly different from 1 indicates a correlation between row and column values.

See Also

BinaryContingencyTable Class
Meta.Numerics.Statistics Namespace
BinaryContingencyTable..::..LogOddsRatio


BivariateSample Class

F#

| Members | See Also
Meta.Numerics Library
BivariateSample Class
Represents a set of data points, where each data point is described by a pair of real numbers.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class BivariateSample : ICollection<XY>,
    IEnumerable<XY>, IEnumerable
Public NotInheritable Class BivariateSample
    Implements ICollection(Of XY), IEnumerable(Of XY),
    IEnumerable
public ref class BivariateSample sealed : ICollection<XY>,
    IEnumerable<XY>, IEnumerable
[<SealedAttribute>]
type BivariateSample =
    class
        interface ICollection<XY>
        interface IEnumerable<XY>
        interface IEnumerable
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BivariateSample()()()() | Initializes a new bivariate sample.
BivariateSample(String, String) | Initializes a new bivariate sample with the given variable names.
Add(XY) | Adds a data point to the sample.
Add(IEnumerable<(Of <<'(XY>)>>)) | Adds multiple data points to the sample.
Add(IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>)) | Adds points from two lists to the sample.
Add(Double, Double) | Adds a data point to the sample.
Clear()()()() | Removes all data points from the sample.
Contains(XY) | Determines whether the sample contains a given data point.
Contains(Double, Double) | Determines whether the sample contains a given data point.
Copy()()()() | Copies the bivariate sample.
CorrelationCoefficient | Gets the correlation coefficient between the two variables.
Count | Gets the number of data points.
Covariance | Gets the covariance of the two variables.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Gets an enumerator of sample values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsReadOnly | Gets a value indicating whether the bivariate sample is read-only.
KendallTauTest()()()() | Performs a Kendall concordance test for association.
LinearLogisticRegression()()()() | Computes the best-fit linear logistic regression from the data.
LinearRegression()()()() | Computes the best-fit linear regression from the data.
PairedStudentTTest()()()() | Performs a paired Student t-test.
PearsonRTest()()()() | Performs a Pearson correlation test for association.
PolynomialRegression(Int32) | Computes the polynomial of given degree which best fits the data.
PopulationCovariance | Estimates of the population covariance of two variables.
Remove(XY) | Removes a data point from the sample.
Remove(Double, Double) | Removes a data point from the sample.
SpearmanRhoTest()()()() | Performs a Spearman rank-order test of association between the two variables.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TransposeXY()()()() | Swaps the X and Y variables in the bivariate sample.
X | Gets a read-only univariate sample consisting of the x-values of the data points.
Y | Gets a read-only univariate sample consisting of the y-values of the data points.

Remarks

A bivariate sample consists of pairs of real numbers, where each pair is an independent measurement. For example, if you measure the height and weight of a sample of people, the data could be stored as a bivariate sample. The class can compute various descriptive statistics for the sample, perform appropriate statistical tests on the sample data, and fit the sample data to various models.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..BivariateSample

See Also

Meta.Numerics.Statistics Namespace


BivariateSample Constructor

F#

Meta.Numerics Library
BivariateSample Constructor

Overload List

Name | Description
BivariateSample()()()() | Initializes a new bivariate sample.
BivariateSample(String, String) | Initializes a new bivariate sample with the given variable names.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample Constructor

F#

Meta.Numerics Library
BivariateSample Constructor
Initializes a new bivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BivariateSample()
Public Sub New
public:
BivariateSample()
new : unit -> BivariateSample

See Also

BivariateSample Class
BivariateSample Overload
Meta.Numerics.Statistics Namespace


BivariateSample Constructor (String, String)

F#

Meta.Numerics Library
BivariateSample Constructor (String, String)
Initializes a new bivariate sample with the given variable names.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BivariateSample(
    string xName,
    string yName
)
Public Sub New (
    xName As String,
    yName As String
)
public:
BivariateSample(
    String^ xName,
    String^ yName
)
new :
        xName : string *
        yName : string -> BivariateSample

Parameters

xName
String
The name of the x-variable.
yName
String
The name of the y-variable.

See Also

BivariateSample Class
BivariateSample Overload
Meta.Numerics.Statistics Namespace


BivariateSample Methods

F#

Meta.Numerics Library
BivariateSample Methods

The BivariateSample type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(XY) | Adds a data point to the sample.
Add(IEnumerable<(Of <<'(XY>)>>)) | Adds multiple data points to the sample.
Add(IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>)) | Adds points from two lists to the sample.
Add(Double, Double) | Adds a data point to the sample.
Clear()()()() | Removes all data points from the sample.
Contains(XY) | Determines whether the sample contains a given data point.
Contains(Double, Double) | Determines whether the sample contains a given data point.
Copy()()()() | Copies the bivariate sample.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Gets an enumerator of sample values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
KendallTauTest()()()() | Performs a Kendall concordance test for association.
LinearLogisticRegression()()()() | Computes the best-fit linear logistic regression from the data.
LinearRegression()()()() | Computes the best-fit linear regression from the data.
PairedStudentTTest()()()() | Performs a paired Student t-test.
PearsonRTest()()()() | Performs a Pearson correlation test for association.
PolynomialRegression(Int32) | Computes the polynomial of given degree which best fits the data.
Remove(XY) | Removes a data point from the sample.
Remove(Double, Double) | Removes a data point from the sample.
SpearmanRhoTest()()()() | Performs a Spearman rank-order test of association between the two variables.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TransposeXY()()()() | Swaps the X and Y variables in the bivariate sample.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Add Method

F#

Meta.Numerics Library
BivariateSample..::Add Method

Overload List

Name | Description
Add(XY) | Adds a data point to the sample.
Add(IEnumerable<(Of <<'(XY>)>>)) | Adds multiple data points to the sample.
Add(IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>)) | Adds points from two lists to the sample.
Add(Double, Double) | Adds a data point to the sample.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Add Method (XY)

F#

Meta.Numerics Library
BivariateSample..::Add Method (XY)
Adds a data point to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    XY point
)
Public Sub Add (
    point As XY
)
public:
virtual void Add(
    XY point
) sealed
abstract Add :
        point : XY -> unit
override Add :
        point : XY -> unit

Parameters

point
XY
The data point.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

BivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Add Method (IEnumerable)

F#

Meta.Numerics Library
BivariateSample..::Add Method (IEnumerable<(Of <(<'XY>)>)>)
Adds multiple data points to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    IEnumerable<XY> points
)
Public Sub Add (
    points As IEnumerable(Of XY)
)
public:
void Add(
    IEnumerable<XY>^ points
)
member Add :
        points : IEnumerable<XY> -> unit

Parameters

points
IEnumerable <(Of <(<' XY >)>)>
The data points.

See Also

BivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Add Method (IList, IList)

F#

Meta.Numerics Library
BivariateSample..::Add Method (IList<(Of <(<'Double>)>)>, IList<(Of <(<'Double>)>)>)
Adds points from two lists to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    IList<double> x,
    IList<double> y
)
Public Sub Add (
    x As IList(Of Double),
    y As IList(Of Double)
)
public:
void Add(
    IList<double>^ x,
    IList<double>^ y
)
member Add :
        x : IList<float> *
        y : IList<float> -> unit

Parameters

x
IList <(Of <(<' Double >)>)>
The x values of the data points.
y
IList <(Of <(<' Double >)>)>
The y values of the data points.

Exceptions

Exception | Condition
Meta.Numerics..::..DimensionMismatchException | The lengths of the two lists are not equal.

See Also

BivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Add Method (Double, Double)

F#

Meta.Numerics Library
BivariateSample..::Add Method (Double, Double)
Adds a data point to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    double x,
    double y
)
Public Sub Add (
    x As Double,
    y As Double
)
public:
void Add(
    double x,
    double y
)
member Add :
        x : float *
        y : float -> unit

Parameters

x
Double
The x-value of the data point.
y
Double
The y-value of the data point.

See Also

BivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Clear Method

F#

Meta.Numerics Library
BivariateSample..::Clear Method
Removes all data points from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Contains Method

F#

Meta.Numerics Library
BivariateSample..::Contains Method

Overload List

Name | Description
Contains(XY) | Determines whether the sample contains a given data point.
Contains(Double, Double) | Determines whether the sample contains a given data point.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Contains Method (XY)

F#

Meta.Numerics Library
BivariateSample..::Contains Method (XY)
Determines whether the sample contains a given data point.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    XY xy
)
Public Function Contains (
    xy As XY
) As Boolean
public:
virtual bool Contains(
    XY xy
) sealed
abstract Contains :
        xy : XY -> bool
override Contains :
        xy : XY -> bool

Parameters

xy
XY
The data point.

Return Value

Boolean
True if the sample contains the given data point, otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

BivariateSample Class
Contains Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Contains Method (Double, Double)

F#

Meta.Numerics Library
BivariateSample..::Contains Method (Double, Double)
Determines whether the sample contains a given data point.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    double x,
    double y
)
Public Function Contains (
    x As Double,
    y As Double
) As Boolean
public:
bool Contains(
    double x,
    double y
)
member Contains :
        x : float *
        y : float -> bool

Parameters

x
Double
The x-value of the data point.
y
Double
The y-value of the data point.

Return Value

Boolean
True if the sample contains the given data point, otherwise false.

See Also

BivariateSample Class
Contains Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Copy Method

F#

Meta.Numerics Library
BivariateSample..::Copy Method
Copies the bivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BivariateSample Copy()
Public Function Copy As BivariateSample
public:
BivariateSample^ Copy()
member Copy : unit -> BivariateSample

Return Value

BivariateSample
An independent copy of the bivariate sample.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.GetEnumerator Method

F#

Meta.Numerics Library
BivariateSample..::GetEnumerator Method
Gets an enumerator of sample values.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public IEnumerator<XY> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of XY)
public:
virtual IEnumerator<XY>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<XY>
override GetEnumerator : unit -> IEnumerator<XY>

Return Value

IEnumerator <(Of <(<' XY >)>)>
An enumerator of sample values.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.KendallTauTest Method

F#

Meta.Numerics Library
BivariateSample..::KendallTauTest Method
Performs a Kendall concordance test for association.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult KendallTauTest()
Public Function KendallTauTest As TestResult
public:
TestResult^ KendallTauTest()
member KendallTauTest : unit -> TestResult

Return Value

TestResult
The result of the test.

Remarks

Kendall's τ is a non-parameteric and robust test of association between two variables. It simply measures the number of cases where an increase in one variable is associated with an increase in the other (corcordant pairs), compared with the number of cases where an increase in one variable is associated with a decrease in the other (discordant pairs).

Because τ depends only on the sign of a change and not its magnitude, it is not skewed by outliers exhibiting very large changes, nor by cases where the degree of change in one variable associated with a given change in the other changes over the range of the varibles. Of course, it may still miss an association whoose sign changes over the range of the variables. For example, if data points lie along a semi-circle in the plane, an increase in the first variable is associated with an increase in the second variable along the rising arc and and decrease in the second variable along the falling arc. No test that looks for single-signed correlation will catch this association.

Because it examine all pairs of data points, the Kendall test requires O(N2) operations. It is thus impractical for very large data sets. While not quite as robust as the Kendall test, the Spearman test is a good fall-back in such cases.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | Count is less than two.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace
BivariateSample..::..PearsonRTest()()()()
BivariateSample..::..SpearmanRhoTest()()()()
http://en.wikipedia.org/wiki/Kendall_tau_test


BivariateSample.LinearLogisticRegression Method

F#

Meta.Numerics Library
BivariateSample..::LinearLogisticRegression Method
Computes the best-fit linear logistic regression from the data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult LinearLogisticRegression()
Public Function LinearLogisticRegression As FitResult
public:
FitResult^ LinearLogisticRegression()
member LinearLogisticRegression : unit -> FitResult

Return Value

FitResult
The fit result.

Remarks

Linear logistic regression is a way to fit binary outcome data to a linear model.

The method assumes that binary outcomes are encoded as 0 and 1. If any y-values other than 0 and 1 are encountered, it throws an InvalidOperationException.

The fit result is two-dimensional. The first parameter is a, the second b.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer than three data points.
System..::..InvalidOperationException | There is a y-value other than 0 or 1.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.LinearRegression Method

F#

Meta.Numerics Library
BivariateSample..::LinearRegression Method
Computes the best-fit linear regression from the data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult LinearRegression()
Public Function LinearRegression As FitResult
public:
FitResult^ LinearRegression()
member LinearRegression : unit -> FitResult

Return Value

FitResult
The result of the fit.

Remarks

Linear regression assumes that the data have been generated by a function y = a + b x + e, where e is normally distributed noise, and determines the values of a and b that best fit the data. It also determines an error matrix on the parameters a and b, and does an F-test to

The fit result is two-dimensional. The first parameter is the intercept a, the second is the slope b. The goodness-of-fit test is a F-test comparing the variance accounted for by the model to the remaining, unexplained variance.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer than three data points.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.PairedStudentTTest Method

F#

Meta.Numerics Library
BivariateSample..::PairedStudentTTest Method
Performs a paired Student t-test.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult PairedStudentTTest()
Public Function PairedStudentTTest As TestResult
public:
TestResult^ PairedStudentTTest()
member PairedStudentTTest : unit -> TestResult

Return Value

TestResult
The result of the test.

Remarks

Like a two-sample, unpaired t-test (StudentTTest(Sample, Sample)), a paired t-test compares two samples to detect a difference in means. Unlike the unpaired version, the paired version assumes that each

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer than two data points.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.PearsonRTest Method

F#

Meta.Numerics Library
BivariateSample..::PearsonRTest Method
Performs a Pearson correlation test for association.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult PearsonRTest()
Public Function PearsonRTest As TestResult
public:
TestResult^ PearsonRTest()
member PearsonRTest : unit -> TestResult

Return Value

TestResult
The result of the test.

Remarks

This test measures the strength of the linear correlation between two variables. The test statistic r is simply the covariance of the two variables, scaled by their respective standard deviations so as to obtain a number between -1 (perfect linear anti-correlation) and +1 (perfect linear correlation).

The Pearson test cannot reliably detect or rule out non-linear associations. For example, variables with a perfect quadratic association may have only a weak linear correlation. If you wish to test for associations that may not be linear, consider using the Spearman or Kendall tests instead.

The Pearson correlation test requires O(N) operations.

The Pearson test requires at least three bivariate values.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | Count is less than three.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace
BivariateSample..::..SpearmanRhoTest()()()()
BivariateSample..::..KendallTauTest()()()()
http://en.wikipedia.org/wiki/Pearson_correlation_coefficient


BivariateSample.PolynomialRegression Method

F#

Meta.Numerics Library
BivariateSample..::PolynomialRegression Method
Computes the polynomial of given degree which best fits the data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult PolynomialRegression(
    int m
)
Public Function PolynomialRegression (
    m As Integer
) As FitResult
public:
FitResult^ PolynomialRegression(
    int m
)
member PolynomialRegression :
        m : int -> FitResult

Parameters

m
Int32
The degree, which must be non-negative.

Return Value

FitResult
The fit result.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | m is negative.
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer data points than coefficients to be fit.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Remove Method

F#

Meta.Numerics Library
BivariateSample..::Remove Method

Overload List

Name | Description
Remove(XY) | Removes a data point from the sample.
Remove(Double, Double) | Removes a data point from the sample.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Remove Method (XY)

F#

Meta.Numerics Library
BivariateSample..::Remove Method (XY)
Removes a data point from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    XY point
)
Public Function Remove (
    point As XY
) As Boolean
public:
virtual bool Remove(
    XY point
) sealed
abstract Remove :
        point : XY -> bool
override Remove :
        point : XY -> bool

Parameters

point
XY
The point to remove.

Return Value

Boolean
True if the given data point was found and removed, otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

BivariateSample Class
Remove Overload
Meta.Numerics.Statistics Namespace


BivariateSample.Remove Method (Double, Double)

F#

Meta.Numerics Library
BivariateSample..::Remove Method (Double, Double)
Removes a data point from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    double x,
    double y
)
Public Function Remove (
    x As Double,
    y As Double
) As Boolean
public:
bool Remove(
    double x,
    double y
)
member Remove :
        x : float *
        y : float -> bool

Parameters

x
Double
The x-value of the data point.
y
Double
The y-value of the data point.

Return Value

Boolean
True if the given data point was found and removed, otherwise false.

See Also

BivariateSample Class
Remove Overload
Meta.Numerics.Statistics Namespace


BivariateSample.SpearmanRhoTest Method

F#

Meta.Numerics Library
BivariateSample..::SpearmanRhoTest Method
Performs a Spearman rank-order test of association between the two variables.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult SpearmanRhoTest()
Public Function SpearmanRhoTest As TestResult
public:
TestResult^ SpearmanRhoTest()
member SpearmanRhoTest : unit -> TestResult

Return Value

TestResult
The result of the test.

Remarks

The Spearman rank-order test of association is a non-parametric test for association between two variables. The test statistic rho is the correlation coefficient of the rank of each entry in the sample. It is thus invariant over monotonic reparameterizations of the data, and will, for example, detect a quadratic or exponential association just as well as a linear association.

The Spearman rank-order test requires O(N log N) operations.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer than three data points.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace
BivariateSample..::..PearsonRTest()()()()
BivariateSample..::..KendallTauTest()()()()
http://en.wikipedia.org/wiki/Spearman%27s_rank_correlation_coefficient


BivariateSample.TransposeXY Method

F#

Meta.Numerics Library
BivariateSample..::TransposeXY Method
Swaps the X and Y variables in the bivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void TransposeXY()
Public Sub TransposeXY
public:
void TransposeXY()
member TransposeXY : unit -> unit

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample Properties

F#

Meta.Numerics Library
BivariateSample Properties

The BivariateSample type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CorrelationCoefficient | Gets the correlation coefficient between the two variables.
Count | Gets the number of data points.
Covariance | Gets the covariance of the two variables.
IsReadOnly | Gets a value indicating whether the bivariate sample is read-only.
PopulationCovariance | Estimates of the population covariance of two variables.
X | Gets a read-only univariate sample consisting of the x-values of the data points.
Y | Gets a read-only univariate sample consisting of the y-values of the data points.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.CorrelationCoefficient Property

F#

Meta.Numerics Library
BivariateSample..::CorrelationCoefficient Property
Gets the correlation coefficient between the two variables.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double CorrelationCoefficient { get; }
Public ReadOnly Property CorrelationCoefficient As Double
    Get
public:
property double CorrelationCoefficient {
    double get ();
}
member CorrelationCoefficient : float with get

Property Value

Double

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Count Property

F#

Meta.Numerics Library
BivariateSample..::Count Property
Gets the number of data points.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Covariance Property

F#

Meta.Numerics Library
BivariateSample..::Covariance Property
Gets the covariance of the two variables.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Covariance { get; }
Public ReadOnly Property Covariance As Double
    Get
public:
property double Covariance {
    double get ();
}
member Covariance : float with get

Property Value

Double

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.IsReadOnly Property

F#

Meta.Numerics Library
BivariateSample..::IsReadOnly Property
Gets a value indicating whether the bivariate sample is read-only.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.PopulationCovariance Property

F#

Meta.Numerics Library
BivariateSample..::PopulationCovariance Property
Estimates of the population covariance of two variables.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationCovariance { get; }
Public ReadOnly Property PopulationCovariance As UncertainValue
    Get
public:
property UncertainValue PopulationCovariance {
    UncertainValue get ();
}
member PopulationCovariance : UncertainValue with get

Return Value

UncertainValue
An estimate, with associated uncertainty, of the population covariance.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.X Property

F#

Meta.Numerics Library
BivariateSample..::X Property
Gets a read-only univariate sample consisting of the x-values of the data points.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample X { get; }
Public ReadOnly Property X As Sample
    Get
public:
property Sample^ X {
    Sample^ get ();
}
member X : Sample with get

Property Value

Sample

Remarks

Use this method to obtain sinformation specific to the x-vales, such as their Median or Variance.

Note that this is a fast, O(1) operation, which does not create an independent copy of the data. The advantage of this is that you can access x-data as a Sample as often as you like without worying about performance. The disadvantage of this is that the returned sample cannot be altered. If you need to alter x-data independent of the bivariate sample, use the Copy()()()() method to obtain an independent copy.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


BivariateSample.Y Property

F#

Meta.Numerics Library
BivariateSample..::Y Property
Gets a read-only univariate sample consisting of the y-values of the data points.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample Y { get; }
Public ReadOnly Property Y As Sample
    Get
public:
property Sample^ Y {
    Sample^ get ();
}
member Y : Sample with get

Property Value

Sample

Remarks

Use this method to obtain sinformation specific to the y-vales, such as their Median or Variance.

Note that this is a fast, O(1) operation, which does not create an independent copy of the data. The advantage of this is that you can access y-data as a Sample as often as you like without worying about performance. The disadvantage of this is that the returned sample cannot be altered. If you need to alter y-data independent of the bivariate sample, use the Copy()()()() method to obtain an independent copy.

See Also

BivariateSample Class
Meta.Numerics.Statistics Namespace


ContingencyTable Class

F#

| Members | See Also
Meta.Numerics Library
ContingencyTable Class
Represents a contingency table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class ContingencyTable
Public Class ContingencyTable
public ref class ContingencyTable
type ContingencyTable =  class end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ContingencyTable(array<Int32,2>[,](,)[,][,]) | Initializes a new contingency table with the given data set.
ContingencyTable(Int32, Int32) | Initializes a new contingency table.
ColumnCount | Gets the number of columns in the table.
ColumnTotal(Int32) | Gets the total counts in the specified column.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment(Int32, Int32) | Increments the count in the specifed cel.
Item[([( Int32, Int32])]) | Gets or sets the count in the specified cell.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Name | Gets or sets the name of the table.
PearsonChiSquaredTest()()()() | Performs a Pearson χ2 test for correlation in the table.
Probability(Int32, Int32) | Estimates the probability of the given cell in the underlying population.
ProbabilityOfColumn(Int32) | Estimates the marginal probility of the given column in the underlying population.
ProbabilityOfColumnConditionalOnRow(Int32, Int32) | Estimates the probability of the given row, conditional on the given column.
ProbabilityOfRow(Int32) | Estimates the marginal probility of the given row in the underlying population.
ProbabilityOfRowConditionalOnColumn(Int32, Int32) | Estimates the probability of the given row, conditional on the given column.
RowCount | Gets the number of rows in the table.
RowTotal(Int32) | Gets the total counts in the specified row.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Total | Gets the total counts in the table.

Remarks

Imagine a controlled experiment in which each data point consists of two category values. For example, a measurement of a driver's car and his nationality, or a person's sex and employment status. Such experiments are typically undertaken to determine what correlation exists between the categories.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..ContingencyTable
Meta.Numerics.Statistics..::..BinaryContingencyTable

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..BinaryContingencyTable
http://en.wikipedia.org/wiki/Contingency_table


ContingencyTable Constructor

F#

Meta.Numerics Library
ContingencyTable Constructor

Overload List

Name | Description
ContingencyTable(array<Int32,2>[,](,)[,][,]) | Initializes a new contingency table with the given data set.
ContingencyTable(Int32, Int32) | Initializes a new contingency table.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable Constructor (Int32[,])

F#

Meta.Numerics Library
ContingencyTable Constructor (array<Int32,2>[,](,)[,][,])
Initializes a new contingency table with the given data set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ContingencyTable(
    int[,] data
)
Public Sub New (
    data As Integer(,)
)
public:
ContingencyTable(
    array<int,2>^ data
)
new :
        data : int[,] -> ContingencyTable

Parameters

data
array< Int32 ,2>[,](,)[,][,]
A (zero-based) matrix of contingency table entries.

See Also

ContingencyTable Class
ContingencyTable Overload
Meta.Numerics.Statistics Namespace


ContingencyTable Constructor (Int32, Int32)

F#

Meta.Numerics Library
ContingencyTable Constructor (Int32, Int32)
Initializes a new contingency table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ContingencyTable(
    int rows,
    int columns
)
Public Sub New (
    rows As Integer,
    columns As Integer
)
public:
ContingencyTable(
    int rows,
    int columns
)
new :
        rows : int *
        columns : int -> ContingencyTable

Parameters

rows
Int32
The number of rows, which must be positive.
columns
Int32
The number of columns, which must be positive.

See Also

ContingencyTable Class
ContingencyTable Overload
Meta.Numerics.Statistics Namespace


ContingencyTable Methods

F#

Meta.Numerics Library
ContingencyTable Methods

The ContingencyTable type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnTotal(Int32) | Gets the total counts in the specified column.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment(Int32, Int32) | Increments the count in the specifed cel.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
PearsonChiSquaredTest()()()() | Performs a Pearson χ2 test for correlation in the table.
Probability(Int32, Int32) | Estimates the probability of the given cell in the underlying population.
ProbabilityOfColumn(Int32) | Estimates the marginal probility of the given column in the underlying population.
ProbabilityOfColumnConditionalOnRow(Int32, Int32) | Estimates the probability of the given row, conditional on the given column.
ProbabilityOfRow(Int32) | Estimates the marginal probility of the given row in the underlying population.
ProbabilityOfRowConditionalOnColumn(Int32, Int32) | Estimates the probability of the given row, conditional on the given column.
RowTotal(Int32) | Gets the total counts in the specified row.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ColumnTotal Method

F#

Meta.Numerics Library
ContingencyTable..::ColumnTotal Method
Gets the total counts in the specified column.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int ColumnTotal(
    int c
)
Public Overridable Function ColumnTotal (
    c As Integer
) As Integer
public:
virtual int ColumnTotal(
    int c
)
abstract ColumnTotal :
        c : int -> int
override ColumnTotal :
        c : int -> int

Parameters

c
Int32
The (zero-based) column index.

Return Value

Int32
The sum of all counts in the specified column.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.Increment Method

F#

Meta.Numerics Library
ContingencyTable..::Increment Method
Increments the count in the specifed cel.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Increment(
    int r,
    int c
)
Public Sub Increment (
    r As Integer,
    c As Integer
)
public:
void Increment(
    int r,
    int c
)
member Increment :
        r : int *
        c : int -> unit

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.PearsonChiSquaredTest Method

F#

Meta.Numerics Library
ContingencyTable..::PearsonChiSquaredTest Method
Performs a Pearson χ2 test for correlation in the table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual TestResult PearsonChiSquaredTest()
Public Overridable Function PearsonChiSquaredTest As TestResult
public:
virtual TestResult^ PearsonChiSquaredTest()
abstract PearsonChiSquaredTest : unit -> TestResult
override PearsonChiSquaredTest : unit -> TestResult

Return Value

TestResult
The result of the test. The test statistic is χ2 and its likelyhood under the null hypothesis is the (right) probability to obtain a value as large or larger.

Remarks

The Pearson Pearson χ2 test tests for correlation between the row and column values. If row and column values are uncorrelated, then the expected number of counts in a table entry is simply proportional to the totals for its row and column. If that number is large for all entries, then the central limit theorem suggests that the actual number of counts will be distributed normally with mean equal to the expected value and standard deviation equal to its square root. The χ2 statistic measures the departure of the actual table from this expectation in the uncorrelated case, and under this null hypothesis its distribution is known. Having calculated χ2, then, we can compute just how unlikely it was to obtain a value as large or larger than the one obtained.

In cases where either the actual or expected counts for some entries are small or zero, the assumptions of the Pearson χ2 test are violated and it should not be used. For 2 X 2 experiments, the FisherExactTest()()()() is a viable alternative in these cases.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics.Distributions..::..ChiSquaredDistribution


ContingencyTable.Probability Method

F#

Meta.Numerics Library
ContingencyTable..::Probability Method
Estimates the probability of the given cell in the underlying population.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual UncertainValue Probability(
    int r,
    int c
)
Public Overridable Function Probability (
    r As Integer,
    c As Integer
) As UncertainValue
public:
virtual UncertainValue Probability(
    int r,
    int c
)
abstract Probability :
        r : int *
        c : int -> UncertainValue
override Probability :
        r : int *
        c : int -> UncertainValue

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

UncertainValue
The probability for a random event to occur inthe given cell.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ProbabilityOfColumn Method

F#

Meta.Numerics Library
ContingencyTable..::ProbabilityOfColumn Method
Estimates the marginal probility of the given column in the underlying population.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual UncertainValue ProbabilityOfColumn(
    int c
)
Public Overridable Function ProbabilityOfColumn (
    c As Integer
) As UncertainValue
public:
virtual UncertainValue ProbabilityOfColumn(
    int c
)
abstract ProbabilityOfColumn :
        c : int -> UncertainValue
override ProbabilityOfColumn :
        c : int -> UncertainValue

Parameters

c
Int32
The (zero-based) column index.

Return Value

UncertainValue
The probability for a random envent to occur in the given column.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ProbabilityOfColumnConditionalOnRow Method

F#

Meta.Numerics Library
ContingencyTable..::ProbabilityOfColumnConditionalOnRow Method
Estimates the probability of the given row, conditional on the given column.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual UncertainValue ProbabilityOfColumnConditionalOnRow(
    int c,
    int r
)
Public Overridable Function ProbabilityOfColumnConditionalOnRow (
    c As Integer,
    r As Integer
) As UncertainValue
public:
virtual UncertainValue ProbabilityOfColumnConditionalOnRow(
    int c,
    int r
)
abstract ProbabilityOfColumnConditionalOnRow :
        c : int *
        r : int -> UncertainValue
override ProbabilityOfColumnConditionalOnRow :
        c : int *
        r : int -> UncertainValue

Parameters

c
Int32
The (zero-based) column index.
r
Int32
The (zero-based) row index.

Return Value

UncertainValue
The probability for a random event to occur in the given row, if it appears in the given column.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ProbabilityOfRow Method

F#

Meta.Numerics Library
ContingencyTable..::ProbabilityOfRow Method
Estimates the marginal probility of the given row in the underlying population.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual UncertainValue ProbabilityOfRow(
    int r
)
Public Overridable Function ProbabilityOfRow (
    r As Integer
) As UncertainValue
public:
virtual UncertainValue ProbabilityOfRow(
    int r
)
abstract ProbabilityOfRow :
        r : int -> UncertainValue
override ProbabilityOfRow :
        r : int -> UncertainValue

Parameters

r
Int32
The (zero-based) row index.

Return Value

UncertainValue
The probability for a random event to occur in the given row.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ProbabilityOfRowConditionalOnColumn Method

F#

Meta.Numerics Library
ContingencyTable..::ProbabilityOfRowConditionalOnColumn Method
Estimates the probability of the given row, conditional on the given column.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual UncertainValue ProbabilityOfRowConditionalOnColumn(
    int r,
    int c
)
Public Overridable Function ProbabilityOfRowConditionalOnColumn (
    r As Integer,
    c As Integer
) As UncertainValue
public:
virtual UncertainValue ProbabilityOfRowConditionalOnColumn(
    int r,
    int c
)
abstract ProbabilityOfRowConditionalOnColumn :
        r : int *
        c : int -> UncertainValue
override ProbabilityOfRowConditionalOnColumn :
        r : int *
        c : int -> UncertainValue

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

UncertainValue
The probability for a random event to occur in the given row, if it appears in the given column.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.RowTotal Method

F#

Meta.Numerics Library
ContingencyTable..::RowTotal Method
Gets the total counts in the specified row.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int RowTotal(
    int r
)
Public Overridable Function RowTotal (
    r As Integer
) As Integer
public:
virtual int RowTotal(
    int r
)
abstract RowTotal :
        r : int -> int
override RowTotal :
        r : int -> int

Parameters

r
Int32
The (zero-based) row index.

Return Value

Int32
The sum of all counts in the specified row.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable Properties

F#

Meta.Numerics Library
ContingencyTable Properties

The ContingencyTable type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ColumnCount | Gets the number of columns in the table.
Item[([( Int32, Int32])]) | Gets or sets the count in the specified cell.
Name | Gets or sets the name of the table.
RowCount | Gets the number of rows in the table.
Total | Gets the total counts in the table.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.ColumnCount Property

F#

Meta.Numerics Library
ContingencyTable..::ColumnCount Property
Gets the number of columns in the table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int ColumnCount { get; }
Public Overridable ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get ();
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Int32

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.Item Property

F#

Meta.Numerics Library
ContingencyTable..::Item Property
Gets or sets the count in the specified cell.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int this[
    int r,
    int c
] { get; set; }
Public Default Property Item (
    r As Integer,
    c As Integer
) As Integer
    Get
    Set
public:
property int default[int r, int c] {
    int get (int r, int c);
    void set (int r, int c, int value);
}
member Item : int with get, set

Parameters

r
Int32
The (zero-based) row index.
c
Int32
The (zero-based) column index.

Return Value

Int32
The count in the specified cell.

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.Name Property

F#

Meta.Numerics Library
ContingencyTable..::Name Property
Gets or sets the name of the table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.RowCount Property

F#

Meta.Numerics Library
ContingencyTable..::RowCount Property
Gets the number of rows in the table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int RowCount { get; }
Public Overridable ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get ();
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Int32

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


ContingencyTable.Total Property

F#

Meta.Numerics Library
ContingencyTable..::Total Property
Gets the total counts in the table.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int Total { get; }
Public Overridable ReadOnly Property Total As Integer
    Get
public:
virtual property int Total {
    int get ();
}
abstract Total : int with get
override Total : int with get

Property Value

Int32

See Also

ContingencyTable Class
Meta.Numerics.Statistics Namespace


FitResult Class

F#

| Members | See Also
Meta.Numerics Library
FitResult Class
Represents the result of a fit procedure.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class FitResult
Public Class FitResult
public ref class FitResult
type FitResult =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CorrelationCoefficient(Int32, Int32) | Gets the coefficient of correlation between two fit parameters.
Covariance(Int32, Int32) | Gets the covariance of two fit parameters.
CovarianceMatrix | Gets the covariance matrix containing the variances and covariances for all fit parameters.
Dimension | Gets the number of fit parameters.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GoodnessOfFit | Gets a test of the quality of the fit.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parameter(Int32) | Get an estimate of a fit parameter.
Parameters | Gets the best fit parameter set.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

All fit methods in the Meta.Numerics library return their results as an instance of the FitResult class. This includes methods that fit a sample to a distribution (e.g. FitToSample(Sample)), regression methods for bivariate and multivariate data (e.g. LinearLogisticRegression()()()()), and least-squares fits of data with error bars to a model function (e.g. FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][])).

A FitResult instance contains not only the parameter values, but also covariances and a goodness-of-fit test.

The vector of best-fit parameter values can be obtained as an array using the Parameters method. Individual parameter values can be obtained using the Parameter(Int32) method; this method gives not only a best-fit value but also an uncertainty by returning a UncertainValue.

The matrix of covariances can be obtained using the CovarianceMatrix method. Covariances between specific pairs of parameters van be obtained using the Covariance(Int32, Int32) method.

The goodness-of-fit test result stored in the GoodnessOfFit measures the quality of the fit. For fits to distributions, it is a Kolmogorov-Smirnov test. For regressions, it is an F-test. For fits to data with error bars, it is a chi-square test.

Fits are done using the maximum likelyhood method, with results corrected for any small-sample bias.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..FitResult

See Also

Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Maximum_likelihood


FitResult Methods

F#

Meta.Numerics Library
FitResult Methods

The FitResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CorrelationCoefficient(Int32, Int32) | Gets the coefficient of correlation between two fit parameters.
Covariance(Int32, Int32) | Gets the covariance of two fit parameters.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parameter(Int32) | Get an estimate of a fit parameter.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.CorrelationCoefficient Method

F#

Meta.Numerics Library
FitResult..::CorrelationCoefficient Method
Gets the coefficient of correlation between two fit parameters.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double CorrelationCoefficient(
    int n,
    int m
)
Public Function CorrelationCoefficient (
    n As Integer,
    m As Integer
) As Double
public:
double CorrelationCoefficient(
    int n,
    int m
)
member CorrelationCoefficient :
        n : int *
        m : int -> float

Parameters

n
Int32
The (zero-based) number of the first parameter.
m
Int32
The (zero-based) number of the second parameter.

Return Value

Double
The correlation coefficient between the two parameters.

Remarks

The correlation coefficient between two parameters is a re-scaling of their covariance to a number between -1 and 1 that indicates the strength of their correlation.

The correlation coefficient is also called the Pearson R coefficient.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n or m is not within [0,Dimension-1].

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.Covariance Method

F#

Meta.Numerics Library
FitResult..::Covariance Method
Gets the covariance of two fit parameters.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Covariance(
    int n,
    int m
)
Public Function Covariance (
    n As Integer,
    m As Integer
) As Double
public:
double Covariance(
    int n,
    int m
)
member Covariance :
        n : int *
        m : int -> float

Parameters

n
Int32
The (zero-based) number of the fist parameter.
m
Int32
The (zero-based) number of the second parameter.

Return Value

Double
The covariance of the two fit parameters.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n or m is not within [0,Dimension-1].

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.Parameter Method

F#

Meta.Numerics Library
FitResult..::Parameter Method
Get an estimate of a fit parameter.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue Parameter(
    int n
)
Public Function Parameter (
    n As Integer
) As UncertainValue
public:
UncertainValue Parameter(
    int n
)
member Parameter :
        n : int -> UncertainValue

Parameters

n
Int32
The (zero-based) parameter number.

Return Value

UncertainValue
An estimate of the parameter.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is not within [0,Dimension-1].

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult Properties

F#

Meta.Numerics Library
FitResult Properties

The FitResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CovarianceMatrix | Gets the covariance matrix containing the variances and covariances for all fit parameters.
Dimension | Gets the number of fit parameters.
GoodnessOfFit | Gets a test of the quality of the fit.
Parameters | Gets the best fit parameter set.

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.CovarianceMatrix Property

F#

Meta.Numerics Library
FitResult..::CovarianceMatrix Property
Gets the covariance matrix containing the variances and covariances for all fit parameters.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public SymmetricMatrix CovarianceMatrix { get; }
Public ReadOnly Property CovarianceMatrix As SymmetricMatrix
    Get
public:
property SymmetricMatrix^ CovarianceMatrix {
    SymmetricMatrix^ get ();
}
member CovarianceMatrix : SymmetricMatrix with get

Return Value

SymmetricMatrix
The covariance matrix.

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.Dimension Property

F#

Meta.Numerics Library
FitResult..::Dimension Property
Gets the number of fit parameters.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.GoodnessOfFit Property

F#

Meta.Numerics Library
FitResult..::GoodnessOfFit Property
Gets a test of the quality of the fit.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult GoodnessOfFit { get; }
Public ReadOnly Property GoodnessOfFit As TestResult
    Get
public:
property TestResult^ GoodnessOfFit {
    TestResult^ get ();
}
member GoodnessOfFit : TestResult with get

Property Value

TestResult

Remarks

Which test is used to evaluate goodness-of-fit depends on the type of fit that was performed.

If no goodness-of-fit test was performed as a part of the fit, this property will be null.

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


FitResult.Parameters Property

F#

Meta.Numerics Library
FitResult..::Parameters Property
Gets the best fit parameter set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ColumnVector Parameters { get; }
Public ReadOnly Property Parameters As ColumnVector
    Get
public:
property ColumnVector^ Parameters {
    ColumnVector^ get ();
}
member Parameters : ColumnVector with get

Property Value

ColumnVector
A read-only vector containing the best-fit parameter values.

See Also

FitResult Class
Meta.Numerics.Statistics Namespace


Histogram Class

F#

| Members | See Also
Meta.Numerics Library
Histogram Class
Represents a histogram.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class Histogram
Public NotInheritable Class Histogram
public ref class Histogram sealed
[<SealedAttribute>]
type Histogram =  class end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Histogram(IList<(Of <<'(Double>)>>)) | Create a histogram with the given bin borders.
Histogram(Int32) | Creates a histogram with the given number of bins.
AboveRangeBin | Gets a bin for all values above the histogram range.
Add(Double) | Adds a new value to the histogram.
BelowRangeBin | Gets a bin for all values below the histogram range.
Bins | Gets a collection of histogram bins.
ChiSquaredTest(DiscreteDistribution) | Performs a χ2 test comparing the histogram to the given distribution.
Clear()()()() | Sets all bin counts to zero.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Range | The range of values in the histogram.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TotalCounts | Gets the total number of counts in the histogram.

Remarks

A histogram stores the number of occurances of a value (called the count) within a set of ranges (called bins). It is the natural system to store discrete univariate data. The natural system to store continuous univariate data is the Sample class, but often histograms are also used for continuous data, for example because there is too much data to record each value individually.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..Histogram

See Also

Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Histogram


Histogram Constructor

F#

Meta.Numerics Library
Histogram Constructor

Overload List

Name | Description
Histogram(IList<(Of <<'(Double>)>>)) | Create a histogram with the given bin borders.
Histogram(Int32) | Creates a histogram with the given number of bins.

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram Constructor (IList)

F#

Meta.Numerics Library
Histogram Constructor (IList<(Of <(<'Double>)>)>)
Create a histogram with the given bin borders.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Histogram(
    IList<double> binBorders
)
Public Sub New (
    binBorders As IList(Of Double)
)
public:
Histogram(
    IList<double>^ binBorders
)
new :
        binBorders : IList<float> -> Histogram

Parameters

binBorders
IList <(Of <(<' Double >)>)>
A list of bin borders.

Exceptions

Exception | Condition
System..::..ArgumentNullException | binBorders is null.
System..::..ArgumentException | binBorders has less than two values, or the values are not ordered.

See Also

Histogram Class
Histogram Overload
Meta.Numerics.Statistics Namespace


Histogram Constructor (Int32)

F#

Meta.Numerics Library
Histogram Constructor (Int32)
Creates a histogram with the given number of bins.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Histogram(
    int binCount
)
Public Sub New (
    binCount As Integer
)
public:
Histogram(
    int binCount
)
new :
        binCount : int -> Histogram

Parameters

binCount
Int32
The number of bins.

Remarks

By default, the bin borders are the integers, i.e. values in [0, 1) fall into bin 0, values in [1, 2) fall into bin 1, etc.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | binCount is less than 1.

See Also

Histogram Class
Histogram Overload
Meta.Numerics.Statistics Namespace


Histogram Methods

F#

Meta.Numerics Library
Histogram Methods

The Histogram type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(Double) | Adds a new value to the histogram.
ChiSquaredTest(DiscreteDistribution) | Performs a χ2 test comparing the histogram to the given distribution.
Clear()()()() | Sets all bin counts to zero.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.Add Method

F#

Meta.Numerics Library
Histogram..::Add Method
Adds a new value to the histogram.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    double value
)
Public Sub Add (
    value As Double
)
public:
void Add(
    double value
)
member Add :
        value : float -> unit

Parameters

value
Double
The value to add.

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.ChiSquaredTest Method

F#

Meta.Numerics Library
Histogram..::ChiSquaredTest Method
Performs a χ2 test comparing the histogram to the given distribution.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult ChiSquaredTest(
    DiscreteDistribution distribution
)
Public Function ChiSquaredTest (
    distribution As DiscreteDistribution
) As TestResult
public:
TestResult^ ChiSquaredTest(
    DiscreteDistribution^ distribution
)
member ChiSquaredTest :
        distribution : DiscreteDistribution -> TestResult

Parameters

distribution
DiscreteDistribution
The distribution against which to test the histogram.

Return Value

TestResult
The test result.

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.Clear Method

F#

Meta.Numerics Library
Histogram..::Clear Method
Sets all bin counts to zero.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram Properties

F#

Meta.Numerics Library
Histogram Properties

The Histogram type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AboveRangeBin | Gets a bin for all values above the histogram range.
BelowRangeBin | Gets a bin for all values below the histogram range.
Bins | Gets a collection of histogram bins.
Range | The range of values in the histogram.
TotalCounts | Gets the total number of counts in the histogram.

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.AboveRangeBin Property

F#

Meta.Numerics Library
Histogram..::AboveRangeBin Property
Gets a bin for all values above the histogram range.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public HistogramBin AboveRangeBin { get; }
Public ReadOnly Property AboveRangeBin As HistogramBin
    Get
public:
property HistogramBin AboveRangeBin {
    HistogramBin get ();
}
member AboveRangeBin : HistogramBin with get

Property Value

HistogramBin

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.BelowRangeBin Property

F#

Meta.Numerics Library
Histogram..::BelowRangeBin Property
Gets a bin for all values below the histogram range.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public HistogramBin BelowRangeBin { get; }
Public ReadOnly Property BelowRangeBin As HistogramBin
    Get
public:
property HistogramBin BelowRangeBin {
    HistogramBin get ();
}
member BelowRangeBin : HistogramBin with get

Property Value

HistogramBin

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.Bins Property

F#

Meta.Numerics Library
Histogram..::Bins Property
Gets a collection of histogram bins.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public HistogramBinsCollection Bins { get; }
Public ReadOnly Property Bins As HistogramBinsCollection
    Get
public:
property HistogramBinsCollection^ Bins {
    HistogramBinsCollection^ get ();
}
member Bins : HistogramBinsCollection with get

Property Value

HistogramBinsCollection

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.Range Property

F#

Meta.Numerics Library
Histogram..::Range Property
The range of values in the histogram.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Interval Range { get; }
Public ReadOnly Property Range As Interval
    Get
public:
property Interval Range {
    Interval get ();
}
member Range : Interval with get

Property Value

Interval

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


Histogram.TotalCounts Property

F#

Meta.Numerics Library
Histogram..::TotalCounts Property
Gets the total number of counts in the histogram.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int TotalCounts { get; }
Public ReadOnly Property TotalCounts As Integer
    Get
public:
property int TotalCounts {
    int get ();
}
member TotalCounts : int with get

Property Value

Int32

See Also

Histogram Class
Meta.Numerics.Statistics Namespace


HistogramBin Structure

F#

| Members | See Also
Meta.Numerics Library
HistogramBin Structure
Represents one bin in a histogram.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public struct HistogramBin
Public Structure HistogramBin
public value class HistogramBin
[<SealedAttribute>]
type HistogramBin =  struct end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Counts | Gets the number of counts in the bin.
Deincrement()()()() | De-increments (reduces by one) the bin count.
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment()()()() | Increments (increases by one) the bin count.
Range | Gets the range of values stored in the bin.
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..Histogram


HistogramBin Methods

F#

Meta.Numerics Library
HistogramBin Methods

The HistogramBin type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Deincrement()()()() | De-increments (reduces by one) the bin count.
Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode()()()() | Returns the hash code for this instance. (Inherited from ValueType.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Increment()()()() | Increments (increases by one) the bin count.
ToString()()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBin.Deincrement Method

F#

Meta.Numerics Library
HistogramBin..::Deincrement Method
De-increments (reduces by one) the bin count.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Deincrement()
Public Sub Deincrement
public:
void Deincrement()
member Deincrement : unit -> unit

Exceptions

Exception | Condition
System..::..InvalidOperationException | The bin count was already zero.

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBin.Increment Method

F#

Meta.Numerics Library
HistogramBin..::Increment Method
Increments (increases by one) the bin count.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Increment()
Public Sub Increment
public:
void Increment()
member Increment : unit -> unit

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBin Properties

F#

Meta.Numerics Library
HistogramBin Properties

The HistogramBin type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Counts | Gets the number of counts in the bin.
Range | Gets the range of values stored in the bin.

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBin.Counts Property

F#

Meta.Numerics Library
HistogramBin..::Counts Property
Gets the number of counts in the bin.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Counts { get; }
Public ReadOnly Property Counts As Integer
    Get
public:
property int Counts {
    int get ();
}
member Counts : int with get

Property Value

Int32

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBin.Range Property

F#

Meta.Numerics Library
HistogramBin..::Range Property
Gets the range of values stored in the bin.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Interval Range { get; }
Public ReadOnly Property Range As Interval
    Get
public:
property Interval Range {
    Interval get ();
}
member Range : Interval with get

Property Value

Interval

See Also

HistogramBin Structure
Meta.Numerics.Statistics Namespace


HistogramBinsCollection Class

F#

| Members | See Also
Meta.Numerics Library
HistogramBinsCollection Class
Represents a collection of histogram bins.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class HistogramBinsCollection : ICollection<HistogramBin>,
    IEnumerable<HistogramBin>, IEnumerable
Public NotInheritable Class HistogramBinsCollection
    Implements ICollection(Of HistogramBin), IEnumerable(Of HistogramBin),
    IEnumerable
public ref class HistogramBinsCollection sealed : ICollection<HistogramBin>,
    IEnumerable<HistogramBin>, IEnumerable
[<SealedAttribute>]
type HistogramBinsCollection =
    class
        interface ICollection<HistogramBin>
        interface IEnumerable<HistogramBin>
        interface IEnumerable
    end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the number of histogram bins in the collection.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Gets the given histogram bin.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..HistogramBinsCollection

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..Histogram


HistogramBinsCollection Methods

F#

Meta.Numerics Library
HistogramBinsCollection Methods

The HistogramBinsCollection type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

HistogramBinsCollection Class
Meta.Numerics.Statistics Namespace


HistogramBinsCollection Properties

F#

Meta.Numerics Library
HistogramBinsCollection Properties

The HistogramBinsCollection type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the number of histogram bins in the collection.
Item[([( Int32])]) | Gets the given histogram bin.

See Also

HistogramBinsCollection Class
Meta.Numerics.Statistics Namespace


HistogramBinsCollection.Count Property

F#

Meta.Numerics Library
HistogramBinsCollection..::Count Property
Gets the number of histogram bins in the collection.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

HistogramBinsCollection Class
Meta.Numerics.Statistics Namespace


HistogramBinsCollection.Item Property

F#

Meta.Numerics Library
HistogramBinsCollection..::Item Property
Gets the given histogram bin.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public HistogramBin this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As HistogramBin
    Get
public:
property HistogramBin default[int index] {
    HistogramBin get (int index);
}
member Item : HistogramBin with get

Parameters

index
Int32
The bin number.

Return Value

HistogramBin
The specified bin.

See Also

HistogramBinsCollection Class
Meta.Numerics.Statistics Namespace


InsufficientDataException Class

F#

| Members | See Also
Meta.Numerics Library
InsufficientDataException Class
The exception that is thrown when an operation is attempted with less than the minimum required data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class InsufficientDataException : InvalidOperationException
Public Class InsufficientDataException
    Inherits InvalidOperationException
public ref class InsufficientDataException : public InvalidOperationException
type InsufficientDataException =
    class
        inherit InvalidOperationException
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InsufficientDataException()()()() | Initializes a new insufficient data exception.
InsufficientDataException(String) | Inititalizes a new insufficient data exception with the given exception message.
InsufficientDataException(String, Exception) | Initializes a new insufficient data exception with the given exception message and inner exception.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..InvalidOperationException
Meta.Numerics.Statistics..::..InsufficientDataException

See Also

Meta.Numerics.Statistics Namespace


InsufficientDataException Constructor

F#

Meta.Numerics Library
InsufficientDataException Constructor

Overload List

Name | Description
InsufficientDataException()()()() | Initializes a new insufficient data exception.
InsufficientDataException(String) | Inititalizes a new insufficient data exception with the given exception message.
InsufficientDataException(String, Exception) | Initializes a new insufficient data exception with the given exception message and inner exception.

See Also

InsufficientDataException Class
Meta.Numerics.Statistics Namespace


InsufficientDataException Constructor

F#

Meta.Numerics Library
InsufficientDataException Constructor
Initializes a new insufficient data exception.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public InsufficientDataException()
Public Sub New
public:
InsufficientDataException()
new : unit -> InsufficientDataException

See Also

InsufficientDataException Class
InsufficientDataException Overload
Meta.Numerics.Statistics Namespace


InsufficientDataException Constructor (String)

F#

Meta.Numerics Library
InsufficientDataException Constructor (String)
Inititalizes a new insufficient data exception with the given exception message.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public InsufficientDataException(
    string message
)
Public Sub New (
    message As String
)
public:
InsufficientDataException(
    String^ message
)
new :
        message : string -> InsufficientDataException

Parameters

message
String
The exception message.

See Also

InsufficientDataException Class
InsufficientDataException Overload
Meta.Numerics.Statistics Namespace


InsufficientDataException Constructor (String, Exception)

F#

Meta.Numerics Library
InsufficientDataException Constructor (String, Exception)
Initializes a new insufficient data exception with the given exception message and inner exception.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public InsufficientDataException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
InsufficientDataException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> InsufficientDataException

Parameters

message
String
The exeption message.
innerException
Exception
The inner exception.

See Also

InsufficientDataException Class
InsufficientDataException Overload
Meta.Numerics.Statistics Namespace


InsufficientDataException Methods

F#

Meta.Numerics Library
InsufficientDataException Methods

The InsufficientDataException type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InsufficientDataException Class
Meta.Numerics.Statistics Namespace


InsufficientDataException Properties

F#

Meta.Numerics Library
InsufficientDataException Properties

The InsufficientDataException type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)

See Also

InsufficientDataException Class
Meta.Numerics.Statistics Namespace


MultivariateSample Class

F#

| Members | See Also
Meta.Numerics Library
MultivariateSample Class
Represents a multivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class MultivariateSample : ICollection<double[]>,
    IEnumerable<double[]>, IEnumerable
Public NotInheritable Class MultivariateSample
    Implements ICollection(Of Double()), IEnumerable(Of Double()),
    IEnumerable
public ref class MultivariateSample sealed : ICollection<array<double>^>,
    IEnumerable<array<double>^>, IEnumerable
[<SealedAttribute>]
type MultivariateSample =
    class
        interface ICollection<float[]>
        interface IEnumerable<float[]>
        interface IEnumerable
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MultivariateSample(Int32) | Initializes a new multivariate sample.
MultivariateSample(array<String>[]()[][]) | Initializes a new multivariate sample with the given variable names.
Add(IList<(Of <<'(Double>)>>)) | Adds an entry to the sample.
Add(array<Double>[]()[][]) | Adds an entry to the sample.
Clear()()()() | Removes all entries from the sample.
Column(Int32) | Gets the indicated column as a univariate Sample.
Columns(IList<(Of <<'(Int32>)>>)) | Gets the indicated columns as a multivariate sample.
Columns(array<Int32>[]()[][]) | Gets the indicated columns as a multivariate sample.
Contains(IList<(Of <<'(Double>)>>)) | Determines whether the sample contains a given entry.
Contains(array<Double>[]()[][]) | Determines whether the sample contains a given entry.
Copy()()()() | Copies the multivariate sample.
Count | Gets the number of enties in the sample.
Dimension | Gets the dimension of the sample.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Gets an enumerator over the sample entries.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsReadOnly | Gets a value indicating whether the multivariate sample can be modified.
LinearRegression(Int32) | Performs a linear regression analysis.
Moment(IList<(Of <<'(Int32>)>>)) | Computes the given sample raw moment.
Moment(array<Int32>[]()[][]) | Computes the given sample raw moment.
MomentAboutMean(IList<(Of <<'(Int32>)>>)) | Computes the given sample central moment.
MomentAboutMean(array<Int32>[]()[][]) | Computes the given sample central moment.
PrincipalComponentAnalysis()()()() | Performs a principal component analysis of the data.
Remove(IList<(Of <<'(Double>)>>)) | Removes an entry from the sample.
Remove(array<Double>[]()[][]) | Removes an entry from the sample.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TwoColumns(Int32, Int32) | Gets the indicated columns as a BivariateSample.

Remarks

A multivariate sample is simply a sample in which more than one number is associated with each data point. A study which records only the height of each subject could use the Sample class to store its data, but a study which records the income and height of each subject should use MutlivariateSample class. In addition to descriptive statistics, this class offers tests for studying the associations between the recorded variables, and routines for fitting the sample to a model.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..MultivariateSample

See Also

Meta.Numerics.Statistics Namespace


MultivariateSample Constructor

F#

Meta.Numerics Library
MultivariateSample Constructor

Overload List

Name | Description
MultivariateSample(Int32) | Initializes a new multivariate sample.
MultivariateSample(array<String>[]()[][]) | Initializes a new multivariate sample with the given variable names.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample Constructor (Int32)

F#

Meta.Numerics Library
MultivariateSample Constructor (Int32)
Initializes a new multivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample(
    int dimension
)
Public Sub New (
    dimension As Integer
)
public:
MultivariateSample(
    int dimension
)
new :
        dimension : int -> MultivariateSample

Parameters

dimension
Int32
The dimension of the sample space, that is, the number of variables recorded for each sample entry.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | dimension is less than one.

See Also

MultivariateSample Class
MultivariateSample Overload
Meta.Numerics.Statistics Namespace


MultivariateSample Constructor (String[])

F#

Meta.Numerics Library
MultivariateSample Constructor (array<String>[]()[][])
Initializes a new multivariate sample with the given variable names.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample(
    params string[] names
)
Public Sub New (
    ParamArray names As String()
)
public:
MultivariateSample(
    ... array<String^>^ names
)
new :
        names : string[] -> MultivariateSample

Parameters

names
array< String >[]()[][]
The names of the variables.

See Also

MultivariateSample Class
MultivariateSample Overload
Meta.Numerics.Statistics Namespace


MultivariateSample Methods

F#

Meta.Numerics Library
MultivariateSample Methods

The MultivariateSample type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(IList<(Of <<'(Double>)>>)) | Adds an entry to the sample.
Add(array<Double>[]()[][]) | Adds an entry to the sample.
Clear()()()() | Removes all entries from the sample.
Column(Int32) | Gets the indicated column as a univariate Sample.
Columns(IList<(Of <<'(Int32>)>>)) | Gets the indicated columns as a multivariate sample.
Columns(array<Int32>[]()[][]) | Gets the indicated columns as a multivariate sample.
Contains(IList<(Of <<'(Double>)>>)) | Determines whether the sample contains a given entry.
Contains(array<Double>[]()[][]) | Determines whether the sample contains a given entry.
Copy()()()() | Copies the multivariate sample.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Gets an enumerator over the sample entries.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LinearRegression(Int32) | Performs a linear regression analysis.
Moment(IList<(Of <<'(Int32>)>>)) | Computes the given sample raw moment.
Moment(array<Int32>[]()[][]) | Computes the given sample raw moment.
MomentAboutMean(IList<(Of <<'(Int32>)>>)) | Computes the given sample central moment.
MomentAboutMean(array<Int32>[]()[][]) | Computes the given sample central moment.
PrincipalComponentAnalysis()()()() | Performs a principal component analysis of the data.
Remove(IList<(Of <<'(Double>)>>)) | Removes an entry from the sample.
Remove(array<Double>[]()[][]) | Removes an entry from the sample.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TwoColumns(Int32, Int32) | Gets the indicated columns as a BivariateSample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Add Method

F#

Meta.Numerics Library
MultivariateSample..::Add Method

Overload List

Name | Description
Add(IList<(Of <<'(Double>)>>)) | Adds an entry to the sample.
Add(array<Double>[]()[][]) | Adds an entry to the sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Add Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::Add Method (IList<(Of <(<'Double>)>)>)
Adds an entry to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    IList<double> value
)
Public Sub Add (
    value As IList(Of Double)
)
public:
void Add(
    IList<double>^ value
)
member Add :
        value : IList<float> -> unit

Parameters

value
IList <(Of <(<' Double >)>)>
The values associated with the entry.

See Also

MultivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Add Method (Double[])

F#

Meta.Numerics Library
MultivariateSample..::Add Method (array<Double>[]()[][])
Adds an entry to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    params double[] value
)
Public Sub Add (
    ParamArray value As Double()
)
public:
virtual void Add(
    ... array<double>^ value
) sealed
abstract Add :
        value : float[] -> unit
override Add :
        value : float[] -> unit

Parameters

value
array< Double >[]()[][]
The values associated with the entry.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

MultivariateSample Class
Add Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Clear Method

F#

Meta.Numerics Library
MultivariateSample..::Clear Method
Removes all entries from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Column Method

F#

Meta.Numerics Library
MultivariateSample..::Column Method
Gets the indicated column as a univariate Sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample Column(
    int c
)
Public Function Column (
    c As Integer
) As Sample
public:
Sample^ Column(
    int c
)
member Column :
        c : int -> Sample

Parameters

c
Int32
The (zero-based) column index.

Return Value

Sample
A read-only Sample containing all values in the indicated column.

Remarks

Use this method to obtain column-specific information, such as the Median or Variance of the column.

Note that this is a fast, O(1) operation, which does not create an independent copy of the column. The advantage of this is that you can access columns as independent samples as often as you like without worying about performance. The disadvantage of this is that the returned sample cannot be altered. If you need to alter values in a column independent of the multi-variate sample, use the Copy()()()() method to obtain an independent copy of the column.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Columns Method

F#

Meta.Numerics Library
MultivariateSample..::Columns Method

Overload List

Name | Description
Columns(IList<(Of <<'(Int32>)>>)) | Gets the indicated columns as a multivariate sample.
Columns(array<Int32>[]()[][]) | Gets the indicated columns as a multivariate sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Columns Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::Columns Method (IList<(Of <(<'Int32>)>)>)
Gets the indicated columns as a multivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample Columns(
    IList<int> columnIndexes
)
Public Function Columns (
    columnIndexes As IList(Of Integer)
) As MultivariateSample
public:
MultivariateSample^ Columns(
    IList<int>^ columnIndexes
)
member Columns :
        columnIndexes : IList<int> -> MultivariateSample

Parameters

columnIndexes
IList <(Of <(<' Int32 >)>)>
A list of column indexes.

Return Value

MultivariateSample
A read-only MultivariateSample consisting of the indicated columns.

Remarks

Use this method to perform multivariate analyses, such as regression and principal component analyis, using only a subset of the variables in the original multivariate sample.

Note that this is a fast operation, which does not create independent copies of the columns.

See Also

MultivariateSample Class
Columns Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Columns Method (Int32[])

F#

Meta.Numerics Library
MultivariateSample..::Columns Method (array<Int32>[]()[][])
Gets the indicated columns as a multivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample Columns(
    params int[] columnIndexes
)
Public Function Columns (
    ParamArray columnIndexes As Integer()
) As MultivariateSample
public:
MultivariateSample^ Columns(
    ... array<int>^ columnIndexes
)
member Columns :
        columnIndexes : int[] -> MultivariateSample

Parameters

columnIndexes
array< Int32 >[]()[][]
A list of columns indexes.

Return Value

MultivariateSample
A read-only MultivariateSample consisting of the indicated columns.

See Also

MultivariateSample Class
Columns Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Contains Method

F#

Meta.Numerics Library
MultivariateSample..::Contains Method

Overload List

Name | Description
Contains(IList<(Of <<'(Double>)>>)) | Determines whether the sample contains a given entry.
Contains(array<Double>[]()[][]) | Determines whether the sample contains a given entry.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Contains Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::Contains Method (IList<(Of <(<'Double>)>)>)
Determines whether the sample contains a given entry.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    IList<double> value
)
Public Function Contains (
    value As IList(Of Double)
) As Boolean
public:
bool Contains(
    IList<double>^ value
)
member Contains :
        value : IList<float> -> bool

Parameters

value
IList <(Of <(<' Double >)>)>
The values associated with the entry to search for.

Return Value

Boolean
Whether the sample contains the given entry.

See Also

MultivariateSample Class
Contains Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Contains Method (Double[])

F#

Meta.Numerics Library
MultivariateSample..::Contains Method (array<Double>[]()[][])
Determines whether the sample contains a given entry.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    params double[] value
)
Public Function Contains (
    ParamArray value As Double()
) As Boolean
public:
virtual bool Contains(
    ... array<double>^ value
) sealed
abstract Contains :
        value : float[] -> bool
override Contains :
        value : float[] -> bool

Parameters

value
array< Double >[]()[][]
The values associated with the entry to search for.

Return Value

Boolean
Whether the sample contains the given entry.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

MultivariateSample Class
Contains Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Copy Method

F#

Meta.Numerics Library
MultivariateSample..::Copy Method
Copies the multivariate sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample Copy()
Public Function Copy As MultivariateSample
public:
MultivariateSample^ Copy()
member Copy : unit -> MultivariateSample

Return Value

MultivariateSample
An independent copy of the multivariate sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.GetEnumerator Method

F#

Meta.Numerics Library
MultivariateSample..::GetEnumerator Method
Gets an enumerator over the sample entries.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public IEnumerator<double[]> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Double())
public:
virtual IEnumerator<array<double>^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<float[]>
override GetEnumerator : unit -> IEnumerator<float[]>

Return Value

IEnumerator <(Of <(<'array< Double >[]()[][]>)>)>
An iterator over the sample entries.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.LinearRegression Method

F#

Meta.Numerics Library
MultivariateSample..::LinearRegression Method
Performs a linear regression analysis.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult LinearRegression(
    int outputIndex
)
Public Function LinearRegression (
    outputIndex As Integer
) As FitResult
public:
FitResult^ LinearRegression(
    int outputIndex
)
member LinearRegression :
        outputIndex : int -> FitResult

Parameters

outputIndex
Int32
The index of the variable to be predicted.

Return Value

FitResult
The result of the regression.

Remarks

Linear regression finds the linear combination of the other variables that best predicts the output variable.

The noise term epsilon is assumed to be drawn from the same normal distribution for each data point. Note that the model makes no assumptions about the distribution of the x's; it merely asserts a particular underlying relationship between the x's and the y.

Inputs and Outputs

In the returned fit result, the indices of the parameters correspond to indices of the coefficients. The intercept parameter has the index of the output variable. Thus if a linear regression analaysis is done on a 4-dimensional multivariate sample to predict variable number 2, the coefficients of variables 0, 1, and 3 will be parameters 0, 1, and 3, of the returned fit result, and the intercept will be parameter 2.

If you want to include fewer input variables in your regression, use the Columns(IList<(Of <<'(Int32>)>>)) method to create a multivariate sample that includes only the variables you want to use in your regression.

The correlation matrix among fit parameters is also returned with the fit result, as is an F-test for the goodness of the fit. If the result of the F-test is not significant, no conclusions should be drawn from the regression coefficients.

Regression vs. Correlation

If a given coefficient is significantly positive, then a change in the value of the corresponding input variable, holding all other input variables constant, will tend to increase the output variable. Note that italicized condition means that, when there is more than one input variable, a linear regression coefficient measures something different than a linear correlation coefficient.

Suppose, for example, we take a large number of measurements of water temperature, plankton concentration, and fish density in a large number of different locations. A simple correlation analysis might indicate that fish density is positively correlated with both water temperature and plankton concentration. But a regression analysis might reveal that increasing water temperature actually decreases the fish density. This seeming paradoxical situation might occur because fish do much better with more plankton, and plankton do much better at higher temperatures, and this positive knock-on effect of temperature on fish is larger than the negative direct effect.

If we are in a situation where we can control the input variables independently -- for example we are running an aquarium -- we would ceratainly want to know the specific effect of one variable -- that our fishes would actually prefer us to turn down the temperature while maintaining a high plankton level -- rather than the observed effect as a variable changes along with all the others that tend to change with it. This does not mean that the correlation analysis is wrong -- higher temperatures are indeed associated with higher fish densitites in our hypothetical data set. It simply means that you need to be careful to ask the right question for your purpose.

In most cases, it is indeed the specific effect of one variable when others are held constant that we seek. In a controlled experiment, the confounding effects of other variables are removed by the experimental design, either by random assignment or specific controls. In an observational experiment, though, confounding effects can be, and often are, large, and correlation analysis is not sufficient. It is worthwhile keeping this in find in politically charged debates in which easily observed correlations are likely to be bandied about as evidence, while a more difficult regression analysis that would actually be required to support an assertion is left undone.

Cavets

It can occur that two theoretically independent variables are so closely correlated in the observational data that a regression analsysis cannot reliably tease out the independent effect of each. In that case, a fit using only one of the variables will be as good or nearly as good as a fit using both, and the covariance between their corresponding linear regression coefficients will be large. In a situation like this, you should be wary of drawing any conclusions about their seperate effects.

It can also occur that an input variable or a set of input variables is indeed good predictor of an output variable, but via a complex and non-linear relationship that a linear regression analysis will completely miss.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | outputIndex is outside the range of allowed indexes.
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer entries than the dimension of the multivariate sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace
MultivariateSample..::..LinearRegression(Int32)
http://en.wikipedia.org/wiki/Linear_regression


MultivariateSample.Moment Method

F#

Meta.Numerics Library
MultivariateSample..::Moment Method

Overload List

Name | Description
Moment(IList<(Of <<'(Int32>)>>)) | Computes the given sample raw moment.
Moment(array<Int32>[]()[][]) | Computes the given sample raw moment.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Moment Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::Moment Method (IList<(Of <(<'Int32>)>)>)
Computes the given sample raw moment.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Moment(
    IList<int> powers
)
Public Function Moment (
    powers As IList(Of Integer)
) As Double
public:
double Moment(
    IList<int>^ powers
)
member Moment :
        powers : IList<int> -> float

Parameters

powers
IList <(Of <(<' Int32 >)>)>
The power to which each component should be raised.

Return Value

Double
The specified moment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | powers is null.
Meta.Numerics..::..DimensionMismatchException | The length of powers is not equal to the Dimension of the multivariate sample.

See Also

MultivariateSample Class
Moment Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Moment Method (Int32[])

F#

Meta.Numerics Library
MultivariateSample..::Moment Method (array<Int32>[]()[][])
Computes the given sample raw moment.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Moment(
    params int[] powers
)
Public Function Moment (
    ParamArray powers As Integer()
) As Double
public:
double Moment(
    ... array<int>^ powers
)
member Moment :
        powers : int[] -> float

Parameters

powers
array< Int32 >[]()[][]
The power to which each component should be raised.

Return Value

Double
The specified moment.

See Also

MultivariateSample Class
Moment Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.MomentAboutMean Method

F#

Meta.Numerics Library
MultivariateSample..::MomentAboutMean Method

Overload List

Name | Description
MomentAboutMean(IList<(Of <<'(Int32>)>>)) | Computes the given sample central moment.
MomentAboutMean(array<Int32>[]()[][]) | Computes the given sample central moment.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.MomentAboutMean Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::MomentAboutMean Method (IList<(Of <(<'Int32>)>)>)
Computes the given sample central moment.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double MomentAboutMean(
    IList<int> powers
)
Public Function MomentAboutMean (
    powers As IList(Of Integer)
) As Double
public:
double MomentAboutMean(
    IList<int>^ powers
)
member MomentAboutMean :
        powers : IList<int> -> float

Parameters

powers
IList <(Of <(<' Int32 >)>)>
The power to which each component should be raised.

Return Value

Double
The specified moment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | powers is null.
Meta.Numerics..::..DimensionMismatchException | The length of powers is not equal to the Dimension of the multivariate sample.

See Also

MultivariateSample Class
MomentAboutMean Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.MomentAboutMean Method (Int32[])

F#

Meta.Numerics Library
MultivariateSample..::MomentAboutMean Method (array<Int32>[]()[][])
Computes the given sample central moment.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double MomentAboutMean(
    params int[] powers
)
Public Function MomentAboutMean (
    ParamArray powers As Integer()
) As Double
public:
double MomentAboutMean(
    ... array<int>^ powers
)
member MomentAboutMean :
        powers : int[] -> float

Parameters

powers
array< Int32 >[]()[][]
The power to which each component should be raised.

Return Value

Double
The specified moment.

See Also

MultivariateSample Class
MomentAboutMean Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.PrincipalComponentAnalysis Method

F#

Meta.Numerics Library
MultivariateSample..::PrincipalComponentAnalysis Method
Performs a principal component analysis of the data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public PrincipalComponentAnalysis PrincipalComponentAnalysis()
Public Function PrincipalComponentAnalysis As PrincipalComponentAnalysis
public:
PrincipalComponentAnalysis^ PrincipalComponentAnalysis()
member PrincipalComponentAnalysis : unit -> PrincipalComponentAnalysis

Return Value

PrincipalComponentAnalysis
The result of the principal component analysis.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | The number of data entries (Count) is less than the number of variables (Dimension).

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace
MultivariateSample..::..PrincipalComponentAnalysis()()()()


MultivariateSample.Remove Method

F#

Meta.Numerics Library
MultivariateSample..::Remove Method

Overload List

Name | Description
Remove(IList<(Of <<'(Double>)>>)) | Removes an entry from the sample.
Remove(array<Double>[]()[][]) | Removes an entry from the sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Remove Method (IList)

F#

Meta.Numerics Library
MultivariateSample..::Remove Method (IList<(Of <(<'Double>)>)>)
Removes an entry from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    IList<double> values
)
Public Function Remove (
    values As IList(Of Double)
) As Boolean
public:
bool Remove(
    IList<double>^ values
)
member Remove :
        values : IList<float> -> bool

Parameters

values
IList <(Of <(<' Double >)>)>
The values associated with the entry to remove.

Return Value

Boolean
Whether the entry was found and removed.

See Also

MultivariateSample Class
Remove Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.Remove Method (Double[])

F#

Meta.Numerics Library
MultivariateSample..::Remove Method (array<Double>[]()[][])
Removes an entry from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    params double[] value
)
Public Function Remove (
    ParamArray value As Double()
) As Boolean
public:
virtual bool Remove(
    ... array<double>^ value
) sealed
abstract Remove :
        value : float[] -> bool
override Remove :
        value : float[] -> bool

Parameters

value
array< Double >[]()[][]
The values associated with the entry to remove.

Return Value

Boolean
Whether the entry was found and removed.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

MultivariateSample Class
Remove Overload
Meta.Numerics.Statistics Namespace


MultivariateSample.TwoColumns Method

F#

Meta.Numerics Library
MultivariateSample..::TwoColumns Method
Gets the indicated columns as a BivariateSample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BivariateSample TwoColumns(
    int cx,
    int cy
)
Public Function TwoColumns (
    cx As Integer,
    cy As Integer
) As BivariateSample
public:
BivariateSample^ TwoColumns(
    int cx,
    int cy
)
member TwoColumns :
        cx : int *
        cy : int -> BivariateSample

Parameters

cx
Int32
The (zero-based) column index of the X variable.
cy
Int32
The (zero-based) column index of the Y variable.

Return Value

BivariateSample
A read-only BivariateSample consisting of the indicated columns..

Remarks

Use this method to obtain information specific to the two columns, such as the Covariance, or to perform tests specific to the two columns, such as a PearsonRTest()()()().

Note that this is a fast, O(1) operation, which does not create independent copies of the columns. The advantage of this is that you can access pairs of columns as bivariate samples as often as you like without worying about performance. The disadvantage of this is that the returned bivariate sample cannot be altered. If you need to alter values independent of the multi-variate sample, use the Copy()()()() method to obtain an independent copy of the bivariate sample.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample Properties

F#

Meta.Numerics Library
MultivariateSample Properties

The MultivariateSample type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the number of enties in the sample.
Dimension | Gets the dimension of the sample.
IsReadOnly | Gets a value indicating whether the multivariate sample can be modified.

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Count Property

F#

Meta.Numerics Library
MultivariateSample..::Count Property
Gets the number of enties in the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.Dimension Property

F#

Meta.Numerics Library
MultivariateSample..::Dimension Property
Gets the dimension of the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


MultivariateSample.IsReadOnly Property

F#

Meta.Numerics Library
MultivariateSample..::IsReadOnly Property
Gets a value indicating whether the multivariate sample can be modified.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

MultivariateSample Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult Class

F#

| Example | Members | See Also
Meta.Numerics Library
OneWayAnovaResult Class
The result of a one-way ANOVA test.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class OneWayAnovaResult
Public Class OneWayAnovaResult
public ref class OneWayAnovaResult
type OneWayAnovaResult =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Factor | Gets design factor variance data.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Residual | Gets residual variance data.
Result | Gets the result of the F test for the influence of the factor.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Total | Gets total variance data.

Remarks

A one way ANOVA test detects the influence of a categorical factor on the mean of a measured variable, which is assumed to be normally distributed.

A one way ANOVA result is returned by the static OneWayAnovaTest(IList<(Of <<'(Sample>)>>)) method.

While, fundamentally, a one-way ANOVA is a simple statistical test like any other, with a single test statistic (F) and a single associated distribution (the F distribution), some ANOVA users like to examine and report some intermediate quantities used in the computation of the test. In particular, the sum of square deviations and corresponding degrees of freedom associated with the design factor and the residual, and their sum may be of interest. Each of these appear as rows in the common tabular representation of an ANOVA test. To enable this, the class makes this information available as AnovaRow objects returned by the Factor, Residual, and Total properties. This has the unfortunate side-effect of making the AVOVA look more complicated than it really is. If you just want the test result, you can get it from the Result property.

Examples

Suppose you have sampled the heights of aliens from three planets. Heights are approximately normally distributed on each planet. You want to know whether planet-of-origin affects average height. You can do a one-way ANOVA to determine if the planet factor affects mean height.

C# Copy image Copy
Sample group1 = new Sample(4, 5, 6);
Sample group2 = new Sample(3, 4, 5);
Sample group3 = new Sample(5, 6, 8, 9);
OneWayAnovaResult result = Sample.OneWayAnovaTest(group1, group2, group3);
return(result.Result.RightProbability);

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..OneWayAnovaResult

See Also

Meta.Numerics.Statistics Namespace
Sample..::..OneWayAnovaTest(IList<(Of <<'(Sample>)>>))


OneWayAnovaResult Methods

F#

Meta.Numerics Library
OneWayAnovaResult Methods

The OneWayAnovaResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult Properties

F#

Meta.Numerics Library
OneWayAnovaResult Properties

The OneWayAnovaResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Factor | Gets design factor variance data.
Residual | Gets residual variance data.
Result | Gets the result of the F test for the influence of the factor.
Total | Gets total variance data.

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult.Factor Property

F#

Meta.Numerics Library
OneWayAnovaResult..::Factor Property
Gets design factor variance data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public AnovaTestRow Factor { get; }
Public ReadOnly Property Factor As AnovaTestRow
    Get
public:
property AnovaTestRow^ Factor {
    AnovaTestRow^ get ();
}
member Factor : AnovaTestRow with get

Property Value

AnovaTestRow

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult.Residual Property

F#

Meta.Numerics Library
OneWayAnovaResult..::Residual Property
Gets residual variance data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public AnovaRow Residual { get; }
Public ReadOnly Property Residual As AnovaRow
    Get
public:
property AnovaRow^ Residual {
    AnovaRow^ get ();
}
member Residual : AnovaRow with get

Property Value

AnovaRow

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult.Result Property

F#

Meta.Numerics Library
OneWayAnovaResult..::Result Property
Gets the result of the F test for the influence of the factor.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult Result { get; }
Public ReadOnly Property Result As TestResult
    Get
public:
property TestResult^ Result {
    TestResult^ get ();
}
member Result : TestResult with get

Property Value

TestResult

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


OneWayAnovaResult.Total Property

F#

Meta.Numerics Library
OneWayAnovaResult..::Total Property
Gets total variance data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public AnovaRow Total { get; }
Public ReadOnly Property Total As AnovaRow
    Get
public:
property AnovaRow^ Total {
    AnovaRow^ get ();
}
member Total : AnovaRow with get

Property Value

AnovaRow

See Also

OneWayAnovaResult Class
Meta.Numerics.Statistics Namespace


PrincipalComponent Class

F#

| Members | See Also
Meta.Numerics Library
PrincipalComponent Class
Represents a component of a principal component analysis.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class PrincipalComponent
Public NotInheritable Class PrincipalComponent
public ref class PrincipalComponent sealed
[<SealedAttribute>]
type PrincipalComponent =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Analysis | Gets the principal component analysis to which the component belongs.
CumulativeVarianceFraction | Gets the fraction of the total variance accounted for by the principal component and all strong principal components.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Index | Gets the index of the principal component.
NormalizedVector()()()() | Gets the normalized component vector.
ScaledVector()()()() | Gets the scaled component vector.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
VarianceFraction | Gets the fraction of the total variance accounted for by the principal component.
Weight | Gets the weight of the component.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..PrincipalComponent

See Also

Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics..::..PrincipalComponentAnalysis


PrincipalComponent Methods

F#

Meta.Numerics Library
PrincipalComponent Methods

The PrincipalComponent type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
NormalizedVector()()()() | Gets the normalized component vector.
ScaledVector()()()() | Gets the scaled component vector.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.NormalizedVector Method

F#

Meta.Numerics Library
PrincipalComponent..::NormalizedVector Method
Gets the normalized component vector.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector NormalizedVector()
Public Function NormalizedVector As RowVector
public:
RowVector^ NormalizedVector()
member NormalizedVector : unit -> RowVector

Return Value

RowVector

[Missing <returns> documentation for "M:Meta.Numerics.Statistics.PrincipalComponent.NormalizedVector"]

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.ScaledVector Method

F#

Meta.Numerics Library
PrincipalComponent..::ScaledVector Method
Gets the scaled component vector.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public RowVector ScaledVector()
Public Function ScaledVector As RowVector
public:
RowVector^ ScaledVector()
member ScaledVector : unit -> RowVector

Return Value

RowVector

[Missing <returns> documentation for "M:Meta.Numerics.Statistics.PrincipalComponent.ScaledVector"]

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent Properties

F#

Meta.Numerics Library
PrincipalComponent Properties

The PrincipalComponent type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Analysis | Gets the principal component analysis to which the component belongs.
CumulativeVarianceFraction | Gets the fraction of the total variance accounted for by the principal component and all strong principal components.
Index | Gets the index of the principal component.
VarianceFraction | Gets the fraction of the total variance accounted for by the principal component.
Weight | Gets the weight of the component.

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.Analysis Property

F#

Meta.Numerics Library
PrincipalComponent..::Analysis Property
Gets the principal component analysis to which the component belongs.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public PrincipalComponentAnalysis Analysis { get; }
Public ReadOnly Property Analysis As PrincipalComponentAnalysis
    Get
public:
property PrincipalComponentAnalysis^ Analysis {
    PrincipalComponentAnalysis^ get ();
}
member Analysis : PrincipalComponentAnalysis with get

Property Value

PrincipalComponentAnalysis

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.CumulativeVarianceFraction Property

F#

Meta.Numerics Library
PrincipalComponent..::CumulativeVarianceFraction Property
Gets the fraction of the total variance accounted for by the principal component and all strong principal components.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double CumulativeVarianceFraction { get; }
Public ReadOnly Property CumulativeVarianceFraction As Double
    Get
public:
property double CumulativeVarianceFraction {
    double get ();
}
member CumulativeVarianceFraction : float with get

Property Value

Double

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.Index Property

F#

Meta.Numerics Library
PrincipalComponent..::Index Property
Gets the index of the principal component.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Int32

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.VarianceFraction Property

F#

Meta.Numerics Library
PrincipalComponent..::VarianceFraction Property
Gets the fraction of the total variance accounted for by the principal component.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double VarianceFraction { get; }
Public ReadOnly Property VarianceFraction As Double
    Get
public:
property double VarianceFraction {
    double get ();
}
member VarianceFraction : float with get

Property Value

Double

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponent.Weight Property

F#

Meta.Numerics Library
PrincipalComponent..::Weight Property
Gets the weight of the component.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Weight { get; }
Public ReadOnly Property Weight As Double
    Get
public:
property double Weight {
    double get ();
}
member Weight : float with get

Property Value

Double

See Also

PrincipalComponent Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis Class

F#

| Members | See Also
Meta.Numerics Library
PrincipalComponentAnalysis Class
Represents a principal component analysis.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class PrincipalComponentAnalysis
Public NotInheritable Class PrincipalComponentAnalysis
public ref class PrincipalComponentAnalysis sealed
[<SealedAttribute>]
type PrincipalComponentAnalysis =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Component(Int32) | Gets the requested principal component.
Count | Gets the number of data entries.
Dimension | Gets the number of components.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MinimumDimension(Double) | Gets the minimum number of principal components that must be included to explain the given fraction of the total variance.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TransformedSample()()()() | Represents the original data in terms of principal components.

Remarks

Principal component analysis (PCA) is a form of factor analysis. It attempts to identify a small number number of factors such that, by specifing only values of these few factors for each row, the value of each variable can be accurately predicted.

Mathematically, PCA constructs an alternative set of orthonormal basis vectors for a multi-variate data set. These basis vectors, called principal components, are ordered by the total variance explained by each.

Suppose, for example, you measure the value of different possessions possessions for a sample of people: home value, car value, furniture value, etc. You might expect that much of the variation in these numbers can be explained by one underlying factor, which you might call "richness". If this is true, then a PCA analysis will show that the most principal component explains a very large faction of the total variance, and the other less principal components will explain only small fractions of the total variance.

Note that PCA is not invariant with respect to the re-scaling of individual variables.

Note that PCA is an exploratory technique, not a hypothesis test.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..PrincipalComponentAnalysis

See Also

Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis Methods

F#

Meta.Numerics Library
PrincipalComponentAnalysis Methods

The PrincipalComponentAnalysis type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Component(Int32) | Gets the requested principal component.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MinimumDimension(Double) | Gets the minimum number of principal components that must be included to explain the given fraction of the total variance.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
TransformedSample()()()() | Represents the original data in terms of principal components.

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis.Component Method

F#

Meta.Numerics Library
PrincipalComponentAnalysis..::Component Method
Gets the requested principal component.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public PrincipalComponent Component(
    int componentIndex
)
Public Function Component (
    componentIndex As Integer
) As PrincipalComponent
public:
PrincipalComponent^ Component(
    int componentIndex
)
member Component :
        componentIndex : int -> PrincipalComponent

Parameters

componentIndex
Int32
The (zero-based) index of the principal component.

Return Value

PrincipalComponent
The requested principal component.

Remarks

Principal components are ordered by strength. The most principal component, i.e. the component which explains the most variance, has index zero. The least principal component has the highest index.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | componentIndex lies outside the range [0, Dimension-1].

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis.MinimumDimension Method

F#

Meta.Numerics Library
PrincipalComponentAnalysis..::MinimumDimension Method
Gets the minimum number of principal components that must be included to explain the given fraction of the total variance.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int MinimumDimension(
    double P
)
Public Function MinimumDimension (
    P As Double
) As Integer
public:
int MinimumDimension(
    double P
)
member MinimumDimension :
        P : float -> int

Parameters

P
Double
The fraction of the variance to explain, which must lie between zero and one.

Return Value

Int32
The required number of components.

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis.TransformedSample Method

F#

Meta.Numerics Library
PrincipalComponentAnalysis..::TransformedSample Method
Represents the original data in terms of principal components.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public MultivariateSample TransformedSample()
Public Function TransformedSample As MultivariateSample
public:
MultivariateSample^ TransformedSample()
member TransformedSample : unit -> MultivariateSample

Return Value

MultivariateSample
A multivariate sample whose columns are the weights of each principal component in each entry of the originally analyzed sample.

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis Properties

F#

Meta.Numerics Library
PrincipalComponentAnalysis Properties

The PrincipalComponentAnalysis type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the number of data entries.
Dimension | Gets the number of components.

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis.Count Property

F#

Meta.Numerics Library
PrincipalComponentAnalysis..::Count Property
Gets the number of data entries.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


PrincipalComponentAnalysis.Dimension Property

F#

Meta.Numerics Library
PrincipalComponentAnalysis..::Dimension Property
Gets the number of components.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}
member Dimension : int with get

Property Value

Int32

Remarks

The number of components is equal to the number of variables used in the analysis.

See Also

PrincipalComponentAnalysis Class
Meta.Numerics.Statistics Namespace


Sample Class

F#

| Members | See Also
Meta.Numerics Library
Sample Class
Represents a set of data points, where each data point consists of a single real number.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class Sample : ICollection<double>,
    IEnumerable<double>, IEnumerable
Public NotInheritable Class Sample
    Implements ICollection(Of Double), IEnumerable(Of Double),
    IEnumerable
public ref class Sample sealed : ICollection<double>,
    IEnumerable<double>, IEnumerable
[<SealedAttribute>]
type Sample =
    class
        interface ICollection<float>
        interface IEnumerable<float>
        interface IEnumerable
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Sample()()()() | Initializes a new, empty sample.
Sample(IEnumerable<(Of <<'(Double>)>>)) | Initializes a new sample from a list of values.
Sample(array<Double>[]()[][]) | Initializes a new sample from a list of values.
Sample(String) | Initializes a new, empty sample with the given name.
Add(IEnumerable<(Of <<'(Double>)>>)) | Adds multiple values to the sample.
Add(Double) | Adds a value to the sample.
Add(array<Double>[]()[][]) | Adds multiple values to the sample.
Clear()()()() | Remove all values from the sample.
Contains(Double) | Determines whether the sample contains the given value.
Copy()()()() | Copies the sample.
Count | Gets the number of values in the sample.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FisherFTest(Sample, Sample) | Tests whether the variance of two samples is compatible.
GetEnumerator()()()() | Gets an enumerator of sample values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InterquartileRange | Gets the interquartile range of sample measurmements.
InverseLeftProbability(Double) | Gets the sample value corresponding to a given percentile score.
IsReadOnly | Gets a value indicating whether the sample is read-only.
KolmogorovSmirnovTest(Distribution) | Tests whether the sample is compatible with the given distribution.
KolmogorovSmirnovTest(Sample, Sample) | Tests whether the sample is compatible with another sample.
KruskalWallisTest(array<Sample>[]()[][]) | Performs a Kruskal-Wallis test on the given samples.
KruskalWallisTest(IList<(Of <<'(Sample>)>>)) | Performs a Kruskal-Wallis test on the given samples.
KuiperTest(Distribution) | Tests whether the sample is compatible with the given distribution.
LeftProbability(Double) | Gets the fraction of values equal to or less than the given value.
MannWhitneyTest(Sample, Sample) | Tests whether the sample median is compatible with the mean of another sample.
Maximum | Gets the largest value in the sample.
MaximumLikelihoodFit(Func<(Of <<'(IList<(Of <<'(Double>)>>), Distribution>)>>), IList<(Of <<'(Double>)>>)) | Performs a maximum likelihood fit.
Mean | Gets the sample mean.
Median | Gets the sample median.
Minimum | Gets the smallest value in the sample.
Moment(Int32) | Computes the given sample moment.
MomentAboutMean(Int32) | Computes the given sample moment about its mean.
Name | Gets or sets the name of the sample.
OneWayAnovaTest(array<Sample>[]()[][]) | Performs a one-way ANOVA.
OneWayAnovaTest(IList<(Of <<'(Sample>)>>)) | Performs a one-way ANOVA.
PopulationMean | Gets an estimate of the population mean from the sample.
PopulationMoment(Int32) | Estimates the given population moment using the sample.
PopulationMomentAboutMean(Int32) | Estimates the given population moment about the mean using the sample.
PopulationStandardDeviation | Gets an estimate of the population standard deviation from the sample.
PopulationVariance | Gets an estimate of the population variance from the sample.
Remove(Double) | Removes a given value from the sample.
SignTest(Double) | Tests whether the sample median is compatible with the given reference value.
Skewness | Gets the sample skewness.
StandardDeviation | Gets the sample standard deviation.
StudentTTest(Double) | Tests whether the sample mean is compatible with the reference mean.
StudentTTest(Sample, Sample) | Tests whether one sample mean is compatible with another sample mean.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transform(Func<(Of <<'(Double, Double>)>>)) | Transforms all values using a user-supplied function.
Variance | Gets the sample variance.
ZTest(Double, Double) | Performs a z-test.

Remarks

A univariate sample is a data set which records one number for each independent observation. For example, data from a study which measured the weight of each subject could be stored in the Sample class. The class offers descriptive statistics for the sample, estimates of descriptive statistics of the underlying population distribution, and statistical tests to compare the sample distribution to other sample distributions or theoretical models.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..Sample

See Also

Meta.Numerics.Statistics Namespace


Sample Constructor

F#

Meta.Numerics Library
Sample Constructor

Overload List

Name | Description
Sample()()()() | Initializes a new, empty sample.
Sample(IEnumerable<(Of <<'(Double>)>>)) | Initializes a new sample from a list of values.
Sample(array<Double>[]()[][]) | Initializes a new sample from a list of values.
Sample(String) | Initializes a new, empty sample with the given name.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample Constructor

F#

Meta.Numerics Library
Sample Constructor
Initializes a new, empty sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample()
Public Sub New
public:
Sample()
new : unit -> Sample

See Also

Sample Class
Sample Overload
Meta.Numerics.Statistics Namespace


Sample Constructor (IEnumerable)

F#

Meta.Numerics Library
Sample Constructor (IEnumerable<(Of <(<'Double>)>)>)
Initializes a new sample from a list of values.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample(
    IEnumerable<double> values
)
Public Sub New (
    values As IEnumerable(Of Double)
)
public:
Sample(
    IEnumerable<double>^ values
)
new :
        values : IEnumerable<float> -> Sample

Parameters

values
IEnumerable <(Of <(<' Double >)>)>
Values to add to the sample.

Exceptions

Exception | Condition
System..::..ArgumentNullException | values is null.

See Also

Sample Class
Sample Overload
Meta.Numerics.Statistics Namespace


Sample Constructor (Double[])

F#

Meta.Numerics Library
Sample Constructor (array<Double>[]()[][])
Initializes a new sample from a list of values.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample(
    params double[] values
)
Public Sub New (
    ParamArray values As Double()
)
public:
Sample(
    ... array<double>^ values
)
new :
        values : float[] -> Sample

Parameters

values
array< Double >[]()[][]
Values to add to the sample.

See Also

Sample Class
Sample Overload
Meta.Numerics.Statistics Namespace


Sample Constructor (String)

F#

Meta.Numerics Library
Sample Constructor (String)
Initializes a new, empty sample with the given name.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample(
    string name
)
Public Sub New (
    name As String
)
public:
Sample(
    String^ name
)
new :
        name : string -> Sample

Parameters

name
String
The name of the sample.

See Also

Sample Class
Sample Overload
Meta.Numerics.Statistics Namespace


Sample Methods

F#

Meta.Numerics Library
Sample Methods

The Sample type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(IEnumerable<(Of <<'(Double>)>>)) | Adds multiple values to the sample.
Add(Double) | Adds a value to the sample.
Add(array<Double>[]()[][]) | Adds multiple values to the sample.
Clear()()()() | Remove all values from the sample.
Contains(Double) | Determines whether the sample contains the given value.
Copy()()()() | Copies the sample.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FisherFTest(Sample, Sample) | Tests whether the variance of two samples is compatible.
GetEnumerator()()()() | Gets an enumerator of sample values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Gets the sample value corresponding to a given percentile score.
KolmogorovSmirnovTest(Distribution) | Tests whether the sample is compatible with the given distribution.
KolmogorovSmirnovTest(Sample, Sample) | Tests whether the sample is compatible with another sample.
KruskalWallisTest(array<Sample>[]()[][]) | Performs a Kruskal-Wallis test on the given samples.
KruskalWallisTest(IList<(Of <<'(Sample>)>>)) | Performs a Kruskal-Wallis test on the given samples.
KuiperTest(Distribution) | Tests whether the sample is compatible with the given distribution.
LeftProbability(Double) | Gets the fraction of values equal to or less than the given value.
MannWhitneyTest(Sample, Sample) | Tests whether the sample median is compatible with the mean of another sample.
MaximumLikelihoodFit(Func<(Of <<'(IList<(Of <<'(Double>)>>), Distribution>)>>), IList<(Of <<'(Double>)>>)) | Performs a maximum likelihood fit.
Moment(Int32) | Computes the given sample moment.
MomentAboutMean(Int32) | Computes the given sample moment about its mean.
OneWayAnovaTest(array<Sample>[]()[][]) | Performs a one-way ANOVA.
OneWayAnovaTest(IList<(Of <<'(Sample>)>>)) | Performs a one-way ANOVA.
PopulationMoment(Int32) | Estimates the given population moment using the sample.
PopulationMomentAboutMean(Int32) | Estimates the given population moment about the mean using the sample.
Remove(Double) | Removes a given value from the sample.
SignTest(Double) | Tests whether the sample median is compatible with the given reference value.
StudentTTest(Double) | Tests whether the sample mean is compatible with the reference mean.
StudentTTest(Sample, Sample) | Tests whether one sample mean is compatible with another sample mean.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Transform(Func<(Of <<'(Double, Double>)>>)) | Transforms all values using a user-supplied function.
ZTest(Double, Double) | Performs a z-test.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Add Method

F#

Meta.Numerics Library
Sample..::Add Method

Overload List

Name | Description
Add(IEnumerable<(Of <<'(Double>)>>)) | Adds multiple values to the sample.
Add(Double) | Adds a value to the sample.
Add(array<Double>[]()[][]) | Adds multiple values to the sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Add Method (IEnumerable)

F#

Meta.Numerics Library
Sample..::Add Method (IEnumerable<(Of <(<'Double>)>)>)
Adds multiple values to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    IEnumerable<double> values
)
Public Sub Add (
    values As IEnumerable(Of Double)
)
public:
void Add(
    IEnumerable<double>^ values
)
member Add :
        values : IEnumerable<float> -> unit

Parameters

values
IEnumerable <(Of <(<' Double >)>)>
An enumerable set of the values to add.

See Also

Sample Class
Add Overload
Meta.Numerics.Statistics Namespace


Sample.Add Method (Double)

F#

Meta.Numerics Library
Sample..::Add Method (Double)
Adds a value to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    double value
)
Public Sub Add (
    value As Double
)
public:
virtual void Add(
    double value
) sealed
abstract Add :
        value : float -> unit
override Add :
        value : float -> unit

Parameters

value
Double
The value to add.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

Sample Class
Add Overload
Meta.Numerics.Statistics Namespace


Sample.Add Method (Double[])

F#

Meta.Numerics Library
Sample..::Add Method (array<Double>[]()[][])
Adds multiple values to the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    params double[] values
)
Public Sub Add (
    ParamArray values As Double()
)
public:
void Add(
    ... array<double>^ values
)
member Add :
        values : float[] -> unit

Parameters

values
array< Double >[]()[][]
An arbitrary number of values.

See Also

Sample Class
Add Overload
Meta.Numerics.Statistics Namespace


Sample.Clear Method

F#

Meta.Numerics Library
Sample..::Clear Method
Remove all values from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Contains Method

F#

Meta.Numerics Library
Sample..::Contains Method
Determines whether the sample contains the given value.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    double value
)
Public Function Contains (
    value As Double
) As Boolean
public:
virtual bool Contains(
    double value
) sealed
abstract Contains :
        value : float -> bool
override Contains :
        value : float -> bool

Parameters

value
Double
The value to check for.

Return Value

Boolean
True if the sample contains value, otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Copy Method

F#

Meta.Numerics Library
Sample..::Copy Method
Copies the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Sample Copy()
Public Function Copy As Sample
public:
Sample^ Copy()
member Copy : unit -> Sample

Return Value

Sample
An independent copy of the sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.FisherFTest Method

F#

Meta.Numerics Library
Sample..::FisherFTest Method
Tests whether the variance of two samples is compatible.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult FisherFTest(
    Sample a,
    Sample b
)
Public Shared Function FisherFTest (
    a As Sample,
    b As Sample
) As TestResult
public:
static TestResult^ FisherFTest(
    Sample^ a,
    Sample^ b
)
static member FisherFTest :
        a : Sample *
        b : Sample -> TestResult

Parameters

a
Sample
The first sample.
b
Sample
The second sample.

Return Value

TestResult
The result of the test.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.GetEnumerator Method

F#

Meta.Numerics Library
Sample..::GetEnumerator Method
Gets an enumerator of sample values.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public IEnumerator<double> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Double)
public:
virtual IEnumerator<double>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<float>
override GetEnumerator : unit -> IEnumerator<float>

Return Value

IEnumerator <(Of <(<' Double >)>)>
An enumerator of sample values.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.InverseLeftProbability Method

F#

Meta.Numerics Library
Sample..::InverseLeftProbability Method
Gets the sample value corresponding to a given percentile score.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double InverseLeftProbability(
    double P
)
Public Function InverseLeftProbability (
    P As Double
) As Double
public:
double InverseLeftProbability(
    double P
)
member InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The percentile, which must lie between zero and one.

Return Value

Double
The corresponding value.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].
Meta.Numerics.Statistics..::..InsufficientDataException | Count is less than two.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.KolmogorovSmirnovTest Method

F#

Meta.Numerics Library
Sample..::KolmogorovSmirnovTest Method

Overload List

Name | Description
KolmogorovSmirnovTest(Distribution) | Tests whether the sample is compatible with the given distribution.
KolmogorovSmirnovTest(Sample, Sample) | Tests whether the sample is compatible with another sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.KolmogorovSmirnovTest Method (Distribution)

F#

Meta.Numerics Library
Sample..::KolmogorovSmirnovTest Method (Distribution)
Tests whether the sample is compatible with the given distribution.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult KolmogorovSmirnovTest(
    Distribution distribution
)
Public Function KolmogorovSmirnovTest (
    distribution As Distribution
) As TestResult
public:
TestResult^ KolmogorovSmirnovTest(
    Distribution^ distribution
)
member KolmogorovSmirnovTest :
        distribution : Distribution -> TestResult

Parameters

distribution
Distribution
The test distribution.

Return Value

TestResult
The test result. The test statistic is the D statistic and the likelyhood is the right probability to obtain a value of D as large or larger than the one obtained.

Remarks

The null hypothesis of the KS test is that the sample is drawn from the given continuous distribution. The test statsitic D is the maximum deviation of the sample's emperical distribution function (EDF) from the distribution's cumulative distribution function (CDF). A high value of the test statistic, corresponding to a low right tail probability, indicates that the sample distribution disagrees with the given distribution to a degree unlikely to arise from statistical fluctuations.

For small sample sizes, we compute the null distribution of D exactly. For large sample sizes, we use an accurate asympotitc approximation. Therefore it is safe to use this method for all sample sizes.

Exceptions

Exception | Condition
System..::..ArgumentNullException | distribution is null.

See Also

Sample Class
KolmogorovSmirnovTest Overload
Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics.Distributions..::..KolmogorovDistribution
http://en.wikipedia.org/wiki/Kolmogorov-Smirnov_test


Sample.KolmogorovSmirnovTest Method (Sample, Sample)

F#

Meta.Numerics Library
Sample..::KolmogorovSmirnovTest Method (Sample, Sample)
Tests whether the sample is compatible with another sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult KolmogorovSmirnovTest(
    Sample a,
    Sample b
)
Public Shared Function KolmogorovSmirnovTest (
    a As Sample,
    b As Sample
) As TestResult
public:
static TestResult^ KolmogorovSmirnovTest(
    Sample^ a,
    Sample^ b
)
static member KolmogorovSmirnovTest :
        a : Sample *
        b : Sample -> TestResult

Parameters

a
Sample
One sample.
b
Sample
The other sample.

Return Value

TestResult
The test result. The test statistic is the D statistic and the likelyhood is the right probability to obtain a value of D as large or larger than the one obtained.

Exceptions

Exception | Condition
System..::..ArgumentNullException | a or b is null.
Meta.Numerics.Statistics..::..InsufficientDataException | One or both of the samples is empty.

See Also

Sample Class
KolmogorovSmirnovTest Overload
Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Kolmogorov-Smirnov_test


Sample.KruskalWallisTest Method

F#

Meta.Numerics Library
Sample..::KruskalWallisTest Method

Overload List

Name | Description
KruskalWallisTest(array<Sample>[]()[][]) | Performs a Kruskal-Wallis test on the given samples.
KruskalWallisTest(IList<(Of <<'(Sample>)>>)) | Performs a Kruskal-Wallis test on the given samples.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.KruskalWallisTest Method (Sample[])

F#

Meta.Numerics Library
Sample..::KruskalWallisTest Method (array<Sample>[]()[][])
Performs a Kruskal-Wallis test on the given samples.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult KruskalWallisTest(
    params Sample[] samples
)
Public Shared Function KruskalWallisTest (
    ParamArray samples As Sample()
) As TestResult
public:
static TestResult^ KruskalWallisTest(
    ... array<Sample^>^ samples
)
static member KruskalWallisTest :
        samples : Sample[] -> TestResult

Parameters

samples
array< Sample >[]()[][]
The set of samples to compare.

Return Value

TestResult
The result of the test.

See Also

Sample Class
KruskalWallisTest Overload
Meta.Numerics.Statistics Namespace


Sample.KruskalWallisTest Method (IList)

F#

Meta.Numerics Library
Sample..::KruskalWallisTest Method (IList<(Of <(<'Sample>)>)>)
Performs a Kruskal-Wallis test on the given samples.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult KruskalWallisTest(
    IList<Sample> samples
)
Public Shared Function KruskalWallisTest (
    samples As IList(Of Sample)
) As TestResult
public:
static TestResult^ KruskalWallisTest(
    IList<Sample^>^ samples
)
static member KruskalWallisTest :
        samples : IList<Sample> -> TestResult

Parameters

samples
IList <(Of <(<' Sample >)>)>
The set of samples to compare.

Return Value

TestResult
The result of the test.

Remarks

Kruskal-Wallis tests for differences between the samples. It is a non-parametric alternative to the one-way ANOVA (OneWayAnovaTest(array<Sample>[]()[][])).

The test is essentially a one-way ANOVA performed on the ranks of sample values instead of the sample values themselves.

A Kruskal-Wallis test on two samples is equivilent to a Mann-Whitney test (see MannWhitneyTest(Sample, Sample)).

See Also

Sample Class
KruskalWallisTest Overload
Meta.Numerics.Statistics Namespace


Sample.KuiperTest Method

F#

Meta.Numerics Library
Sample..::KuiperTest Method
Tests whether the sample is compatible with the given distribution.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult KuiperTest(
    Distribution distribution
)
Public Function KuiperTest (
    distribution As Distribution
) As TestResult
public:
TestResult^ KuiperTest(
    Distribution^ distribution
)
member KuiperTest :
        distribution : Distribution -> TestResult

Parameters

distribution
Distribution
The test distribution.

Return Value

TestResult
The test result. The test statistic is the V statistic and the likelyhood is the right probability to obtain a value of V as large or larger than the one obtained.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Kuiper%27s_test


Sample.LeftProbability Method

F#

Meta.Numerics Library
Sample..::LeftProbability Method
Gets the fraction of values equal to or less than the given value.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double LeftProbability(
    double value
)
Public Function LeftProbability (
    value As Double
) As Double
public:
double LeftProbability(
    double value
)
member LeftProbability :
        value : float -> float

Parameters

value
Double
The reference value.

Return Value

Double
The fraction of values in the sample that are less than or equal to the given reference value.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.MannWhitneyTest Method

F#

Meta.Numerics Library
Sample..::MannWhitneyTest Method
Tests whether the sample median is compatible with the mean of another sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult MannWhitneyTest(
    Sample a,
    Sample b
)
Public Shared Function MannWhitneyTest (
    a As Sample,
    b As Sample
) As TestResult
public:
static TestResult^ MannWhitneyTest(
    Sample^ a,
    Sample^ b
)
static member MannWhitneyTest :
        a : Sample *
        b : Sample -> TestResult

Parameters

a
Sample
The fisrt sample.
b
Sample
The second sample.

Return Value

TestResult
The result of the test.

Remarks

The Mann-Whitney test is a non-parametric alternative to Student's t-test. Essentially, it supposes that the medians of the two samples are equal and tests the likelihood of this null hypothesis. Unlike the t-test, it does not assume that the sample distributions are normal.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Mann-Whitney_U_test


Sample.MaximumLikelihoodFit Method

F#

Meta.Numerics Library
Sample..::MaximumLikelihoodFit Method
Performs a maximum likelihood fit.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult MaximumLikelihoodFit(
    Func<IList<double>, Distribution> factory,
    IList<double> start
)
Public Function MaximumLikelihoodFit (
    factory As Func(Of IList(Of Double), Distribution),
    start As IList(Of Double)
) As FitResult
public:
FitResult^ MaximumLikelihoodFit(
    Func<IList<double>^, Distribution^>^ factory,
    IList<double>^ start
)
member MaximumLikelihoodFit :
        factory : Func<IList<float>, Distribution> *
        start : IList<float> -> FitResult

Parameters

factory
Func <(Of <(<' IList <(Of <(<' Double >)>)>, Distribution >)>)>
A function that returns a distribution when given its defining parameters.
start
IList <(Of <(<' Double >)>)>
An initial guess for the defining parameters.

Return Value

FitResult
The result of the fit, containg the parameters that result in the best fit, covariance matrix among those parameters, and a test of the goodness of fit.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
http://en.wikipedia.org/wiki/Maximum_likelihood


Sample.Moment Method

F#

Meta.Numerics Library
Sample..::Moment Method
Computes the given sample moment.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Moment(
    int n
)
Public Function Moment (
    n As Integer
) As Double
public:
double Moment(
    int n
)
member Moment :
        n : int -> float

Parameters

n
Int32
The order of the moment to compute.

Return Value

Double
The nth moment of the sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.MomentAboutMean Method

F#

Meta.Numerics Library
Sample..::MomentAboutMean Method
Computes the given sample moment about its mean.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double MomentAboutMean(
    int n
)
Public Function MomentAboutMean (
    n As Integer
) As Double
public:
double MomentAboutMean(
    int n
)
member MomentAboutMean :
        n : int -> float

Parameters

n
Int32
The order of the moment to compute.

Return Value

Double
The nth moment about its mean of the sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.OneWayAnovaTest Method

F#

Meta.Numerics Library
Sample..::OneWayAnovaTest Method

Overload List

Name | Description
OneWayAnovaTest(array<Sample>[]()[][]) | Performs a one-way ANOVA.
OneWayAnovaTest(IList<(Of <<'(Sample>)>>)) | Performs a one-way ANOVA.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.OneWayAnovaTest Method (Sample[])

F#

Meta.Numerics Library
Sample..::OneWayAnovaTest Method (array<Sample>[]()[][])
Performs a one-way ANOVA.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static OneWayAnovaResult OneWayAnovaTest(
    params Sample[] samples
)
Public Shared Function OneWayAnovaTest (
    ParamArray samples As Sample()
) As OneWayAnovaResult
public:
static OneWayAnovaResult^ OneWayAnovaTest(
    ... array<Sample^>^ samples
)
static member OneWayAnovaTest :
        samples : Sample[] -> OneWayAnovaResult

Parameters

samples
array< Sample >[]()[][]
The samples to compare.

Return Value

OneWayAnovaResult
The result of an F-test comparing the between-group variance to the within-group variance.

Remarks

The one-way ANOVA is an extension of the Student t-test (StudentTTest(Sample, Sample)) to more than two groups. The test's null hypothesis is that all the groups' data are drawn from the same distribution. If the null hypothesis is rejected, it indicates that at least one of the groups differs significantly from the others.

Given more than two groups, you should use an ANOVA to test for differences in the means of the groups rather than perform multiple t-tests. The reason is that each t-test incurs a small risk of a false positive, so multiple t-tests increase the total risk of a false positive. For example, given a 95% confidence requirement, there is only a 5% chance that a t-test will incorrectly diagnose a significant difference. But given 5 samples, there are 5 * 4 /2 = 10 t-tests to be performed, giving about a 40% chance that at least one of them will incorrectly diagnose a significant difference! The ANOVA avoids the accumulation of risk by performing a single test at the required confidence level to test for any significant differences between the groups.

A one-way ANOVA performed on just two samples is equivilent to a t-test (StudentTTest(Sample, Sample)).

ANOVA is an acronym for "Analysis of Variance". Do not be confused by the name and by the use of a ratio-of-variances test statistic: an ANOVA is primarily (although not exclusively) sensitive to changes in the mean between samples. The variances being compared by the test are not the variances of the individual samples; instead the test is comparing the variance of all samples considered together as one single sample to the variances of the samples considered individually. If the means of some groups differ significantly, then the variance of the unified sample will be much larger than the vairiances of the individual samples, and the test will signal a significant difference. Thus the test uses variance as a tool to detect shifts in mean, not because it is interesed in the individual sample variances per se.

ANOVA is most appropriate when the sample data are approximately normal and the samples are distinguished by a nominal variable. For example, given a random sampling of the ages of members of five different political parties, a one-way ANOVA would be an appropriate test of the whether the different parties tend to attract different-aged memberships.

On the other hand, given data on the incomes and vacation lengths of a large number of people, dividing the people into five income quintiles and performing a one-way ANOVA to compare the vacation day distribution of each quintile would not be an appropriate way to test the hypothesis that richer people take longer vacations. Since income is a cardinal variable, it would be better to in this case of put the data into a BivariateSample and perform a test of association, such as a PearsonRTest()()()(), SpearmanRhoTest()()()(), or KendallTauTest()()()() between the two variables. If you have measurements of additional variables for each indiviual, a LinearRegression(Int32) analysis would allow you to adjust for confounding effects of the other variables.

See Also

Sample Class
OneWayAnovaTest Overload
Meta.Numerics.Statistics Namespace


Sample.OneWayAnovaTest Method (IList)

F#

Meta.Numerics Library
Sample..::OneWayAnovaTest Method (IList<(Of <(<'Sample>)>)>)
Performs a one-way ANOVA.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static OneWayAnovaResult OneWayAnovaTest(
    IList<Sample> samples
)
Public Shared Function OneWayAnovaTest (
    samples As IList(Of Sample)
) As OneWayAnovaResult
public:
static OneWayAnovaResult^ OneWayAnovaTest(
    IList<Sample^>^ samples
)
static member OneWayAnovaTest :
        samples : IList<Sample> -> OneWayAnovaResult

Parameters

samples
IList <(Of <(<' Sample >)>)>
The samples to compare.

Return Value

OneWayAnovaResult
The result of the test.

Remarks

For detailed information, see the variable argument overload.

See Also

Sample Class
OneWayAnovaTest Overload
Meta.Numerics.Statistics Namespace


Sample.PopulationMoment Method

F#

Meta.Numerics Library
Sample..::PopulationMoment Method
Estimates the given population moment using the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationMoment(
    int n
)
Public Function PopulationMoment (
    n As Integer
) As UncertainValue
public:
UncertainValue PopulationMoment(
    int n
)
member PopulationMoment :
        n : int -> UncertainValue

Parameters

n
Int32
The order of the moment.

Return Value

UncertainValue
An estimate of the nth moment of the population.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.PopulationMomentAboutMean Method

F#

Meta.Numerics Library
Sample..::PopulationMomentAboutMean Method
Estimates the given population moment about the mean using the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationMomentAboutMean(
    int n
)
Public Function PopulationMomentAboutMean (
    n As Integer
) As UncertainValue
public:
UncertainValue PopulationMomentAboutMean(
    int n
)
member PopulationMomentAboutMean :
        n : int -> UncertainValue

Parameters

n
Int32
The order of the moment.

Return Value

UncertainValue
An estimate, with uncertainty, of the nth moment about the mean of the underlying population.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | n is negative.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Remove Method

F#

Meta.Numerics Library
Sample..::Remove Method
Removes a given value from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    double value
)
Public Function Remove (
    value As Double
) As Boolean
public:
virtual bool Remove(
    double value
) sealed
abstract Remove :
        value : float -> bool
override Remove :
        value : float -> bool

Parameters

value
Double
The value to remove.

Return Value

Boolean
True if the value was found and removed, otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.SignTest Method

F#

Meta.Numerics Library
Sample..::SignTest Method
Tests whether the sample median is compatible with the given reference value.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult SignTest(
    double referenceMedian
)
Public Function SignTest (
    referenceMedian As Double
) As TestResult
public:
TestResult^ SignTest(
    double referenceMedian
)
member SignTest :
        referenceMedian : float -> TestResult

Parameters

referenceMedian
Double
The reference median.

Return Value

TestResult
The result of the test.

Remarks

The sign test is a non-parametric alternative to the Student t-test (StudentTTest(Double)). It tests whether the sample is consistent with the given refernce median.

The null hypothesis for the test is that the median of the underlying population from which the sample is drawn is the reference median. The test statistic is simply number of sample values that lie above the median. Since each sample value is equally likely to be below or above the population median, each draw is an independent Bernoulli trial, and the total number of values above the population median is distributed accordng to a binomial distribution (BinomialDistribution).

The left probability of the test result is the chance of the sample median being so low, assuming the sample to have been drawn from a population with the reference median. The right probability of the test result is the chance of the sample median being so high, assuming the sample to have been drawn from a population with the reference median.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
Sample..::..StudentTTest(Double)


Sample.StudentTTest Method

F#

Meta.Numerics Library
Sample..::StudentTTest Method

Overload List

Name | Description
StudentTTest(Double) | Tests whether the sample mean is compatible with the reference mean.
StudentTTest(Sample, Sample) | Tests whether one sample mean is compatible with another sample mean.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.StudentTTest Method (Double)

F#

| Example | See Also
Meta.Numerics Library
Sample..::StudentTTest Method (Double)
Tests whether the sample mean is compatible with the reference mean.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult StudentTTest(
    double referenceMean
)
Public Function StudentTTest (
    referenceMean As Double
) As TestResult
public:
TestResult^ StudentTTest(
    double referenceMean
)
member StudentTTest :
        referenceMean : float -> TestResult

Parameters

referenceMean
Double
The reference mean.

Return Value

TestResult
The result of the test. The test statistic is a t-value. If t > 0, the one-sided likelyhood to obtain a greater value under the null hypothesis is the (right) propability of that value. If t < 0, the corresponding one-sided likelyhood is the (left) probability of that value. The two-sided likelyhood to obtain a t-value as far or farther from zero as the value obtained is just twice the one-sided likelyhood.

Remarks

The test statistic of Student's t-test is the difference between the sample mean and the reference mean, measured in units of the sample mean uncertainty. Under the null hypothesis that the sample was drawn from a normally distributed population with the given reference mean, this statistic can be shown to follow a Student distribution (StudentDistribution). If t is far from zero, with correspondingly small left or right tail probability, then the sample is unlikely to have been drawn from a population with the given reference mean.

Because the distribution of a t-statistic assumes a normally distributed population, this test should only be used only on sample data compatible with a normal distribution. The sign test (SignTest(Double)) is a non-parametric alternative that can be used to test the compatibility of the sample median with an assumed population median.

Examples

In some country, the legal limit blood alcohol limit for drivers is 80 on some scale. Because they have noticed that the results given by their measuring device fluctuate, the police perform three seperate measurements on a suspected drunk driver. They obtain the results 81, 84, and 93. They argue that, because all three results exceed the limit, the court should be very confident that the driver's blood alcohol level did, in fact, exceed the legal limit. You are the driver's lawyer. Can you make an argument to that the court shouldn't be so sure?

Here is some code that computes the probability of obtaining such high measured values, assuming that the true level is exactly 80.

C# Copy image Copy
Sample values = new Sample();
values.Add(81, 84, 93);
TestResult result = values.StudentTTest(80);
return(result.RightProbability);

What level of statistical confidence do you think should a court require in order to pronounce a defendant guilty?

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer than two data points in the sample.

See Also

Sample Class
StudentTTest Overload
Meta.Numerics.Statistics Namespace
Meta.Numerics.Statistics.Distributions..::..StudentDistribution


Sample.StudentTTest Method (Sample, Sample)

F#

Meta.Numerics Library
Sample..::StudentTTest Method (Sample, Sample)
Tests whether one sample mean is compatible with another sample mean.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static TestResult StudentTTest(
    Sample a,
    Sample b
)
Public Shared Function StudentTTest (
    a As Sample,
    b As Sample
) As TestResult
public:
static TestResult^ StudentTTest(
    Sample^ a,
    Sample^ b
)
static member StudentTTest :
        a : Sample *
        b : Sample -> TestResult

Parameters

a
Sample
The first sample, which must contain at least two entries.
b
Sample
The second sample, which must contain at least two entries.

Return Value

TestResult
The result of an (equal-variance) Student t-test.

See Also

Sample Class
StudentTTest Overload
Meta.Numerics.Statistics Namespace


Sample.Transform Method

F#

Meta.Numerics Library
Sample..::Transform Method
Transforms all values using a user-supplied function.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Transform(
    Func<double, double> transformFunction
)
Public Sub Transform (
    transformFunction As Func(Of Double, Double)
)
public:
void Transform(
    Func<double, double>^ transformFunction
)
member Transform :
        transformFunction : Func<float, float> -> unit

Parameters

transformFunction
Func <(Of <(<' Double, Double >)>)>
The function used to transform the values, which must not be null.

Remarks

For example, to replace all values with their logarithms, apply a transform using Log(Double).

If the supplied transform function throws an excaption, or returns infinite or NaN values, the transformation may be incomplete or the data corrupted.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.ZTest Method

F#

| Example | See Also
Meta.Numerics Library
Sample..::ZTest Method
Performs a z-test.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TestResult ZTest(
    double referenceMean,
    double referenceStandardDeviation
)
Public Function ZTest (
    referenceMean As Double,
    referenceStandardDeviation As Double
) As TestResult
public:
TestResult^ ZTest(
    double referenceMean,
    double referenceStandardDeviation
)
member ZTest :
        referenceMean : float *
        referenceStandardDeviation : float -> TestResult

Parameters

referenceMean
Double
The mean of the comparison population.
referenceStandardDeviation
Double
The standard deviation of the comparison population.

Return Value

TestResult
A test result indicating whether the sample mean is significantly different from that of the comparison population.

Remarks

A z-test determines whether the sample is compatible with a normal population with known mean and standard deviation. In most cases, Student's t-test (StudentTTest(Double)), which does not assume a known population standard deviation, is more appropriate.

Examples

Suppose a standardized test exists, for which it is known that the mean score is 100 and the standard deviation is 15 across the entire population. The test is administered to a small sample of a subpopulation, who obtain a mean sample score of 95. You can use the z-test to determine how likely it is that the subpopulation mean really is lower than the population mean, that is that their slightly lower mean score in your sample is not merely a fluke.

Exceptions

Exception | Condition
Meta.Numerics.Statistics..::..InsufficientDataException | Count is zero.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
Sample..::..StudentTTest(Double)


Sample Properties

F#

Meta.Numerics Library
Sample Properties

The Sample type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the number of values in the sample.
InterquartileRange | Gets the interquartile range of sample measurmements.
IsReadOnly | Gets a value indicating whether the sample is read-only.
Maximum | Gets the largest value in the sample.
Mean | Gets the sample mean.
Median | Gets the sample median.
Minimum | Gets the smallest value in the sample.
Name | Gets or sets the name of the sample.
PopulationMean | Gets an estimate of the population mean from the sample.
PopulationStandardDeviation | Gets an estimate of the population standard deviation from the sample.
PopulationVariance | Gets an estimate of the population variance from the sample.
Skewness | Gets the sample skewness.
StandardDeviation | Gets the sample standard deviation.
Variance | Gets the sample variance.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Count Property

F#

Meta.Numerics Library
Sample..::Count Property
Gets the number of values in the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.InterquartileRange Property

F#

Meta.Numerics Library
Sample..::InterquartileRange Property
Gets the interquartile range of sample measurmements.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Interval InterquartileRange { get; }
Public ReadOnly Property InterquartileRange As Interval
    Get
public:
property Interval InterquartileRange {
    Interval get ();
}
member InterquartileRange : Interval with get

Property Value

Interval

Remarks

The interquartile range is the interval between the 25th and the 75th percentile.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
Sample..::..InverseLeftProbability(Double)


Sample.IsReadOnly Property

F#

Meta.Numerics Library
Sample..::IsReadOnly Property
Gets a value indicating whether the sample is read-only.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Maximum Property

F#

Meta.Numerics Library
Sample..::Maximum Property
Gets the largest value in the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Maximum { get; }
Public ReadOnly Property Maximum As Double
    Get
public:
property double Maximum {
    double get ();
}
member Maximum : float with get

Property Value

Double

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Mean Property

F#

Meta.Numerics Library
Sample..::Mean Property
Gets the sample mean.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Mean { get; }
Public ReadOnly Property Mean As Double
    Get
public:
property double Mean {
    double get ();
}
member Mean : float with get

Property Value

Double

Remarks

The mean is the average of all values in the sample.

See Also

Sample Class
Meta.Numerics.Statistics Namespace
Sample..::..PopulationMean


Sample.Median Property

F#

Meta.Numerics Library
Sample..::Median Property
Gets the sample median.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Median { get; }
Public ReadOnly Property Median As Double
    Get
public:
property double Median {
    double get ();
}
member Median : float with get

Property Value

Double

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Minimum Property

F#

Meta.Numerics Library
Sample..::Minimum Property
Gets the smallest value in the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Minimum { get; }
Public ReadOnly Property Minimum As Double
    Get
public:
property double Minimum {
    double get ();
}
member Minimum : float with get

Property Value

Double

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Name Property

F#

Meta.Numerics Library
Sample..::Name Property
Gets or sets the name of the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.PopulationMean Property

F#

Meta.Numerics Library
Sample..::PopulationMean Property
Gets an estimate of the population mean from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationMean { get; }
Public ReadOnly Property PopulationMean As UncertainValue
    Get
public:
property UncertainValue PopulationMean {
    UncertainValue get ();
}
member PopulationMean : UncertainValue with get

Property Value

UncertainValue

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.PopulationStandardDeviation Property

F#

Meta.Numerics Library
Sample..::PopulationStandardDeviation Property
Gets an estimate of the population standard deviation from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationStandardDeviation { get; }
Public ReadOnly Property PopulationStandardDeviation As UncertainValue
    Get
public:
property UncertainValue PopulationStandardDeviation {
    UncertainValue get ();
}
member PopulationStandardDeviation : UncertainValue with get

Property Value

UncertainValue

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.PopulationVariance Property

F#

Meta.Numerics Library
Sample..::PopulationVariance Property
Gets an estimate of the population variance from the sample.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue PopulationVariance { get; }
Public ReadOnly Property PopulationVariance As UncertainValue
    Get
public:
property UncertainValue PopulationVariance {
    UncertainValue get ();
}
member PopulationVariance : UncertainValue with get

Property Value

UncertainValue

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Skewness Property

F#

Meta.Numerics Library
Sample..::Skewness Property
Gets the sample skewness.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Skewness { get; }
Public ReadOnly Property Skewness As Double
    Get
public:
property double Skewness {
    double get ();
}
member Skewness : float with get

Property Value

Double

Remarks

Skewness is the third central moment, measured in units of the appropriate power of the standard deviation.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.StandardDeviation Property

F#

Meta.Numerics Library
Sample..::StandardDeviation Property
Gets the sample standard deviation.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double StandardDeviation { get; }
Public ReadOnly Property StandardDeviation As Double
    Get
public:
property double StandardDeviation {
    double get ();
}
member StandardDeviation : float with get

Property Value

Double

Remarks

Note this is the actual standard deviation of the sample values, not the infered standard deviation of the underlying population; to obtain the latter use PopulationStandardDeviation.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


Sample.Variance Property

F#

Meta.Numerics Library
Sample..::Variance Property
Gets the sample variance.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Variance { get; }
Public ReadOnly Property Variance As Double
    Get
public:
property double Variance {
    double get ();
}
member Variance : float with get

Property Value

Double

Remarks

Note this is the actual variance of the sample values, not the infered variance of the underlying population; to obtain the latter use PopulationVariance.

See Also

Sample Class
Meta.Numerics.Statistics Namespace


TestResult Class

F#

| Members | See Also
Meta.Numerics Library
TestResult Class
Represents the result of a statistical test.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class TestResult
Public Class TestResult
public ref class TestResult
type TestResult =  class end

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Distribution | Gets the distribution of the test statistic under the null hypothesis.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LeftProbability | Get the probability, under the null hypothesis, of obtaining a test statistic value as small or smaller than the one actually obtained.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
RightProbability | Get the probability, under the null hypothesis, of obtaining a test statistic value as large as or larger than the one actually obtained.
Statistic | Gets the value of the test statistic.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

A statistical test compares a data set to a model (or to another data set) and computes a single, real number, called the test statistic, which measures how much the data set differs from model (or the other data set). The key to a useful statistical test is that the distribution of the test statistic, under the assumption that the model actually explains the data (or that the other data set is drawn from the same distribution) is known. This assumption is called the null hypothesis.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..TestResult

See Also

Meta.Numerics.Statistics Namespace


TestResult Methods

F#

Meta.Numerics Library
TestResult Methods

The TestResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


TestResult Properties

F#

Meta.Numerics Library
TestResult Properties

The TestResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Distribution | Gets the distribution of the test statistic under the null hypothesis.
LeftProbability | Get the probability, under the null hypothesis, of obtaining a test statistic value as small or smaller than the one actually obtained.
RightProbability | Get the probability, under the null hypothesis, of obtaining a test statistic value as large as or larger than the one actually obtained.
Statistic | Gets the value of the test statistic.

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


TestResult.Distribution Property

F#

Meta.Numerics Library
TestResult..::Distribution Property
Gets the distribution of the test statistic under the null hypothesis.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public Distribution Distribution { get; }
Public ReadOnly Property Distribution As Distribution
    Get
public:
property Distribution^ Distribution {
    Distribution^ get ();
}
member Distribution : Distribution with get

Property Value

Distribution

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


TestResult.LeftProbability Property

F#

Meta.Numerics Library
TestResult..::LeftProbability Property
Get the probability, under the null hypothesis, of obtaining a test statistic value as small or smaller than the one actually obtained.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double LeftProbability { get; }
Public ReadOnly Property LeftProbability As Double
    Get
public:
property double LeftProbability {
    double get ();
}
member LeftProbability : float with get

Property Value

Double

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


TestResult.RightProbability Property

F#

Meta.Numerics Library
TestResult..::RightProbability Property
Get the probability, under the null hypothesis, of obtaining a test statistic value as large as or larger than the one actually obtained.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double RightProbability { get; }
Public ReadOnly Property RightProbability As Double
    Get
public:
property double RightProbability {
    double get ();
}
member RightProbability : float with get

Property Value

Double

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


TestResult.Statistic Property

F#

Meta.Numerics Library
TestResult..::Statistic Property
Gets the value of the test statistic.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Statistic { get; }
Public ReadOnly Property Statistic As Double
    Get
public:
property double Statistic {
    double get ();
}
member Statistic : float with get

Property Value

Double

See Also

TestResult Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement Generic Class

F#

| Members | See Also
Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Class
Represents an experimental data point that is a function of an arbitrary variable.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class UncertainMeasurement<T>

Public Class UncertainMeasurement(Of T)
generic<typename T>
public ref class UncertainMeasurement
type UncertainMeasurement<'T> =  class end

Type Parameters

T
The type of the ordinate (independent variable) characterizing the data point.

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UncertainMeasurement<(Of <(<'T>)>)>(T, UncertainValue) | Initializes a new data point with the given values for the ordinate and uncertain abcissa.
UncertainMeasurement<(Of <(<'T>)>)>(T, Double, Double) | Initializes a new data point with the given values for the ordinate, abcissa, and uncertainty.
Equality(UncertainMeasurement<(Of <<'(T>)>>), UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether two data points are equal.
Equals(Object) | Determines whether the object represents the same data point. (Overrides Object..::..Equals(Object).)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Gets a hash code for the data point. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Inequality(UncertainMeasurement<(Of <<'(T>)>>), UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether two data points are not equal.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
X | Gets or sets the value of the ordinate (independent variable).
Y | Gets or sets the uncertain value of the abcissa (the depdent variable).

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..UncertainMeasurement<(Of <(<'T>)>)>

See Also

Meta.Numerics.Statistics Namespace


UncertainMeasurement Constructor

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Constructor

Overload List

Name | Description
UncertainMeasurement<(Of <(<'T>)>)>(T, UncertainValue) | Initializes a new data point with the given values for the ordinate and uncertain abcissa.
UncertainMeasurement<(Of <(<'T>)>)>(T, Double, Double) | Initializes a new data point with the given values for the ordinate, abcissa, and uncertainty.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement Constructor (T, UncertainValue)

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Constructor (T, UncertainValue)
Initializes a new data point with the given values for the ordinate and uncertain abcissa.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainMeasurement(
    T x,
    UncertainValue y
)
Public Sub New (
    x As T,
    y As UncertainValue
)
public:
UncertainMeasurement(
    T x,
    UncertainValue y
)
new :
        x : 'T *
        y : UncertainValue -> UncertainMeasurement

Parameters

x
T
The ordinate.
y
UncertainValue
The abcissa.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
UncertainMeasurement<(Of <(<'T>)>)> Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurement Constructor (T, Double, Double)

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Constructor (T, Double, Double)
Initializes a new data point with the given values for the ordinate, abcissa, and uncertainty.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainMeasurement(
    T x,
    double y,
    double dy
)
Public Sub New (
    x As T,
    y As Double,
    dy As Double
)
public:
UncertainMeasurement(
    T x,
    double y,
    double dy
)
new :
        x : 'T *
        y : float *
        dy : float -> UncertainMeasurement

Parameters

x
T
The ordinate.
y
Double
The best estimate of the abcissa.
dy
Double
The uncertainty in the abcissa.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
UncertainMeasurement<(Of <(<'T>)>)> Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurement Methods

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Methods

The UncertainMeasurement<(Of <(<'T>)>)> generic type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the object represents the same data point. (Overrides Object..::..Equals(Object).)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Gets a hash code for the data point. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.Equals Method

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::Equals Method
Determines whether the object represents the same data point.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Object
The object.

Return Value

Boolean
True if the object represents the same data point, otherwise false.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.GetHashCode Method

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::GetHashCode Method
Gets a hash code for the data point.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A hash code for the data point.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement Operators

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Operators

The UncertainMeasurement<(Of <(<'T>)>)> generic type exposes the following operators.

Operators

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equality(UncertainMeasurement<(Of <<'(T>)>>), UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether two data points are equal.
Inequality(UncertainMeasurement<(Of <<'(T>)>>), UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether two data points are not equal.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.Equality Operator

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::Equality Operator
Determines whether two data points are equal.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator ==(
    UncertainMeasurement<T> d1,
    UncertainMeasurement<T> d2
)
Public Shared Operator = (
    d1 As UncertainMeasurement(Of T),
    d2 As UncertainMeasurement(Of T)
) As Boolean
public:
static bool operator ==(
    UncertainMeasurement<T>^ d1,
    UncertainMeasurement<T>^ d2
)
static let inline (=)
        d1 : UncertainMeasurement<'T> *
        d2 : UncertainMeasurement<'T>  : bool

Parameters

d1
UncertainMeasurement <(Of <(<' T >)>)>
The first data point.
d2
UncertainMeasurement <(Of <(<' T >)>)>
The second data point.

Return Value

Boolean
True if the data points are equal, otherwise false.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.Inequality Operator

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::Inequality Operator
Determines whether two data points are not equal.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static bool operator !=(
    UncertainMeasurement<T> d1,
    UncertainMeasurement<T> d2
)
Public Shared Operator <> (
    d1 As UncertainMeasurement(Of T),
    d2 As UncertainMeasurement(Of T)
) As Boolean
public:
static bool operator !=(
    UncertainMeasurement<T>^ d1,
    UncertainMeasurement<T>^ d2
)
static let inline (<>)
        d1 : UncertainMeasurement<'T> *
        d2 : UncertainMeasurement<'T>  : bool

Parameters

d1
UncertainMeasurement <(Of <(<' T >)>)>
The first data point.
d2
UncertainMeasurement <(Of <(<' T >)>)>
The second data point.

Return Value

Boolean
True if the data points are not equal, otherwise false.

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement Properties

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)> Properties

The UncertainMeasurement<(Of <(<'T>)>)> generic type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
X | Gets or sets the value of the ordinate (independent variable).
Y | Gets or sets the uncertain value of the abcissa (the depdent variable).

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.X Property

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::X Property
Gets or sets the value of the ordinate (independent variable).

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public T X { get; }
Public ReadOnly Property X As T
    Get
public:
property T X {
    T get ();
}
member X : 'T with get

Property Value

T

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurement.Y Property

F#

Meta.Numerics Library
UncertainMeasurement<(Of <(<'T>)>)>..::Y Property
Gets or sets the uncertain value of the abcissa (the depdent variable).

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainValue Y { get; }
Public ReadOnly Property Y As UncertainValue
    Get
public:
property UncertainValue Y {
    UncertainValue get ();
}
member Y : UncertainValue with get

Property Value

UncertainValue

See Also

UncertainMeasurement<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Class

F#

| Members | See Also
Meta.Numerics Library
UncertainMeasurementSample Class
Represents a set of UncertainMeasurement<(Of <(<'T>)>)> measurements.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class UncertainMeasurementSample : UncertainMeasurementSample<double>
Public NotInheritable Class UncertainMeasurementSample
    Inherits UncertainMeasurementSample(Of Double)
public ref class UncertainMeasurementSample sealed : public UncertainMeasurementSample<double>
[<SealedAttribute>]
type UncertainMeasurementSample =
    class
        inherit UncertainMeasurementSample<float>
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UncertainMeasurementSample()()()() | Initializes a new, empty data set.
UncertainMeasurementSample(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(Double>)>>)>)>>)) | Initializes a new data set with the specified data.
Add(UncertainMeasurement<(Of <<'(T>)>>)) | Adds a new data point to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Add(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(T>)>>)>)>>)) | Adds a series of data points to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Add(T, Double, Double) | Adds a new data point to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Clear()()()() | Removes all data points from the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Contains(UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether the set contains the given data point. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Count | Gets the size of the data set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToConstant()()()() | Fits the data to a constant value.
FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][]) | Fits the data to an arbitrary parameterized function. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
FitToLine()()()() | Fits the data to a line.
FitToLinearFunction(array<Func<(Of <<'(T, Double>)>>)>[]()[][]) | Fits the data to a linear combination of fit functions. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
FitToPolynomial(Int32) | Fits the data to a polynomial.
FitToProportionality()()()() | Fit the data to a proportionality relationship.
GetEnumerator()()()() | Gets an enumerator over the measurements. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Remove(UncertainMeasurement<(Of <<'(T>)>>)) | Removes a data point from the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Remarks

This class adds functionality to the UncertainMeasurementSample class which applies when the independent variable (X variable) is a single real number. This includes fitting to a constant, line, or polynomial.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..UncertainMeasurementSample <(Of <(<' Double >)>)>
Meta.Numerics.Statistics..::..UncertainMeasurementSample

See Also

Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Constructor

F#

Meta.Numerics Library
UncertainMeasurementSample Constructor

Overload List

Name | Description
UncertainMeasurementSample()()()() | Initializes a new, empty data set.
UncertainMeasurementSample(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(Double>)>>)>)>>)) | Initializes a new data set with the specified data.

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Constructor

F#

Meta.Numerics Library
UncertainMeasurementSample Constructor
Initializes a new, empty data set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainMeasurementSample()
Public Sub New
public:
UncertainMeasurementSample()
new : unit -> UncertainMeasurementSample

See Also

UncertainMeasurementSample Class
UncertainMeasurementSample Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Constructor (IEnumerable)

F#

Meta.Numerics Library
UncertainMeasurementSample Constructor (IEnumerable<(Of <(<'UncertainMeasurement<(Of <(<'Double>)>)>>)>)>)
Initializes a new data set with the specified data.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainMeasurementSample(
    IEnumerable<UncertainMeasurement<double>> data
)
Public Sub New (
    data As IEnumerable(Of UncertainMeasurement(Of Double))
)
public:
UncertainMeasurementSample(
    IEnumerable<UncertainMeasurement<double>^>^ data
)
new :
        data : IEnumerable<UncertainMeasurement<float>> -> UncertainMeasurementSample

Parameters

data
IEnumerable <(Of <(<' UncertainMeasurement <(Of <(<' Double >)>)>>)>)>
An enumerator over the UncertainMeasurement<(Of <(<'T>)>)>s to place in the set.

See Also

UncertainMeasurementSample Class
UncertainMeasurementSample Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Methods

F#

Meta.Numerics Library
UncertainMeasurementSample Methods

The UncertainMeasurementSample type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(UncertainMeasurement<(Of <<'(T>)>>)) | Adds a new data point to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Add(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(T>)>>)>)>>)) | Adds a series of data points to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Add(T, Double, Double) | Adds a new data point to the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Clear()()()() | Removes all data points from the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Contains(UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether the set contains the given data point. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToConstant()()()() | Fits the data to a constant value.
FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][]) | Fits the data to an arbitrary parameterized function. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
FitToLine()()()() | Fits the data to a line.
FitToLinearFunction(array<Func<(Of <<'(T, Double>)>>)>[]()[][]) | Fits the data to a linear combination of fit functions. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
FitToPolynomial(Int32) | Fits the data to a polynomial.
FitToProportionality()()()() | Fit the data to a proportionality relationship.
GetEnumerator()()()() | Gets an enumerator over the measurements. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Remove(UncertainMeasurement<(Of <<'(T>)>>)) | Removes a data point from the set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToConstant Method

F#

Meta.Numerics Library
UncertainMeasurementSample..::FitToConstant Method
Fits the data to a constant value.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToConstant()
Public Function FitToConstant As FitResult
public:
FitResult^ FitToConstant()
member FitToConstant : unit -> FitResult

Return Value

FitResult
A fit result containing the best combined value and a χ2 test of the quality of the fit.

Remarks

This method provides a simple way to

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToLine Method

F#

Meta.Numerics Library
UncertainMeasurementSample..::FitToLine Method
Fits the data to a line.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToLine()
Public Function FitToLine As FitResult
public:
FitResult^ FitToLine()
member FitToLine : unit -> FitResult

Return Value

FitResult
A fit result containing the best-fit intercept and slope parameters and a χ2 test of the quality of the fit.

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToPolynomial Method

F#

Meta.Numerics Library
UncertainMeasurementSample..::FitToPolynomial Method
Fits the data to a polynomial.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToPolynomial(
    int order
)
Public Function FitToPolynomial (
    order As Integer
) As FitResult
public:
FitResult^ FitToPolynomial(
    int order
)
member FitToPolynomial :
        order : int -> FitResult

Parameters

order
Int32
The order of the polynomial to fit.

Return Value

FitResult
A fit result containg the best-fit polynomial coefficients, in order of ascending power from 0 to order, and a χ2 test of the quality of the fit.

Exceptions

Exception | Condition
System..::..InvalidOperationException | There are more polynomial coefficients than data points.

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToProportionality Method

F#

Meta.Numerics Library
UncertainMeasurementSample..::FitToProportionality Method
Fit the data to a proportionality relationship.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToProportionality()
Public Function FitToProportionality As FitResult
public:
FitResult^ FitToProportionality()
member FitToProportionality : unit -> FitResult

Return Value

FitResult
A fit result containing the best-fit proportionality constant parameter and a χ2 test of the quality of the fit.

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Properties

F#

Meta.Numerics Library
UncertainMeasurementSample Properties

The UncertainMeasurementSample type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the size of the data set. (Inherited from UncertainMeasurementSample<(Of <(<'T>)>)>.)

See Also

UncertainMeasurementSample Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Generic Class

F#

| Members | See Also
Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)> Class
Represents a set of measurements.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public class UncertainMeasurementSample<T> : ICollection<UncertainMeasurement<T>>,
    IEnumerable<UncertainMeasurement<T>>, IEnumerable

Public Class UncertainMeasurementSample(Of T)
    Implements ICollection(Of UncertainMeasurement(Of T)), IEnumerable(Of UncertainMeasurement(Of T)),
    IEnumerable
generic<typename T>
public ref class UncertainMeasurementSample : ICollection<UncertainMeasurement<T>^>,
    IEnumerable<UncertainMeasurement<T>^>, IEnumerable
type UncertainMeasurementSample<'T> =
    class
        interface ICollection<UncertainMeasurement<'T>>
        interface IEnumerable<UncertainMeasurement<'T>>
        interface IEnumerable
    end

Type Parameters

T
The type of independent variable associated with each measurement.

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UncertainMeasurementSample<(Of <(<'T>)>)>()()()() | Initializes a new, empty data set.
Add(UncertainMeasurement<(Of <<'(T>)>>)) | Adds a new data point to the set.
Add(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(T>)>>)>)>>)) | Adds a series of data points to the set.
Add(T, Double, Double) | Adds a new data point to the set.
Clear()()()() | Removes all data points from the set.
Contains(UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether the set contains the given data point.
Count | Gets the size of the data set.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][]) | Fits the data to an arbitrary parameterized function.
FitToLinearFunction(array<Func<(Of <<'(T, Double>)>>)>[]()[][]) | Fits the data to a linear combination of fit functions.
GetEnumerator()()()() | Gets an enumerator over the measurements.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove(UncertainMeasurement<(Of <<'(T>)>>)) | Removes a data point from the set.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics..::..UncertainMeasurementSample<(Of <(<'T>)>)>
Meta.Numerics.Statistics..::..UncertainMeasurementSample

See Also

Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Constructor

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)> Constructor
Initializes a new, empty data set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UncertainMeasurementSample()
Public Sub New
public:
UncertainMeasurementSample()
new : unit -> UncertainMeasurementSample

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Methods

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)> Methods

The UncertainMeasurementSample<(Of <(<'T>)>)> generic type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Add(UncertainMeasurement<(Of <<'(T>)>>)) | Adds a new data point to the set.
Add(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(T>)>>)>)>>)) | Adds a series of data points to the set.
Add(T, Double, Double) | Adds a new data point to the set.
Clear()()()() | Removes all data points from the set.
Contains(UncertainMeasurement<(Of <<'(T>)>>)) | Determines whether the set contains the given data point.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][]) | Fits the data to an arbitrary parameterized function.
FitToLinearFunction(array<Func<(Of <<'(T, Double>)>>)>[]()[][]) | Fits the data to a linear combination of fit functions.
GetEnumerator()()()() | Gets an enumerator over the measurements.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove(UncertainMeasurement<(Of <<'(T>)>>)) | Removes a data point from the set.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Add Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Add Method

Overload List

Name | Description
Add(UncertainMeasurement<(Of <<'(T>)>>)) | Adds a new data point to the set.
Add(IEnumerable<(Of <<'(UncertainMeasurement<(Of <<'(T>)>>)>)>>)) | Adds a series of data points to the set.
Add(T, Double, Double) | Adds a new data point to the set.

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Add Method (UncertainMeasurement)

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Add Method (UncertainMeasurement<(Of <(<'T>)>)>)
Adds a new data point to the set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    UncertainMeasurement<T> datum
)
Public Sub Add (
    datum As UncertainMeasurement(Of T)
)
public:
virtual void Add(
    UncertainMeasurement<T>^ datum
) sealed
abstract Add :
        datum : UncertainMeasurement<'T> -> unit
override Add :
        datum : UncertainMeasurement<'T> -> unit

Parameters

datum
UncertainMeasurement <(Of <(<' T >)>)>
The data point.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Add Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Add Method (IEnumerable)

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Add Method (IEnumerable<(Of <(<'UncertainMeasurement<(Of <(<'T>)>)>>)>)>)
Adds a series of data points to the set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    IEnumerable<UncertainMeasurement<T>> data
)
Public Sub Add (
    data As IEnumerable(Of UncertainMeasurement(Of T))
)
public:
void Add(
    IEnumerable<UncertainMeasurement<T>^>^ data
)
member Add :
        data : IEnumerable<UncertainMeasurement<'T>> -> unit

Parameters

data
IEnumerable <(Of <(<' UncertainMeasurement <(Of <(<' T >)>)>>)>)>
The data points.

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Add Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Add Method (T, Double, Double)

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Add Method (T, Double, Double)
Adds a new data point to the set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Add(
    T x,
    double y,
    double dy
)
Public Sub Add (
    x As T,
    y As Double,
    dy As Double
)
public:
void Add(
    T x,
    double y,
    double dy
)
member Add :
        x : 'T *
        y : float *
        dy : float -> unit

Parameters

x
T
The value of the ordinate (independent variable).
y
Double
The value of the abcissa (dependent variable).
dy
Double
The uncertainty of the abcissa (dependent variable).

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Add Overload
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Clear Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Clear Method
Removes all data points from the set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Contains Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Contains Method
Determines whether the set contains the given data point.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Contains(
    UncertainMeasurement<T> datum
)
Public Function Contains (
    datum As UncertainMeasurement(Of T)
) As Boolean
public:
virtual bool Contains(
    UncertainMeasurement<T>^ datum
) sealed
abstract Contains :
        datum : UncertainMeasurement<'T> -> bool
override Contains :
        datum : UncertainMeasurement<'T> -> bool

Parameters

datum
UncertainMeasurement <(Of <(<' T >)>)>
The data point.

Return Value

Boolean
True if the set contains the given data point, otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToFunction Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::FitToFunction Method
Fits the data to an arbitrary parameterized function.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToFunction(
    Func<double[], T, double> function,
    double[] start
)
Public Function FitToFunction (
    function As Func(Of Double(), T, Double),
    start As Double()
) As FitResult
public:
FitResult^ FitToFunction(
    Func<array<double>^, T, double>^ function,
    array<double>^ start
)
member FitToFunction :
        function : Func<float[], 'T, float> *
        start : float[] -> FitResult

Parameters

function
Func <(Of <(<'array< Double >[]()[][], T, Double >)>)>
The fit function.
start
array< Double >[]()[][]
An initial guess at the parameters.

Return Value

FitResult
A fit result containing the best-fitting function parameters and a χ2 test of the quality of the fit.

Exceptions

Exception | Condition
System..::..ArgumentNullException | function or start are null.
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer data points than fit parameters.

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.FitToLinearFunction Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::FitToLinearFunction Method
Fits the data to a linear combination of fit functions.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FitResult FitToLinearFunction(
    Func<T, double>[] functions
)
Public Function FitToLinearFunction (
    functions As Func(Of T, Double)()
) As FitResult
public:
FitResult^ FitToLinearFunction(
    array<Func<T, double>^>^ functions
)
member FitToLinearFunction :
        functions : Func<'T, float>[] -> FitResult

Parameters

functions
array< Func <(Of <(<' T, Double >)>)>>[]()[][]
The component functions.

Return Value

FitResult
A fit result containing the best-fit coefficients of the component functions and a χ2 test of the quality of the fit.

Exceptions

Exception | Condition
System..::..ArgumentNullException | functions is null.
Meta.Numerics.Statistics..::..InsufficientDataException | There are fewer data points than fit parameters.

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.GetEnumerator Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::GetEnumerator Method
Gets an enumerator over the measurements.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public IEnumerator<UncertainMeasurement<T>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of UncertainMeasurement(Of T))
public:
virtual IEnumerator<UncertainMeasurement<T>^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<UncertainMeasurement<'T>>
override GetEnumerator : unit -> IEnumerator<UncertainMeasurement<'T>>

Return Value

IEnumerator <(Of <(<' UncertainMeasurement <(Of <(<' T >)>)>>)>)>
An enumerator over the measurements.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Remove Method

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Remove Method
Removes a data point from the set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public bool Remove(
    UncertainMeasurement<T> datum
)
Public Function Remove (
    datum As UncertainMeasurement(Of T)
) As Boolean
public:
virtual bool Remove(
    UncertainMeasurement<T>^ datum
) sealed
abstract Remove :
        datum : UncertainMeasurement<'T> -> bool
override Remove :
        datum : UncertainMeasurement<'T> -> bool

Parameters

datum
UncertainMeasurement <(Of <(<' T >)>)>
The data point to remove.

Return Value

Boolean
True if the data point was found and removed; otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample Properties

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)> Properties

The UncertainMeasurementSample<(Of <(<'T>)>)> generic type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Gets the size of the data set.

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


UncertainMeasurementSample.Count Property

F#

Meta.Numerics Library
UncertainMeasurementSample<(Of <(<'T>)>)>..::Count Property
Gets the size of the data set.

Namespace: Meta.Numerics.Statistics
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

UncertainMeasurementSample<(Of <(<'T>)>)> Class
Meta.Numerics.Statistics Namespace


Meta.Numerics.Statistics.Distributions Namespace

F#

Meta.Numerics Library
Meta.Numerics.Statistics.Distributions Namespace
Contains types that represent probability distributions.

Types

All Types | Classes
Name | Description
BernoulliDistribution | Represents a Bernoulli distribution.
BetaDistribution | Represents a beta distribution.
BinomialDistribution | Represents a discrete binomial distribution.
CauchyDistribution | Represents a Cauchy distribution.
ChiSquaredDistribution | Represents a χ2 distribution.
DiscreteDistribution | Represents all discrete, univariate probability distrubtions.
DiscreteUniformDistribution | Describes a discrete uniform distribution.
Distribution | Represents all continuous, univariate probability distribution.
ExponentialDistribution | Represents an exponential distribution.
FisherDistribution | Represents the distribution of Fisher's F-statistic.
GammaDistribution | Represents a Gamma distribution.
GeometricDistribution | Represents a geometric distribution.
GumbelDistribution | Represents a Gumbel distribution.
KolmogorovDistribution | Represents the distribution of the Kolmogorov-Smirnov D statistic.
KuiperDistribution | Represents the asymptotic distribution of Kuiper's V statistic.
LogisticDistribution | Represents a logistic distribution.
LognormalDistribution | Represents a log-normal distribution.
MomentMath | Contains methods for converting between different kinds of moments.
NormalDistribution | Represents a normal (Gaussian) distribution.
ParetoDistribution | Represents a Pareto or power law distribution.
PearsonRDistribution | Represents the distribution of Pearsons's r statistic.
PoissonDistribution | Represented a Poisson distribution.
StudentDistribution | Represents the distribution of Student't t statistic.
TriangularDistribution | Represents a triangular distribution.
UniformDistribution | Represents a uniform distribution over an interval.
UnivariateDistribution | Represents a probability distribution over a single variable.
WaldDistribution | Represents a Wald distribution.
WeibullDistribution | Represents a Weibull distribution.


BernoulliDistribution Class

F#

| Members | See Also
Meta.Numerics Library
BernoulliDistribution Class
Represents a Bernoulli distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class BernoulliDistribution : DiscreteDistribution
Public NotInheritable Class BernoulliDistribution
    Inherits DiscreteDistribution
public ref class BernoulliDistribution sealed : public DiscreteDistribution
[<SealedAttribute>]
type BernoulliDistribution =
    class
        inherit DiscreteDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BernoulliDistribution(Double) | Initializes a new Bernoulli distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

A Bernoulli distribution describes a trial with two possible outcomes. These outcomes are usually called "success" and "failure", but the same framework is applicable to any binary set of outcomes: right or left, true or false, male or female, dead or alive, etc. We represent the outcomes by 1 and 0, which are the only two integers for which the Bernoulli probability does not vanish. The parameter p1 is the probability of obtaining outcome 1.

When multiple, independent Bernoulli trials are conducted, the binomial distribution (BinomialDistribution) describes the probablity of obtaining any particular number of successes.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..BernoulliDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
Meta.Numerics.Statistics.Distributions..::..BinomialDistribution
http://mathworld.wolfram.com/BinomialDistribution.html
http://en.wikipedia.org/wiki/Bernoulli_distribution


BernoulliDistribution Constructor

F#

Meta.Numerics Library
BernoulliDistribution Constructor
Initializes a new Bernoulli distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BernoulliDistribution(
    double p1
)
Public Sub New (
    p1 As Double
)
public:
BernoulliDistribution(
    double p1
)
new :
        p1 : float -> BernoulliDistribution

Parameters

p1
Double
The probability of outcome 1, which must lie between zero and one.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution Methods

F#

Meta.Numerics Library
BernoulliDistribution Methods

The BernoulliDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
BernoulliDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
BernoulliDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftExclusiveProbability(
    int k
)
Public Overrides Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
) override
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


BernoulliDistribution.Moment Method

F#

Meta.Numerics Library
BernoulliDistribution..::Moment Method
Gets a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The raw moment Mr.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
BernoulliDistribution..::MomentAboutMean Method
Gets a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The central moment Cr.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
BernoulliDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityMass(
    int k
)
Public Overrides Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) override
abstract ProbabilityMass :
        k : int -> float
override ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
BernoulliDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightExclusiveProbability(
    int k
)
Public Overrides Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
) override
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


BernoulliDistribution Properties

F#

Meta.Numerics Library
BernoulliDistribution Properties

The BernoulliDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
BernoulliDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.Maximum Property

F#

Meta.Numerics Library
BernoulliDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Maximum { get; }
Public Overrides ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () override;
}
abstract Maximum : int with get
override Maximum : int with get

Property Value

Int32

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.Mean Property

F#

Meta.Numerics Library
BernoulliDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.Minimum Property

F#

Meta.Numerics Library
BernoulliDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Minimum { get; }
Public Overrides ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () override;
}
abstract Minimum : int with get
override Minimum : int with get

Property Value

Int32

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.Skewness Property

F#

Meta.Numerics Library
BernoulliDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BernoulliDistribution.Variance Property

F#

Meta.Numerics Library
BernoulliDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

BernoulliDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution Class

F#

| Members | See Also
Meta.Numerics Library
BetaDistribution Class
Represents a beta distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class BetaDistribution : Distribution
Public NotInheritable Class BetaDistribution
    Inherits Distribution
public ref class BetaDistribution sealed : public Distribution
[<SealedAttribute>]
type BetaDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BetaDistribution(Double, Double) | Initializes a new β distribution.
Alpha | Gets the left shape parameter.
Beta | Gets the right shape parameter.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Beta distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The beta distribution is defined on the interval [0,1]. Depending on its two shape parameters, it can take on a wide variety of forms on this interval.

If the two shape parameters are equal, the distribution is symmetric. If the first shape parameter is less than one, the distribution has a singularity at its left endpoint. If the first shape parameter is greater than one, the distribution goes to zero at its left endpoint. The second shape parameter similarly governs the distribution's behavior at its right endpoint.

When both shape parameters are one, the beta distribution reduces to a standard uniform distribution.

Beta distributions describe the maximum and minimum values obtained from multiple, independent draws from a standard uniform distribution. For n draws, the maximum value is distributed as B(n,1).

Similiarly, the minimum value is distributed as B(1,n).

Because of the wide variety of shapes it can take, the beta distribution is sometimes used as an ad hoc model to describe any distribution observed on a finite interval.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..BetaDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Beta_distribution
http://mathworld.wolfram.com/BetaDistribution.html


BetaDistribution Constructor

F#

Meta.Numerics Library
BetaDistribution Constructor
Initializes a new β distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BetaDistribution(
    double alpha,
    double beta
)
Public Sub New (
    alpha As Double,
    beta As Double
)
public:
BetaDistribution(
    double alpha,
    double beta
)
new :
        alpha : float *
        beta : float -> BetaDistribution

Parameters

alpha
Double
The left shape parameter, which controls the form of the distribution near x=0.
beta
Double
The right shape parameter, which controls the form of the distribution near x=1.

Remarks

The alpha shape parameter controls the form of the distribution near x=0. The beta shape parameter controls the form of the distribution near z=1. If a shape parameter is less than one, the PDF diverges on the side of the distribution it controls. If a shape parameter is greater than one, the PDF goes to zero on the side of the distribution it controls. If the left and right shapre parameters are equal, the distribution is symmetric about x=1/2.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Beta_distribution


BetaDistribution Methods

F#

Meta.Numerics Library
BetaDistribution Methods

The BetaDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Beta distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.FitToSample Method

F#

Meta.Numerics Library
BetaDistribution..::FitToSample Method
Computes the Beta distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameters.

Remarks

The returned fit parameters are the α (Alpha) and β (Beta) parameters, in that order. These are the same parameters, in the same order, that are required by the BetaDistribution(Double, Double) constructor to specify a new Beta distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.
System..::..InvalidOperationException | Not all the entries in sample lie between zero and one.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.GetRandomValue Method

F#

Meta.Numerics Library
BetaDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
BetaDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
BetaDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.LeftProbability Method

F#

Meta.Numerics Library
BetaDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Moment Method

F#

Meta.Numerics Library
BetaDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


BetaDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
BetaDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


BetaDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
BetaDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.RightProbability Method

F#

Meta.Numerics Library
BetaDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution Properties

F#

Meta.Numerics Library
BetaDistribution Properties

The BetaDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Alpha | Gets the left shape parameter.
Beta | Gets the right shape parameter.
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Alpha Property

F#

Meta.Numerics Library
BetaDistribution..::Alpha Property
Gets the left shape parameter.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Alpha { get; }
Public ReadOnly Property Alpha As Double
    Get
public:
property double Alpha {
    double get ();
}
member Alpha : float with get

Property Value

Double

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Beta Property

F#

Meta.Numerics Library
BetaDistribution..::Beta Property
Gets the right shape parameter.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Beta { get; }
Public ReadOnly Property Beta As Double
    Get
public:
property double Beta {
    double get ();
}
member Beta : float with get

Property Value

Double

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Mean Property

F#

Meta.Numerics Library
BetaDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Skewness Property

F#

Meta.Numerics Library
BetaDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Support Property

F#

Meta.Numerics Library
BetaDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BetaDistribution.Variance Property

F#

Meta.Numerics Library
BetaDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

BetaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution Class

F#

| Members | See Also
Meta.Numerics Library
BinomialDistribution Class
Represents a discrete binomial distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class BinomialDistribution : DiscreteDistribution
Public NotInheritable Class BinomialDistribution
    Inherits DiscreteDistribution
public ref class BinomialDistribution sealed : public DiscreteDistribution
[<SealedAttribute>]
type BinomialDistribution =
    class
        inherit DiscreteDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BinomialDistribution(Double, Int32) | Initializes a new binomial distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The binomial distribution gives the probability of obtaining k successes in n independent Bernoulli trials in which the probability of success in each trial is p.

For a single trial, the binomial distribution reduces to a Bernoulli distribution (BernoulliDistribution).

The test statistic for a sign test (SignTest(Double)) is distributed according to the Bernoulli distribution.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..BinomialDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://mathworld.wolfram.com/BinomialDistribution.html
http://en.wikipedia.org/wiki/Binomial_distribution


BinomialDistribution Constructor

F#

Meta.Numerics Library
BinomialDistribution Constructor
Initializes a new binomial distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public BinomialDistribution(
    double p,
    int n
)
Public Sub New (
    p As Double,
    n As Integer
)
public:
BinomialDistribution(
    double p,
    int n
)
new :
        p : float *
        n : int -> BinomialDistribution

Parameters

p
Double
The probability of the success in a single trial, which must lie between zero and one.
n
Int32
The number of trials, which must be positive.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution Methods

F#

Meta.Numerics Library
BinomialDistribution Methods

The BinomialDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
BinomialDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
BinomialDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftExclusiveProbability(
    int k
)
Public Overrides Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
) override
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


BinomialDistribution.Moment Method

F#

Meta.Numerics Library
BinomialDistribution..::Moment Method
Gets a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The raw moment Mr.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
BinomialDistribution..::MomentAboutMean Method
Gets a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The central moment Cr.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
BinomialDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityMass(
    int k
)
Public Overrides Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) override
abstract ProbabilityMass :
        k : int -> float
override ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
BinomialDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightExclusiveProbability(
    int k
)
Public Overrides Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
) override
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


BinomialDistribution Properties

F#

Meta.Numerics Library
BinomialDistribution Properties

The BinomialDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.Maximum Property

F#

Meta.Numerics Library
BinomialDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Maximum { get; }
Public Overrides ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () override;
}
abstract Maximum : int with get
override Maximum : int with get

Property Value

Int32

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.Mean Property

F#

Meta.Numerics Library
BinomialDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.Minimum Property

F#

Meta.Numerics Library
BinomialDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Minimum { get; }
Public Overrides ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () override;
}
abstract Minimum : int with get
override Minimum : int with get

Property Value

Int32

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.Skewness Property

F#

Meta.Numerics Library
BinomialDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


BinomialDistribution.Variance Property

F#

Meta.Numerics Library
BinomialDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

BinomialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution Class

F#

| Members | See Also
Meta.Numerics Library
CauchyDistribution Class
Represents a Cauchy distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class CauchyDistribution : Distribution
Public NotInheritable Class CauchyDistribution
    Inherits Distribution
public ref class CauchyDistribution sealed : public Distribution
[<SealedAttribute>]
type CauchyDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CauchyDistribution()()()() | Initializes a new standard Cauchy distribution.
CauchyDistribution(Double, Double) | Initializes a new Cauchy distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FullWithAtHalfMaximum | Gets the full width at half maximum (FWHM) of the Cauchy distribution.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

In physical applications, the Cauchy distribution is usually called a Lorentz distribution. It models the shape of a spectral line.

The Cauchy distribution has "fat tails". In fact, it falls off at the minimum possible rate consistent with having a convergent integral. For this same reason, none of its moments (above the zeroth) are defined.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..CauchyDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cauchy_distribution


CauchyDistribution Constructor

F#

Meta.Numerics Library
CauchyDistribution Constructor

Overload List

Name | Description
CauchyDistribution()()()() | Initializes a new standard Cauchy distribution.
CauchyDistribution(Double, Double) | Initializes a new Cauchy distribution.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution Constructor

F#

Meta.Numerics Library
CauchyDistribution Constructor
Initializes a new standard Cauchy distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public CauchyDistribution()
Public Sub New
public:
CauchyDistribution()
new : unit -> CauchyDistribution

See Also

CauchyDistribution Class
CauchyDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
CauchyDistribution Constructor (Double, Double)
Initializes a new Cauchy distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public CauchyDistribution(
    double mu,
    double gamma
)
Public Sub New (
    mu As Double,
    gamma As Double
)
public:
CauchyDistribution(
    double mu,
    double gamma
)
new :
        mu : float *
        gamma : float -> CauchyDistribution

Parameters

mu
Double
The centroid of the distribution.
gamma
Double
The width parameter of the distribution.

See Also

CauchyDistribution Class
CauchyDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution Methods

F#

Meta.Numerics Library
CauchyDistribution Methods

The CauchyDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.Cumulant Method

F#

Meta.Numerics Library
CauchyDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


CauchyDistribution.GetRandomValue Method

F#

Meta.Numerics Library
CauchyDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
CauchyDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
CauchyDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.LeftProbability Method

F#

Meta.Numerics Library
CauchyDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.Moment Method

F#

Meta.Numerics Library
CauchyDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


CauchyDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
CauchyDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


CauchyDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
CauchyDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.RightProbability Method

F#

Meta.Numerics Library
CauchyDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution Properties

F#

Meta.Numerics Library
CauchyDistribution Properties

The CauchyDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
FullWithAtHalfMaximum | Gets the full width at half maximum (FWHM) of the Cauchy distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.FullWithAtHalfMaximum Property

F#

Meta.Numerics Library
CauchyDistribution..::FullWithAtHalfMaximum Property
Gets the full width at half maximum (FWHM) of the Cauchy distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double FullWithAtHalfMaximum { get; }
Public ReadOnly Property FullWithAtHalfMaximum As Double
    Get
public:
property double FullWithAtHalfMaximum {
    double get ();
}
member FullWithAtHalfMaximum : float with get

Property Value

Double

Remarks

The full-width at half maximum (FWHM) is the width of the distribution peak at half its maximum value.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.Mean Property

F#

Meta.Numerics Library
CauchyDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.Median Property

F#

Meta.Numerics Library
CauchyDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


CauchyDistribution.Variance Property

F#

Meta.Numerics Library
CauchyDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

CauchyDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution Class

F#

| Members | See Also
Meta.Numerics Library
ChiSquaredDistribution Class
Represents a χ2 distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class ChiSquaredDistribution : Distribution
Public NotInheritable Class ChiSquaredDistribution
    Inherits Distribution
public ref class ChiSquaredDistribution sealed : public Distribution
[<SealedAttribute>]
type ChiSquaredDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChiSquaredDistribution(Int32) | Initializes a new χ2 distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
DegreesOfFreedom | Gets the number of degrees of freedom ν of the distribution.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

A chi squared distribution is an asymmetrical distribution ranging from zero to infinity with a peak near its number of degrees of freedom ν. It is a one-parameter distribution determined entirely by the parameter nu.

The figure above shows the χ2 distribution for ν = 6, as well as the normal distribution with equal mean and variance for reference.

The sum of the squares of ν independent standard-normal distributed variables is distributed as χ2 with ν degrees of freedom.

The χ2 distribution appears in least-squares fitting as the distribution of the sum-of-squared-deviations under the null hypothesis that the model explains the data. For example, the goodness-of-fit statistic returned by the model our model fitting methods (FitToFunction(Func<(Of <<'(array<Double>[]()[][], T, Double>)>>), array<Double>[]()[][]), FitToLinearFunction(array<Func<(Of <<'(T, Double>)>>)>[]()[][]), FitToLine()()()(), and others) follows a χ2 distribution.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..ChiSquaredDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
ContingencyTable..::..PearsonChiSquaredTest()()()()
http://en.wikipedia.org/wiki/Chi-square_distribution


ChiSquaredDistribution Constructor

F#

Meta.Numerics Library
ChiSquaredDistribution Constructor
Initializes a new χ2 distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ChiSquaredDistribution(
    int nu
)
Public Sub New (
    nu As Integer
)
public:
ChiSquaredDistribution(
    int nu
)
new :
        nu : int -> ChiSquaredDistribution

Parameters

nu
Int32
The number of degrees of freedom, which must be positive.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution Methods

F#

Meta.Numerics Library
ChiSquaredDistribution Methods

The ChiSquaredDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Cumulant Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


ChiSquaredDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.LeftProbability Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Moment Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ChiSquaredDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ChiSquaredDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.RightProbability Method

F#

Meta.Numerics Library
ChiSquaredDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution Properties

F#

Meta.Numerics Library
ChiSquaredDistribution Properties

The ChiSquaredDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the number of degrees of freedom ν of the distribution.
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.DegreesOfFreedom Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::DegreesOfFreedom Property
Gets the number of degrees of freedom ν of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public int DegreesOfFreedom { get; }
Public ReadOnly Property DegreesOfFreedom As Integer
    Get
public:
property int DegreesOfFreedom {
    int get ();
}
member DegreesOfFreedom : int with get

Property Value

Int32

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Mean Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Median Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Skewness Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Support Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ChiSquaredDistribution.Variance Property

F#

Meta.Numerics Library
ChiSquaredDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

ChiSquaredDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution Class

F#

| Members | See Also
Meta.Numerics Library
DiscreteDistribution Class
Represents all discrete, univariate probability distrubtions.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class DiscreteDistribution : UnivariateDistribution
Public MustInherit Class DiscreteDistribution
    Inherits UnivariateDistribution
public ref class DiscreteDistribution abstract : public UnivariateDistribution
[<AbstractClassAttribute>]
type DiscreteDistribution =
    class
        inherit UnivariateDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DiscreteDistribution()()()() | Initializes a new instance of the DiscreteDistribution class
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile.
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value.
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value.
Maximum | Gets the largest value in the distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimum | Gets the smallest value in the distribution.
Moment(Int32) | Gets a raw moment of the distribution. (Overrides UnivariateDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides UnivariateDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value.
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

Remarks

A discrete distribution is a distribution over the integers.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..BernoulliDistribution
Meta.Numerics.Statistics.Distributions..::..BinomialDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteUniformDistribution
Meta.Numerics.Statistics.Distributions..::..GeometricDistribution
Meta.Numerics.Statistics.Distributions..::..PoissonDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution Constructor

F#

Meta.Numerics Library
DiscreteDistribution Constructor
Initializes a new instance of the DiscreteDistribution class

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected DiscreteDistribution()
Protected Sub New
protected:
DiscreteDistribution()
new : unit -> DiscreteDistribution

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution Methods

F#

Meta.Numerics Library
DiscreteDistribution Methods

The DiscreteDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile.
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value.
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides UnivariateDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides UnivariateDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value.
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.ExpectationValue Method

F#

Meta.Numerics Library
DiscreteDistribution..::ExpectationValue Method
Computes the expectation value of an artibrary function.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double ExpectationValue(
    Func<int, double> f
)
Public Overridable Function ExpectationValue (
    f As Func(Of Integer, Double)
) As Double
public:
virtual double ExpectationValue(
    Func<int, double>^ f
)
abstract ExpectationValue :
        f : Func<int, float> -> float
override ExpectationValue :
        f : Func<int, float> -> float

Parameters

f
Func <(Of <(<' Int32, Double >)>)>
The function.

Return Value

Double
The expectation value of the function.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.GetRandomValue Method

F#

Meta.Numerics Library
DiscreteDistribution..::GetRandomValue Method
Produces a random integer drawn from the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int GetRandomValue(
    Random rng
)
Public Overridable Function GetRandomValue (
    rng As Random
) As Integer
public:
virtual int GetRandomValue(
    Random^ rng
)
abstract GetRandomValue :
        rng : Random -> int
override GetRandomValue :
        rng : Random -> int

Parameters

rng
Random
A random number generator.

Return Value

Int32
A random integer drawn from the distribution.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
DiscreteDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual int InverseLeftProbability(
    double P
)
Public Overridable Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
)
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
DiscreteDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double LeftExclusiveProbability(
    int k
)
Public Overridable Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
)
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


DiscreteDistribution.LeftInclusiveProbability Method

F#

Meta.Numerics Library
DiscreteDistribution..::LeftInclusiveProbability Method
Computes the probability of obtaining a value less than or equal to the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double LeftInclusiveProbability(
    int k
)
Public Overridable Function LeftInclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftInclusiveProbability(
    int k
)
abstract LeftInclusiveProbability :
        k : int -> float
override LeftInclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value les than or equal to k.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.Moment Method

F#

Meta.Numerics Library
DiscreteDistribution..::Moment Method
Gets a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The raw moment Mr.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
DiscreteDistribution..::MomentAboutMean Method
Gets a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The central moment Cr.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
DiscreteDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract double ProbabilityMass(
    int k
)
Public MustOverride Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) abstract
abstract ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
DiscreteDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double RightExclusiveProbability(
    int k
)
Public Overridable Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
)
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


DiscreteDistribution Properties

F#

Meta.Numerics Library
DiscreteDistribution Properties

The DiscreteDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Maximum | Gets the largest value in the distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.Maximum Property

F#

Meta.Numerics Library
DiscreteDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract int Maximum { get; }
Public MustOverride ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () abstract;
}
abstract Maximum : int with get

Property Value

Int32

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.Mean Property

F#

Meta.Numerics Library
DiscreteDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteDistribution.Minimum Property

F#

Meta.Numerics Library
DiscreteDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract int Minimum { get; }
Public MustOverride ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () abstract;
}
abstract Minimum : int with get

Property Value

Int32

See Also

DiscreteDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution Class

F#

| Members | See Also
Meta.Numerics Library
DiscreteUniformDistribution Class
Describes a discrete uniform distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class DiscreteUniformDistribution : DiscreteDistribution
Public NotInheritable Class DiscreteUniformDistribution
    Inherits DiscreteDistribution
public ref class DiscreteUniformDistribution sealed : public DiscreteDistribution
[<SealedAttribute>]
type DiscreteUniformDistribution =
    class
        inherit DiscreteDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DiscreteUniformDistribution(Int32, Int32) | Instantiates a new discrete uniform distribution with the given endpoints.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Moment(Int32) | Gets a raw moment of the distribution. (Inherited from DiscreteDistribution.)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

In a discrete uniform distribution, each integer in the allowed range is equally probable.

For example, the distribution of results for one roll of a fair die is DiscreteUniformDistribution(1,6).

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteUniformDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution Constructor

F#

Meta.Numerics Library
DiscreteUniformDistribution Constructor
Instantiates a new discrete uniform distribution with the given endpoints.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public DiscreteUniformDistribution(
    int a,
    int b
)
Public Sub New (
    a As Integer,
    b As Integer
)
public:
DiscreteUniformDistribution(
    int a,
    int b
)
new :
        a : int *
        b : int -> DiscreteUniformDistribution

Parameters

a
Int32
One end-point.
b
Int32
The other end-point.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution Methods

F#

Meta.Numerics Library
DiscreteUniformDistribution Methods

The DiscreteUniformDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Moment(Int32) | Gets a raw moment of the distribution. (Inherited from DiscreteDistribution.)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Cumulant Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


DiscreteUniformDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftExclusiveProbability(
    int k
)
Public Overrides Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
) override
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


DiscreteUniformDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::MomentAboutMean Method
Gets a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The central moment Cr.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityMass(
    int k
)
Public Overrides Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) override
abstract ProbabilityMass :
        k : int -> float
override ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
DiscreteUniformDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightExclusiveProbability(
    int k
)
Public Overrides Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
) override
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


DiscreteUniformDistribution Properties

F#

Meta.Numerics Library
DiscreteUniformDistribution Properties

The DiscreteUniformDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Maximum Property

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Maximum { get; }
Public Overrides ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () override;
}
abstract Maximum : int with get
override Maximum : int with get

Property Value

Int32

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Mean Property

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Minimum Property

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Minimum { get; }
Public Overrides ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () override;
}
abstract Minimum : int with get
override Minimum : int with get

Property Value

Int32

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Skewness Property

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


DiscreteUniformDistribution.Variance Property

F#

Meta.Numerics Library
DiscreteUniformDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

DiscreteUniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution Class

F#

| Members | See Also
Meta.Numerics Library
Distribution Class
Represents all continuous, univariate probability distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class Distribution : UnivariateDistribution
Public MustInherit Class Distribution
    Inherits UnivariateDistribution
public ref class Distribution abstract : public UnivariateDistribution
[<AbstractClassAttribute>]
type Distribution =
    class
        inherit UnivariateDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Distribution()()()() | Initializes a new instance of the Distribution class
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value.
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value.
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point.
Mean | Gets the mean of the distribution. (Inherited from UnivariateDistribution.)
Median | Gets the median of the distribution.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides UnivariateDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides UnivariateDistribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point.
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..BetaDistribution
Meta.Numerics.Statistics.Distributions..::..CauchyDistribution
Meta.Numerics.Statistics.Distributions..::..ChiSquaredDistribution
Meta.Numerics.Statistics.Distributions..::..ExponentialDistribution
Meta.Numerics.Statistics.Distributions..::..FisherDistribution
Meta.Numerics.Statistics.Distributions..::..GammaDistribution
Meta.Numerics.Statistics.Distributions..::..GumbelDistribution
Meta.Numerics.Statistics.Distributions..::..KolmogorovDistribution
Meta.Numerics.Statistics.Distributions..::..KuiperDistribution
Meta.Numerics.Statistics.Distributions..::..LogisticDistribution
Meta.Numerics.Statistics.Distributions..::..LognormalDistribution
Meta.Numerics.Statistics.Distributions..::..NormalDistribution
Meta.Numerics.Statistics.Distributions..::..ParetoDistribution
Meta.Numerics.Statistics.Distributions..::..PearsonRDistribution
Meta.Numerics.Statistics.Distributions..::..StudentDistribution
Meta.Numerics.Statistics.Distributions..::..TriangularDistribution
Meta.Numerics.Statistics.Distributions..::..UniformDistribution
Meta.Numerics.Statistics.Distributions..::..WaldDistribution
Meta.Numerics.Statistics.Distributions..::..WeibullDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


Distribution Constructor

F#

Meta.Numerics Library
Distribution Constructor
Initializes a new instance of the Distribution class

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected Distribution()
Protected Sub New
protected:
Distribution()
new : unit -> Distribution

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution Methods

F#

Meta.Numerics Library
Distribution Methods

The Distribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value.
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value.
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides UnivariateDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides UnivariateDistribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point.
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.ExpectationValue Method

F#

Meta.Numerics Library
Distribution..::ExpectationValue Method
Computes the expectation value of the given function.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double ExpectationValue(
    Func<double, double> f
)
Public Overridable Function ExpectationValue (
    f As Func(Of Double, Double)
) As Double
public:
virtual double ExpectationValue(
    Func<double, double>^ f
)
abstract ExpectationValue :
        f : Func<float, float> -> float
override ExpectationValue :
        f : Func<float, float> -> float

Parameters

f
Func <(Of <(<' Double, Double >)>)>
The function.

Return Value

Double
The expectation value of the function.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.GetRandomValue Method

F#

Meta.Numerics Library
Distribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double GetRandomValue(
    Random rng
)
Public Overridable Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
)
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.InverseLeftProbability Method

F#

Meta.Numerics Library
Distribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double InverseLeftProbability(
    double P
)
Public Overridable Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
)
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.InverseRightProbability Method

F#

Meta.Numerics Library
Distribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double InverseRightProbability(
    double Q
)
Public Overridable Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
)
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.LeftProbability Method

F#

Meta.Numerics Library
Distribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double LeftProbability(
    double x
)
Public Overridable Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
)
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.Moment Method

F#

Meta.Numerics Library
Distribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


Distribution.MomentAboutMean Method

F#

Meta.Numerics Library
Distribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


Distribution.ProbabilityDensity Method

F#

Meta.Numerics Library
Distribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract double ProbabilityDensity(
    double x
)
Public MustOverride Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) abstract
abstract ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.RightProbability Method

F#

Meta.Numerics Library
Distribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double RightProbability(
    double x
)
Public Overridable Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
)
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution Properties

F#

Meta.Numerics Library
Distribution Properties

The Distribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Inherited from UnivariateDistribution.)
Median | Gets the median of the distribution.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing.
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.Median Property

F#

Meta.Numerics Library
Distribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Median { get; }
Public Overridable ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get ();
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


Distribution.Support Property

F#

Meta.Numerics Library
Distribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual Interval Support { get; }
Public Overridable ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get ();
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

Distribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution Class

F#

| Members | See Also
Meta.Numerics Library
ExponentialDistribution Class
Represents an exponential distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class ExponentialDistribution : Distribution
Public NotInheritable Class ExponentialDistribution
    Inherits Distribution
public ref class ExponentialDistribution sealed : public Distribution
[<SealedAttribute>]
type ExponentialDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExponentialDistribution()()()() | Initializes a new standard exponential distribution.
ExponentialDistribution(Double) | Initializes a new exponential distribution with the given mean.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the exponential distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

Remarks

An exponential distribution falls off exponentially in the range from zero to infinity. It is a one-parameter distribution, determined entirely by its rate of fall-off.

The exponential distribution describes the distribution of decay times of radioactive particles.

An exponential distribution with mean one is called a standard exponential distribution. Any exponential distribution can be converted to a standard exponential by reparameterizing the data into "fractions of the mean," i.e. z = x / μ.

Processes resulting in events that are exponentially distributed in time are said to be "ageless" because the hazard function of the exponential distribution is constant. The Weibull distribution (WeibullDistribution) is a generalization of the exponential distribution which the hazard function changes (typically by increasing) with time.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..ExponentialDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
WeibullDistribution
http://en.wikipedia.org/wiki/Exponential_distribution


ExponentialDistribution Constructor

F#

Meta.Numerics Library
ExponentialDistribution Constructor

Overload List

Name | Description
ExponentialDistribution()()()() | Initializes a new standard exponential distribution.
ExponentialDistribution(Double) | Initializes a new exponential distribution with the given mean.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution Constructor

F#

Meta.Numerics Library
ExponentialDistribution Constructor
Initializes a new standard exponential distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ExponentialDistribution()
Public Sub New
public:
ExponentialDistribution()
new : unit -> ExponentialDistribution

See Also

ExponentialDistribution Class
ExponentialDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution Constructor (Double)

F#

Meta.Numerics Library
ExponentialDistribution Constructor (Double)
Initializes a new exponential distribution with the given mean.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ExponentialDistribution(
    double mu
)
Public Sub New (
    mu As Double
)
public:
ExponentialDistribution(
    double mu
)
new :
        mu : float -> ExponentialDistribution

Parameters

mu
Double
The mean, which must be positive.

See Also

ExponentialDistribution Class
ExponentialDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution Methods

F#

Meta.Numerics Library
ExponentialDistribution Methods

The ExponentialDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the exponential distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Cumulant Method

F#

Meta.Numerics Library
ExponentialDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


ExponentialDistribution.FitToSample Method

F#

Meta.Numerics Library
ExponentialDistribution..::FitToSample Method
Computes the exponential distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameter.

Remarks

The returned fit parameter is μ (the Mean). This is the same parameter that is required by the ExponentialDistribution(Double) constructor to specify a new exponential distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than two values.
System..::..InvalidOperationException | sample contains non-positive values.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
ExponentialDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
ExponentialDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.LeftProbability Method

F#

Meta.Numerics Library
ExponentialDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Moment Method

F#

Meta.Numerics Library
ExponentialDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ExponentialDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
ExponentialDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ExponentialDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
ExponentialDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.RightProbability Method

F#

Meta.Numerics Library
ExponentialDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution Properties

F#

Meta.Numerics Library
ExponentialDistribution Properties

The ExponentialDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
ExponentialDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Mean Property

F#

Meta.Numerics Library
ExponentialDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Median Property

F#

Meta.Numerics Library
ExponentialDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Skewness Property

F#

Meta.Numerics Library
ExponentialDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.StandardDeviation Property

F#

Meta.Numerics Library
ExponentialDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ExponentialDistribution.Support Property

F#

Meta.Numerics Library
ExponentialDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

ExponentialDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution Class

F#

| Members | See Also
Meta.Numerics Library
FisherDistribution Class
Represents the distribution of Fisher's F-statistic.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class FisherDistribution : Distribution
Public NotInheritable Class FisherDistribution
    Inherits Distribution
public ref class FisherDistribution sealed : public Distribution
[<SealedAttribute>]
type FisherDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FisherDistribution(Double, Double) | Initializes a new Fisher distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
DenominatorDegreesOfFreedom | Gets the number of degrees of freedom in the denominator.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
NumeratorDegreesOfFreedom | Gets the number of degrees of freedom in the numerator.
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The ratio of the variances of two sets of normally distributed variables is distributed according to Fisher's F-distribution.

Many test statistics are ratios of variances and are therefore distributed according to the F-distribution. These include the F-test (FisherFTest(Sample, Sample)), the goodness-of-fit test for a multi-linear regression (LinearRegression(Int32)), and ANOVA tests (OneWayAnovaTest(IList<(Of <<'(Sample>)>>))).

The Fisher distribution is related to the Beta distribution (BetaDistribution) by a simple variable transformation.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..FisherDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/F_distribution


FisherDistribution Constructor

F#

Meta.Numerics Library
FisherDistribution Constructor
Initializes a new Fisher distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public FisherDistribution(
    double nu1,
    double nu2
)
Public Sub New (
    nu1 As Double,
    nu2 As Double
)
public:
FisherDistribution(
    double nu1,
    double nu2
)
new :
        nu1 : float *
        nu2 : float -> FisherDistribution

Parameters

nu1
Double
The number of degrees of freedom in the numerator, which must be positive.
nu2
Double
The number of degrees of freedom in the denominator, which must be positive.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
Sample..::..FisherFTest(Sample, Sample)


FisherDistribution Methods

F#

Meta.Numerics Library
FisherDistribution Methods

The FisherDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
FisherDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
FisherDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.LeftProbability Method

F#

Meta.Numerics Library
FisherDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.Moment Method

F#

Meta.Numerics Library
FisherDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


FisherDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
FisherDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


FisherDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
FisherDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.RightProbability Method

F#

Meta.Numerics Library
FisherDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution Properties

F#

Meta.Numerics Library
FisherDistribution Properties

The FisherDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DenominatorDegreesOfFreedom | Gets the number of degrees of freedom in the denominator.
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
NumeratorDegreesOfFreedom | Gets the number of degrees of freedom in the numerator.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.DenominatorDegreesOfFreedom Property

F#

Meta.Numerics Library
FisherDistribution..::DenominatorDegreesOfFreedom Property
Gets the number of degrees of freedom in the denominator.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double DenominatorDegreesOfFreedom { get; }
Public ReadOnly Property DenominatorDegreesOfFreedom As Double
    Get
public:
property double DenominatorDegreesOfFreedom {
    double get ();
}
member DenominatorDegreesOfFreedom : float with get

Property Value

Double

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.Mean Property

F#

Meta.Numerics Library
FisherDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.NumeratorDegreesOfFreedom Property

F#

Meta.Numerics Library
FisherDistribution..::NumeratorDegreesOfFreedom Property
Gets the number of degrees of freedom in the numerator.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double NumeratorDegreesOfFreedom { get; }
Public ReadOnly Property NumeratorDegreesOfFreedom As Double
    Get
public:
property double NumeratorDegreesOfFreedom {
    double get ();
}
member NumeratorDegreesOfFreedom : float with get

Property Value

Double

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


FisherDistribution.Variance Property

F#

Meta.Numerics Library
FisherDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

FisherDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution Class

F#

| Members | See Also
Meta.Numerics Library
GammaDistribution Class
Represents a Gamma distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class GammaDistribution : Distribution
Public NotInheritable Class GammaDistribution
    Inherits Distribution
public ref class GammaDistribution sealed : public Distribution
[<SealedAttribute>]
type GammaDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GammaDistribution(Double) | Initializes a new instance of the standard Gamma distribution.
GammaDistribution(Double, Double) | Initializes a new instance of a Gamma distribution with the given parameters.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Gamma distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ScaleParameter | Gets the scale parameter for the distribution.
ShapeParameter | Gets the shape parameter for the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The sum of n exponentially distributed variates is a Gamma distributed variate.

When the shape parameter is an integer, the Gamma distribution is also called the Erlang distribution. When the shape parameter is one, the Gamma distribution reduces to the exponential distribution.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..GammaDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
Meta.Numerics.Statistics.Distributions..::..ExponentialDistribution


GammaDistribution Constructor

F#

Meta.Numerics Library
GammaDistribution Constructor

Overload List

Name | Description
GammaDistribution(Double) | Initializes a new instance of the standard Gamma distribution.
GammaDistribution(Double, Double) | Initializes a new instance of a Gamma distribution with the given parameters.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution Constructor (Double)

F#

Meta.Numerics Library
GammaDistribution Constructor (Double)
Initializes a new instance of the standard Gamma distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public GammaDistribution(
    double shape
)
Public Sub New (
    shape As Double
)
public:
GammaDistribution(
    double shape
)
new :
        shape : float -> GammaDistribution

Parameters

shape
Double
The shape parameter, which must be positive.

See Also

GammaDistribution Class
GammaDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
GammaDistribution Constructor (Double, Double)
Initializes a new instance of a Gamma distribution with the given parameters.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public GammaDistribution(
    double shape,
    double scale
)
Public Sub New (
    shape As Double,
    scale As Double
)
public:
GammaDistribution(
    double shape,
    double scale
)
new :
        shape : float *
        scale : float -> GammaDistribution

Parameters

shape
Double
The shape parameter, which must be positive.
scale
Double
The scale parameter, which must be positive.

See Also

GammaDistribution Class
GammaDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution Methods

F#

Meta.Numerics Library
GammaDistribution Methods

The GammaDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Gamma distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Cumulant Method

F#

Meta.Numerics Library
GammaDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


GammaDistribution.FitToSample Method

F#

Meta.Numerics Library
GammaDistribution..::FitToSample Method
Computes the Gamma distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameters.

Remarks

The returned fit parameters are the ShapeParameter and ScaleParameter, in that order. These are the same parameters, in the same order, that are required by the GammaDistribution(Double, Double) constructor to specify a new Gamma distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
System..::..InvalidOperationException | sample contains non-positive values.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.GetRandomValue Method

F#

Meta.Numerics Library
GammaDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
GammaDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.LeftProbability Method

F#

Meta.Numerics Library
GammaDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Moment Method

F#

Meta.Numerics Library
GammaDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


GammaDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
GammaDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


GammaDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
GammaDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.RightProbability Method

F#

Meta.Numerics Library
GammaDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution Properties

F#

Meta.Numerics Library
GammaDistribution Properties

The GammaDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
ScaleParameter | Gets the scale parameter for the distribution.
ShapeParameter | Gets the shape parameter for the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
GammaDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Mean Property

F#

Meta.Numerics Library
GammaDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.ScaleParameter Property

F#

Meta.Numerics Library
GammaDistribution..::ScaleParameter Property
Gets the scale parameter for the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ScaleParameter { get; }
Public ReadOnly Property ScaleParameter As Double
    Get
public:
property double ScaleParameter {
    double get ();
}
member ScaleParameter : float with get

Property Value

Double

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.ShapeParameter Property

F#

Meta.Numerics Library
GammaDistribution..::ShapeParameter Property
Gets the shape parameter for the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ShapeParameter { get; }
Public ReadOnly Property ShapeParameter As Double
    Get
public:
property double ShapeParameter {
    double get ();
}
member ShapeParameter : float with get

Property Value

Double

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Skewness Property

F#

Meta.Numerics Library
GammaDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Support Property

F#

Meta.Numerics Library
GammaDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GammaDistribution.Variance Property

F#

Meta.Numerics Library
GammaDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

GammaDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution Class

F#

| Members | See Also
Meta.Numerics Library
GeometricDistribution Class
Represents a geometric distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class GeometricDistribution : DiscreteDistribution
Public NotInheritable Class GeometricDistribution
    Inherits DiscreteDistribution
public ref class GeometricDistribution sealed : public DiscreteDistribution
[<SealedAttribute>]
type GeometricDistribution =
    class
        inherit DiscreteDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GeometricDistribution(Double) | Initializes a new geometric distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Inherited from DiscreteDistribution.)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The probability of obtaining each integer value in a geometric distribution is lower than the probability of obtaining the previous value by a constant factor. The probability thus decreases geometricly with the value, giving the distribution its name.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..GeometricDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution Constructor

F#

Meta.Numerics Library
GeometricDistribution Constructor
Initializes a new geometric distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public GeometricDistribution(
    double p
)
Public Sub New (
    p As Double
)
public:
GeometricDistribution(
    double p
)
new :
        p : float -> GeometricDistribution

Parameters

p
Double
The probabability of the value zero.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution Methods

F#

Meta.Numerics Library
GeometricDistribution Methods

The GeometricDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Inherited from DiscreteDistribution.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Inherited from DiscreteDistribution.)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
GeometricDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
GeometricDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftExclusiveProbability(
    int k
)
Public Overrides Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
) override
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


GeometricDistribution.Moment Method

F#

Meta.Numerics Library
GeometricDistribution..::Moment Method
Gets a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The raw moment Mr.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
GeometricDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityMass(
    int k
)
Public Overrides Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) override
abstract ProbabilityMass :
        k : int -> float
override ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
GeometricDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightExclusiveProbability(
    int k
)
Public Overrides Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
) override
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


GeometricDistribution Properties

F#

Meta.Numerics Library
GeometricDistribution Properties

The GeometricDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.Maximum Property

F#

Meta.Numerics Library
GeometricDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Maximum { get; }
Public Overrides ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () override;
}
abstract Maximum : int with get
override Maximum : int with get

Property Value

Int32

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.Mean Property

F#

Meta.Numerics Library
GeometricDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.Minimum Property

F#

Meta.Numerics Library
GeometricDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Minimum { get; }
Public Overrides ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () override;
}
abstract Minimum : int with get
override Minimum : int with get

Property Value

Int32

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.Skewness Property

F#

Meta.Numerics Library
GeometricDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.StandardDeviation Property

F#

Meta.Numerics Library
GeometricDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GeometricDistribution.Variance Property

F#

Meta.Numerics Library
GeometricDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

GeometricDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution Class

F#

| Members | See Also
Meta.Numerics Library
GumbelDistribution Class
Represents a Gumbel distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class GumbelDistribution : Distribution
Public NotInheritable Class GumbelDistribution
    Inherits Distribution
public ref class GumbelDistribution sealed : public Distribution
[<SealedAttribute>]
type GumbelDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GumbelDistribution()()()() | Initializes a new standard Gumbel distribution.
GumbelDistribution(Double, Double) | Initializes a new Gumbel distribution with the given parameters.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
LocationParameter | Gets the location parameter of the distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ScaleParameter | Gets the scale parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..GumbelDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Gumbel_distribution


GumbelDistribution Constructor

F#

Meta.Numerics Library
GumbelDistribution Constructor

Overload List

Name | Description
GumbelDistribution()()()() | Initializes a new standard Gumbel distribution.
GumbelDistribution(Double, Double) | Initializes a new Gumbel distribution with the given parameters.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution Constructor

F#

Meta.Numerics Library
GumbelDistribution Constructor
Initializes a new standard Gumbel distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public GumbelDistribution()
Public Sub New
public:
GumbelDistribution()
new : unit -> GumbelDistribution

See Also

GumbelDistribution Class
GumbelDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
GumbelDistribution Constructor (Double, Double)
Initializes a new Gumbel distribution with the given parameters.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public GumbelDistribution(
    double location,
    double scale
)
Public Sub New (
    location As Double,
    scale As Double
)
public:
GumbelDistribution(
    double location,
    double scale
)
new :
        location : float *
        scale : float -> GumbelDistribution

Parameters

location
Double
The location parameter.
scale
Double
The scale parameter, which must be positive.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | scale is negative or zero.

See Also

GumbelDistribution Class
GumbelDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution Methods

F#

Meta.Numerics Library
GumbelDistribution Methods

The GumbelDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Cumulant Method

F#

Meta.Numerics Library
GumbelDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


GumbelDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
GumbelDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.LeftProbability Method

F#

Meta.Numerics Library
GumbelDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Moment Method

F#

Meta.Numerics Library
GumbelDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


GumbelDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
GumbelDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


GumbelDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
GumbelDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.RightProbability Method

F#

Meta.Numerics Library
GumbelDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution Properties

F#

Meta.Numerics Library
GumbelDistribution Properties

The GumbelDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
LocationParameter | Gets the location parameter of the distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
ScaleParameter | Gets the scale parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.LocationParameter Property

F#

Meta.Numerics Library
GumbelDistribution..::LocationParameter Property
Gets the location parameter of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double LocationParameter { get; }
Public ReadOnly Property LocationParameter As Double
    Get
public:
property double LocationParameter {
    double get ();
}
member LocationParameter : float with get

Property Value

Double

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Mean Property

F#

Meta.Numerics Library
GumbelDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Median Property

F#

Meta.Numerics Library
GumbelDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.ScaleParameter Property

F#

Meta.Numerics Library
GumbelDistribution..::ScaleParameter Property
Gets the scale parameter of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ScaleParameter { get; }
Public ReadOnly Property ScaleParameter As Double
    Get
public:
property double ScaleParameter {
    double get ();
}
member ScaleParameter : float with get

Property Value

Double

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Skewness Property

F#

Meta.Numerics Library
GumbelDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.StandardDeviation Property

F#

Meta.Numerics Library
GumbelDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Support Property

F#

Meta.Numerics Library
GumbelDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


GumbelDistribution.Variance Property

F#

Meta.Numerics Library
GumbelDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

GumbelDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution Class

F#

| Members | See Also
Meta.Numerics Library
KolmogorovDistribution Class
Represents the distribution of the Kolmogorov-Smirnov D statistic.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class KolmogorovDistribution : Distribution
Public NotInheritable Class KolmogorovDistribution
    Inherits Distribution
public ref class KolmogorovDistribution sealed : public Distribution
[<SealedAttribute>]
type KolmogorovDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
KolmogorovDistribution()()()() | Initializes a new asymptotic Kolmogorov distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The D statistic in a Kolmogorov-Smirnov test is distributed (under the null hypothesis) according to a Kolmogorov disribution, in the limit of a large sample size.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..KolmogorovDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution Constructor

F#

Meta.Numerics Library
KolmogorovDistribution Constructor
Initializes a new asymptotic Kolmogorov distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public KolmogorovDistribution()
Public Sub New
public:
KolmogorovDistribution()
new : unit -> KolmogorovDistribution

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution Methods

F#

Meta.Numerics Library
KolmogorovDistribution Methods

The KolmogorovDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.LeftProbability Method

F#

Meta.Numerics Library
KolmogorovDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.Moment Method

F#

Meta.Numerics Library
KolmogorovDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


KolmogorovDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
KolmogorovDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


KolmogorovDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
KolmogorovDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.RightProbability Method

F#

Meta.Numerics Library
KolmogorovDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution Properties

F#

Meta.Numerics Library
KolmogorovDistribution Properties

The KolmogorovDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.Mean Property

F#

Meta.Numerics Library
KolmogorovDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.Median Property

F#

Meta.Numerics Library
KolmogorovDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.Support Property

F#

Meta.Numerics Library
KolmogorovDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KolmogorovDistribution.Variance Property

F#

Meta.Numerics Library
KolmogorovDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

KolmogorovDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution Class

F#

| Members | See Also
Meta.Numerics Library
KuiperDistribution Class
Represents the asymptotic distribution of Kuiper's V statistic.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class KuiperDistribution : Distribution
Public NotInheritable Class KuiperDistribution
    Inherits Distribution
public ref class KuiperDistribution sealed : public Distribution
[<SealedAttribute>]
type KuiperDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
KuiperDistribution()()()() | Initializes a new Kuiper distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..KuiperDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution Constructor

F#

Meta.Numerics Library
KuiperDistribution Constructor
Initializes a new Kuiper distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public KuiperDistribution()
Public Sub New
public:
KuiperDistribution()
new : unit -> KuiperDistribution

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution Methods

F#

Meta.Numerics Library
KuiperDistribution Methods

The KuiperDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.LeftProbability Method

F#

Meta.Numerics Library
KuiperDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.Moment Method

F#

Meta.Numerics Library
KuiperDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


KuiperDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
KuiperDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


KuiperDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
KuiperDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.RightProbability Method

F#

Meta.Numerics Library
KuiperDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution Properties

F#

Meta.Numerics Library
KuiperDistribution Properties

The KuiperDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.Mean Property

F#

Meta.Numerics Library
KuiperDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.Support Property

F#

Meta.Numerics Library
KuiperDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


KuiperDistribution.Variance Property

F#

Meta.Numerics Library
KuiperDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

KuiperDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution Class

F#

| Members | See Also
Meta.Numerics Library
LogisticDistribution Class
Represents a logistic distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class LogisticDistribution : Distribution
Public NotInheritable Class LogisticDistribution
    Inherits Distribution
public ref class LogisticDistribution sealed : public Distribution
[<SealedAttribute>]
type LogisticDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LogisticDistribution()()()() | Initializes a new standard logistic distribution.
LogisticDistribution(Double, Double) | Initializes a new logistic distribution with the given mean and width parameters.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

Like the normal distribution, the logistic distribution is a symmetric, unimodal distribution distribution with exponentially supressed tails.

A logistic distribution with mean zero and standard deviation one is called a standard logistic distribution. Any logistic distribution can be converted to a standard logistic distribution by reparameterzing into z = (x-m)/s.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..LogisticDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Logistic_distribution


LogisticDistribution Constructor

F#

Meta.Numerics Library
LogisticDistribution Constructor

Overload List

Name | Description
LogisticDistribution()()()() | Initializes a new standard logistic distribution.
LogisticDistribution(Double, Double) | Initializes a new logistic distribution with the given mean and width parameters.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution Constructor

F#

Meta.Numerics Library
LogisticDistribution Constructor
Initializes a new standard logistic distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public LogisticDistribution()
Public Sub New
public:
LogisticDistribution()
new : unit -> LogisticDistribution

Remarks

The standard logistic distribution has zero mean and a unit width parameter.

See Also

LogisticDistribution Class
LogisticDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
LogisticDistribution Constructor (Double, Double)
Initializes a new logistic distribution with the given mean and width parameters.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public LogisticDistribution(
    double m,
    double s
)
Public Sub New (
    m As Double,
    s As Double
)
public:
LogisticDistribution(
    double m,
    double s
)
new :
        m : float *
        s : float -> LogisticDistribution

Parameters

m
Double
The mean.
s
Double
The width parameter.

See Also

LogisticDistribution Class
LogisticDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution Methods

F#

Meta.Numerics Library
LogisticDistribution Methods

The LogisticDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Cumulant Method

F#

Meta.Numerics Library
LogisticDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


LogisticDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
LogisticDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
LogisticDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.LeftProbability Method

F#

Meta.Numerics Library
LogisticDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Moment Method

F#

Meta.Numerics Library
LogisticDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


LogisticDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
LogisticDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


LogisticDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
LogisticDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.RightProbability Method

F#

Meta.Numerics Library
LogisticDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution Properties

F#

Meta.Numerics Library
LogisticDistribution Properties

The LogisticDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
LogisticDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Mean Property

F#

Meta.Numerics Library
LogisticDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Median Property

F#

Meta.Numerics Library
LogisticDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Skewness Property

F#

Meta.Numerics Library
LogisticDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.StandardDeviation Property

F#

Meta.Numerics Library
LogisticDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LogisticDistribution.Variance Property

F#

Meta.Numerics Library
LogisticDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

LogisticDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution Class

F#

| Members | See Also
Meta.Numerics Library
LognormalDistribution Class
Represents a log-normal distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class LognormalDistribution : Distribution
Public NotInheritable Class LognormalDistribution
    Inherits Distribution
public ref class LognormalDistribution sealed : public Distribution
[<SealedAttribute>]
type LognormalDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LognormalDistribution()()()() | Initializes a standard log-normal distribution.
LognormalDistribution(Double, Double) | Initializes a log-normal distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the log-normal distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
Mu | Gets the value of the μ parameter.
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Sigma | Gets the value of the σ parameter.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The logrithm of a log-normal distributed variable is distributed normally.

The log-normal distribution is commonly used in financial engineering as a model of stock prices. If the rate of return on an asset is distributed normally, then its price will be distributed log-normally.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..LognormalDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
Meta.Numerics.Statistics.Distributions..::..NormalDistribution
http://en.wikipedia.org/wiki/Log-normal_distribution


LognormalDistribution Constructor

F#

Meta.Numerics Library
LognormalDistribution Constructor

Overload List

Name | Description
LognormalDistribution()()()() | Initializes a standard log-normal distribution.
LognormalDistribution(Double, Double) | Initializes a log-normal distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution Constructor

F#

Meta.Numerics Library
LognormalDistribution Constructor
Initializes a standard log-normal distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public LognormalDistribution()
Public Sub New
public:
LognormalDistribution()
new : unit -> LognormalDistribution

Remarks

A standard log-normal distribution has μ = 0 and σ = 1. It is the log transform of the standard normal distribution.

See Also

LognormalDistribution Class
LognormalDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
LognormalDistribution Constructor (Double, Double)
Initializes a log-normal distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public LognormalDistribution(
    double mu,
    double sigma
)
Public Sub New (
    mu As Double,
    sigma As Double
)
public:
LognormalDistribution(
    double mu,
    double sigma
)
new :
        mu : float *
        sigma : float -> LognormalDistribution

Parameters

mu
Double
The mean of the underlying normal distribution.
sigma
Double
The standard deviation of the underlying normal distribution.

Remarks

Note that the values of μ and σ parameters are not the mean and standard deviation of the log-normal distribution. They are the mean and standard deviation of their logrithms z = ln x. This is the standard method of characterizing a log-normal distribution.

See Also

LognormalDistribution Class
LognormalDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution Methods

F#

Meta.Numerics Library
LognormalDistribution Methods

The LognormalDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the log-normal distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.FitToSample Method

F#

Meta.Numerics Library
LognormalDistribution..::FitToSample Method
Computes the log-normal distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameters.

Remarks

The returned fit parameters are the μ (Mu) and σ (Sigma) parameters, in that order. These are the same parameters, in the same order, that are required by the LognormalDistribution(Double, Double) constructor to specify a new log-normal distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.
System..::..InvalidOperationException | sample contains non-positive values.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.GetRandomValue Method

F#

Meta.Numerics Library
LognormalDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
LognormalDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
LognormalDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.LeftProbability Method

F#

Meta.Numerics Library
LognormalDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Moment Method

F#

Meta.Numerics Library
LognormalDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


LognormalDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
LognormalDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


LognormalDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
LognormalDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.RightProbability Method

F#

Meta.Numerics Library
LognormalDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution Properties

F#

Meta.Numerics Library
LognormalDistribution Properties

The LognormalDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Mu | Gets the value of the μ parameter.
Sigma | Gets the value of the σ parameter.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
LognormalDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Mean Property

F#

Meta.Numerics Library
LognormalDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Median Property

F#

Meta.Numerics Library
LognormalDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Mu Property

F#

Meta.Numerics Library
LognormalDistribution..::Mu Property
Gets the value of the μ parameter.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Mu { get; }
Public ReadOnly Property Mu As Double
    Get
public:
property double Mu {
    double get ();
}
member Mu : float with get

Property Value

Double

Remarks

Note that the value of this parameter is not the mean of the distribution. It is the value given to the distribution constructor (LognormalDistribution(Double, Double)), which is the mean of the underlying normal distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Sigma Property

F#

Meta.Numerics Library
LognormalDistribution..::Sigma Property
Gets the value of the σ parameter.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double Sigma { get; }
Public ReadOnly Property Sigma As Double
    Get
public:
property double Sigma {
    double get ();
}
member Sigma : float with get

Property Value

Double

Remarks

Note that the value of this parameter is not the standard deviation of the distribution. It is the value given to the distribution constructor (LognormalDistribution(Double, Double)), which is the sandard deviation of the underlying normal distribution.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Skewness Property

F#

Meta.Numerics Library
LognormalDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Support Property

F#

Meta.Numerics Library
LognormalDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


LognormalDistribution.Variance Property

F#

Meta.Numerics Library
LognormalDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

LognormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath Class

F#

| Members | See Also
Meta.Numerics Library
MomentMath Class
Contains methods for converting between different kinds of moments.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static class MomentMath
Public NotInheritable Class MomentMath
public ref class MomentMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MomentMath =  class end

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CentralToCumulant(Double, array<Double>[]()[][]) | Converts central moments to cumulants.
CentralToRaw(Double, array<Double>[]()[][]) | Converts central moments to raw moments.
CumulantToCentral(array<Double>[]()[][]) | Converts cumulants to central moments.
CumulantToRaw(array<Double>[]()[][]) | Converts cumulants to raw moments.
RawToCentral(array<Double>[]()[][]) | Converts raw moments to central moments.
RawToCumulant(array<Double>[]()[][]) | Converts raw moments to cumulants.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..MomentMath

See Also

Meta.Numerics.Statistics.Distributions Namespace


MomentMath Methods

F#

Meta.Numerics Library
MomentMath Methods

The MomentMath type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CentralToCumulant(Double, array<Double>[]()[][]) | Converts central moments to cumulants.
CentralToRaw(Double, array<Double>[]()[][]) | Converts central moments to raw moments.
CumulantToCentral(array<Double>[]()[][]) | Converts cumulants to central moments.
CumulantToRaw(array<Double>[]()[][]) | Converts cumulants to raw moments.
RawToCentral(array<Double>[]()[][]) | Converts raw moments to central moments.
RawToCumulant(array<Double>[]()[][]) | Converts raw moments to cumulants.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.CentralToCumulant Method

F#

Meta.Numerics Library
MomentMath..::CentralToCumulant Method
Converts central moments to cumulants.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] CentralToCumulant(
    double mu,
    double[] C
)
Public Shared Function CentralToCumulant (
    mu As Double,
    C As Double()
) As Double()
public:
static array<double>^ CentralToCumulant(
    double mu,
    array<double>^ C
)
static member CentralToCumulant :
        mu : float *
        C : float[] -> float[]

Parameters

mu
Double
The mean.
C
array< Double >[]()[][]
A set of central moments.

Return Value

array< Double >[]()[][]
The corresponding set of cumulants.

Exceptions

Exception | Condition
System..::..ArgumentNullException | C is null.
System..::..ArgumentOutOfRangeException | The zeroth central moment is not one, or the first central moment is not zero.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.CentralToRaw Method

F#

Meta.Numerics Library
MomentMath..::CentralToRaw Method
Converts central moments to raw moments.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] CentralToRaw(
    double mu,
    double[] C
)
Public Shared Function CentralToRaw (
    mu As Double,
    C As Double()
) As Double()
public:
static array<double>^ CentralToRaw(
    double mu,
    array<double>^ C
)
static member CentralToRaw :
        mu : float *
        C : float[] -> float[]

Parameters

mu
Double
The mean.
C
array< Double >[]()[][]
A set of central moments.

Return Value

array< Double >[]()[][]
The corresponding set of central moments.

Exceptions

Exception | Condition
System..::..ArgumentNullException | C is null.
System..::..ArgumentOutOfRangeException | The zeroth central moment is not one, or the first central moment is not zero.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.CumulantToCentral Method

F#

Meta.Numerics Library
MomentMath..::CumulantToCentral Method
Converts cumulants to central moments.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] CumulantToCentral(
    double[] K
)
Public Shared Function CumulantToCentral (
    K As Double()
) As Double()
public:
static array<double>^ CumulantToCentral(
    array<double>^ K
)
static member CumulantToCentral :
        K : float[] -> float[]

Parameters

K
array< Double >[]()[][]
A set of cumulants.

Return Value

array< Double >[]()[][]
The corresponding set of central moments.

Exceptions

Exception | Condition
System..::..ArgumentNullException | K is null.
System..::..ArgumentOutOfRangeException | The zeroth cumulant is not zero.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.CumulantToRaw Method

F#

Meta.Numerics Library
MomentMath..::CumulantToRaw Method
Converts cumulants to raw moments.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] CumulantToRaw(
    double[] K
)
Public Shared Function CumulantToRaw (
    K As Double()
) As Double()
public:
static array<double>^ CumulantToRaw(
    array<double>^ K
)
static member CumulantToRaw :
        K : float[] -> float[]

Parameters

K
array< Double >[]()[][]
A set of cumulants.

Return Value

array< Double >[]()[][]
The corresponding set of raw moments.

Exceptions

Exception | Condition
System..::..ArgumentNullException | K is null.
System..::..ArgumentOutOfRangeException | The zeroth cumulant is not zero.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.RawToCentral Method

F#

Meta.Numerics Library
MomentMath..::RawToCentral Method
Converts raw moments to central moments.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] RawToCentral(
    double[] M
)
Public Shared Function RawToCentral (
    M As Double()
) As Double()
public:
static array<double>^ RawToCentral(
    array<double>^ M
)
static member RawToCentral :
        M : float[] -> float[]

Parameters

M
array< Double >[]()[][]
A set of raw moments.

Return Value

array< Double >[]()[][]
The corresponding set of central moments.

Exceptions

Exception | Condition
System..::..ArgumentNullException | M is null.
System..::..ArgumentOutOfRangeException | The zeroth raw moment is not one.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


MomentMath.RawToCumulant Method

F#

Meta.Numerics Library
MomentMath..::RawToCumulant Method
Converts raw moments to cumulants.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static double[] RawToCumulant(
    double[] M
)
Public Shared Function RawToCumulant (
    M As Double()
) As Double()
public:
static array<double>^ RawToCumulant(
    array<double>^ M
)
static member RawToCumulant :
        M : float[] -> float[]

Parameters

M
array< Double >[]()[][]
A set of raw moments.

Return Value

array< Double >[]()[][]
The corresponding set of cumulants.

Exceptions

Exception | Condition
System..::..ArgumentNullException | M is null.
System..::..ArgumentOutOfRangeException | The zeroth raw moment is not one.

See Also

MomentMath Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution Class

F#

| Members | See Also
Meta.Numerics Library
NormalDistribution Class
Represents a normal (Gaussian) distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class NormalDistribution : Distribution
Public NotInheritable Class NormalDistribution
    Inherits Distribution
public ref class NormalDistribution sealed : public Distribution
[<SealedAttribute>]
type NormalDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
NormalDistribution()()()() | Initializes a new standard normal distribution.
NormalDistribution(Double, Double) | Initializes a new normal distribution with the given mean and standard deviation.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the normal distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

Remarks

A normal distribution is a bell-shaped curve centered at its mean and falling off symmetrically on each side. It is a two-parameter distribution determined by giving its mean and standard deviation, i.e. its center and width. Its range is the entire real number line, but the tails, i.e. points more than a few standard deviations from the means, fall off extremely rapidly.

A normal distribution with mean zero and standard deviation one is called a standard normal distribution. Any normal distribution can be converted to a standard normal distribution by reparameterzing the data in terms of "standard deviations from the mean", i.e. z = (x - μ) / σ.

Normal distribution appear in many contexts. In practical work, the normal distribution is often used as a crude model for the distribution of any continuous parameter that tends to cluster near its average, for example human height and weight. In more refined theoretical work, the normal distribution often emerges as a limiting distribution. For example, it can be shown that, if a large number of errors affect a measurement, then for nearly any underlying distribution of error terms, the distribution of total error tends to a normal distribution.

The normal distribution is sometimes called a Gaussian distribtuion, after the mathematician Friedrich Gauss.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..NormalDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Normal_distribution


NormalDistribution Constructor

F#

Meta.Numerics Library
NormalDistribution Constructor

Overload List

Name | Description
NormalDistribution()()()() | Initializes a new standard normal distribution.
NormalDistribution(Double, Double) | Initializes a new normal distribution with the given mean and standard deviation.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution Constructor

F#

Meta.Numerics Library
NormalDistribution Constructor
Initializes a new standard normal distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public NormalDistribution()
Public Sub New
public:
NormalDistribution()
new : unit -> NormalDistribution

Remarks

The standard normal distribution has mean zero and standard deviation one.

See Also

NormalDistribution Class
NormalDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution Constructor (Double, Double)

F#

Meta.Numerics Library
NormalDistribution Constructor (Double, Double)
Initializes a new normal distribution with the given mean and standard deviation.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public NormalDistribution(
    double mu,
    double sigma
)
Public Sub New (
    mu As Double,
    sigma As Double
)
public:
NormalDistribution(
    double mu,
    double sigma
)
new :
        mu : float *
        sigma : float -> NormalDistribution

Parameters

mu
Double
The mean.
sigma
Double
The standard deviation, which must be positive.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | sigma is less than or equal to zero.

See Also

NormalDistribution Class
NormalDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution Methods

F#

Meta.Numerics Library
NormalDistribution Methods

The NormalDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the normal distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.Cumulant Method

F#

Meta.Numerics Library
NormalDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


NormalDistribution.FitToSample Method

F#

Meta.Numerics Library
NormalDistribution..::FitToSample Method
Computes the normal distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameters.

Remarks

The returned fit parameters are the μ (Mean) and σ (StandardDeviation) parameters, in that order. These are the same parameters, in the same order, that are required by the NormalDistribution(Double, Double) constructor to specify a new normal distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.GetRandomValue Method

F#

Meta.Numerics Library
NormalDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
NormalDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
NormalDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.LeftProbability Method

F#

Meta.Numerics Library
NormalDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.Moment Method

F#

Meta.Numerics Library
NormalDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


NormalDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
NormalDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


NormalDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
NormalDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.RightProbability Method

F#

Meta.Numerics Library
NormalDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution Properties

F#

Meta.Numerics Library
NormalDistribution Properties

The NormalDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
NormalDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.Mean Property

F#

Meta.Numerics Library
NormalDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.Median Property

F#

Meta.Numerics Library
NormalDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.Skewness Property

F#

Meta.Numerics Library
NormalDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


NormalDistribution.StandardDeviation Property

F#

Meta.Numerics Library
NormalDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

NormalDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution Class

F#

| Members | See Also
Meta.Numerics Library
ParetoDistribution Class
Represents a Pareto or power law distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class ParetoDistribution : Distribution
Public NotInheritable Class ParetoDistribution
    Inherits Distribution
public ref class ParetoDistribution sealed : public Distribution
[<SealedAttribute>]
type ParetoDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ParetoDistribution(Double, Double) | Initializes a new Pareto distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GiniCoefficient | Gets the Gini coefficient corresponding to the distribution.
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ScaleParameter | Gets the scale parameter of the Pareto distribution.
ShapeParameter | Gets the shape parameter of the Pareto distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..ParetoDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Pareto_distribution


ParetoDistribution Constructor

F#

Meta.Numerics Library
ParetoDistribution Constructor
Initializes a new Pareto distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public ParetoDistribution(
    double mu,
    double alpha
)
Public Sub New (
    mu As Double,
    alpha As Double
)
public:
ParetoDistribution(
    double mu,
    double alpha
)
new :
        mu : float *
        alpha : float -> ParetoDistribution

Parameters

mu
Double
The scale parameter, which must be positive.
alpha
Double
The shape parameter, which must be positive.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution Methods

F#

Meta.Numerics Library
ParetoDistribution Methods

The ParetoDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
ParetoDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
ParetoDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.LeftProbability Method

F#

Meta.Numerics Library
ParetoDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Moment Method

F#

Meta.Numerics Library
ParetoDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ParetoDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
ParetoDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


ParetoDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
ParetoDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.RightProbability Method

F#

Meta.Numerics Library
ParetoDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution Properties

F#

Meta.Numerics Library
ParetoDistribution Properties

The ParetoDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
GiniCoefficient | Gets the Gini coefficient corresponding to the distribution.
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
ScaleParameter | Gets the scale parameter of the Pareto distribution.
ShapeParameter | Gets the shape parameter of the Pareto distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.GiniCoefficient Property

F#

Meta.Numerics Library
ParetoDistribution..::GiniCoefficient Property
Gets the Gini coefficient corresponding to the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double GiniCoefficient { get; }
Public ReadOnly Property GiniCoefficient As Double
    Get
public:
property double GiniCoefficient {
    double get ();
}
member GiniCoefficient : float with get

Property Value

Double

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Mean Property

F#

Meta.Numerics Library
ParetoDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Median Property

F#

Meta.Numerics Library
ParetoDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.ScaleParameter Property

F#

Meta.Numerics Library
ParetoDistribution..::ScaleParameter Property
Gets the scale parameter of the Pareto distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ScaleParameter { get; }
Public ReadOnly Property ScaleParameter As Double
    Get
public:
property double ScaleParameter {
    double get ();
}
member ScaleParameter : float with get

Property Value

Double

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.ShapeParameter Property

F#

Meta.Numerics Library
ParetoDistribution..::ShapeParameter Property
Gets the shape parameter of the Pareto distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ShapeParameter { get; }
Public ReadOnly Property ShapeParameter As Double
    Get
public:
property double ShapeParameter {
    double get ();
}
member ShapeParameter : float with get

Property Value

Double

Remarks

For a given shape parameter α, the probability density falls off as x-(α+1).

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Skewness Property

F#

Meta.Numerics Library
ParetoDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.StandardDeviation Property

F#

Meta.Numerics Library
ParetoDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Support Property

F#

Meta.Numerics Library
ParetoDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


ParetoDistribution.Variance Property

F#

Meta.Numerics Library
ParetoDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

ParetoDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution Class

F#

| Members | See Also
Meta.Numerics Library
PearsonRDistribution Class
Represents the distribution of Pearsons's r statistic.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class PearsonRDistribution : Distribution
Public NotInheritable Class PearsonRDistribution
    Inherits Distribution
public ref class PearsonRDistribution sealed : public Distribution
[<SealedAttribute>]
type PearsonRDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PearsonRDistribution(Int32) | Initializes a new instance of the Pearson r distribution for the given number of pairs.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..PearsonRDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution Constructor

F#

Meta.Numerics Library
PearsonRDistribution Constructor
Initializes a new instance of the Pearson r distribution for the given number of pairs.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public PearsonRDistribution(
    int n
)
Public Sub New (
    n As Integer
)
public:
PearsonRDistribution(
    int n
)
new :
        n : int -> PearsonRDistribution

Parameters

n
Int32
The number of pairs, which must be three or more.

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution Methods

F#

Meta.Numerics Library
PearsonRDistribution Methods

The PearsonRDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.LeftProbability Method

F#

Meta.Numerics Library
PearsonRDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.Moment Method

F#

Meta.Numerics Library
PearsonRDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


PearsonRDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
PearsonRDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


PearsonRDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
PearsonRDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution Properties

F#

Meta.Numerics Library
PearsonRDistribution Properties

The PearsonRDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.Mean Property

F#

Meta.Numerics Library
PearsonRDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.Skewness Property

F#

Meta.Numerics Library
PearsonRDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.Support Property

F#

Meta.Numerics Library
PearsonRDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PearsonRDistribution.Variance Property

F#

Meta.Numerics Library
PearsonRDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

PearsonRDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution Class

F#

| Members | See Also
Meta.Numerics Library
PoissonDistribution Class
Represented a Poisson distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class PoissonDistribution : DiscreteDistribution
Public NotInheritable Class PoissonDistribution
    Inherits DiscreteDistribution
public ref class PoissonDistribution sealed : public DiscreteDistribution
[<SealedAttribute>]
type PoissonDistribution =
    class
        inherit DiscreteDistribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PoissonDistribution(Double) | Creates a new instance of a Poisson distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Overrides DiscreteDistribution..::..LeftInclusiveProbability(Int32).)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..PoissonDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution Constructor

F#

Meta.Numerics Library
PoissonDistribution Constructor
Creates a new instance of a Poisson distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public PoissonDistribution(
    double mu
)
Public Sub New (
    mu As Double
)
public:
PoissonDistribution(
    double mu
)
new :
        mu : float -> PoissonDistribution

Parameters

mu
Double
The mean, which must be positive.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution Methods

F#

Meta.Numerics Library
PoissonDistribution Methods

The PoissonDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Int32, Double>)>>)) | Computes the expectation value of an artibrary function. (Inherited from DiscreteDistribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Produces a random integer drawn from the distribution. (Inherited from DiscreteDistribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Computes the value corresponding to the given percentile. (Overrides DiscreteDistribution..::..InverseLeftProbability(Double).)
LeftExclusiveProbability(Int32) | Computes the probability of obtaining a value less than the given value. (Overrides DiscreteDistribution..::..LeftExclusiveProbability(Int32).)
LeftInclusiveProbability(Int32) | Computes the probability of obtaining a value less than or equal to the given value. (Overrides DiscreteDistribution..::..LeftInclusiveProbability(Int32).)
Moment(Int32) | Gets a raw moment of the distribution. (Overrides DiscreteDistribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Gets a central moment of the distribution. (Overrides DiscreteDistribution..::..MomentAboutMean(Int32).)
ProbabilityMass(Int32) | Returns the probability of the obtaining the given value. (Overrides DiscreteDistribution..::..ProbabilityMass(Int32).)
RightExclusiveProbability(Int32) | Computes the probability of obtaining a value greater than the given value. (Overrides DiscreteDistribution..::..RightExclusiveProbability(Int32).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Cumulant Method

F#

Meta.Numerics Library
PoissonDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


PoissonDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
PoissonDistribution..::InverseLeftProbability Method
Computes the value corresponding to the given percentile.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Integer
public:
virtual int InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> int
override InverseLeftProbability :
        P : float -> int

Parameters

P
Double
The percentile.

Return Value

Int32
The value.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.LeftExclusiveProbability Method

F#

Meta.Numerics Library
PoissonDistribution..::LeftExclusiveProbability Method
Computes the probability of obtaining a value less than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftExclusiveProbability(
    int k
)
Public Overrides Function LeftExclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftExclusiveProbability(
    int k
) override
abstract LeftExclusiveProbability :
        k : int -> float
override LeftExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly less than k.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..RightExclusiveProbability(Int32)


PoissonDistribution.LeftInclusiveProbability Method

F#

Meta.Numerics Library
PoissonDistribution..::LeftInclusiveProbability Method
Computes the probability of obtaining a value less than or equal to the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftInclusiveProbability(
    int k
)
Public Overrides Function LeftInclusiveProbability (
    k As Integer
) As Double
public:
virtual double LeftInclusiveProbability(
    int k
) override
abstract LeftInclusiveProbability :
        k : int -> float
override LeftInclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value les than or equal to k.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Moment Method

F#

Meta.Numerics Library
PoissonDistribution..::Moment Method
Gets a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The raw moment Mr.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
PoissonDistribution..::MomentAboutMean Method
Gets a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment.

Return Value

Double
The central moment Cr.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.ProbabilityMass Method

F#

Meta.Numerics Library
PoissonDistribution..::ProbabilityMass Method
Returns the probability of the obtaining the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityMass(
    int k
)
Public Overrides Function ProbabilityMass (
    k As Integer
) As Double
public:
virtual double ProbabilityMass(
    int k
) override
abstract ProbabilityMass :
        k : int -> float
override ProbabilityMass :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The probability of obtaining the value.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.RightExclusiveProbability Method

F#

Meta.Numerics Library
PoissonDistribution..::RightExclusiveProbability Method
Computes the probability of obtaining a value greater than the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightExclusiveProbability(
    int k
)
Public Overrides Function RightExclusiveProbability (
    k As Integer
) As Double
public:
virtual double RightExclusiveProbability(
    int k
) override
abstract RightExclusiveProbability :
        k : int -> float
override RightExclusiveProbability :
        k : int -> float

Parameters

k
Int32
The value.

Return Value

Double
The total probability of obtaining a value strictly greater than k.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
DiscreteDistribution..::..LeftExclusiveProbability(Int32)


PoissonDistribution Properties

F#

Meta.Numerics Library
PoissonDistribution Properties

The PoissonDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Maximum | Gets the largest value in the distribution. (Overrides DiscreteDistribution..::..Maximum.)
Mean | Gets the mean of the distribution. (Overrides DiscreteDistribution..::..Mean.)
Minimum | Gets the smallest value in the distribution. (Overrides DiscreteDistribution..::..Minimum.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
PoissonDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Maximum Property

F#

Meta.Numerics Library
PoissonDistribution..::Maximum Property
Gets the largest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Maximum { get; }
Public Overrides ReadOnly Property Maximum As Integer
    Get
public:
virtual property int Maximum {
    int get () override;
}
abstract Maximum : int with get
override Maximum : int with get

Property Value

Int32

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Mean Property

F#

Meta.Numerics Library
PoissonDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Minimum Property

F#

Meta.Numerics Library
PoissonDistribution..::Minimum Property
Gets the smallest value in the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override int Minimum { get; }
Public Overrides ReadOnly Property Minimum As Integer
    Get
public:
virtual property int Minimum {
    int get () override;
}
abstract Minimum : int with get
override Minimum : int with get

Property Value

Int32

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Skewness Property

F#

Meta.Numerics Library
PoissonDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


PoissonDistribution.Variance Property

F#

Meta.Numerics Library
PoissonDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

PoissonDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution Class

F#

| Members | See Also
Meta.Numerics Library
StudentDistribution Class
Represents the distribution of Student't t statistic.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class StudentDistribution : Distribution
Public NotInheritable Class StudentDistribution
    Inherits Distribution
public ref class StudentDistribution sealed : public Distribution
[<SealedAttribute>]
type StudentDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
StudentDistribution(Double) | Initializes a new Student distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
DegreesOfFreedom | Gets the number of degrees of freedom.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The mean of n independent standard-normal distributed variables, divided by their root mean square, is distributed according a Student distribution with n degrees of freedom. Since this is the form of the expression for the mean of a sample divided by its standard deviation, the Student distribution expresses the distribution of sample means arround the population mean, for a normally distributed population.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..StudentDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
Sample..::..StudentTTest(Double)
http://en.wikipedia.org/wiki/Student_t_distribution


StudentDistribution Constructor

F#

Meta.Numerics Library
StudentDistribution Constructor
Initializes a new Student distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public StudentDistribution(
    double nu
)
Public Sub New (
    nu As Double
)
public:
StudentDistribution(
    double nu
)
new :
        nu : float -> StudentDistribution

Parameters

nu
Double
The number of degrees of freedom, which must be positive.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution Methods

F#

Meta.Numerics Library
StudentDistribution Methods

The StudentDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Overrides Distribution..::..GetRandomValue(Random).)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.GetRandomValue Method

F#

Meta.Numerics Library
StudentDistribution..::GetRandomValue Method
Returns a random value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double GetRandomValue(
    Random rng
)
Public Overrides Function GetRandomValue (
    rng As Random
) As Double
public:
virtual double GetRandomValue(
    Random^ rng
) override
abstract GetRandomValue :
        rng : Random -> float
override GetRandomValue :
        rng : Random -> float

Parameters

rng
Random
A random number generator.

Return Value

Double
A number distributed according to the distribution.

Remarks

Note that the random number generator rng will be advanced by this method. The next call to its generator methods will not give the same value as it would had it not been passed to this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | rng is null.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
StudentDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.LeftProbability Method

F#

Meta.Numerics Library
StudentDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.Moment Method

F#

Meta.Numerics Library
StudentDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


StudentDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
StudentDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


StudentDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
StudentDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.RightProbability Method

F#

Meta.Numerics Library
StudentDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution Properties

F#

Meta.Numerics Library
StudentDistribution Properties

The StudentDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DegreesOfFreedom | Gets the number of degrees of freedom.
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Inherited from Distribution.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.DegreesOfFreedom Property

F#

Meta.Numerics Library
StudentDistribution..::DegreesOfFreedom Property
Gets the number of degrees of freedom.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double DegreesOfFreedom { get; }
Public ReadOnly Property DegreesOfFreedom As Double
    Get
public:
property double DegreesOfFreedom {
    double get ();
}
member DegreesOfFreedom : float with get

Property Value

Double

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.Mean Property

F#

Meta.Numerics Library
StudentDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.Median Property

F#

Meta.Numerics Library
StudentDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.Skewness Property

F#

Meta.Numerics Library
StudentDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


StudentDistribution.Variance Property

F#

Meta.Numerics Library
StudentDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

StudentDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution Class

F#

| Members | See Also
Meta.Numerics Library
TriangularDistribution Class
Represents a triangular distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class TriangularDistribution : Distribution
Public NotInheritable Class TriangularDistribution
    Inherits Distribution
public ref class TriangularDistribution sealed : public Distribution
[<SealedAttribute>]
type TriangularDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
TriangularDistribution(Double, Double, Double) | Initializes a new triangular distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

Like a uniform distribution, a triangular distribution is confined to a finite interval. Unlike a uniform distribution, a triangular distribution is not uniform across the interval.

Triangular distributions are often used in project planning, where a maximum, minimum, and most likely value for some quantity is known or supposed.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..TriangularDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Triangular_distribution


TriangularDistribution Constructor

F#

Meta.Numerics Library
TriangularDistribution Constructor
Initializes a new triangular distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public TriangularDistribution(
    double a,
    double b,
    double c
)
Public Sub New (
    a As Double,
    b As Double,
    c As Double
)
public:
TriangularDistribution(
    double a,
    double b,
    double c
)
new :
        a : float *
        b : float *
        c : float -> TriangularDistribution

Parameters

a
Double
One inflection point of the distribution.
b
Double
A second inflection point of the distribution.
c
Double
A third inflection point of the distribution.

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution Methods

F#

Meta.Numerics Library
TriangularDistribution Methods

The TriangularDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
TriangularDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.LeftProbability Method

F#

Meta.Numerics Library
TriangularDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.Moment Method

F#

Meta.Numerics Library
TriangularDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


TriangularDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
TriangularDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


TriangularDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
TriangularDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.RightProbability Method

F#

Meta.Numerics Library
TriangularDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution Properties

F#

Meta.Numerics Library
TriangularDistribution Properties

The TriangularDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.Mean Property

F#

Meta.Numerics Library
TriangularDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.Support Property

F#

Meta.Numerics Library
TriangularDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


TriangularDistribution.Variance Property

F#

Meta.Numerics Library
TriangularDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

TriangularDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution Class

F#

| Members | See Also
Meta.Numerics Library
UniformDistribution Class
Represents a uniform distribution over an interval.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class UniformDistribution : Distribution
Public NotInheritable Class UniformDistribution
    Inherits Distribution
public ref class UniformDistribution sealed : public Distribution
[<SealedAttribute>]
type UniformDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UniformDistribution()()()() | Initializes a new standard uniform distribution.
UniformDistribution(Interval) | Initializes a new uniform distribution on the given interval.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..UniformDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Uniform_distribution_(continuous)


UniformDistribution Constructor

F#

Meta.Numerics Library
UniformDistribution Constructor

Overload List

Name | Description
UniformDistribution()()()() | Initializes a new standard uniform distribution.
UniformDistribution(Interval) | Initializes a new uniform distribution on the given interval.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution Constructor

F#

Meta.Numerics Library
UniformDistribution Constructor
Initializes a new standard uniform distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UniformDistribution()
Public Sub New
public:
UniformDistribution()
new : unit -> UniformDistribution

Remarks

A standard uniform distribution is uniform on the interval [0,1].

See Also

UniformDistribution Class
UniformDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution Constructor (Interval)

F#

Meta.Numerics Library
UniformDistribution Constructor (Interval)
Initializes a new uniform distribution on the given interval.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public UniformDistribution(
    Interval range
)
Public Sub New (
    range As Interval
)
public:
UniformDistribution(
    Interval range
)
new :
        range : Interval -> UniformDistribution

Parameters

range
Interval
The range of the distribution.

See Also

UniformDistribution Class
UniformDistribution Overload
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution Methods

F#

Meta.Numerics Library
UniformDistribution Methods

The UniformDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Cumulant Method

F#

Meta.Numerics Library
UniformDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


UniformDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
UniformDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
UniformDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.LeftProbability Method

F#

Meta.Numerics Library
UniformDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Moment Method

F#

Meta.Numerics Library
UniformDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


UniformDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
UniformDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


UniformDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
UniformDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution Properties

F#

Meta.Numerics Library
UniformDistribution Properties

The UniformDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Overrides UnivariateDistribution..::..ExcessKurtosis.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Overrides UnivariateDistribution..::..StandardDeviation.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Inherited from UnivariateDistribution.)

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
UniformDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ExcessKurtosis { get; }
Public Overrides ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get () override;
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Mean Property

F#

Meta.Numerics Library
UniformDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Median Property

F#

Meta.Numerics Library
UniformDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Skewness Property

F#

Meta.Numerics Library
UniformDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.StandardDeviation Property

F#

Meta.Numerics Library
UniformDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double StandardDeviation { get; }
Public Overrides ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get () override;
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UniformDistribution.Support Property

F#

Meta.Numerics Library
UniformDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

UniformDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution Class

F#

| Members | See Also
Meta.Numerics Library
UnivariateDistribution Class
Represents a probability distribution over a single variable.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract class UnivariateDistribution
Public MustInherit Class UnivariateDistribution
public ref class UnivariateDistribution abstract
[<AbstractClassAttribute>]
type UnivariateDistribution =  class end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UnivariateDistribution()()()() | Initializes a new instance of the UnivariateDistribution class
Cumulant(Int32) | Computes a cumulant of the distribution.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution.
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Mean | Gets the mean of the distribution.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Moment(Int32) | Computes a raw moment of the distribution.
MomentAboutMean(Int32) | Computes a central moment of the distribution.
Skewness | Gets the skewness of the distribution.
StandardDeviation | Gets the standard deviation of the distribution.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..DiscreteDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution

See Also

Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution Constructor

F#

Meta.Numerics Library
UnivariateDistribution Constructor
Initializes a new instance of the UnivariateDistribution class

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
protected UnivariateDistribution()
Protected Sub New
protected:
UnivariateDistribution()
new : unit -> UnivariateDistribution

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution Methods

F#

Meta.Numerics Library
UnivariateDistribution Methods

The UnivariateDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Moment(Int32) | Computes a raw moment of the distribution.
MomentAboutMean(Int32) | Computes a central moment of the distribution.
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.Cumulant Method

F#

Meta.Numerics Library
UnivariateDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Cumulant(
    int r
)
Public Overridable Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
)
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


UnivariateDistribution.Moment Method

F#

Meta.Numerics Library
UnivariateDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public abstract double Moment(
    int r
)
Public MustOverride Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) abstract
abstract Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


UnivariateDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
UnivariateDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double MomentAboutMean(
    int r
)
Public Overridable Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
)
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


UnivariateDistribution Properties

F#

Meta.Numerics Library
UnivariateDistribution Properties

The UnivariateDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution.
Mean | Gets the mean of the distribution.
Skewness | Gets the skewness of the distribution.
StandardDeviation | Gets the standard deviation of the distribution.
Variance | Gets the variance of the distribution.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.ExcessKurtosis Property

F#

Meta.Numerics Library
UnivariateDistribution..::ExcessKurtosis Property
Gets the excess kurtosis of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double ExcessKurtosis { get; }
Public Overridable ReadOnly Property ExcessKurtosis As Double
    Get
public:
virtual property double ExcessKurtosis {
    double get ();
}
abstract ExcessKurtosis : float with get
override ExcessKurtosis : float with get

Property Value

Double

Remarks

The excess kurtosis of a distribution is a measurement of the fatness of its tails relative to the normal distribution.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.Mean Property

F#

Meta.Numerics Library
UnivariateDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Mean { get; }
Public Overridable ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get ();
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.Skewness Property

F#

Meta.Numerics Library
UnivariateDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Skewness { get; }
Public Overridable ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get ();
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.StandardDeviation Property

F#

Meta.Numerics Library
UnivariateDistribution..::StandardDeviation Property
Gets the standard deviation of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double StandardDeviation { get; }
Public Overridable ReadOnly Property StandardDeviation As Double
    Get
public:
virtual property double StandardDeviation {
    double get ();
}
abstract StandardDeviation : float with get
override StandardDeviation : float with get

Property Value

Double

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


UnivariateDistribution.Variance Property

F#

Meta.Numerics Library
UnivariateDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public virtual double Variance { get; }
Public Overridable ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get ();
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

UnivariateDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution Class

F#

| Members | See Also
Meta.Numerics Library
WaldDistribution Class
Represents a Wald distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class WaldDistribution : Distribution
Public NotInheritable Class WaldDistribution
    Inherits Distribution
public ref class WaldDistribution sealed : public Distribution
[<SealedAttribute>]
type WaldDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
WaldDistribution(Double, Double) | Initializes a new Wald distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Determines the parameters of the Wald distribution that best fits a sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
ShapeParameter | Gets the shape parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..WaldDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Inverse_Gaussian_distribution


WaldDistribution Constructor

F#

Meta.Numerics Library
WaldDistribution Constructor
Initializes a new Wald distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public WaldDistribution(
    double mean,
    double shape
)
Public Sub New (
    mean As Double,
    shape As Double
)
public:
WaldDistribution(
    double mean,
    double shape
)
new :
        mean : float *
        shape : float -> WaldDistribution

Parameters

mean
Double
The mean value, which must be positive.
shape
Double
The shape parameter, which must be positive.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution Methods

F#

Meta.Numerics Library
WaldDistribution Methods

The WaldDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Overrides UnivariateDistribution..::..Cumulant(Int32).)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Determines the parameters of the Wald distribution that best fits a sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Inherited from Distribution.)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Inherited from Distribution.)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Inherited from Distribution.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Cumulant Method

F#

Meta.Numerics Library
WaldDistribution..::Cumulant Method
Computes a cumulant of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Cumulant(
    int r
)
Public Overrides Function Cumulant (
    r As Integer
) As Double
public:
virtual double Cumulant(
    int r
) override
abstract Cumulant :
        r : int -> float
override Cumulant :
        r : int -> float

Parameters

r
Int32
The index of the cumulant to compute.

Return Value

Double
The rth cumulant of the distribution.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Cumulant


WaldDistribution.FitToSample Method

F#

Meta.Numerics Library
WaldDistribution..::FitToSample Method
Determines the parameters of the Wald distribution that best fits a sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The fit.

Remarks

The returned fit parameters are the Mean and ShapeParameter, in that order. These are the same parameters, in the same order, that are required by the WaldDistribution(Double, Double) constructor to specify a new Wald distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
System..::..InvalidOperationException | sample contains non-positive values.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.LeftProbability Method

F#

Meta.Numerics Library
WaldDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Moment Method

F#

Meta.Numerics Library
WaldDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


WaldDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
WaldDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


WaldDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
WaldDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution Properties

F#

Meta.Numerics Library
WaldDistribution Properties

The WaldDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Inherited from Distribution.)
ShapeParameter | Gets the shape parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Overrides UnivariateDistribution..::..Skewness.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Mean Property

F#

Meta.Numerics Library
WaldDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.ShapeParameter Property

F#

Meta.Numerics Library
WaldDistribution..::ShapeParameter Property
Gets the shape parameter of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ShapeParameter { get; }
Public ReadOnly Property ShapeParameter As Double
    Get
public:
property double ShapeParameter {
    double get ();
}
member ShapeParameter : float with get

Property Value

Double

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Skewness Property

F#

Meta.Numerics Library
WaldDistribution..::Skewness Property
Gets the skewness of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Skewness { get; }
Public Overrides ReadOnly Property Skewness As Double
    Get
public:
virtual property double Skewness {
    double get () override;
}
abstract Skewness : float with get
override Skewness : float with get

Property Value

Double

Remarks

The skewness of a distribution is a measurement of its asymmetry about its mean. It is the third moment about the mean, measured in units of the cubed standard deviation.

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Support Property

F#

Meta.Numerics Library
WaldDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WaldDistribution.Variance Property

F#

Meta.Numerics Library
WaldDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

WaldDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution Class

F#

| Members | See Also
Meta.Numerics Library
WeibullDistribution Class
Represents a Weibull distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public sealed class WeibullDistribution : Distribution
Public NotInheritable Class WeibullDistribution
    Inherits Distribution
public ref class WeibullDistribution sealed : public Distribution
[<SealedAttribute>]
type WeibullDistribution =
    class
        inherit Distribution
    end

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
WeibullDistribution(Double, Double) | Initializes a new Weibull distribution.
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Weibull distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ScaleParameter | Gets the scale parameter of the distribution.
ShapeParameter | Gets the shape parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

Remarks

The Weibull distribution is a generalized form of the exponential distriubtion for which the decay probability is not constant, but instead increases with time (for shape parameters greater than one) or, less commonly, decreases with time (for shape parameters less than one). When the shape parameter is one, the Weibull distribution reduces to the exponential distribution.

The Weibull distribution is commonly used in engineering applications to model the time-to-failure of industrial componets.

Inheritance Hierarchy

System..::..Object
Meta.Numerics.Statistics.Distributions..::..UnivariateDistribution
Meta.Numerics.Statistics.Distributions..::..Distribution
Meta.Numerics.Statistics.Distributions..::..WeibullDistribution

See Also

Meta.Numerics.Statistics.Distributions Namespace
http://en.wikipedia.org/wiki/Weibull_distribution


WeibullDistribution Constructor

F#

Meta.Numerics Library
WeibullDistribution Constructor
Initializes a new Weibull distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public WeibullDistribution(
    double scale,
    double shape
)
Public Sub New (
    scale As Double,
    shape As Double
)
public:
WeibullDistribution(
    double scale,
    double shape
)
new :
        scale : float *
        shape : float -> WeibullDistribution

Parameters

scale
Double
The scale parameter, which must be positive.
shape
Double
The shape parameter, which must be positive.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution Methods

F#

Meta.Numerics Library
WeibullDistribution Methods

The WeibullDistribution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cumulant(Int32) | Computes a cumulant of the distribution. (Inherited from UnivariateDistribution.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpectationValue(Func<(Of <<'(Double, Double>)>>)) | Computes the expectation value of the given function. (Inherited from Distribution.)
FitToSample(Sample) | Computes the Weibull distribution that best fits the given sample.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetRandomValue(Random) | Returns a random value. (Inherited from Distribution.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InverseLeftProbability(Double) | Returns the point at which the cumulative distribution function attains a given value. (Overrides Distribution..::..InverseLeftProbability(Double).)
InverseRightProbability(Double) | Returns the point at which the right probability function attains the given value. (Overrides Distribution..::..InverseRightProbability(Double).)
LeftProbability(Double) | Returns the cumulative probability to the left of (below) the given point. (Overrides Distribution..::..LeftProbability(Double).)
Moment(Int32) | Computes a raw moment of the distribution. (Overrides Distribution..::..Moment(Int32).)
MomentAboutMean(Int32) | Computes a central moment of the distribution. (Overrides Distribution..::..MomentAboutMean(Int32).)
ProbabilityDensity(Double) | Returns the probability density at the given point. (Overrides Distribution..::..ProbabilityDensity(Double).)
RightProbability(Double) | Return the cumulative probability to the right of (above) the given point. (Overrides Distribution..::..RightProbability(Double).)
ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.FitToSample Method

F#

Meta.Numerics Library
WeibullDistribution..::FitToSample Method
Computes the Weibull distribution that best fits the given sample.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public static FitResult FitToSample(
    Sample sample
)
Public Shared Function FitToSample (
    sample As Sample
) As FitResult
public:
static FitResult^ FitToSample(
    Sample^ sample
)
static member FitToSample :
        sample : Sample -> FitResult

Parameters

sample
Sample
The sample to fit.

Return Value

FitResult
The best fit parameters.

Remarks

The returned fit parameters are the ShapeParameter and ScaleParameter, in that order. These are the same parameters, in the same order, that are required by the WeibullDistribution(Double, Double) constructor to specify a new Weibull distribution.

Exceptions

Exception | Condition
System..::..ArgumentNullException | sample is null.
System..::..InvalidOperationException | sample contains non-positive values.
Meta.Numerics.Statistics..::..InsufficientDataException | sample contains fewer than three values.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.InverseLeftProbability Method

F#

Meta.Numerics Library
WeibullDistribution..::InverseLeftProbability Method
Returns the point at which the cumulative distribution function attains a given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseLeftProbability(
    double P
)
Public Overrides Function InverseLeftProbability (
    P As Double
) As Double
public:
virtual double InverseLeftProbability(
    double P
) override
abstract InverseLeftProbability :
        P : float -> float
override InverseLeftProbability :
        P : float -> float

Parameters

P
Double
The left cumulative probability P, which must lie between 0 and 1.

Return Value

Double
The value x at which LeftProbability(Double) equals P.

Remarks

The inverse left probability is commonly called the quantile function. Given a quantile, it tells which variable value is the lower border of that quantile.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | P lies outside [0,1].

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.InverseRightProbability Method

F#

Meta.Numerics Library
WeibullDistribution..::InverseRightProbability Method
Returns the point at which the right probability function attains the given value.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double InverseRightProbability(
    double Q
)
Public Overrides Function InverseRightProbability (
    Q As Double
) As Double
public:
virtual double InverseRightProbability(
    double Q
) override
abstract InverseRightProbability :
        Q : float -> float
override InverseRightProbability :
        Q : float -> float

Parameters

Q
Double
The right cumulative probability, which must lie between 0 and 1.

Return Value

Double
The value x for which RightProbability(Double) equals Q.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.LeftProbability Method

F#

Meta.Numerics Library
WeibullDistribution..::LeftProbability Method
Returns the cumulative probability to the left of (below) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double LeftProbability(
    double x
)
Public Overrides Function LeftProbability (
    x As Double
) As Double
public:
virtual double LeftProbability(
    double x
) override
abstract LeftProbability :
        x : float -> float
override LeftProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability to obtain a result below the reference point.

Remarks

The left probability function is commonly called the cumulative distribution function (CDF).

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.Moment Method

F#

Meta.Numerics Library
WeibullDistribution..::Moment Method
Computes a raw moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Moment(
    int r
)
Public Overrides Function Moment (
    r As Integer
) As Double
public:
virtual double Moment(
    int r
) override
abstract Moment :
        r : int -> float
override Moment :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth raw moment of the distribution.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


WeibullDistribution.MomentAboutMean Method

F#

Meta.Numerics Library
WeibullDistribution..::MomentAboutMean Method
Computes a central moment of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double MomentAboutMean(
    int r
)
Public Overrides Function MomentAboutMean (
    r As Integer
) As Double
public:
virtual double MomentAboutMean(
    int r
) override
abstract MomentAboutMean :
        r : int -> float
override MomentAboutMean :
        r : int -> float

Parameters

r
Int32
The order of the moment to compute.

Return Value

Double
The rth central moment of the distribution.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace
UnivariateDistribution..::..Moment(Int32)


WeibullDistribution.ProbabilityDensity Method

F#

Meta.Numerics Library
WeibullDistribution..::ProbabilityDensity Method
Returns the probability density at the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double ProbabilityDensity(
    double x
)
Public Overrides Function ProbabilityDensity (
    x As Double
) As Double
public:
virtual double ProbabilityDensity(
    double x
) override
abstract ProbabilityDensity :
        x : float -> float
override ProbabilityDensity :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The probability density p(x).

Remarks

The probability density function (PDF) gives the relative probability of obtaining different values.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.RightProbability Method

F#

Meta.Numerics Library
WeibullDistribution..::RightProbability Method
Return the cumulative probability to the right of (above) the given point.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double RightProbability(
    double x
)
Public Overrides Function RightProbability (
    x As Double
) As Double
public:
virtual double RightProbability(
    double x
) override
abstract RightProbability :
        x : float -> float
override RightProbability :
        x : float -> float

Parameters

x
Double
The reference point.

Return Value

Double
The integrated probability 1-P(x1) to obtain a result above the reference point.

Remarks

In survival analysis, the right probability function is commonly called the survival function, because it gives the fraction of the population remaining after the given time.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution Properties

F#

Meta.Numerics Library
WeibullDistribution Properties

The WeibullDistribution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ExcessKurtosis | Gets the excess kurtosis of the distribution. (Inherited from UnivariateDistribution.)
Mean | Gets the mean of the distribution. (Overrides UnivariateDistribution..::..Mean.)
Median | Gets the median of the distribution. (Overrides Distribution..::..Median.)
ScaleParameter | Gets the scale parameter of the distribution.
ShapeParameter | Gets the shape parameter of the distribution.
Skewness | Gets the skewness of the distribution. (Inherited from UnivariateDistribution.)
StandardDeviation | Gets the standard deviation of the distribution. (Inherited from UnivariateDistribution.)
Support | Gets the interval over which the distribution is nonvanishing. (Overrides Distribution..::..Support.)
Variance | Gets the variance of the distribution. (Overrides UnivariateDistribution..::..Variance.)

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.Mean Property

F#

Meta.Numerics Library
WeibullDistribution..::Mean Property
Gets the mean of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Mean { get; }
Public Overrides ReadOnly Property Mean As Double
    Get
public:
virtual property double Mean {
    double get () override;
}
abstract Mean : float with get
override Mean : float with get

Property Value

Double

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.Median Property

F#

Meta.Numerics Library
WeibullDistribution..::Median Property
Gets the median of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Median { get; }
Public Overrides ReadOnly Property Median As Double
    Get
public:
virtual property double Median {
    double get () override;
}
abstract Median : float with get
override Median : float with get

Property Value

Double

Remarks

The median is the point with equal integrated probability above and below, i.e. with P(x1) = 0.5.

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.ScaleParameter Property

F#

Meta.Numerics Library
WeibullDistribution..::ScaleParameter Property
Gets the scale parameter of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ScaleParameter { get; }
Public ReadOnly Property ScaleParameter As Double
    Get
public:
property double ScaleParameter {
    double get ();
}
member ScaleParameter : float with get

Property Value

Double

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.ShapeParameter Property

F#

Meta.Numerics Library
WeibullDistribution..::ShapeParameter Property
Gets the shape parameter of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public double ShapeParameter { get; }
Public ReadOnly Property ShapeParameter As Double
    Get
public:
property double ShapeParameter {
    double get ();
}
member ShapeParameter : float with get

Property Value

Double

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.Support Property

F#

Meta.Numerics Library
WeibullDistribution..::Support Property
Gets the interval over which the distribution is nonvanishing.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override Interval Support { get; }
Public Overrides ReadOnly Property Support As Interval
    Get
public:
virtual property Interval Support {
    Interval get () override;
}
abstract Support : Interval with get
override Support : Interval with get

Property Value

Interval

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace


WeibullDistribution.Variance Property

F#

Meta.Numerics Library
WeibullDistribution..::Variance Property
Gets the variance of the distribution.

Namespace: Meta.Numerics.Statistics.Distributions
Assembly: Meta.Numerics (in Meta.Numerics.dll) Version: 3.0.0.0 (3.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | F#
public override double Variance { get; }
Public Overrides ReadOnly Property Variance As Double
    Get
public:
virtual property double Variance {
    double get () override;
}
abstract Variance : float with get
override Variance : float with get

Property Value

Double

See Also

WeibullDistribution Class
Meta.Numerics.Statistics.Distributions Namespace